#opendaylight-meeting: beryllium weekly sync

Meeting started by anipbu at 15:30:42 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:30:52)
    1. Prem for VPNService (Prem, 15:31:30)
    2. LuisGomez for integration (LuisGomez, 15:31:42)
    3. lori for lispflowmapping (lori, 15:31:53)
    4. yamahata for neutron northbound (yamahata, 15:31:59)
    5. yangide (davidmichaelkarr, 15:32:07)
    6. https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/Weekly_Sync_Meeting#Agenda <- Agenda for Beryllium Weekly Sync (anipbu, 15:32:20)
    7. Venkat for VTN (gvrangan, 15:32:31)
    8. rgoulding for AAA (rgoulding, 15:33:10)
    9. Thanh releng (zxiiro, 15:33:28)
    10. vrpolak for integration/distribution (vrpolak, 15:33:40)
    11. anipbu for usc nemo (anipbu, 15:33:56)
    12. Alec Leckey (NetIDE) (aleckey, 15:35:20)

  2. blocking issues (anipbu, 15:35:56)
    1. Just an FYI to everyone here we had to kick Jenkins this morning due to some issues we're seeing. We're getting it back online now (anipbu, 15:36:36)
    2. adetalhouet (adetalhouet, 15:38:54)
    3. yuling (yuling, 15:39:59)
    4. davidmichaelkarr asks robert varga to respond to email inquiries about yangtools (anipbu, 15:43:24)
    5. OpenFlowPlugin implementations (anipbu, 15:43:46)
    6. adetalhouet says we currently have two OpenFlowPlugin implementations in place and wants to know why one of them is not compatible with the other features ODL provide (anipbu, 15:46:20)
    7. Both OFP implementations have the same API but somewhat different behaviors. Conflict occurs when two instances try to bind to the same port. We need to find solution for how to ship Beryllium if two applications require different version of the plugin. (anipbu, 15:52:26)
    8. possible solutions: 1) Require every project to use only one implementation. 2) Create two different karaf distributions (anipbu, 15:53:23)
    9. LuisGomez says we should bring OFP up for TSC call tomorrow (anipbu, 15:54:25)
    10. possible solutions: 3) document which applications work with which plugin (anipbu, 15:56:00)
    11. ACTION: anipbu send email to add OFP discussion to tomorrow's TSC call. (anipbu, 15:57:06)
    12. yuling asked about making changes to integration/test such as renaming feature test name. LuisGomez says that's okay. (anipbu, 15:59:46)
    13. reminder to update distribution repo if there are feature name changes, otherwise it will break distribution (anipbu, 16:04:26)
    14. Copyright notice: if you modify a file (make code changes) with an existing copyright header, you have some options: copyright year can use xxxx-yyyy notation if continuous or comma if discontinuous. copyright owner can be updated if your company makes significant modifications to the code (>50%). Add a new line to list additional copyright owner (anipbu, 16:07:24)
    15. ACTION: robertvarga should respond to email inquiries about yangtools from davidmichaelkarr (anipbu, 16:08:29)

  3. red flags (anipbu, 16:08:55)
    1. ACTION: abhijitkumbhare to respond to inquiries about conflicting OFP version issues (anipbu, 16:09:44)
    2. reminder that M5 Code Freeze is tomorrow for offset 2 projects (anipbu, 16:10:06)
    3. we will also be doing Branch Cutting (anipbu, 16:10:29)

  4. cookies (anipbu, 16:13:08)


Meeting ended at 16:13:19 UTC (full logs).

Action items

  1. anipbu send email to add OFP discussion to tomorrow's TSC call.
  2. robertvarga should respond to email inquiries about yangtools from davidmichaelkarr
  3. abhijitkumbhare to respond to inquiries about conflicting OFP version issues


Action items, by person

  1. anipbu
    1. anipbu send email to add OFP discussion to tomorrow's TSC call.
  2. davidmichaelkarr
    1. robertvarga should respond to email inquiries about yangtools from davidmichaelkarr


People present (lines said)

  1. anipbu (44)
  2. LuisGomez (13)
  3. zxiiro (11)
  4. vrpolak (9)
  5. yuling (8)
  6. adetalhouet (5)
  7. Prem (4)
  8. odl_meetbot (4)
  9. davidmichaelkarr (3)
  10. lori (2)
  11. gvrangan (1)
  12. rgoulding (1)
  13. yamahata (1)
  14. aleckey (1)


Generated by MeetBot 0.1.4.