#opendaylight-meeting: boron release review

Meeting started by anipbu at 14:30:16 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 14:30:23)
    1. PTL and TSC members please #info in (anipbu, 14:30:28)
    2. anipbu (anipbu, 14:38:02)

  2. USC (Unified Secure Channel) (anipbu, 14:45:24)
    1. https://wiki.opendaylight.org/view/USC:Boron:Release_Review <-- Release Review (anipbu, 14:45:28)
    2. https://wiki.opendaylight.org/view/USC:Boron:Release_Notes <-- Release Notes (anipbu, 14:45:32)
    3. anipbu is representing USC (anipbu, 14:45:36)
    4. https://jenkins.opendaylight.org/releng/view/usc/job/usc-csit-1node-tcp-all-boron/ <--- USC System tests now passes (anipbu, 14:47:10)
    5. https://jenkins.opendaylight.org/releng/view/usc/job/usc-csit-1node-tcp-only-boron/ <--- USC system tests now passes (anipbu, 14:47:28)
    6. USC is approved for Boron. Congratulations. (anipbu, 14:52:12)

  3. NEUTRON (Neutron Northbound) (anipbu, 14:52:26)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:Boron:Release_Review <-- Release Review (anipbu, 14:52:31)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:Boron:Release_Notes <-- Release Notes (anipbu, 14:52:36)
    3. Isaku Yamahata is representing NEUTRON (anipbu, 14:52:40)
    4. ACTION: yamahata to add links to more details about the deprecated APIs, etc. in the release notes (anipbu, 14:57:50)
    5. https://review.openstack.org/#/c/359954/ (yamahata, 15:00:39)
    6. http://logs.openstack.org/54/359954/1/check/gate-tempest-dsvm-networking-odl-boron-snapshot/47fbe34/ (yamahata, 15:01:05)
    7. ACTION: yamahata to add links to external openstack tests in release review template. (anipbu, 15:02:08)
    8. NEUTRON approved for Boron pending action items. Congratulations! (anipbu, 15:02:50)

  4. TOPOPROCESSING (anipbu, 15:03:15)
    1. https://wiki.opendaylight.org/view/Topology_Processing_Framework:BORON_Release_Review <-- Release Review (anipbu, 15:03:19)
    2. https://wiki.opendaylight.org/view/Topology_Processing_Framework:BORON_Release_Notes <-- Release Notes (anipbu, 15:03:25)
    3. Andrej Záň is representing TOPOPROCESSING (anipbu, 15:03:30)
    4. ACTION: AnZa to update the list of features on release review (anipbu, 15:07:54)
    5. https://wiki.opendaylight.org/view/Topology_Processing_Framework:BORON_Release_Notes#Changes_Since_Previous_Releases (anipbu, 15:09:15)
    6. ACTION: AnZa to update the release notes regarding the statement "API was slightly changed" (anipbu, 15:10:36)
    7. ACTION: AnZa to update the links to the documentation to point to the asciidocs/rst files (currently it is pointing to gerrit patches). (anipbu, 15:13:28)
    8. TOPOPROCESSING approved for Boron pending action items. Congratulations! (anipbu, 15:16:20)

  5. OPENFLOWJAVA (anipbu, 15:16:30)
    1. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Boron_Release_Review <-- Release Review (anipbu, 15:16:36)
    2. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Boron_Release_Notes <-- Release Notes (anipbu, 15:16:40)
    3. Michal Polkorab is representing OPENFLOWJAVA (anipbu, 15:16:45)
    4. ACTION: oflibMichal to update the target environment (anipbu, 15:22:53)
    5. ACTION: oflibMichal to add link to the sonar unit test report to release review template (anipbu, 15:25:34)
    6. OPENFLOWJAVA approved for Boron pending action items. Congratulations! (anipbu, 15:28:37)

  6. NEMO (Network Modeling) (anipbu, 15:29:09)
    1. https://wiki.opendaylight.org/view/NEMO:Boron:Release_Review <-- Release Review (anipbu, 15:29:13)
    2. https://wiki.opendaylight.org/view/NEMO:Boron:Release_Notes <-- Release Notes (anipbu, 15:29:17)
    3. anipbu is representing NEMO (anipbu, 15:29:21)
    4. NEMO approved for Boron. Congratulations! (anipbu, 15:43:15)

  7. cookies (anipbu, 15:44:45)


Meeting ended at 15:44:54 UTC (full logs).

Action items

  1. yamahata to add links to more details about the deprecated APIs, etc. in the release notes
  2. yamahata to add links to external openstack tests in release review template.
  3. AnZa to update the list of features on release review
  4. AnZa to update the release notes regarding the statement "API was slightly changed"
  5. AnZa to update the links to the documentation to point to the asciidocs/rst files (currently it is pointing to gerrit patches).
  6. oflibMichal to update the target environment
  7. oflibMichal to add link to the sonar unit test report to release review template


Action items, by person

  1. AnZa
    1. AnZa to update the list of features on release review
    2. AnZa to update the release notes regarding the statement "API was slightly changed"
    3. AnZa to update the links to the documentation to point to the asciidocs/rst files (currently it is pointing to gerrit patches).
  2. oflibMichal
    1. oflibMichal to update the target environment
    2. oflibMichal to add link to the sonar unit test report to release review template
  3. yamahata
    1. yamahata to add links to more details about the deprecated APIs, etc. in the release notes
    2. yamahata to add links to external openstack tests in release review template.


People present (lines said)

  1. anipbu (114)
  2. vrpolak (15)
  3. yamahata (15)
  4. oflibMichal (14)
  5. AnZa (10)
  6. odl_meetbot (3)


Generated by MeetBot 0.1.4.