#opendaylight-meeting: boron release review
Meeting started by anipbu at 14:30:32 UTC
(full logs).
Meeting summary
- roll call (anipbu, 14:30:38)
  - PTL and TSC members please #info in
    (anipbu,
    14:30:46)
 
  - anipbu (anipbu,
    14:30:51)
 
  - Ryan Goulding (rgoulding) for AAA (rgoulding,
    14:31:23)
 
  - skitt (skitt,
    14:31:24)
 
  - Alec Leckey for NetIDE (aleckey,
    14:31:42)
 
  - colindixon for docs, and TSC (colindixon,
    14:31:49)
 
  - Jensen Zhang for ALTO (jensen_zhang,
    14:32:09)
 
  - Kai for ALTO (emiapwil,
    14:33:16)
 
  - Vratko polak for integration/distribution and
    integration/test (vrpolak,
    14:34:09)
 
  - VivekSri for Genius (VivekSri,
    14:34:30)
 
 
- AAA (anipbu, 14:34:56)
  - https://wiki.opendaylight.org/view/AAA:Boron:Release_Review
    <--- Release Review (anipbu,
    14:35:01)
 
  - https://wiki.opendaylight.org/view/AAA:Boron:Release_Notes
    <--- Release Notes (anipbu,
    14:35:06)
 
  - rgoulding is representing AAA (anipbu,
    14:35:11)
 
  - https://wiki.opendaylight.org/view/AAA:Boron:Release_Review
    (rgoulding,
    14:40:02)
 
  - idmlite is not a feature in aaa for boron.
    tests are failing, but they are invalid anyways. (anipbu,
    14:41:18)
 
  - all of AAA features are experimental
    (anipbu,
    14:42:24)
 
  - AAA has tested RC2 and found no problems
    (anipbu,
    14:42:34)
 
  - ACTION: rgoulding to
    follow up with shiro experimental state (anipbu,
    14:45:37)
 
  - ACTION: rgoulding to
    follow up on code coverage for the system test: "odl-aaa-cli and
    odl-aaa-cert features do not seem to be tested in the one passing
    job." (anipbu,
    14:48:12)
 
  - AAA approved for Boron pending action items.
    Congratulations! (anipbu,
    14:48:31)
 
 
- ODLPARENT (anipbu, 14:48:36)
  - https://wiki.opendaylight.org/view/ODL_Parent:Boron:Release_Review
    <--- Release Review (anipbu,
    14:48:40)
 
  - https://wiki.opendaylight.org/view/ODL_Parent:Boron:Release_Notes
    <--- Release Notes (anipbu,
    14:48:44)
 
  - skitt is representing ODLPARENT (anipbu,
    14:48:52)
 
  - odlparent has no blockers in RC2 (tested).  no
    experimental features.  no user facing features (anipbu,
    14:51:28)
 
  - karaf 3.0.7 upgrade is complete (anipbu,
    14:51:47)
 
  - ODLPARENT has system test waiver approved by
    the integration team
    https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Waiver/System_Test
    (anipbu,
    14:53:11)
 
  - ODLPARENT approved for Boron.
    Congratulations! (anipbu,
    14:55:00)
 
 
- NETIDE (anipbu, 14:55:05)
  - https://wiki.opendaylight.org/view/NetIDE:Boron_Release_Review
    <--- Release Review (anipbu,
    14:55:11)
 
  - https://wiki.opendaylight.org/view/NetIDE:Boron_Release_Notes
    <--- Release Notes (anipbu,
    14:55:14)
 
  - aleckey is representing NETIDE (anipbu,
    14:55:24)
 
  - netide has tested RC2 and found no
    issues (anipbu,
    14:57:41)
 
  - netide features are experimental (anipbu,
    14:59:17)
 
  - NetIDE feature repository is included in
    integration, but its features are commented out, so the do not
    participate in compatibility testing (-all- jobs) (anipbu,
    14:59:38)
 
  - ACTION: aleckey to
    follow up on pushing the docuemntation into reStructuredText so it's
    all in one place (anipbu,
    15:00:41)
 
  - NETIDE approved for Boron.
    Congratulations! (anipbu,
    15:01:11)
 
 
- ALTO (anipbu, 15:01:16)
  - https://wiki.opendaylight.org/view/ALTO:Boron:Release_Review
    <--- Release Review (anipbu,
    15:01:21)
 
  - https://wiki.opendaylight.org/view/ALTO:Boron:Release_Notes
    <--- Release Notes (anipbu,
    15:01:26)
 
  - jensen_zhang is representing ALTO (anipbu,
    15:01:30)
 
  - alto has tested RC2 and found no
    blockers (anipbu,
    15:04:19)
 
  - all of alto features are experimental
    (anipbu,
    15:04:37)
 
  - ALTO approved for Boron.
    Congratulations! (anipbu,
    15:11:33)
 
 
- BGPCEP (anipbu, 15:11:41)
  - https://wiki.opendaylight.org/view/BGP_LS_PCEP:Boron_Release_Review
    <--- Release Review (anipbu,
    15:11:47)
 
  - https://wiki.opendaylight.org/view/BGP_LS_PCEP:Boron_Release_Notes
    <--- Release Notes (anipbu,
    15:11:51)
 
  - milfabia is representing BGPCEP (anipbu,
    15:11:56)
 
  - CRITICAL: bug 6497 appears to be a blocking bug
    somewhere between bgpcep and yangtools, it's being debugged and a
    fix is hoped for by tomorrow (colindixon,
    15:17:52)
 
  - ACTION: milfabia to
    follow up with bug 6497 (anipbu,
    15:18:24)
 
  - ACTION: milfabia to
    update the target environment (anipbu,
    15:22:09)
 
  - https://lists.opendaylight.org/pipermail/bgpcep-dev/2016-August/000729.html
    email with CSIT analysis. (jamoluhrsen,
    15:22:34)
 
  - ACTION: milfabia to
    update the list of features and if they are user-facing or
    experimental, etc. (anipbu,
    15:22:44)
 
  - 10 CSIT jobs (which is great), but 8 of them
    have unexpected failures.  as vrpolak points out, they might be
    consistently failing but they should point to an open non-blocking
    bug if so. (jamoluhrsen,
    15:23:28)
 
  - ACTION: milfabia to
    update the release notes with reference on TCPMD5 migration
    (anipbu,
    15:26:20)
 
  - ACTION: milfabia to
    follow up on the CSIT failures.  (if they are all experimental
    features, then okay.  but for any non-experimental features, the
    CSIT must pass, etc) (anipbu,
    15:27:13)
 
  - ACTION: anipbu to
    follow up with BGPCEP over email (anipbu,
    15:33:27)
 
  - CAPWAP cannot made their release review.  Will
    reschedule. (anipbu,
    15:34:39)
 
  - CONTROLLER was unresponsive.  Will
    reschedule. (anipbu,
    15:36:50)
 
 
- DLUX (anipbu, 15:38:01)
  - https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Boron_Release_Review
    <--- Release Review (anipbu,
    15:38:16)
 
  - https://wiki.opendaylight.org/view/OpenDaylight_DLUX:Boron:Release_Notes
    <--- Release Notes (anipbu,
    15:38:28)
 
  - mmcoulombe is representing DLUX (anipbu,
    15:38:39)
 
  - all dlux features should be considered
    experimental (jamoluhrsen,
    15:40:25)
 
  - ACTION: mmcoulombe to
    test RC2 today or (worst case) tomorrow and confirm if there are any
    blocking issues and update the spreadsheet appropriately:
    https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
    (anipbu,
    15:45:21)
 
  - dlux docs are still accurate since nothing
    really change since helium release for DLUX (anipbu,
    15:45:56)
 
  - ACTION: mmcoulombe to
    update the release notes target environment (anipbu,
    15:47:58)
 
  - DLUX approved for Boron pending action items.
    Congratulations! (anipbu,
    15:49:26)
 
 
- DOCS (anipbu, 15:49:35)
  - https://wiki.opendaylight.org/view/Documentation/Boron/Release_Review
    <--- Release Review (anipbu,
    15:49:36)
 
  - https://wiki.opendaylight.org/view/Documentation/Boron/Release_Notes
    <--- Release Notes (anipbu,
    15:49:42)
 
  - colindixon is representing DOCS (anipbu,
    15:49:48)
 
  - migration to reST is ongoing pending 12
    projects
    https://git.opendaylight.org/gerrit/#/q/(topic:adoc2rst+OR+topic:adoc2rst-user)+status:open
    (anipbu,
    15:51:43)
 
  - docs does not need to test RC2: N/A
    (anipbu,
    15:52:20)
 
  - http://docs.opendaylight.org/
    this is the big thing we delivered (colindixon,
    15:55:00)
 
  - we also no support inclusion of docs directly
    from project repos (colindixon,
    15:55:13)
 
  - ACTION: colindixon to
    update Non Code Aspects with appropriate links. (anipbu,
    15:55:47)
 
  - DOCS approved for Boron.
    Congratulations! (anipbu,
    15:58:17)
 
  - EMAN cannot made their release review.  Will
    reschedule. (anipbu,
    15:58:59)
 
 
- GENIUS (anipbu, 15:59:25)
  - https://wiki.opendaylight.org/view/Genius:Boron:Release_Review
    <--- Release Review (anipbu,
    15:59:33)
 
  - https://wiki.opendaylight.org/view/Genius:Boron:Release_Note
    <--- Release Notes (anipbu,
    15:59:40)
 
  - VivekSri is representing GENIUS (anipbu,
    15:59:45)
 
  - https://lists.opendaylight.org/pipermail/genius-dev/2016-August/000282.html
    email about CSIT analysis for Genius project (jamoluhrsen,
    16:02:19)
 
  - CSIT patches are pending merge. (anipbu,
    16:02:24)
 
  - NetVirt project is extensivey using genius
    features, and thus genius features are also tested with NetVirt
    CSIT (anipbu,
    16:02:26)
 
  - there is currently no csit so by definition all
    features would be experimental. (jamoluhrsen,
    16:02:38)
 
  - integration team needs to review those
    patches (jamoluhrsen,
    16:02:51)
 
  - netvirt is going to be labeled experimental all
    over the place too, so we can't use that project's CSIT for
    genius (jamoluhrsen,
    16:03:22)
 
  - ACTION: jamoluhrsen
    to review genius csit patches. (jamoluhrsen,
    16:04:00)
 
  - https://git.opendaylight.org/gerrit/#/c/39665/
    (VivekSri,
    16:04:13)
 
  - genius has pending docs patches for review:
    https://git.opendaylight.org/gerrit/#/c/39665/ (anipbu,
    16:04:40)
 
  - ACTION: VivekSri to
    follow up on docs patches (anipbu,
    16:04:54)
 
  - ACTION: VivekSri to
    follow up on CSIT tests and "experimental" tag for relevant
    features. (anipbu,
    16:05:24)
 
  - genius has tested RC2 and found no
    blockers (anipbu,
    16:07:43)
 
  - genius has no security considerations
    (anipbu,
    16:11:15)
 
  - GENIUS approved for Boron pending action items.
    Congratulations! (anipbu,
    16:15:19)
 
 
- L2SWITCH (anipbu, 16:17:01)
  - https://wiki.opendaylight.org/view/L2_Switch:Boron:Release_Review
    <--- Release Review (anipbu,
    16:17:06)
 
  - https://wiki.opendaylight.org/view/L2_Switch:Boron:Release_Notes
    <--- Release Notes (anipbu,
    16:17:10)
 
  - evanz is representing L2SWITCH (anipbu,
    16:17:19)
 
  - https://lists.opendaylight.org/pipermail/l2switch-dev/2016-August/001260.html
    csit analysis email. (jamoluhrsen,
    16:17:45)
 
  - looks like all l2switch features should have
    the experimental label. (jamoluhrsen,
    16:18:16)
 
  - l2switch to test RC2 and report the status of
    any blocking bugs (anipbu,
    16:22:39)
 
  - ACTION: evanz to
    update the list of features and if they are user-facing or
    experimental, etc. (anipbu,
    16:24:19)
 
  - ACTION: evanz to
    follow up on RC2 testing and update the spreadsheet (anipbu,
    16:24:47)
 
  - ACTION: evanz to
    figure out if the scale test is a real regression or just a test
    failure (colindixon,
    16:25:47)
 
  - https://jenkins.opendaylight.org/releng/view/l2switch/job/l2switch-csit-1node-periodic-host-scalability-daily-only-boron/plot/Inventory%20Host%20Scalability/
    scalability test showing zero, but was 100 in the past (jamoluhrsen,
    16:25:53)
 
  - ACTION: anipbu evanz:
    l2switch to follow up over email to cover: rc2 testing, updating
    features list on release review template, and csit/scale test
    issues (anipbu,
    16:33:18)
 
  - MDSAL was unresponsive.  Will
    reschedule. (anipbu,
    16:35:22)
 
  - NIC was unresponsive.  Will reschedule.
    (anipbu,
    16:36:26)
 
 
- cookies (anipbu, 16:38:54)
 
Meeting ended at 16:39:02 UTC
(full logs).
Action items
  - rgoulding to follow up with shiro experimental state
 
  - rgoulding to follow up on code coverage for the system test: "odl-aaa-cli and odl-aaa-cert features do not seem to be tested in the one passing job."
 
  - aleckey to follow up on pushing the docuemntation into reStructuredText so it's all in one place
 
  - milfabia to follow up with bug 6497
 
  - milfabia to update the target environment
 
  - milfabia to update the list of features and if they are user-facing or experimental, etc.
 
  - milfabia to update the release notes with reference on TCPMD5 migration
 
  - milfabia to follow up on the CSIT failures.  (if they are all experimental features, then okay.  but for any non-experimental features, the CSIT must pass, etc)
 
  - anipbu to follow up with BGPCEP over email
 
  - mmcoulombe to test RC2 today or (worst case) tomorrow and confirm if there are any blocking issues and update the spreadsheet appropriately: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
 
  - mmcoulombe to update the release notes target environment
 
  - colindixon to update Non Code Aspects with appropriate links.
 
  - jamoluhrsen to review genius csit patches.
 
  - VivekSri to follow up on docs patches
 
  - VivekSri to follow up on CSIT tests and "experimental" tag for relevant features.
 
  - evanz to update the list of features and if they are user-facing or experimental, etc.
 
  - evanz to follow up on RC2 testing and update the spreadsheet
 
  - evanz to figure out if the scale test is a real regression or just a test failure
 
  - anipbu evanz: l2switch to follow up over email to cover: rc2 testing, updating features list on release review template, and csit/scale test issues
 
Action items, by person
  -  aleckey 
    - aleckey to follow up on pushing the docuemntation into reStructuredText so it's all in one place
 
  
 
  -  anipbu 
    - anipbu to follow up with BGPCEP over email
 
    - anipbu evanz: l2switch to follow up over email to cover: rc2 testing, updating features list on release review template, and csit/scale test issues
 
  
 
  -  colindixon 
    - colindixon to update Non Code Aspects with appropriate links.
 
  
 
  -  evanz 
    - evanz to update the list of features and if they are user-facing or experimental, etc.
 
    - evanz to follow up on RC2 testing and update the spreadsheet
 
    - evanz to figure out if the scale test is a real regression or just a test failure
 
    - anipbu evanz: l2switch to follow up over email to cover: rc2 testing, updating features list on release review template, and csit/scale test issues
 
  
 
  -  jamoluhrsen 
    - jamoluhrsen to review genius csit patches.
 
  
 
  -  milfabia 
    - milfabia to follow up with bug 6497
 
    - milfabia to update the target environment
 
    - milfabia to update the list of features and if they are user-facing or experimental, etc.
 
    - milfabia to update the release notes with reference on TCPMD5 migration
 
    - milfabia to follow up on the CSIT failures.  (if they are all experimental features, then okay.  but for any non-experimental features, the CSIT must pass, etc)
 
  
 
  -  mmcoulombe 
    - mmcoulombe to test RC2 today or (worst case) tomorrow and confirm if there are any blocking issues and update the spreadsheet appropriately: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
 
    - mmcoulombe to update the release notes target environment
 
  
 
  -  rgoulding 
    - rgoulding to follow up with shiro experimental state
 
    - rgoulding to follow up on code coverage for the system test: "odl-aaa-cli and odl-aaa-cert features do not seem to be tested in the one passing job."
 
  
 
  -  VivekSri 
    - VivekSri to follow up on docs patches
 
    - VivekSri to follow up on CSIT tests and "experimental" tag for relevant features.
 
  
 
People present (lines said)
  - anipbu (197)
 
  - colindixon (78)
 
  - jamoluhrsen (25)
 
  - rgoulding (21)
 
  - VivekSri (16)
 
  - vrpolak (16)
 
  - milfabia (15)
 
  - skitt (10)
 
  - mmcoulombe (9)
 
  - jensen_zhang (5)
 
  - odl_meetbot (5)
 
  - evanz (4)
 
  - aleckey (4)
 
  - Sai_ (3)
 
  - emiapwil (3)
 
  - LuisGomez (1)
 
Generated by MeetBot 0.1.4.