#opendaylight-meeting: boron release review

Meeting started by anipbu at 15:01:09 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 15:01:14)
    1. PTL and TSC members please #info in (anipbu, 15:01:19)
    2. anipbu (anipbu, 15:01:24)
    3. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020 (anipbu, 15:02:39)

  2. INTEGRATION/DISTRIBUTION (anipbu, 15:03:03)
    1. from Integration/Distribution import Vratko Polak as vrpolak (vrpolak, 15:03:40)
    2. https://wiki.opendaylight.org/view/Integration/Distribution/Boron_Release_Review <--- Release Review (anipbu, 15:03:56)
    3. https://wiki.opendaylight.org/view/Integration/Distribution/Boron_Release_Notes <--- Release Notes (anipbu, 15:04:00)
    4. vrpolak is representing INTEGRATION/DISTRIBUTION (anipbu, 15:04:23)
    5. int/dis has two specific tests for Version functionality (1 failure due to known non-blocking Bug 6003) (anipbu, 15:06:03)
    6. int/dis has tested RC2. No blockers found. (anipbu, 15:06:20)
    7. INTEGRATION/DISTRIBUTION approved for Boron. Congratulations! (anipbu, 15:09:44)

  3. SXP (anipbu, 15:10:27)
    1. https://wiki.opendaylight.org/view/SXP:Boron:Release_Review <--- Release Review (anipbu, 15:10:31)
    2. https://wiki.opendaylight.org/view/SXP:Boron:Release_Notes <--- Release Notes (anipbu, 15:10:36)
    3. mamihale is representing SXP (anipbu, 15:11:19)
    4. sxp has texted RC2 and found no blocking bugs (anipbu, 15:15:06)
    5. CSIT review: https://lists.opendaylight.org/pipermail/integration-dev/2016-August/008042.html (anipbu, 15:15:22)
    6. https://lists.opendaylight.org/pipermail/sxp-dev/2016-August/000057.html email for sxp csit analysis (jamoluhrsen, 15:16:53)
    7. sxp has only one user facing feature odl-sxp-controller (anipbu, 15:17:41)
    8. mamihale has agreed that all SXP features are experimental in boron (anipbu, 15:18:06)
    9. ACTION: mamihale to update the release review with the list of features and their attributes (anipbu, 15:18:20)
    10. ACTION: mamihale to put links to the asciidocs/rst documents into the release review template (anipbu, 15:19:27)
    11. SXP to complete action items and follow up (anipbu, 15:22:33)
    12. ACTION: anipbu to follow up with SXP on action items (anipbu, 15:24:39)

  4. OCPPLUGIN (anipbu, 15:25:25)
    1. https://wiki.opendaylight.org/view/OCP_Plugin:Boron_Release_Notes <--- Release Review (anipbu, 15:25:30)
    2. https://wiki.opendaylight.org/view/OCP_Plugin:Boron_Release_Review <--- Release Notes (anipbu, 15:25:34)
    3. richardchien is representing SXP (anipbu, 15:25:40)
    4. ocpplugin has texted RC2 and found no blocking issues (anipbu, 15:26:33)
    5. all ocpplugin features are marked as experimental (anipbu, 15:27:00)
    6. https://lists.opendaylight.org/pipermail/ocpplugin-dev/2016-August/000024.html csit analysis email for ocplugin (jamoluhrsen, 15:27:27)
    7. all system tests are meeting expectations (jamoluhrsen, 15:27:39)
    8. info about the simulator can be found in user guide (anipbu, 15:30:26)
    9. OCPPLUGIN approved for Boron. Congratulations! (anipbu, 15:32:16)

  5. GROUPBASEDPOLICY (anipbu, 15:32:23)
    1. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Boron/Release_note <--- Release Review (anipbu, 15:32:29)
    2. https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Releases/Boron/Release_review <--- Release Notes (anipbu, 15:32:33)
    3. vlavor is representing GROUPBASEDPOLICY (anipbu, 15:32:42)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=6421 (anipbu, 15:33:25)
    5. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2016-August/003559.html email for gbp csit review (jamoluhrsen, 15:33:49)
    6. bug 6421 is already fixed accoridng to vlavor (anipbu, 15:34:34)
    7. odl-groupbasedpolicy-ofoverlay is nonexperimental feature. All other features are experimental. (anipbu, 15:40:00)
    8. ACTION: jamoluhrsen vlavor to follow up on the CSIT failures for odl-groupbasedpolicy-ofoverlay (anipbu, 15:43:39)
    9. groupbasedpolicy to follow up (anipbu, 15:45:13)
    10. GROUPBASEDPOLICY approved for Boron pending action items. Congratulations! (anipbu, 15:47:13)

  6. NETVIRT (anipbu, 15:47:44)
    1. https://wiki.opendaylight.org/view/NetVirt:Boron_Release_Review <--- Release Review (anipbu, 15:47:48)
    2. https://lists.opendaylight.org/pipermail/netvirt-dev/2016-August/001391.html <--- email review of netvirt CSIT (jamoluhrsen, 15:48:10)
    3. shague_ is representing NETVIRT (anipbu, 15:48:11)
    4. https://wiki.opendaylight.org/view/NetVirt:Boron_Release_Notes (shague_, 15:49:32)
    5. https://wiki.opendaylight.org/view/NetVirt:Boron_Release_Notes <--- Release Notes (anipbu, 15:49:38)
    6. all netvirt features are marked as experimental (anipbu, 15:52:13)
    7. ACTION: shague_ to add more about vpnservice/netvirt migration in docs (anipbu, 15:56:25)
    8. ACTION: shague_ to work on addressing CSIT failures and update the experimental tag if necessary (anipbu, 15:58:01)
    9. netvirt has tested rc2 and found no blockers (anipbu, 15:58:35)
    10. NETVIRT approved for Boron pending action items. Congratulations! (anipbu, 15:58:40)

  7. OPFLEX (anipbu, 15:58:44)
    1. https://wiki.opendaylight.org/view/OpFlex:Boron_Release_Review <--- Release Review (anipbu, 15:58:47)
    2. https://wiki.opendaylight.org/view/OpFlex:Boron_Release_Notes <--- Release Notes (anipbu, 15:58:50)
    3. readams is representing OPFLEX (anipbu, 15:58:55)
    4. opflex has a system test waiver (jamoluhrsen, 15:59:00)
    5. opflex ran automated system test against ACI with OpenStack on physical hardware. All the tests passed (green). (anipbu, 16:03:01)
    6. ACTION: anipbu readams zxiiro: to add opflex to the boron release artifacts: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/ (anipbu, 16:05:50)
    7. opflex has texted RC2 on automated systems. tests pass (green) (anipbu, 16:06:56)
    8. OPFLEX approved for Boron pending action items. Congratulations! (anipbu, 16:07:59)

  8. NEXT (anipbu, 16:08:28)
    1. https://wiki.opendaylight.org/view/NeXt:Boron_Release_Review <--- Release Review (anipbu, 16:08:34)
    2. https://wiki.opendaylight.org/view/NeXt:Boron_Release_Notes <--- Release Notes (anipbu, 16:08:39)
    3. aikepaer is representing NEXT (anipbu, 16:08:56)
    4. aikepaer has agreed to mark all next features as experimental in boron (anipbu, 16:11:58)
    5. ACTION: aikepaer to update the release review template and change the features as experimental (anipbu, 16:13:04)
    6. next has tested RC2 and found no blockers (anipbu, 16:13:14)
    7. ACTION: aikepaer anipbu zxiiro: to work with next ui toolkit to upload the artifacts to release https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/ (anipbu, 16:14:22)
    8. NEXT approved for Boron pending action items. Congratulations! (anipbu, 16:17:15)

  9. SXP (anipbu, 16:17:20)
    1. SXP approved for Boron. Congratulations! (anipbu, 16:17:23)

  10. IOTDM (anipbu, 16:17:30)
    1. https://wiki.opendaylight.org/view/Iotdm:Boron_Release_Notes <--- Release Review (anipbu, 16:17:35)
    2. https://wiki.opendaylight.org/view/Iotdm:_Boron_Release_Review <--- Release Notes (anipbu, 16:17:38)
    3. jburns is representing IOTDM (anipbu, 16:17:42)
    4. https://lists.opendaylight.org/pipermail/iotdm-dev/2016-August/000172.html <--- email for csit analysis of IOTDM (jamoluhrsen, 16:18:53)
    5. all features experimental (jamoluhrsen, 16:19:02)
    6. ACTION: jburns to test RC2 and update the spreadsheet (anipbu, 16:23:31)
    7. ACTION: jburns to update the release notes with sections on changes/migration/compability/deprecation (anipbu, 16:25:49)
    8. ACTION: jamoluhrsen jburns to follow up on CSIT and experimental tags (anipbu, 16:28:43)
    9. ACTION: jburns to update the release review with the list of features and their attributes (anipbu, 16:28:56)
    10. IOTDM to follow up on action items (anipbu, 16:29:12)
    11. ACTION: anipbu to follow up with IOTDM (anipbu, 16:29:20)

  11. VTN (anipbu, 16:30:35)
    1. https://wiki.opendaylight.org/view/VTN:Boron:Release_Review <--- Release Review (anipbu, 16:30:40)
    2. https://wiki.opendaylight.org/view/VTN:Boron:Release_Notes <--- Release Notes (anipbu, 16:30:44)
    3. hideyuki is representing VTN (anipbu, 16:30:48)
    4. https://lists.opendaylight.org/pipermail/vtn-dev/2016-August/001585.html <--- email for VTN csit analysis (jamoluhrsen, 16:31:27)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=6595 (hideyuki, 16:31:43)
    6. all VTN features are experimental due to system test expectations (jamoluhrsen, 16:31:50)
    7. VTN project has tested RC2, and it worked fine. (hideyuki, 16:32:24)
    8. for RC2, VTN is red pending openflowplugin to fix bug 6595 (anipbu, 16:34:32)
    9. ACTION: hideyuki anipbu zxiiro: to work with releng team to upload vtn cooridnator to the release nexus repo: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2 (anipbu, 16:38:29)
    10. ACTION: hideyuki to update the release review with the list of features and their attributes (anipbu, 16:39:29)
    11. ACTION: hideyuki to work with openflowteam to resolve pending blocking bug (6595) (anipbu, 16:40:37)
    12. ACTION: jamoluhrsen hideyuki to work offline to resolve CSIT failures and update the experimental tags for VTN (anipbu, 16:41:06)
    13. VTN to follow up with action items (anipbu, 16:41:41)
    14. ACTION: anipbu to follow up with VTN (anipbu, 16:41:49)
    15. if the blocking bug 6595 is not fixed by Boron, then there is a big limitation on VTN feature on Boron which is VTN doesn't work with OF10 in Boron. (anipbu, 16:42:34)

  12. SFC (anipbu, 16:44:13)
    1. https://wiki.opendaylight.org/view/Service_Function_Chaining:Boron_Release_Review <--- Release Review (anipbu, 16:44:18)
    2. https://wiki.opendaylight.org/view/Service_Function_Chaining:Boron_Release_Notes <--- Release Notes (anipbu, 16:44:23)
    3. ebrjohn is representing SFC (anipbu, 16:44:53)
    4. https://lists.opendaylight.org/pipermail/sfc-dev/2016-August/003389.html <--- csit email analysis for SFC (jamoluhrsen, 16:45:10)
    5. all sfc features experimental currently, but some work being done currently that may clean things up. (jamoluhrsen, 16:45:38)
    6. https://lists.opendaylight.org/pipermail/sfc-dev/2016-August/003389.html (ebrjohn, 16:47:18)
    7. ACTION: jamoluhrsen ebrjohn to follow up on CSIT test and experimental tags for SFC features. (anipbu, 16:50:43)
    8. SFC to follow up on action items (anipbu, 16:51:10)
    9. ACTION: anipbu to follow up with SFC (anipbu, 16:51:16)
    10. SFC has tested RC2 and found no blockers (anipbu, 16:53:01)
    11. https://lists.opendaylight.org/pipermail/release/2016-August/008036.html (ebrjohn, 16:53:26)
    12. https://bugs.opendaylight.org/show_bug.cgi?id=6526 (ebrjohn, 16:53:40)
    13. SFC approved for Boron pending action items. Congratulations! (anipbu, 16:54:02)

  13. TSDR (anipbu, 16:54:20)
  14. FAAS (anipbu, 16:56:53)
    1. https://wiki.opendaylight.org/view/FaaS:Boron_Release_Review <--- Release Review (anipbu, 16:56:58)
    2. https://wiki.opendaylight.org/view/FaaS:Boron_Release_Notes <--- Release Notes (anipbu, 16:57:01)
    3. xingjun is representing FAAS (anipbu, 16:57:08)
    4. FAAS has tested RC2 and found no blockers (anipbu, 16:58:08)
    5. xingjun has agreed that all FAAS features are experimental. (anipbu, 16:58:34)
    6. FAAS has no CSIT, so all experimental (jamoluhrsen, 16:58:39)
    7. ACTION: xingjun to update the release review with the list of features and their attributes (anipbu, 16:58:55)
    8. ACTION: xingjun to update the release notes with the sections on changes/migration/compabilities/deprecation. (anipbu, 17:03:11)

  15. cookies (anipbu, 18:17:02)


Meeting ended at 18:17:07 UTC (full logs).

Action items

  1. mamihale to update the release review with the list of features and their attributes
  2. mamihale to put links to the asciidocs/rst documents into the release review template
  3. anipbu to follow up with SXP on action items
  4. jamoluhrsen vlavor to follow up on the CSIT failures for odl-groupbasedpolicy-ofoverlay
  5. shague_ to add more about vpnservice/netvirt migration in docs
  6. shague_ to work on addressing CSIT failures and update the experimental tag if necessary
  7. anipbu readams zxiiro: to add opflex to the boron release artifacts: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/
  8. aikepaer to update the release review template and change the features as experimental
  9. aikepaer anipbu zxiiro: to work with next ui toolkit to upload the artifacts to release https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/
  10. jburns to test RC2 and update the spreadsheet
  11. jburns to update the release notes with sections on changes/migration/compability/deprecation
  12. jamoluhrsen jburns to follow up on CSIT and experimental tags
  13. jburns to update the release review with the list of features and their attributes
  14. anipbu to follow up with IOTDM
  15. hideyuki anipbu zxiiro: to work with releng team to upload vtn cooridnator to the release nexus repo: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2
  16. hideyuki to update the release review with the list of features and their attributes
  17. hideyuki to work with openflowteam to resolve pending blocking bug (6595)
  18. jamoluhrsen hideyuki to work offline to resolve CSIT failures and update the experimental tags for VTN
  19. anipbu to follow up with VTN
  20. jamoluhrsen ebrjohn to follow up on CSIT test and experimental tags for SFC features.
  21. anipbu to follow up with SFC
  22. xingjun to update the release review with the list of features and their attributes
  23. xingjun to update the release notes with the sections on changes/migration/compabilities/deprecation.


Action items, by person

  1. aikepaer
    1. aikepaer to update the release review template and change the features as experimental
    2. aikepaer anipbu zxiiro: to work with next ui toolkit to upload the artifacts to release https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/
  2. anipbu
    1. anipbu to follow up with SXP on action items
    2. anipbu readams zxiiro: to add opflex to the boron release artifacts: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/
    3. aikepaer anipbu zxiiro: to work with next ui toolkit to upload the artifacts to release https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/
    4. anipbu to follow up with IOTDM
    5. hideyuki anipbu zxiiro: to work with releng team to upload vtn cooridnator to the release nexus repo: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2
    6. anipbu to follow up with VTN
    7. anipbu to follow up with SFC
  3. ebrjohn
    1. jamoluhrsen ebrjohn to follow up on CSIT test and experimental tags for SFC features.
  4. hideyuki
    1. hideyuki anipbu zxiiro: to work with releng team to upload vtn cooridnator to the release nexus repo: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2
    2. hideyuki to update the release review with the list of features and their attributes
    3. hideyuki to work with openflowteam to resolve pending blocking bug (6595)
    4. jamoluhrsen hideyuki to work offline to resolve CSIT failures and update the experimental tags for VTN
  5. jamoluhrsen
    1. jamoluhrsen vlavor to follow up on the CSIT failures for odl-groupbasedpolicy-ofoverlay
    2. jamoluhrsen jburns to follow up on CSIT and experimental tags
    3. jamoluhrsen hideyuki to work offline to resolve CSIT failures and update the experimental tags for VTN
    4. jamoluhrsen ebrjohn to follow up on CSIT test and experimental tags for SFC features.
  6. jburns
    1. jburns to test RC2 and update the spreadsheet
    2. jburns to update the release notes with sections on changes/migration/compability/deprecation
    3. jamoluhrsen jburns to follow up on CSIT and experimental tags
    4. jburns to update the release review with the list of features and their attributes
  7. mamihale
    1. mamihale to update the release review with the list of features and their attributes
    2. mamihale to put links to the asciidocs/rst documents into the release review template
  8. readams
    1. anipbu readams zxiiro: to add opflex to the boron release artifacts: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/
  9. shague_
    1. shague_ to add more about vpnservice/netvirt migration in docs
    2. shague_ to work on addressing CSIT failures and update the experimental tag if necessary
  10. vlavor
    1. jamoluhrsen vlavor to follow up on the CSIT failures for odl-groupbasedpolicy-ofoverlay
  11. xingjun
    1. xingjun to update the release review with the list of features and their attributes
    2. xingjun to update the release notes with the sections on changes/migration/compabilities/deprecation.
  12. zxiiro
    1. anipbu readams zxiiro: to add opflex to the boron release artifacts: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/opflex/agent-ovs/
    2. aikepaer anipbu zxiiro: to work with next ui toolkit to upload the artifacts to release https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/next/next/
    3. hideyuki anipbu zxiiro: to work with releng team to upload vtn cooridnator to the release nexus repo: https://nexus.opendaylight.org/content/repositories/autorelease-1452/org/opendaylight/vtn/distribution.vtn-coordinator/6.3.0-Boron-RC2/distribution.vtn-coordinator-6.3.0-Boron-RC2-bin.tar.bz2


People present (lines said)

  1. anipbu (235)
  2. colindixon (65)
  3. jamoluhrsen (47)
  4. hideyuki (33)
  5. ebrjohn (29)
  6. jburns (19)
  7. vrpolak (15)
  8. readams (12)
  9. aikepaer (10)
  10. vlavor (10)
  11. xingjun (9)
  12. shague_ (9)
  13. yuling_ (7)
  14. odl_meetbot (6)
  15. zxiiro (5)
  16. mamihale (5)
  17. richardchien (3)
  18. LuisGomez (3)
  19. afredette (2)
  20. gvrangan (1)
  21. LuisGomez_ (1)


Generated by MeetBot 0.1.4.