#opendaylight-meeting: boron release review
Meeting started by anipbu at 14:30:59 UTC
(full logs).
Meeting summary
- roll call (anipbu, 14:31:04)
  - PTL and TSC members please #info in
    (anipbu,
    14:31:09)
 
  - TSDR (yuling_,
    14:31:19)
 
  - anipbu (anipbu,
    14:31:23)
 
  - sdninterfaceapp (RafatJahan,
    14:31:33)
 
  - Vratko Polak for integration (vrpolak,
    14:31:43)
 
  - vijay for snbi (vjanandr,
    14:31:52)
 
 
- TSDR (anipbu, 14:32:55)
  - https://wiki.opendaylight.org/view/Boron_Release_Review
    (yuling_,
    14:33:04)
 
  - https://wiki.opendaylight.org/view/Boron_Release_Review
    <--- Release Review (anipbu,
    14:33:17)
 
  - https://wiki.opendaylight.org/view/TSDR:Beryllium:Release_Review
    (yuling_,
    14:33:30)
 
  - https://wiki.opendaylight.org/view/Boron_Release_Review
    (yuling_,
    14:33:54)
 
  - https://wiki.opendaylight.org/view/Boron_Release_Notes
    (yuling_,
    14:34:33)
 
  - https://wiki.opendaylight.org/view/Boron_Release_Notes
    <--- Release Notes (anipbu,
    14:34:45)
 
  - yuling_ is representing TSDR (anipbu,
    14:34:58)
 
  - ACTION: yuling_ to
    update the release review with the list of features and their
    attributes (anipbu,
    14:36:18)
 
  - TSDR has tested RC2 and found no
    problems (anipbu,
    14:38:13)
 
  - all features are non-experimental, except for
    Cassandra, which is currently tagged as experimental.  However, the
    TSDR team believes cassandra should be nonexperimental. (anipbu,
    14:41:16)
 
  - ACTION: yuling_
    jamoluhrsen to follow up with CSIT test adn experimental tag of
    cassandra (anipbu,
    14:41:54)
 
  - TSDR to follow up on action items (anipbu,
    14:45:14)
 
  - ACTION: anipbu to
    follow up with TSDR (anipbu,
    14:45:21)
 
 
- SDNINTERFACEAPP (anipbu, 14:45:51)
  - https://wiki.opendaylight.org/view/ODL-SDNi:Boron_Release_Review
    <--- Release Review (anipbu,
    14:45:57)
 
  - https://wiki.opendaylight.org/view/ODL-SDNi:Boron_Release_Review
    (RafatJahan,
    14:45:58)
 
  - https://wiki.opendaylight.org/view/ODL-SDNi:Boron_Release_Notes
    <--- Release Notes (anipbu,
    14:46:01)
 
  - RafatJahan is representing
    SDNINTERFACEAPP (anipbu,
    14:46:18)
 
  - ChristineH is representing SNMP4SDN
    (ChristineH,
    14:46:34)
 
  - SDNINTERFACEAPP  tested RC2 and found no
    problems (anipbu,
    14:48:44)
 
  - RafatJahan has agreed to make mark all features
    as experimental (anipbu,
    14:50:07)
 
  - https://git.opendaylight.org/gerrit/#/c/34875/
    (colindixon,
    14:51:15)
 
  - ACTION: RafatJahan to
    review this patch:
    https://git.opendaylight.org/gerrit/#/c/34875/ (anipbu,
    14:51:46)
 
  - ACTION: RafatJahan to
    update release view wiki page with the links to the asciidocs/rst
    files (anipbu,
    14:52:49)
 
  - rovarga asked about removal of forked BGPCEP
    code somewhere on the roadmap (anipbu,
    14:54:13)
 
  - RafatJahan responds regarding bgcep fork: there
    are plans, but will need to check with PTL Sirisha (anipbu,
    14:55:25)
 
  - ACTION: RafatJahan to
    follow up with rovarga in addressing the fork of BGCEP in
    Carbon (anipbu,
    14:55:52)
 
  - SDNINTERFACEAPP approved for Boron pending
    action items.  Congratulations! (anipbu,
    14:57:01)
 
 
- SNBI (anipbu, 14:57:05)
  - https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:BoronReleaseReview
    <--- Release Review (anipbu,
    14:57:09)
 
  - https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:BoronReleaseReview
    (vjanandr,
    14:57:12)
 
  - https://wiki.opendaylight.org/view/SNBI_Boron_Release_Notes
    <--- Release Notes (anipbu,
    14:57:13)
 
  - frankbrockners is representing SNBI
    (anipbu,
    14:57:24)
 
  - vjanandr is representing SNBI (anipbu,
    14:57:49)
 
  - ACTION: vjanandr to
    test RC2 (anipbu,
    15:00:51)
 
  - vjanandr has agreed that all features will be
    marked experimental (anipbu,
    15:01:15)
 
  - ACTION: vjanandr to
    update the release review with the list of features and their
    attributes (anipbu,
    15:01:32)
 
  - https://git.opendaylight.org/gerrit/#/c/44983/
    (vjanandr,
    15:02:37)
 
  - ACTION: colindixon to
    review https://git.opendaylight.org/gerrit/#/c/44983/ (anipbu,
    15:02:50)
 
  - SNBI approved for Boron pending action items.
    Congratulations! (anipbu,
    15:04:50)
 
  - ACTION: SNMP to
    reschedule. (anipbu,
    15:05:58)
 
 
- SNMP4SDN (anipbu, 15:06:05)
  - https://wiki.opendaylight.org/view/SNMP4SDN:Beryllium_Release_Review
    <--- Release Review (anipbu,
    15:06:11)
 
  - https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Note
    (ChristineH_,
    15:10:51)
 
  - https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Review
    <--- Release Review (anipbu,
    15:11:00)
 
  - https://wiki.opendaylight.org/view/SNMP4SDN:Boron_Release_Note
    <--- Release Notes (anipbu,
    15:11:05)
 
  - ChristineH is representing SNMP4SDN
    (anipbu,
    15:11:10)
 
  - SNMP4SDN has tested RC2 and found blocking bug:
    https://bugs.opendaylight.org/show_bug.cgi?id=6607 (anipbu,
    15:11:31)
 
  - ACTION: ChristineH to
    update the release review with the list of features and their
    attributes (anipbu,
    15:13:29)
 
  - the user-facing features: odl-snmp4sdn-all and
    odl-snmp4sdn-snmp4sdn (anipbu,
    15:16:01)
 
  - ChristineH_ has agreed to mark all features as
    experimental for now (will be updated once the external test results
    are published) (anipbu,
    15:19:07)
 
  - ACTION: ChristineH_
    and jamoluhrsen to follow up on publishing the test results and the
    experimental tag. (anipbu,
    15:20:21)
 
  - ACTION: ChristineH_
    to add adoc/rst links to release review (anipbu,
    15:25:47)
 
  - SNMP4SDN approved for Boron pending action
    items.  Congratulations! (anipbu,
    15:25:52)
 
 
- TTP (anipbu, 15:25:57)
  - https://wiki.opendaylight.org/view/Table_Type_Patterns/Boron/Release_Review
    <--- Release Review (anipbu,
    15:26:03)
 
  - https://wiki.opendaylight.org/view/Table_Type_Patterns/Boron/Release_Notes
    <--- Release Notes (anipbu,
    15:26:07)
 
  - colindixon is representing TTP (anipbu,
    15:26:10)
 
  - ACTION: colindixon to
    update the release review with the list of features and their
    attributes (anipbu,
    15:28:22)
 
  - ACTION: colindixon to
    test TTP for RC2 and report status of testing on here:
    https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
    (anipbu,
    15:29:19)
 
  - All TTP features are experimental (anipbu,
    15:29:39)
 
  - user facing features: odl-ttp-model
    (anipbu,
    15:29:51)
 
  - the CLI tools is a serpate non-karaf feature.
    It is described in more details in the documentation.  This docs is
    linked form the release review template (anipbu,
    15:31:52)
 
  - TTP approved for Boron pending action items.
    Congratulations! (anipbu,
    15:33:18)
 
  - VPNSERVICE has dropped out of boron so there
    will be no release review for that project. (anipbu,
    15:33:53)
 
  - ACTION: YANG-PUSH to
    reschedule (anipbu,
    15:35:44)
 
 
- YANGIDE (anipbu, 15:35:59)
  - David Karr for yangide (davidmichaelkarr,
    15:36:02)
 
  - https://wiki.opendaylight.org/view/YangIDE/Boron/Release_Review
    <--- Release Review (anipbu,
    15:36:03)
 
  - https://wiki.opendaylight.org/view/YangIDE/Boron/Release_Notes
    <--- Release Notes (anipbu,
    15:36:07)
 
  - davidmichaelkarr is representing YANGIDE
    (anipbu,
    15:36:20)
 
  - davidmichaelkarr has tested RC2 in the sense
    that the yangide was downloaded today and tested.  Did not see any
    issues (anipbu,
    15:40:34)
 
  - https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template
    (jamoluhrsen,
    15:43:48)
 
  - davidmichaelkarr has agreed to mark all YANGIDE
    features as experimental (anipbu,
    15:48:02)
 
  - ACTION: davidmichaelkarr jamoluhrsen to follow up on
    publishing the test results and updating the experimental tag as
    appropriate. (anipbu,
    15:48:38)
 
  - YANGIDE approved for Boron pending action
    items.  Congratulations! (anipbu,
    15:51:41)
 
 
- YANGTOOLS (anipbu, 15:52:28)
  - https://wiki.opendaylight.org/view/YANG_Tools:Boron:Release_Review
    <--- Release Review (anipbu,
    15:52:33)
 
  - https://wiki.opendaylight.org/view/YANG_Tools:Boron:Release_Notes
    <--- Release Notes (anipbu,
    15:52:37)
 
  - rovarga is representing YANGTOOLS (anipbu,
    15:52:41)
 
  - ACTION: rovarga to
    update spreadsheet on RC2 testing for yangtools (anipbu,
    15:55:32)
 
  - yangtools has system test waiver (anipbu,
    15:55:45)
 
  - All yangtools features are marked as
    experimental (anipbu,
    15:56:11)
 
  - the plan is to introduce stable features in
    Carbon by splitting current features into smaller chunks
    (rovarga,
    15:56:56)
 
  - yangtools has tested RC2.  Status is green with
    no problems found. (anipbu,
    15:57:00)
 
  - no deprecation of api in yangtools for Boron
    release. only remove previously deprecated things (anipbu,
    16:00:18)
 
  - ACTION: rovarga to
    mentioned in the release notes the previously-deprecated things that
    have been removed in Boron (anipbu,
    16:01:44)
 
  - ACTION: anipbu to
    look into https://bugs.opendaylight.org/show_bug.cgi?id=5340 for
    future enhancement (anipbu,
    16:05:03)
 
  - YANGTOOLS approved for Boron pending action
    items.  Congratulations! (anipbu,
    16:05:18)
 
 
- EMAN (anipbu, 16:05:43)
  - https://lists.opendaylight.org/pipermail/eman-dev/2016-August/000022.html
    <--- csit analysis email for EMAN (jamoluhrsen,
    16:07:40)
 
  - all features experimental (jamoluhrsen,
    16:07:48)
 
  - https://wiki.opendaylight.org/view/Eman:Boron_Release_Notes
    <--- Release Notes (anipbu,
    16:07:57)
 
  - ACTION: george to
    generate release review template (anipbu,
    16:10:16)
 
  - ACTION: EMAN to
    reschedule (anipbu,
    16:10:17)
 
 
- HONEYCOMB/VBD (anipbu, 16:11:01)
  - https://wiki.opendaylight.org/view/Honeycomb/vbd:Boron:Release_Review
    <--- Release Review (anipbu,
    16:11:05)
 
  - https://wiki.opendaylight.org/view/Honeycomb/vbd:Boron:Release_Notes
    <--- Release Notes (anipbu,
    16:11:10)
 
  - wojdec1 is representing HONEYCOMB/VBD
    (anipbu,
    16:11:32)
 
  - no CSIT for honeycomb/vbd.  all features
    expiremental (jamoluhrsen,
    16:12:03)
 
  - vbd has tested RC2.  RC2 status now green with
    no problem found. (anipbu,
    16:15:04)
 
  - all vbd features are marked as experimental in
    boron (anipbu,
    16:17:53)
 
  - HONEYCOMB/VBD approved for Boron pending action
    items.  Congratulations! (anipbu,
    16:21:45)
 
  - NIC has asked to reschedule (anipbu,
    16:22:05)
 
  - ACTION: NIC to
    reschedule (anipbu,
    16:22:10)
 
 
- OPENFLOWPLUGIN (anipbu, 16:22:38)
  - https://lists.opendaylight.org/pipermail/openflowplugin-dev/2016-September/005943.html
    <--- email for boron csit analysis for openflowplugin (jamoluhrsen,
    16:23:52)
 
  - https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Review
    (abhijitkumbhare,
    16:24:10)
 
  - https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Boron_Release_Notes
    <--- Release Notes (anipbu,
    16:25:00)
 
  - abhijitkumbhare is representing
    OPENFLOWPLUGIN (anipbu,
    16:25:13)
 
  - openflowplugin has tested RC2 and found 3
    blockers (anipbu,
    16:28:15)
 
  - https://bugs.opendaylight.org/show_bug.cgi?id=6554
    (jozef bacigal) (abhijitkumbhare,
    16:28:50)
 
  - https://bugs.opendaylight.org/show_bug.cgi?id=6176
    (probably andrej leitner or tomas slusny) (abhijitkumbhare,
    16:29:29)
 
  - the three blocker bugs found in RC2 is:
    https://bugs.opendaylight.org/show_bug.cgi?id=6595 (shuva ),
    https://bugs.opendaylight.org/show_bug.cgi?id=6554 (jozef bacigal),
    https://bugs.opendaylight.org/show_bug.cgi?id=6176 (probably andrej
    leitner or tomas slusny) (anipbu,
    16:30:39)
 
  - only limitied documentation has been merged on
    or around openflowplugin (anipbu,
    16:31:37)
 
  - ACTION: abhijitkumbhare to update the release review with the
    list of features and their attributes (anipbu,
    16:33:08)
 
  - ACTION: jamoluhrsen:
    abhijitkumbhare: to follow up on CSIT tests and experimental tags
    for openflowplugin (anipbu,
    16:40:45)
 
  - ACTION: abhijitkumbhare to update the section under "Changes
    Since Previous Releases" including clarifying more content for
    "Migration", "Compatibility", "Deprecation" with some mention of the
    He design. (anipbu,
    16:42:30)
 
  - ACTION: openflowplugin to follow up with action items
    (anipbu,
    16:43:23)
 
  - ACTION: anipbu to
    follow up with openflowplugin (anipbu,
    16:43:33)
 
 
- cookies (anipbu, 16:46:19)
 
Meeting ended at 16:46:26 UTC
(full logs).
Action items
  - yuling_ to update the release review with the list of features and their attributes
 
  - yuling_ jamoluhrsen to follow up with CSIT test adn experimental tag of cassandra
 
  - anipbu to follow up with TSDR
 
  - RafatJahan to review this patch: https://git.opendaylight.org/gerrit/#/c/34875/
 
  - RafatJahan to update release view wiki page with the links to the asciidocs/rst files
 
  - RafatJahan to follow up with rovarga in addressing the fork of BGCEP in Carbon
 
  - vjanandr to test RC2
 
  - vjanandr to update the release review with the list of features and their attributes
 
  - colindixon to review https://git.opendaylight.org/gerrit/#/c/44983/
 
  - SNMP to reschedule.
 
  - ChristineH to update the release review with the list of features and their attributes
 
  - ChristineH_ and jamoluhrsen to follow up on publishing the test results and the experimental tag.
 
  - ChristineH_ to add adoc/rst links to release review
 
  - colindixon to update the release review with the list of features and their attributes
 
  - colindixon to test TTP for RC2 and report status of testing on here: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
 
  - YANG-PUSH to reschedule
 
  - davidmichaelkarr jamoluhrsen to follow up on publishing the test results and updating the experimental tag as appropriate.
 
  - rovarga to update spreadsheet on RC2 testing for yangtools
 
  - rovarga to mentioned in the release notes the previously-deprecated things that have been removed in Boron
 
  - anipbu to look into https://bugs.opendaylight.org/show_bug.cgi?id=5340 for future enhancement
 
  - george to generate release review template
 
  - EMAN to reschedule
 
  - NIC to reschedule
 
  - abhijitkumbhare to update the release review with the list of features and their attributes
 
  - jamoluhrsen: abhijitkumbhare: to follow up on CSIT tests and experimental tags for openflowplugin
 
  - abhijitkumbhare to update the section under "Changes Since Previous Releases" including clarifying more content for "Migration", "Compatibility", "Deprecation" with some mention of the He design.
 
  - openflowplugin to follow up with action items
 
  - anipbu to follow up with openflowplugin
 
Action items, by person
  -  abhijitkumbhare 
    - abhijitkumbhare to update the release review with the list of features and their attributes
 
    - jamoluhrsen: abhijitkumbhare: to follow up on CSIT tests and experimental tags for openflowplugin
 
    - abhijitkumbhare to update the section under "Changes Since Previous Releases" including clarifying more content for "Migration", "Compatibility", "Deprecation" with some mention of the He design.
 
  
 
  -  anipbu 
    - anipbu to follow up with TSDR
 
    - anipbu to look into https://bugs.opendaylight.org/show_bug.cgi?id=5340 for future enhancement
 
    - anipbu to follow up with openflowplugin
 
  
 
  -  ChristineH 
    - ChristineH to update the release review with the list of features and their attributes
 
  
 
  -  ChristineH_ 
    - ChristineH_ and jamoluhrsen to follow up on publishing the test results and the experimental tag.
 
    - ChristineH_ to add adoc/rst links to release review
 
  
 
  -  colindixon 
    - colindixon to review https://git.opendaylight.org/gerrit/#/c/44983/
 
    - colindixon to update the release review with the list of features and their attributes
 
    - colindixon to test TTP for RC2 and report status of testing on here: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
 
  
 
  -  davidmichaelkarr 
    - davidmichaelkarr jamoluhrsen to follow up on publishing the test results and updating the experimental tag as appropriate.
 
  
 
  -  george 
    - george to generate release review template
 
  
 
  -  jamoluhrsen 
    - yuling_ jamoluhrsen to follow up with CSIT test adn experimental tag of cassandra
 
    - ChristineH_ and jamoluhrsen to follow up on publishing the test results and the experimental tag.
 
    - davidmichaelkarr jamoluhrsen to follow up on publishing the test results and updating the experimental tag as appropriate.
 
    - jamoluhrsen: abhijitkumbhare: to follow up on CSIT tests and experimental tags for openflowplugin
 
  
 
  -  RafatJahan 
    - RafatJahan to review this patch: https://git.opendaylight.org/gerrit/#/c/34875/
 
    - RafatJahan to update release view wiki page with the links to the asciidocs/rst files
 
    - RafatJahan to follow up with rovarga in addressing the fork of BGCEP in Carbon
 
  
 
  -  rovarga 
    - RafatJahan to follow up with rovarga in addressing the fork of BGCEP in Carbon
 
    - rovarga to update spreadsheet on RC2 testing for yangtools
 
    - rovarga to mentioned in the release notes the previously-deprecated things that have been removed in Boron
 
  
 
  -  vjanandr 
    - vjanandr to test RC2
 
    - vjanandr to update the release review with the list of features and their attributes
 
  
 
  -  yuling_ 
    - yuling_ to update the release review with the list of features and their attributes
 
    - yuling_ jamoluhrsen to follow up with CSIT test adn experimental tag of cassandra
 
  
 
  - UNASSIGNED
    - SNMP to reschedule.
 
    - YANG-PUSH to reschedule
 
    - EMAN to reschedule
 
    - NIC to reschedule
 
    - openflowplugin to follow up with action items
 
  
 
People present (lines said)
  - anipbu (257)
 
  - jamoluhrsen (48)
 
  - colindixon (41)
 
  - yuling_ (39)
 
  - abhijitkumbhare (27)
 
  - RafatJahan (19)
 
  - davidmichaelkarr (18)
 
  - ChristineH_ (18)
 
  - rovarga (16)
 
  - vjanandr (15)
 
  - odl_meetbot (10)
 
  - vrpolak (9)
 
  - george (5)
 
  - wojdec1 (5)
 
  - LuisGomez (4)
 
  - zxiiro (3)
 
  - ChristineH (3)
 
Generated by MeetBot 0.1.4.