#opendaylight-meeting: boron release review

Meeting started by anipbu at 17:30:34 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 17:30:40)
    1. anipbu for release (anipbu, 17:30:45)

  2. CONTROLLER (anipbu, 17:32:31)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Review <--- Release Review (anipbu, 17:32:36)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Notes <--- Release Notes (anipbu, 17:32:40)
    3. rovarga is representing CONTROLLER (anipbu, 17:32:49)
    4. rovarga states controller has no other blocker bugs in RC3 except for 6540 (anipbu, 17:35:23)
    5. ACTION: rovarga will catch up on regression report (anipbu, 17:35:44)
    6. ACTION: rovarga to update the deprecated API section (anipbu, 17:39:00)
    7. https://jenkins.opendaylight.org/releng/view/controller/ <--- Controller has system tests that are failing and therefore do not meet test expectations of being nonexperimental (anipbu, 17:40:36)
    8. ACTION: rovarga to follow up with integration/test team on the experimental tag for controller (anipbu, 17:40:55)
    9. ACTION: rovarga to update the release review with the list of features and their attributes (anipbu, 17:41:37)
    10. project governance will need to be solved, I will take some time at the DDF to draft some options (rovarga, 17:43:16)
    11. ACTION: rovarga to update the section on bugzilla: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Review#Bugzilla_.28summary_of_bug_situation.29 (anipbu, 17:43:40)
    12. this will probably involve splitting up the live parts into a project and abandoning the rest (rovarga, 17:44:00)
    13. rovarga states that controller delivered the code bits, but there were no resources to take care of the collateral. even sending out statuses was problematic (anipbu, 17:44:16)
    14. CONTROLLER approved for Boron pending action items. Congratulations! (anipbu, 17:45:44)

  3. MDSAL (anipbu, 17:45:54)
    1. https://wiki.opendaylight.org/view/MD-SAL:Boron:Release_Review <--- Release Review (anipbu, 17:46:16)
    2. https://wiki.opendaylight.org/view/MD-SAL:Boron:Release_Notes <--- Release Notes (anipbu, 17:46:20)
    3. rovarga is representing MDSAL (anipbu, 17:46:27)
    4. the only blocker currently is the 6540 situation, otherwise we're good. It can be degraded to critical (rovarga, 17:47:36)
    5. binding specification v2 is the experimental feature, as it is preview quality only and is not tested (anipbu, 17:50:36)
    6. we do not have any user-facing features (anipbu, 17:50:40)
    7. ACTION: rovarga to update the release review template to state that binding specification v2 is the *experimental* feature (anipbu, 17:51:25)
    8. MDSAL received a system test waiver for Boron:https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Waiver/System_Test#MD-SAL (anipbu, 17:52:27)
    9. all mdsal features are nonexperimental (anipbu, 17:55:30)
    10. ACTION: rovarga to update the release review with the list of features and their attributes (anipbu, 17:56:00)
    11. ACTION: rovarga to update the release review template with the links to the adoc/rst documentation guides (anipbu, 17:56:29)
    12. rovarga states that same thing about governance applies here as well, but I think we have better options in the project (anipbu, 18:00:37)
    13. MDSAL approved for Boron pending action items. Congratulations! (anipbu, 18:01:31)

  4. cookies (anipbu, 18:02:36)


Meeting ended at 18:02:42 UTC (full logs).

Action items

  1. rovarga will catch up on regression report
  2. rovarga to update the deprecated API section
  3. rovarga to follow up with integration/test team on the experimental tag for controller
  4. rovarga to update the release review with the list of features and their attributes
  5. rovarga to update the section on bugzilla: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Review#Bugzilla_.28summary_of_bug_situation.29
  6. rovarga to update the release review template to state that binding specification v2 is the *experimental* feature
  7. rovarga to update the release review with the list of features and their attributes
  8. rovarga to update the release review template with the links to the adoc/rst documentation guides


Action items, by person

  1. rovarga
    1. rovarga will catch up on regression report
    2. rovarga to update the deprecated API section
    3. rovarga to follow up with integration/test team on the experimental tag for controller
    4. rovarga to update the release review with the list of features and their attributes
    5. rovarga to update the section on bugzilla: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Boron:Release_Review#Bugzilla_.28summary_of_bug_situation.29
    6. rovarga to update the release review template to state that binding specification v2 is the *experimental* feature
    7. rovarga to update the release review with the list of features and their attributes
    8. rovarga to update the release review template with the links to the adoc/rst documentation guides


People present (lines said)

  1. anipbu (61)
  2. rovarga (19)
  3. odl_meetbot (6)
  4. jamoluhrsen (4)
  5. hideyuki (3)


Generated by MeetBot 0.1.4.