#opendaylight-meeting: kernel projects

Meeting started by colindixon at 17:05:42 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:05:49)
    1. no major topics for today (colindixon, 17:07:16)

  2. bugs query to do bug scrub going forward (colindixon, 17:07:32)
    1. ryan did this (colindixon, 17:07:40)
    2. https://bugs.opendaylight.org/buglist.cgi?list_id=46270&order=product%2Cchangeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- all bugs in kernel projects (colindixon, 17:07:52)
    3. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- critical/major bugs in kernel projects (colindixon, 17:08:03)
    4. https://github.com/vorburger/opendaylight-eclipse-setup (vorburger, 17:09:00)

  3. using oomph to manage maven projects (colindixon, 17:10:02)
    1. https://github.com/vorburger/opendaylight-eclipse-setup#how-to-add-additional-m2e-lifecycle-mapping information about how it can be done and made relatively easy (colindixon, 17:10:14)
    2. it sounds like the next steps are getting things to work so that eclipse can build in a separate environment with a separate target so eclipse actually works (colindixon, 17:12:35)
    3. vorburger says that he's done out about 8 gerrits that fix this and it should all work now (colindixon, 17:12:58)
    4. as far as vorburger knows, this is all done and working as of about 4 hours ago: https://lists.opendaylight.org/pipermail/dev/2016-November/002896.html (colindixon, 17:14:16)
    5. many, many kudos to vorburger for doing all this hard work (colindixon, 17:14:44)
    6. colindixon asks why vorburger uses Eclipse over IntelliJ, he answers 1.) it's what he's used to and 2.) philosophically Eclipse is much more open source and community oriented (colindixon, 17:16:12)

  4. config filtering parent (colindixon, 17:19:04)
    1. https://git.opendaylight.org/gerrit/#/c/44561/ vrpolak says that this should be ready to merge it (colindixon, 17:19:22)
    2. skitt asks why we want to add a new parent to stable/boron, is there some fetures that we need to backport that depend on this (colindixon, 17:20:07)
    3. vrpolak says that this is really a way to get a better way to specify the version that the distribution reports (colindixon, 17:21:55)
    4. https://git.opendaylight.org/gerrit/#/q/project:controller+status:merged+NOT+owner:%22Tom+Pantelis+%253Ctpanteli%2540brocade.com%253E%22 (colindixon, 17:23:47)

  5. log messages database (colindixon, 17:27:27)
    1. https://git.opendaylight.org/gerrit/#/c/39410/ (colindixon, 17:27:29)
    2. https://lists.opendaylight.org/pipermail/dev/2016-November/002894.html colindixon's mail picking up this thread (colindixon, 17:28:39)
    3. vorburger says that first stage is to get this patch to run everywhere so that we can actaully have a catalog we can use going forward (colindixon, 17:30:58)
    4. vorburger says that we have this extraction checker that isn't running everywhere because it's in the yangtools checkstyle logging and in the odlparent checkstyle we're not allowed to depend on them (colindixon, 17:31:38)
    5. vorburger had been planning to submit the checkstyle rules to the public checkstyle so that we could deal with it in a sane way (colindixon, 17:32:30)
    6. ACTION: vorburger will push the yangtools publicly usable checkstyle things into the upstream checkstyle rules so that it also works for IDEs (colindixon, 17:34:30)
    7. in the long run, vorburger argues that the "right" way to get stable log messages would be to use some new facade that would give unique IDs to each log message, e.g., JBOSS logging (colindixon, 17:35:11)
    8. skitt says this hasn't succeeded in his experience except at IBM in a closed environment because it makes logging hard (colindixon, 17:35:36)
    9. skitt says that using gettext-based methods to use the english text as the log message ID + some lightweight translation to deal with when you edit it or translate it into other languages (colindixon, 17:37:23)
    10. skitt says that there are cool things he's used where logstash lets you click on surprising error messages in logstash to file a bug, that would be cool here (colindixon, 17:39:12)
    11. https://github.com/sevntu-checkstyle/sevntu.checkstyle/issues/461 is what I'll have to start on picking up - I had dropped the ball on that. If anyone has capacity to help with that, please contact me! (vorburger, 17:41:07)
    12. ryan also says that if there are particular log messages that annoy us, we should open bugs for it (colindixon, 17:41:35)
    13. adetalhouet points out that many of the most annoying log messages come from the config subsystem, which is slowly being phased out (colindixon, 17:43:17)

  6. deprecating or removing config subsystem (colindixon, 17:44:08)
    1. colindixon asks if we can remove config subsystem in carbon, adetalhouet says that ~2/3s of ODL still uses the config subsystem (colindixon, 17:44:44)
    2. ACTION: colindixon will bring up the issue of maybe deprecating the config subsystem in carbon and/or saying we will do it in the future (colindixon, 17:47:43)
    3. skitt says that a lot of projects fall into one of two bits: so inactive they don't even merge patches even if you give them for free, and so active that people ignore things until they're actually removed (colindixon, 17:49:02)
    4. a good example of the second one is the Data Tree Change Listener (colindixon, 17:49:18)
    5. ACTION: colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things (colindixon, 17:53:38)

  7. patch review (colindixon, 17:53:51)
    1. https://github.com/awaitility/awaitility (vorburger, 17:54:29)
    2. https://git.opendaylight.org/gerrit/#/c/48109/ both skitt and vorburger say that awaitility is really nice and it's already introduced and can be used (colindixon, 17:54:47)
    3. lots of people talking about query and depth parameters with patches come in (colindixon, 18:01:52)


Meeting ended at 18:01:55 UTC (full logs).

Action items

  1. vorburger will push the yangtools publicly usable checkstyle things into the upstream checkstyle rules so that it also works for IDEs
  2. colindixon will bring up the issue of maybe deprecating the config subsystem in carbon and/or saying we will do it in the future
  3. colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things


Action items, by person

  1. colindixon
    1. colindixon will bring up the issue of maybe deprecating the config subsystem in carbon and/or saying we will do it in the future
    2. colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
  2. vorburger
    1. vorburger will push the yangtools publicly usable checkstyle things into the upstream checkstyle rules so that it also works for IDEs


People present (lines said)

  1. colindixon (58)
  2. vorburger (7)
  3. skitt (7)
  4. odl_meetbot (7)
  5. adetalhouet (6)
  6. rovarga (2)


Generated by MeetBot 0.1.4.