#opendaylight-meeting: kernel_projects

Meeting started by Sai_ at 16:57:58 UTC (full logs).

Meeting summary

  1. - previous-meeting-minutes (Sai_, 16:58:40)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/kernel_projects/opendaylight-meeting-kernel_projects.2016-12-06-16.56.html (Sai_, 16:59:05)

  2. - Agenda (Sai_, 16:59:12)
    1. - Action items (Sai_, 16:59:42)
    2. - Call for any topics to be added (Sai_, 16:59:55)
    3. - BUG-5902 API Explorer does not work (Sai_, 17:00:15)
    4. - Core dashboards (Sai_, 17:00:32)

  3. - Call for any topics to be added (Sai_, 17:03:23)
  4. - Review action items (Sai_, 17:03:43)
    1. ACTION: - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things (Sai_, 17:05:51)

  5. - BUG-5902 API Explorer does not work (Sai_, 17:06:52)
    1. - BUG-5902 API Explorer does not work if started as http://admin:admin@localhost:8181/apidoc/explorer/index.html (Sai_, 17:07:08)
    2. ACTION: - ryan to check with Martin offline wrt Bug 5902 (Sai_, 17:07:31)

  6. - odlparent SingleFeatureTest improvement (Sai_, 17:07:54)
    1. - https://git.opendaylight.org/gerrit/#/c/48901/ (Sai_, 17:08:06)
    2. - SingleFeatureTest now fails if diag CLI command would have failed (Sai_, 17:08:58)
    3. - The patch will help us detect a whole range of issues, notably any blueprint related problems, much earlier in our development cycle than we currently are. (Sai_, 17:09:22)
    4. - Stephen points that karaf4 might be useful here. (Sai_, 17:10:09)
    5. ACTION: - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit https://git.opendaylight.org/gerrit/#/c/48901/ (Sai_, 17:11:42)
    6. - Michael requests someone to volunteer for css work (Sai_, 17:15:56)
    7. - Alexis volunteers to help Micheal with css work. (Sai_, 17:16:33)
    8. - Michael points that it won't increase any build time. (Sai_, 17:17:22)

  7. - infrautils Caches infra (Sai_, 17:17:32)
    1. - https://git.opendaylight.org/gerrit/#/c/48920/ (Sai_, 17:17:43)
    2. - Ideally, It should be faster to go ahead and read cache rather than reading in MD-SAL (Sai_, 17:19:08)
    3. - colin points that currently there is no caching in MD-SAL binding aware, If you have clustering enabled all reads will end up as local reads (Sai_, 17:20:13)
    4. - Robert asks that how does read trigger ? rather than reading , can we do it ahead of time by DTCL. (Sai_, 17:24:16)
    5. - Micheal points that caches already exists in some projects (Genius) (Sai_, 17:25:31)
    6. basically, there are two ways this would likely help: (1) avoid the serialization from BindingIndependent to BindingAaware classes tha thappens on ever DataStore read, (2) it could allow for (possibly stale) local reads from the cache instead of reading from the shard leader (colindixon, 17:26:24)
    7. lotos of discussion here about what might make sense in the longer run, but colindixon would like to note that shoudln't stop progress now (colindixon, 17:26:56)

  8. - Review code change dashboards (Sai_, 17:31:12)
    1. - Robert asks if there is any update on karaf4 (Sai_, 17:32:12)
    2. - Stephen is working on it, requested help from controller project in mailing list. (Sai_, 17:33:02)
    3. - All projects (possibly) need work on features.xml augmentation. (Sai_, 17:35:01)
    4. - since it is not a part of feature freeze, it should be ok. (Sai_, 17:35:56)
    5. - Ryan volunteers to help on projects wrt changing features.xml (Sai_, 17:37:03)
    6. - Robert points colindixon to add this topic in this week TSC meeting. (Sai_, 17:38:36)
    7. - Patch wrt Call-Home functionality exists (not merged yet) in controller project, pushed by Bala. (Sai_, 17:41:15)
    8. - Alexis is interested in providing feedback (Sai_, 17:41:47)
    9. - Robert asks if is integrated wrt AAA, Ryan volunteers to review (Sai_, 17:42:26)
    10. - TomP / Alexis request to breakdown the patch in to several patches (Sai_, 17:42:54)
    11. ACTION: - Bala to add notes (or breakdown patches in to several patches) for patch change id - 49253 (Sai_, 17:45:07)
    12. - Alexis requests one of the netconf committer to review the patch (Sai_, 17:48:27)

  9. - Participants (Sai_, 17:50:40)
    1. - Sai / Ryan / Alexis / Bala / Colin / Igor / Michael / Robert / Stephen / TomP / Viera / Vratko (Sai_, 17:51:42)


Meeting ended at 17:51:48 UTC (full logs).

Action items

  1. - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
  2. - ryan to check with Martin offline wrt Bug 5902
  3. - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit https://git.opendaylight.org/gerrit/#/c/48901/
  4. - Bala to add notes (or breakdown patches in to several patches) for patch change id - 49253


Action items, by person

  1. colindixon
    1. - colindixon to add a topic for next week or maybe an e-mail about how to mechanically potentially allow us to special case true-leaf projects to avoid things
  2. UNASSIGNED
    1. - ryan to check with Martin offline wrt Bug 5902
    2. - Michael to discuss with Stephen regarding karaf 4 distribution wrt gerrit https://git.opendaylight.org/gerrit/#/c/48901/
    3. - Bala to add notes (or breakdown patches in to several patches) for patch change id - 49253


People present (lines said)

  1. Sai_ (49)
  2. odl_meetbot (5)
  3. adetalhouet (4)
  4. colindixon (2)
  5. rovarga (1)


Generated by MeetBot 0.1.4.