#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 16:59:46 UTC (full logs).

Meeting summary

  1. last meeting action items (Sai, 17:01:16)
    1. - last meeting notes https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-01-19-17.00.html (Sai, 17:01:54)

  2. Agenda bashing (Sai, 17:02:20)
    1. I think the major topics we want to hit today are (i) blocking/critical bugs, (ii) outstanding patches on master, and (iii) boron planning if we have time (colindixon, 17:03:29)
    2. Agenda items - OpenDaylight Developer's Forum Attendance Query Bug 4969: there is a patch in master, will there be a cherry pick to stable/beryllium? Bug 3934: there is a patch in master, will there be a cherry pick to stable/beryllium? Bug 3866: there is a patch in master, will there be a cherry pick to stable/beryllium? Revisionless import; is this being tracked? RC0 issues (Sai, 17:04:59)

  3. OpenDaylight Developer's Forum Attendance Query (Sai, 17:05:23)
    1. Ryan/Colin/Tom P / Robert/ Sai are attending sessions. (Sai, 17:06:42)
    2. a better place to chat regarding boron planning (Sai, 17:06:52)

  4. Bug 4969 (Sai, 17:07:05)
    1. - JSONCodecFactory NPE (Sai, 17:08:14)
    2. - Ryan asks can we expect a cherry pick before sometime release ? (Sai, 17:08:35)
    3. - Tony says yes (Sai, 17:08:42)
    4. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- blocking and critical bugs in yangtools, controller, mdsal, odlparent, netconf, and aaa (colindixon, 17:08:48)

  5. Bug 3934 (Sai, 17:09:05)
    1. Tony says patch is on master ..ready to be cherry picked to beryllium. (Sai, 17:10:10)
    2. - Ryan asks is there any plan to cherry pick to lithium/stable (Sai, 17:10:42)
    3. - Updated comment in bugzilla (Sai, 17:11:13)

  6. Bug 3866 (Sai, 17:11:23)
    1. Tony says it doesn't go to lithium (Sai, 17:11:47)

  7. Bug 4684 (Sai, 17:12:11)
    1. - Ryan asks Steven if he checked on this bug, Steven says he is going to check it. (Sai, 17:12:44)

  8. Bug 5019 (Sai, 17:13:14)
    1. - Tom P says patches are ready - Robert is going to send waiver notification. (Sai, 17:13:53)

  9. Ownership of bugs (Sai, 17:14:33)
    1. - there are bugs opened but none responds to email threads (Sai, 17:14:58)

  10. Bug 2974 (Sai, 17:15:39)
    1. - Tony is working on it (Sai, 17:15:45)

  11. Bug 2912 (Sai, 17:16:03)
    1. - Tony says he didn't get time to change documentation. Just needs a change in java docs. (Sai, 17:16:39)
    2. - updated in bugzilla (Sai, 17:16:58)

  12. Ownership of bugs (Sai, 17:17:48)
    1. - bugs with 4k series are related to 5 node cluster (Sai, 17:18:08)
    2. - Tony asks do we officially support 5 node cluster ? (Sai, 17:18:32)
    3. - Tony says official support for lithium it is 3 node .. Colin says we don't provide documentation for 5 node cluster. It only should be less supported but not supported. (Sai, 17:19:35)
    4. - Bug 4164 is a 3 node cluster query (Sai, 17:20:16)
    5. - Colin changed Bug 4164 to resolved & Won't fix (Sai, 17:21:25)
    6. - Bug 4664 (Sai, 17:22:02)
    7. - is it (4164) a duplicate of Bug 5019 ? (Sai, 17:23:10)
    8. ACTION: - marked as duplicate of 5019. Anil will reach out when it is fixed. (Sai, 17:25:17)
    9. Bug 4574 5 node cluster (Sai, 17:25:49)
    10. colin suggests to decrease priority since it deals with 5 node cluster (Sai, 17:26:16)
    11. updated comments in bugzilla (Sai, 17:27:52)
    12. - 4572 a 5 node cluster bug (Sai, 17:28:12)
    13. - decreased priority since it is 5 node (Sai, 17:29:35)
    14. - Added Anil as watcher for all the 5 node clusters (Sai, 17:29:50)
    15. Bug 4484 (Sai, 17:30:32)
    16. decreased priority & added Anil as watcher. (Sai, 17:30:45)
    17. Bug 5099 (Sai, 17:33:02)
    18. ACTION: - Ryan will follow up on bug 5099 (Sai, 17:33:19)
    19. Bug 5101 target for beryllium, 5087/6/5 are targetted for boron. (Sai, 17:34:53)
    20. 4588/4784 targeted for boron (Sai, 17:35:14)
    21. - Bug 4771 targeted for boron. (Sai, 17:35:59)
    22. - Bug 4771 - Tony says will be more documented when they start working on boron. (Sai, 17:37:35)
    23. Bug 5103 - Entity ownership service - Ryan asks should there be a bug opened for it in openflow plugin ? (Sai, 17:40:45)
    24. ACTION: Ryan follows up with Robert on bug 5103 - regarding opening a new bug in openflow plugin. (Sai, 17:41:51)
    25. - Added SR target milestone to boron (Sai, 17:43:05)
    26. - resetted SR target milestone (Sai, 17:44:46)
    27. - Bug 5096 - (Sai, 17:46:09)
    28. ACTION: Tony needs to follow up Bug 5096 with MD-SAl netconf commiters (Sai, 17:46:44)

  13. Revisionless import (Sai, 17:47:55)
    1. bug is 2974 but not 3975 (Sai, 17:49:49)
    2. Boron planning will be discussed in next meeting (Sai, 17:51:17)
    3. ACTION: - Ryan will capture the notes ahead of meeting for boron planning (Sai, 17:52:06)


Meeting ended at 17:52:17 UTC (full logs).

Action items

  1. - marked as duplicate of 5019. Anil will reach out when it is fixed.
  2. - Ryan will follow up on bug 5099
  3. Ryan follows up with Robert on bug 5103 - regarding opening a new bug in openflow plugin.
  4. Tony needs to follow up Bug 5096 with MD-SAl netconf commiters
  5. - Ryan will capture the notes ahead of meeting for boron planning


People present (lines said)

  1. Sai (68)
  2. odl_meetbot (5)
  3. colindixon (4)


Generated by MeetBot 0.1.4.