#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai_ at 16:58:44 UTC (full logs).

Meeting summary

  1. last-meeting-notes (Sai_, 17:01:07)
    1. #topic https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-01-26-16.59.html (Sai_, 17:01:19)

  2. Agenda-bashing (Sai_, 17:02:02)
    1. - followup of previous meeting action items- - marked as duplicate of 5019. Anil will reach out when it is fixed. - Ryan will follow up on bug 5099 Ryan follows up with Robert on bug 5103 - regarding opening a new bug in openflow plugin. Tony needs to follow up Bug 5096 with MD-SAl netconf commiters - Ryan will capture the notes ahead of meeting for boron planning (Sai_, 17:02:43)
    2. - today's agenda (Sai_, 17:02:53)
    3. - Call for any other topics, Bug 4948 Discussion, Review any outstanding major or critical bugs RC-0 Issues. (Sai_, 17:03:19)
    4. ACTION: - Ryan will followup with Anil wrt 5019 (Sai_, 17:05:34)
    5. - Ryan requests Tony to update the Bug 5099 (Sai_, 17:06:26)
    6. - Robert says Bug 5103 is boron work. (Sai_, 17:07:06)
    7. - Bug 5096 - No update from Joseph - Updated comments in bugjilla (Sai_, 17:08:02)
    8. ACTION: - Ryan ensures there will boron planning discussion in next week's meeting. Requests users to come up with any list of plan for Boron planning. (Sai_, 17:09:40)
    9. - Robert says discussion should be generic through email list and then dig in to details. He is not sure whether we can dive in to individual points at this point. (Sai_, 17:10:54)
    10. - Robert says we nee to build an agenda for developer summit. (Sai_, 17:11:53)
    11. - Ryan agrees to it. (Sai_, 17:12:08)

  3. Review critical bugs (Sai_, 17:13:33)
    1. - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46894&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_format=advanced&resolution=--- (Sai_, 17:13:57)

  4. - Bug-4948 (Sai_, 17:14:12)
    1. - Bala is original author and consensus is required on pushing the patch. (Sai_, 17:14:42)
    2. - Bala says tested against both lithium / beryllium and works good. (Sai_, 17:15:18)
    3. - Bala says we are at the mercy of netconf - it is a benign fix. (Sai_, 17:16:33)
    4. - Bala explained the patch in detail and followed up the comments in git. (Sai_, 17:17:19)
    5. - Bala is unclear which exact runtime exception is being thrown by the code. (Sai_, 17:19:37)
    6. - Tony says having specific exceptions from device is better. (Sai_, 17:20:18)
    7. - Colindixon says everyone agrees on long term plan. Bala's patch preserves behaviour. (Sai_, 17:21:49)
    8. - Bala says the current code is well tested against devices (Sai_, 17:22:37)
    9. - Colindixon says bugs against SR1 (Sai_, 17:23:34)
    10. ACTION: - Tony pushes the fix provided a comment in the patch of 4948 is added which ensures how and where the fix against particular devices is done. (Sai_, 17:25:48)
    11. ACTION: - Wrt Bug 4948 - Bala opens a new bug against Beryllium SR1 so as to satisfy the comments in the git. (Sai_, 17:26:40)
    12. - Bala says he is not clear why the code is specific against all particular devices, but it should be generic to all devices. (Sai_, 17:28:00)
    13. - Tony says this was the MD-SAL proposal last year, he was against it. This is the consequence of it. (Sai_, 17:28:36)

  5. Bug5019 (Sai_, 17:29:48)
  6. 2916 (Sai_, 17:30:46)
    1. tony didn;t get a chance to go through (Sai_, 17:31:01)

  7. 3866 (Sai_, 17:31:10)
    1. - Tony will update the bug (Sai_, 17:31:27)

  8. Bug 5135 (Sai_, 17:31:39)
    1. - Tony says it is related to clustering. (Sai_, 17:32:46)
    2. ACTION: - Ryan will followup with Anil & others (please go through comments section in bugzilla) wrt Bug 5135 (Sai_, 17:34:15)

  9. Bug-5153 (Sai_, 17:34:26)
    1. - TomP haven't see this. Clustering call is dominated with performance issues. (Sai_, 17:35:21)
    2. ACTION: - Ryan will followup on Bug 5153 (Sai_, 17:35:52)

  10. - revisionless import Bug 2974 (Sai_, 17:36:13)
    1. - Tony says it is still in progress. Decreased priority to major , since we have a workaround. (Sai_, 17:37:00)

  11. - Bug 1435 (Sai_, 17:39:28)
    1. - Tony requests TomP to look in to it. (Sai_, 17:39:32)
    2. - updated status to blocker (Sai_, 17:39:40)
    3. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1798258463 (anipbu, 17:40:03)

  12. RC1 issue (Sai_, 17:40:16)
    1. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1798258463 (Sai_, 17:40:24)
    2. - Anibu requests everyone to go through the two controller bugs (Sai_, 17:41:16)
    3. TomP thinks these are sporadic, should be fine with a re-run. (Sai_, 17:42:16)
    4. -https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-all-beryllium/101/ (Sai_, 17:45:08)
    5. - https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-only-beryllium/540/ (Sai_, 17:45:35)
    6. ACTION: - Ryan will follow up with Luis wrt https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-all-beryllium/101/ (Sai_, 17:46:49)

  13. controller bootup and restconf calls (Sai_, 17:48:38)
    1. - Colindixon is it safe to make to make the RESTconf calls as soon as the controller shows up. Adding jjust timeout is not the solution. (Sai_, 17:48:42)
    2. - Robert says it is long standing discussion, (how do we know when is the controller completely installed / initialized). (Sai_, 17:49:51)
    3. https://lists.opendaylight.org/pipermail/discuss/2016-January/006127.html (rovarga, 17:50:40)
    4. ACTION: - Ryan goes through archive wrt controller completely being installed/initialized and comes up with a plan (Sai_, 17:50:52)
    5. - participants - Ryan, Sai, Abhijit, Alexis, An Ho, Bala, Colin, Gary Wu, Robert Varga, Stephen Kitt, Tcere, Tom P , Tony, Viera (Sai_, 17:52:07)


Meeting ended at 17:52:31 UTC (full logs).

Action items

  1. - Ryan will followup with Anil wrt 5019
  2. - Ryan ensures there will boron planning discussion in next week's meeting. Requests users to come up with any list of plan for Boron planning.
  3. - Tony pushes the fix provided a comment in the patch of 4948 is added which ensures how and where the fix against particular devices is done.
  4. - Wrt Bug 4948 - Bala opens a new bug against Beryllium SR1 so as to satisfy the comments in the git.
  5. - Ryan will followup with Anil & others (please go through comments section in bugzilla) wrt Bug 5135
  6. - Ryan will followup on Bug 5153
  7. - Ryan will follow up with Luis wrt https://jenkins.opendaylight.org/releng/job/controller-csit-3node-clustering-all-beryllium/101/
  8. - Ryan goes through archive wrt controller completely being installed/initialized and comes up with a plan


People present (lines said)

  1. Sai_ (70)
  2. odl_meetbot (7)
  3. rovarga (1)
  4. anipbu (1)
  5. colindixon (0)


Generated by MeetBot 0.1.4.