#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 17:13:21 UTC (full logs).

Meeting summary

  1. Agenda (Sai, 17:14:03)
    1. - Agenda Items - 0. Previous meeting Action items 1. Hash over the Action Items for February 2, 2016 Meeting 2. Beryllium Blockers/Issues 3. Developers Forum Query 4. Boron Planning 5. Possibility of Deprecating DataChangeListener in favor of DataTreeChangeListener? 6. Possibility of Deprecating Netconf mount through config subsystem (Sai, 17:14:14)

  2. Previous meeting Action items (Sai, 17:14:34)
    1. - Bug 5135 - Ryan asks Tony if this is an actual issue ? Tony says we need to confirm if it is a duplicate. (Sai, 17:14:42)
    2. ACTION: - Bug 5135 Ryan followup with Anil (Sai, 17:14:48)
    3. - Bug 5153 - Luis not able to reproduce. (Sai, 17:14:54)
    4. - uncommon scenario - TomP needs counters for debugging but not Tx Id (Sai, 17:17:07)
    5. - TomP says he can use UUID and try to fix (not to overkill) (Sai, 17:18:36)
    6. - Targeted not for Be. Bug exists from Day1. It is not a blocker. (Sai, 17:19:33)

  3. - Beryllium Blockers/Issues (Sai, 17:21:06)
    1. -Bug4866 - Anil/TomP have added patches (Sai, 17:22:10)
    2. - Bug5153 - Luis says it is not a blocker (Sai, 17:22:42)
    3. for critical bugs - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46894&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_format=advanced&resolution=--- (Sai, 17:23:32)
    4. - Bug4866 - decreased priority of 4866 - because several bugs others are created. Change status to Waiting for Review. Anil fix in openflowplugin bypasses the new RPC (missing retries & changing routing table) (Sai, 17:27:05)
    5. - Ryan requests TomP to create a new bug wrt Bug4866 (Sai, 17:27:37)
    6. ACTION: - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed) (Sai, 17:28:17)
    7. - Bug5247 - It has a patch for master. (Sai, 17:29:36)
    8. - TomP waiting since it says -1 from jenkins. (Sai, 17:30:01)
    9. - Tony says TomP & Robert needs to figure it out. (Sai, 17:30:16)
    10. ACTION: - Robert updates Bug5247 (Sai, 17:31:41)
    11. - Bug1435 - Tony says not aimed for Be. (Sai, 17:32:17)
    12. - Ryan changes milestone to Be-1 (Sai, 17:33:25)
    13. - Bug2912 - Tony fixes comments (Sai, 17:34:25)
    14. ACTION: - Tony fixes Bug2912 (Sai, 17:34:40)

  4. - Developers Forum Query (Sai, 17:35:13)
    1. - Ryan requests everyone to take atleast one action item on the project they work on so that we can prepare better for developer forum. (Sai, 17:36:46)
    2. - colindixon says there are complications in splitting core MD-SAl - we should discuss the advantages of splitting in forum. (Sai, 17:37:27)
    3. - colindixon says it helps users in resolving ambiguity about the importance and reasoning behind splitting projects. (Sai, 17:39:46)

  5. - Boron Planning (Sai, 17:40:13)
    1. - Possibility of Deprecating DataChangeListener in favor of DataTreeChangeListener? (Sai, 17:40:36)
    2. - TomP & Tony echos people find it easy with DTCL (much deeper access) (Sai, 17:42:53)
    3. - Ryan asks how do we document to make it to easier for people who are trying to use DTCL (Sai, 17:44:02)
    4. - Tony says he needs to checkout the patches (Sai, 17:44:19)
    5. - colindixon says we need have this where ONOS seems better. (Sai, 17:44:56)
    6. ACTION: - colindixon opens an improvement bug wrt improving usability of DTCL (Sai, 17:45:46)
    7. - Possibility of Deprecating Netconf mount through config subsystem (Sai, 17:46:41)
    8. ACTION: - Ryan follows up with Tony wrt Possibility of Deprecating Netconf mount through config subsystem (Sai, 17:48:19)

  6. - Java8 features (Sai, 17:49:05)
    1. - colindixon says we can use java8 features in master (Sai, 17:49:33)
    2. - An Ho says patch has been merged. (Sai, 17:50:31)
    3. - colindixon says it is a really good example for fixing downstream/upstream issues. (Sai, 17:51:28)

  7. attendees (Sai, 17:54:24)


Meeting ended at 17:54:43 UTC (full logs).

Action items

  1. - Bug 5135 Ryan followup with Anil
  2. - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed)
  3. - Robert updates Bug5247
  4. - Tony fixes Bug2912
  5. - colindixon opens an improvement bug wrt improving usability of DTCL
  6. - Ryan follows up with Tony wrt Possibility of Deprecating Netconf mount through config subsystem


Action items, by person

  1. colindixon
    1. - colindixon opens an improvement bug wrt improving usability of DTCL
  2. UNASSIGNED
    1. - Bug 5135 Ryan followup with Anil
    2. - TomP to create a new bug wrt Bug4866 (Ryan is closing out bug4866 as fixed)
    3. - Robert updates Bug5247
    4. - Tony fixes Bug2912
    5. - Ryan follows up with Tony wrt Possibility of Deprecating Netconf mount through config subsystem


People present (lines said)

  1. Sai (51)
  2. odl_meetbot (5)
  3. LuisGomez (4)
  4. colindixon (2)
  5. oflibMichal (1)
  6. phrobb (1)
  7. jamoluhrsen (1)


Generated by MeetBot 0.1.4.