#opendaylight-meeting: MD-SAL Interest Call

Meeting started by colindixon at 16:00:30 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:00:37)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-06-21-16.01.html previous week's minutes (colindixon, 16:00:48)
    2. 1.) Upgrade ietf-{inet,yang}-types to 2013-07-15 (colindixon, 16:01:58)
    3. 2.) Infrastructure Issues; are they solved or ongoing? (colindixon, 16:02:10)
    4. 3.) Review the new Dashboards (colindixon, 16:02:21)
    5. 4.) Karaf 3.0.7 upgrade (colindixon, 16:02:35)

  2. action items from last week (colindixon, 16:03:49)
    1. ACTION: Ryan will followup with Tony regarding M3 status. Tony said it would be done by 06/14/2016 (colindixon, 16:05:37)
    2. https://wiki.opendaylight.org/view/Using_Blueprint#Application_configuration (rgoulding, 16:06:16)
    3. Alexis and Ryan updated the blueprint guide for migration with information about the toaster (see above link about Application configuration) (colindixon, 16:07:55)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=6121 LazyDataObject bug opened by Ryan (colindixon, 16:08:19)
    5. ACTION: TomP to document in wiki regarding "specific-reference-list" blueprint extension.- corresponding gerrit patch - https://git.opendaylight.org/gerrit/#/c/40267 (colindixon, 16:08:32)
    6. https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit (rgoulding, 16:11:06)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=5973 (rgoulding, 16:11:12)
    8. the above two links are about trying to remove very old dependenceis from controller (colindixon, 16:11:45)
    9. ACTION: skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we thnk are erroneous at this point) (colindixon, 16:12:05)

  3. Upgrade ietf-{inet,yang}-types to 2013-07-15 (colindixon, 16:12:36)
    1. https://wiki.opendaylight.org/view/Weather#Upgrade_ietf-.7Binet.2Cyang.7D-types_to_2013-07-15 (colindixon, 16:12:47)
    2. we need to start merging these patches since M5 is coming (colindixon, 16:13:03)
    3. e-mail thread has trailed off with no dissent (colindixon, 16:13:34)
    4. anipbu asks if there is an order to this, if it needs to be coordinated or can be spread over a few weeks (colindixon, 16:13:59)
    5. the weahter event expresses dependencies, but people seem unsure if merging earlier patches will break downstream peopel that depend on them, colindixon suspects it will (colindixon, 16:15:57)
    6. anipbu says it might be easier to have them all +2ed by committers, and then submitted by Thanh relatively all-at-once (colindixon, 16:16:41)
    7. ACTION: anipbu to help track this and make sure that we have buy in from everyone (colindixon, 16:17:28)

  4. infrastructure instability (colindixon, 16:17:40)
    1. rgoulding, rovaraga, skitt, and tpantelis all say they're having issues with jenkins jobs being erratic (colindixon, 16:18:04)
    2. skitt says that single feature tests are taking too long and hitting timeouts (colindixon, 16:18:28)
    3. that seems to be causing the most of the errorenous issues (colindixon, 16:18:42)
    4. skitt doesn't know if it's hitting issues because of (a) the more complete karaf we're using since moving to blueprint taking too long to come up, (b) just having feautres repos that are too large and/or, (c) slower CPUs in the private cloud than the public cloud (colindixon, 16:19:57)
    5. skitt notes that (a) didn't seem to start when that change was made, but it was something that changed (colindixon, 16:20:28)
    6. https://lists.opendaylight.org/pipermail/discuss/2016-June/006706.html (rgoulding, 16:21:38)
    7. rgoulding and tpantelis say they're seeing random failures, they could be traced back to slower things and timing issues (colindixon, 16:23:29)
    8. skitt and tpantelis both note (as well as colindixon) that it seems to be taking up to 10+ minutes to clone occasionally (colindixon, 16:27:45)
    9. https://jenkins.opendaylight.org/releng/job/controller-distribution-check-beryllium/110/console tpantelis notes that this seems to be failing after the "Reactor Summary:", which is odd (colindixon, 16:34:12)
    10. rgoulding asks about the timing of this, it's hit just before offset 0 M5, which was pretty brutal, waiting might have been better (colindixon, 16:34:46)
    11. colindixon says that the past experience is that the only real lull is right after the release for 2-6 weeks (colindixon, 16:36:27)
    12. colindixon asks people to please send constructive feedback on errors we're seeing and why we think it's infrastructure related, not just assume that zxiiro and tykeal are on it necessarily (colindixon, 16:37:07)

  5. Karaf 3.0.7 upgrade (colindixon, 16:37:16)
    1. skitt says it looks good, he's going to run CSIT on it soon, but it should be merged in Boron, but likely not a few a few weeks (colindixon, 16:37:44)
    2. skitt says that unless somebody else wants to run with it, skitt would like to not merge it this week (since it's already Tuesday) and he's out on PTO for 3 weeks (colindixon, 16:38:55)

  6. new code merge dashboards (colindixon, 16:39:50)
    1. (colindixon, 16:40:08)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:mer (colindixon, 16:40:09)
    3. (colindixon, 16:40:18)
    4. (colindixon, 16:40:20)
    5. (colindixon, 16:40:21)
    6. (colindixon, 16:40:21)
    7. (colindixon, 16:40:24)
    8. (colindixon, 16:40:26)
    9. (colindixon, 16:40:27)
    10. (colindixon, 16:40:29)
    11. (colindixon, 16:40:30)
    12. (colindixon, 16:40:32)
    13. (colindixon, 16:40:33)
    14. (colindixon, 16:40:35)
    15. (colindixon, 16:40:36)
    16. (colindixon, 16:40:38)
    17. (colindixon, 16:40:39)
    18. (colindixon, 16:40:40)
    19. (colindixon, 16:40:41)
    20. (colindixon, 16:41:13)
    21. #link (colindixon, 16:41:26)
    22. #link (colindixon, 16:41:27)
    23. #link (colindixon, 16:41:28)
    24. #link (colindixon, 16:41:30)
    25. #link (colindixon, 16:41:31)
    26. #link (colindixon, 16:41:33)
    27. #link (colindixon, 16:41:34)
    28. #link (colindixon, 16:41:36)
    29. #link (colindixon, 16:41:37)
    30. #link (colindixon, 16:41:39)
    31. #link (colindixon, 16:41:40)
    32. #link (colindixon, 16:41:42)
    33. (colindixon, 16:41:43)
    34. (colindixon, 16:41:45)
    35. (colindixon, 16:41:46)
    36. (colindixon, 16:41:48)
    37. (colindixon, 16:41:49)
    38. (colindixon, 16:41:51)
    39. (colindixon, 16:41:52)
    40. (colindixon, 16:41:54)
    41. (colindixon, 16:41:55)
    42. (colindixon, 16:41:57)
    43. (colindixon, 16:41:58)
    44. (colindixon, 16:42:00)
    45. (colindixon, 16:42:01)
    46. (colindixon, 16:42:03)
    47. (colindixon, 16:42:04)
    48. (colindixon, 16:42:06)
    49. (colindixon, 16:42:07)
    50. (colindixon, 16:42:08)
    51. (colindixon, 16:42:09)
    52. trying to send the links into IRC seems to have massively blown up my IRC client's sending messages (colindixon, 16:43:03)
    53. https://wiki.opendaylight.org/index.php?title=MD-SAL_Weekly_Call&oldid=47278#Upcoming_Agenda_Topics the querieis are in the "This Week" section here (colindixon, 16:44:02)
    54. https://git.opendaylight.org/gerrit/#/c/40520 (rgoulding, 16:45:21)
    55. there's some interesting patches coming across, that allow for minimial local builds to save time, also hot redeploys (colindixon, 16:45:43)
    56. from Martin: only 36 seconds build time for Yangtools with -Pq active :) (rgoulding, 16:48:15)
    57. lots of discussion of pathces, mostly inofrmational about new cool things available now (colindixon, 17:01:41)


Meeting ended at 17:01:43 UTC (full logs).

Action items

  1. Ryan will followup with Tony regarding M3 status. Tony said it would be done by 06/14/2016
  2. TomP to document in wiki regarding "specific-reference-list" blueprint extension.- corresponding gerrit patch - https://git.opendaylight.org/gerrit/#/c/40267
  3. skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we thnk are erroneous at this point)
  4. anipbu to help track this and make sure that we have buy in from everyone


People present (lines said)

  1. colindixon (98)
  2. rgoulding (6)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.