#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai_ at 15:58:21 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai_, 15:58:50)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-09-13-15.56.html (Sai_, 15:59:09)

  2. - Agenda (Sai_, 16:00:51)
    1. - Call for any topics to be added (Sai_, 16:02:37)
    2. - Review Action items (Sai_, 16:02:47)
    3. - Review the code change dashboards (Sai_, 16:02:56)

  3. - Call for any topics to be added (Sai_, 16:03:16)
    1. - AnHo adds topic " Branding MD-SAL call as kernel utils call " (Sai_, 16:04:02)
    2. - colindixon / ryan / stephen +1 (Sai_, 16:05:06)
    3. - Sai / Igor +1 (Sai_, 16:05:37)
    4. AGREED: we will change the name to the kernel projects weekly call (colindixon, 16:05:50)
    5. ACTION: - Ryan / colindixon / Sai_ to move wiki space for the new meeting "kernel projects weekly call" from existing MD_SAL weekly call (current link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call) (Sai_, 16:07:18)

  4. - Review Action items (Sai_, 16:07:31)
    1. ACTION: - Stephen to update bugs 5955 / 5966 with information discussed ert or.json licensing (Sai_, 16:07:58)
    2. ACTION: - TomP to release note "rapidly swapping candidate stuff" (Sai_, 16:08:08)

  5. - Review dashboards (Sai_, 16:08:28)
    1. - Alexis moving netconf to blueprint (Sai_, 16:10:17)
    2. rgoulding asks if there's a plan to support YANG 1.1 in Carbon (colindixon, 16:12:05)
    3. igor says there are plans to support part of YANG 1.1, but probably not all (colindixon, 16:12:30)
    4. - Ryan offers support for yang 1.1 (Sai_, 16:12:51)
    5. ACTION: martin to start a meeting arond YANG 1.1 and invite whoever else, there's also a topic for the DDF at the summit (colindixon, 16:13:57)
    6. - unit test failures in ayngtools is quite often (Sai_, 16:14:51)
    7. https://lists.opendaylight.org/pipermail/release/2016-September/008334.html (anipbu, 16:15:15)
    8. - An says release note has these points noted. (Sai_, 16:15:29)
    9. - https://lists.opendaylight.org/pipermail/release/2016-September/008334.html (Sai_, 16:15:38)
    10. adetalhouet says that thre are sal-rest-docgen failing unit tests too (colindixon, 16:16:04)
    11. does xsql work anymore? should we get rid of it? (colindixon, 16:17:01)
    12. - Sharon isn't responding for Alexis, TomP suggests to comment the part of code and move forward. (Sai_, 16:18:04)
    13. ACTION: adetalhouet to deprecate xsql so that we can kill it later (colindixon, 16:18:46)

  6. - carbon_dev_forum (Sai_, 16:19:59)
    1. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum look through the topics, add your name and/or new topics if you need them (colindixon, 16:20:10)
    2. adetalhouet asks about fast and/or phased, colindixon says that unless rovarga or edwarnicke (or somebody new) starts to drive it again, he suspects it will peter out (colindixon, 16:22:02)
    3. skitt says that he was never a strong believer in fast and/or phased (colindixon, 16:24:17)
    4. there's something else, namely semantic versioning, that he is, but it's not clear how far we can get in carbon (colindixon, 16:24:38)
    5. - colindixon says moving it to fixed version range would be an improvement. (Sai_, 16:25:44)
    6. colindixon says that moving from a fixed version for everything to a fixed version range, and then make merges produce a new micro every time so that we *could* decouple merge from release (or not) as we see (colindixon, 16:27:47)
    7. skitt adds that's closer to what he'd do, he'd also like to use the mvn release:release plugin to automate what we current do with autorelease, but one project at a time (colindixon, 16:28:35)
    8. colindixon notes that we did it with hydrogen and we had issues, rovarga notes that it didn't work well with properties (colindixon, 16:29:49)
    9. - colindixon points do we intend to do in carbon ? Move to version ranges / build releasing other than workflow may be componeents of it (Sai_, 16:31:24)
    10. moving to karaf 4 would be part of this (colindixon, 16:32:52)
    11. skitt notes the problem is mostly in process and people, which requires that things coalesce and you need pretty big sticks or carrots (colindixon, 16:35:30)
    12. skitt is doubtful, given that, that it could be done in carbon (colindixon, 16:35:40)
    13. ACTION: colindixon to send out a mail about what we might be able to experiment with in Carbon w.r.t. phased releases, e.g., semantic version (colindixon, 16:36:44)

  7. - participants (Sai_, 16:37:25)
    1. - Sai / Phil / Colin / Alexis / An / Igor / Martin / Ryan / Stephen / TomP / TOmas / Vaclav / Vratko (Sai_, 16:37:57)


Meeting ended at 16:38:05 UTC (full logs).

Action items

  1. - Ryan / colindixon / Sai_ to move wiki space for the new meeting "kernel projects weekly call" from existing MD_SAL weekly call (current link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call)
  2. - Stephen to update bugs 5955 / 5966 with information discussed ert or.json licensing
  3. - TomP to release note "rapidly swapping candidate stuff"
  4. martin to start a meeting arond YANG 1.1 and invite whoever else, there's also a topic for the DDF at the summit
  5. adetalhouet to deprecate xsql so that we can kill it later
  6. colindixon to send out a mail about what we might be able to experiment with in Carbon w.r.t. phased releases, e.g., semantic version


Action items, by person

  1. adetalhouet
    1. adetalhouet to deprecate xsql so that we can kill it later
  2. colindixon
    1. - Ryan / colindixon / Sai_ to move wiki space for the new meeting "kernel projects weekly call" from existing MD_SAL weekly call (current link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call)
    2. colindixon to send out a mail about what we might be able to experiment with in Carbon w.r.t. phased releases, e.g., semantic version
  3. Sai_
    1. - Ryan / colindixon / Sai_ to move wiki space for the new meeting "kernel projects weekly call" from existing MD_SAL weekly call (current link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call)
  4. UNASSIGNED
    1. - Stephen to update bugs 5955 / 5966 with information discussed ert or.json licensing
    2. - TomP to release note "rapidly swapping candidate stuff"
    3. martin to start a meeting arond YANG 1.1 and invite whoever else, there's also a topic for the DDF at the summit


People present (lines said)

  1. Sai_ (37)
  2. colindixon (24)
  3. odl_meetbot (9)
  4. rovarga (6)
  5. adetalhouet (3)
  6. anipbu (1)


Generated by MeetBot 0.1.4.