#opendaylight-meeting: OpenDaylight TSC

Meeting started by ChrisPriceAB at 15:03:10 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:03:14)
    1. Chris Price (ChrisPriceAB, 15:03:56)
    2. gkaempfer (gkaempfer, 15:06:21)
    3. colindixon (colindixon, 15:06:25)
    4. colindixon hasn't prepared any meeting agenda because summit (colindixon, 15:06:34)
    5. adetalhouet (adetalhouet, 15:06:43)
    6. we have 5 people right now, as far as I know and thus we *don't* have a quarum (colindixon, 15:07:02)
    7. abhijitkumbhare (abhijitkumbhare, 15:10:09)
    8. agenda topics for today: APAC time-zone meetings, committer activity (colindixon, 15:11:50)
    9. ACTION: dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 15:11:57)
    10. ACTION: phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process (colindixon, 15:12:42)
    11. ACTION: dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework (colindixon, 15:13:24)
    12. ACTION: colindixon to start a thread on when projects/committers need to be approvied to participate how in elections (colindixon, 15:13:31)
    13. ACTION: LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon (colindixon, 15:13:59)
    14. replacement of org.json will be a topic (colindixon, 15:14:36)

  2. events (colindixon, 15:15:55)
    1. we are coming to you live from the OpenDaylight summit (colindixon, 15:16:06)
    2. it's time to start the election for the commiter representatives on the board (colindixon, 15:16:20)
    3. you have to be a committer member of the nonprofit to run and/or vote (colindixon, 15:17:04)
    4. for reference mlemay_ and luisgomez are our two currrent committer members of the board (colindixon, 15:17:17)
    5. OPNFV is doing a plugfest in early December at UNH (colindixon, 15:17:32)
    6. they idea is that we can bring in not just regular ODL, but also commercial distributions, etc. (colindixon, 15:17:53)
    7. this is free and it could be fun (colindixon, 15:18:05)
    8. ACTION: ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page (colindixon, 15:18:27)
    9. http://events.linuxfoundation.org/events/opnfv-plugfest (adetalhouet, 15:19:24)
    10. colindixon asks phrobb if he wants to comment on the success fo the summit (colindixon, 15:19:28)
    11. https://wiki.opnfv.org/display/EVNT/Plugfest+-+Colorado+Release OPNFV plugfest planning wiki (ChrisPriceAB, 15:19:47)
    12. we had just north of 500 people at the summit this year, it was 650 last year in the bay area, phrobb thinks we would have been 700-750 if we'd been in the bay area (colindixon, 15:20:01)
    13. we will be doing the summit in 2017 in the bay area, already decided (colindixon, 15:20:30)
    14. phrobb says the general idea going forward is to try to move to having a joint event, e.g., ONS, or possibly with OPNFV and others (colindixon, 15:21:12)
    15. phrobb says that the general idea is that value is decreasing over time to having these events as there are more of them and there are more newer projects (colindixon, 15:22:11)
    16. Chris Luke says that as an end-user, he can't go to 16 events per year, some aggregation is a must (colindixon, 15:22:35)
    17. phrobb says he'd like to make ONS look more like that (colindixon, 15:22:49)
    18. gkaempfer and colindixon says that it was hard to attend what you needed, e.g., DDF vs. summit, and even DDF vs. DDF (colindixon, 15:24:25)
    19. two options, make it longer or have less stuff (colindixon, 15:24:55)
    20. phrobb notes that the last day has typically been over (colindixon, 15:25:45)
    21. ChrisPriceAB says that OpenStack did that and had that problem, but got people to attend on the last day as things went on (colindixon, 15:26:01)
    22. Chris Luke said that traiming at NANOG on Sunday, when we do community tutorials they're not going to show up on Sunday (colindixon, 15:26:39)
    23. ACTION: colindixon to start a thread on some of the future summit structure ideas (colindixon, 15:27:00)
    24. for tutorials, there are some questions about how we could do things better, e.g., prepackaged VMs (which we do) and avoiding having to have internet access (colindixon, 15:30:04)
    25. ACTION: phrobb and tykeal to look into an ODL infra micro-datacter in a box to make things work better (colindixon, 15:30:26)

  3. boron (colindixon, 15:32:10)
    1. Boron autorelease still failing and we are a month from release. (anipbu, 15:33:01)
    2. autorelease is still failing, zxiiro and anipbu are looking into it, but it's no obvious what's going on, vishnoianil is lookint into the logs (colindixon, 15:33:09)
    3. we're now having issues with figuring out what's failing because we're not using the maven jenkins plugin, but now we have to go through the logs manually (colindixon, 15:34:08)
    4. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 15:34:27)

  4. carbon (colindixon, 15:34:29)
    1. Kindly remind projects to submit their Carbon M0 Status. We are missing status from 35 projects: alto, atrium, capwap, cardinal, centinel, controller, didm, flux, docs, mean, faas, genius, vbd, iotdm, l2switch, lack, lispflowmapping, mdsal, natapp, netvirt, next, nic, openflowjava, opflex, sdninterfaceapp, snbi, snmp, sep, tsdr, ftp, usecplugin, vtn, (anipbu, 15:35:29)
    2. we're collecting M0 statuses (colindixon, 15:35:45)
    3. Last date to submit Offset 0 projects is next week 10/6 (anipbu, 15:35:46)
    4. We are in progress of cleaning up the weather page. Please respond to respective emails regarding items archived, etc. (anipbu, 15:36:01)

  5. stable/beryllium (colindixon, 15:36:41)
    1. The Beryllium SR4 is in three weeks with a cutoff on 10/16 23:59 UTC. (anipbu, 15:36:43)
    2. 75 patches still pending on (anipbu, 15:36:49)
    3. https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/beryllium <-- Patches (anipbu, 15:37:26)
    4. if you need to cherry-pick something to beryllium, do it now (colindixon, 15:38:08)

  6. infra (colindixon, 15:38:37)
    1. upgrades of our infra will continue (colindixon, 15:39:24)
    2. we're still engaging with people about the F5 device that will improve network connectivity to the rest of the world (colindixon, 15:39:57)
    3. we're shifting resouces out of the LF core data center, into the collaborative projects infrastructure (colindixon, 15:41:33)
    4. we're still making progress on newer resoruces for a second "availabilty zone" and creating ODL forge (colindixon, 15:43:02)
    5. we're also talking about how to give people in the community ssh access to VMs (colindixon, 15:43:10)

  7. APAC time-zone TSC meetings (colindixon, 15:43:48)
    1. http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 (colindixon, 15:43:51)
    2. phrobb asks if we should defer to the newer TSC, colindixon and gkaempfer don't really think it's going to matter (colindixon, 15:45:27)
    3. the overwhelming choice seems to be one TSC meeting a month at an APAC-friendly time zone (colindixon, 15:46:12)
    4. phrobb notes that making sure TSC members can attend might make it make sense to wait for new TSC elections (colindixon, 15:46:31)
    5. ACTION: colindixon to put APAC time zone on next week's schedule (colindixon, 15:46:49)

  8. org.json version and license issue (colindixon, 15:46:59)
    1. https://wiki.opendaylight.org/view/Weather#Downgrade_to_org.json_20090211 <--- Weather item on json (anipbu, 15:47:38)
    2. there's some reason to believe we should fix this in Carbon (colindixon, 15:49:34)
    3. colindixon asks if we want to make this a blocking issue in Carbon (colindixon, 15:50:07)
    4. colindixon notes that rgoulding and skitt are working on this, but we should probably make it a formal blocking issue (colindixon, 15:50:57)
    5. ACTION: colindixon to make org.json migration a blocking issue for carbon (colindixon, 15:51:21)

  9. tracking committer activity and project activity (colindixon, 15:54:23)
    1. https://lists.opendaylight.org/pipermail/release/2016-September/008306.html (adetalhouet, 15:54:27)
    2. this is informally tracked in my head and anipbu's head and phrobb's head (colindixon, 15:54:37)
    3. https://lists.opendaylight.org/pipermail/release/2016-September/008306.html (colindixon, 15:54:44)
    4. colindixon says he thinks is the main question is do we want to formally track project liveness and activity (colindixon, 15:55:45)
    5. ChrisPriceAB says that the OPNFV just launched some kind of project health monitoring to figure who needs help and how to help them (colindixon, 15:56:14)
    6. colindixon says that his worry is that the incremental value we get from formal tracking vs. informal tracking is low and the potential negative implications of having a good/bad list could disincentivize projects from participating and maybe make OpenDaylight look bad (colindixon, 15:58:14)
    7. ChrisPriceAB and adetalhouet note that there are reasons why you want to write it down an track things formally, namely to avoid the occasional thing you miss when your tracking things informally (colindixon, 15:58:42)
    8. ChrisPriceAB and anipbu say if you do this, you want make it clear that your goal it to help not shame (colindixon, 15:59:05)
    9. zxiiro says that saying "help wanted" instead of "inactive" might help a lot (colindixon, 16:00:37)
    10. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity ina positive way (colindixon, 16:01:19)

  10. cookies (colindixon, 16:01:36)
    1. please VOTE, closes in 2 hours (colindixon, 16:01:41)


Meeting ended at 16:01:46 UTC (full logs).

Action items

  1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  2. phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
  3. dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
  4. colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
  5. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
  6. ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page
  7. colindixon to start a thread on some of the future summit structure ideas
  8. phrobb and tykeal to look into an ODL infra micro-datacter in a box to make things work better
  9. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  10. colindixon to put APAC time zone on next week's schedule
  11. colindixon to make org.json migration a blocking issue for carbon
  12. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity ina positive way


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page
  2. colindixon
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
    3. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
    4. colindixon to start a thread on some of the future summit structure ideas
    5. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    6. colindixon to put APAC time zone on next week's schedule
    7. colindixon to make org.json migration a blocking issue for carbon
    8. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity ina positive way
  3. dfarrell07
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
  4. phrobb
    1. phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
    2. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
    3. ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page
    4. phrobb and tykeal to look into an ODL infra micro-datacter in a box to make things work better
    5. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity ina positive way


People present (lines said)

  1. colindixon (78)
  2. anipbu (9)
  3. odl_meetbot (8)
  4. ChrisPriceAB (7)
  5. adetalhouet (3)
  6. abhijitkumbhare (2)
  7. gkaempfer (1)
  8. phrobb (0)
  9. dfarrell07 (0)


Generated by MeetBot 0.1.4.