#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:22 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:28)
    1. gkaempfer (gkaempfer, 17:00:38)
    2. colindixon (colindixon, 17:00:44)
    3. Chris Luke for Ed Warnicke (Chrisy, 17:00:50)
    4. ttkacik (ttkacik, 17:00:54)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=47803 agenda in the usual place (colindixon, 17:00:56)
    6. Anil Vishnoi (vishnoianil, 17:01:04)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-07-14-17.00.html last week's meeting minutes (colindixon, 17:01:06)
    8. https://lists.opendaylight.org/pipermail/tsc/2016-July/005594.html vishnoianil, phrobb and abhijitkumbhare started a discussion the project categorization, so that it can be helpful for users who wants to propose a project proposal and looking for all the relevant projects in that scope. (colindixon, 17:01:18)
    9. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2016-July/005525.html colindixon to reached out to openflowplugin devs about whether we could at least keep them through the Boron release (colindixon, 17:01:25)
    10. abhijitkumbhare (abhijitkumbhare, 17:01:34)
    11. https://lists.opendaylight.org/pipermail/release/2016-July/007250.html distribution size is fixed for now, but some attention is needed in the longer run (colindixon, 17:01:36)
    12. https://lists.opendaylight.org/pipermail/release/2016-July/007288.html Thanh started a thread on changes in releng/builder and jenkins jobs (colindixon, 17:01:47)
    13. Chrisy reached to to edwarnicke about fast and/phased carbon, but didn't hear anything (colindixon, 17:01:54)
    14. https://lists.opendaylight.org/pipermail/tsc/2016-July/005614.html thread on committing to a Carbon release outline by 7/28 (with links to sample Carbon release plan and tentative dates) (colindixon, 17:02:08)
    15. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan sample carbon release plan (with tentative dates) (colindixon, 17:02:16)
    16. snackewm for Uri (snackewm, 17:02:25)
    17. ACTION: anipu to follow up with relevant projects about distribution size: https://lists.opendaylight.org/pipermail/release/2016-July/007250.html (colindixon, 17:02:28)
    18. ACTION: skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?) (colindixon, 17:03:10)
    19. ACTION: colindixon and phrobb to set up a poll of committers, PTLs and TSC members to see if there's a desire to have one TSC meeting a month at an APAC-friendly time (colindixon, 17:03:13)
    20. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon? (colindixon, 17:03:22)
    21. rovarga for jmedved (rovarga, 17:03:24)
    22. ACTION: phrobb to work on having a policy for how attendance to design forums works going forward with community involvement (colindixon, 17:03:56)
    23. ACTION: phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?) (colindixon, 17:04:39)
    24. Daniel Farrell (dfarrell07, 17:04:49)
    25. mohnish anumala (mohnish__, 17:04:52)
    26. mohnish__ is attending (colindixon, 17:05:45)
    27. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <- pointer to Carbon DDF Topics wiki page (phrobb, 17:06:05)
    28. https://lists.opendaylight.org/pipermail/release/2016-July/007369.html mail asking projects for input on how infrastructure issues have affected them and will affect their release (colindixon, 17:06:06)

  2. mailing list discussions (colindixon, 17:07:21)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-July/005499.html having one TSC meeting a month at an APAC-friendly time (colindixon, 17:07:32)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-July/005539.html escalation process we have in OpenDaylight (colindixon, 17:07:44)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-July/005538.html better understanding the wiki search engine whitelist (colindixon, 17:07:57)
    4. the current way it works, is with NOFOLLOW, anything that's on the homepage and anything that's in the project list are on the list of "follow" pages, that are easy to search for (colindixon, 17:09:07)
    5. this does seem to be working better than before, but there are some bugs (colindixon, 17:10:05)
    6. the current process for updating it is to basically ask for a page to be added to the list of follow pages, but it has to be linked to from a follow list (colindixon, 17:10:29)
    7. ACTION: colindixon to follow up on the whitelist (follow/nofollow) thread with this information (colindixon, 17:10:43)
    8. https://lists.opendaylight.org/pipermail/tsc/2016-June/005377.html Additional questions in the Project Proposal Template (colindixon, 17:11:16)
    9. https://lists.opendaylight.org/pipermail/tsc/2016-June/005428.html Fast and/or Phased Planning for the Carbon Release (may be moot at this point) (colindixon, 17:11:37)
    10. https://lists.opendaylight.org/pipermail/tsc/2016-June/005407.html Asking the Board to Remove the Singularity Principle (colindixon, 17:11:46)
    11. https://lists.opendaylight.org/pipermail/tsc/2016-July/005594.html Categorizing projects, both on the wiki and for new projects to browse (colindixon, 17:11:57)
    12. ACTION: colindixon to try to drive some/all of these ongoing discussions to completion (colindixon, 17:12:12)

  3. events (colindixon, 17:12:38)
    1. https://www.opendaylight.org/global-events (colindixon, 17:12:44)
    2. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <- pointer to Carbon DDF Topics wiki page (colindixon, 17:13:12)

  4. boron (colindixon, 17:13:21)
    1. We will be introducing changes the deviation statement API in yangtools, affecting DeviateDefinition. The only impacted projects should be mdsal. (anipbu, 17:13:42)
    2. https://wiki.opendaylight.org/view/Weather#Change_of_deviation_statement_API_in_yangtools <--- Weather item for deviation statement API (anipbu, 17:13:47)
    3. We will be cutting branches and version bumping all the projects in unison at M5-Offset2 (anipbu, 17:14:08)
    4. https://lists.opendaylight.org/pipermail/release/2016-July/007354.html <--- Notification email regarding branch cutting (anipbu, 17:14:13)
    5. The Boron Autorelease job was failing this week due to compilation errors in centinel-streamhandler. It has been fixed with patch 41969. (anipbu, 17:14:32)
    6. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/187/org.opendaylight.centinel$centinel-streamhandler/ <--- Autorelease failure in centinel (anipbu, 17:14:37)
    7. https://git.opendaylight.org/gerrit/#/c/41969/ <--- Patch fixing boron autorelease (anipbu, 17:14:40)
    8. Boron M5 Offset 1 are due today 7/21/2016. Projects should take a moment to send their status. (anipbu, 17:14:55)
    9. We are missing M5 Status from three projects: controller (Tony Tkacik), infrautils (Guy Sela), netconf (Tomas Cere) (anipbu, 17:15:06)
    10. https://lists.opendaylight.org/pipermail/release/2016-July/007379.html <--- Status Email Template (anipbu, 17:15:22)
    11. We would like to request feedback from projects if recent issues affected your schedule or project readiness in Boron (anipbu, 17:15:40)
    12. https://lists.opendaylight.org/pipermail/release/2016-July/007369.html <--- Polling projects on readiness (anipbu, 17:15:45)
    13. rovarga says that we're going to need tcpmd5 in Boron until sndinterface app drops it's dependence on tcpmd5, but we don't know when to expect that (colindixon, 17:18:08)
    14. ACTION: anipbu to reach out to sdninterfaceapp about removing dependency on tcpmd5 (colindixon, 17:18:24)
    15. colindixon adds that in the past, we've allowed people to pull in release versions from prior versions, but rovarga says that this might not work with some config subsystem changes (colindixon, 17:19:06)
    16. vishnoianil asks how to solve this problem generally, if projects drop that others need (colindixon, 17:20:01)
    17. colindixon says that this is usually handled out-of-band, for example we were able to convince snmp to participate to prevent problems (colindixon, 17:20:52)
    18. anipbu and rovarga note that they reached out to the people depending on tcpmd5 to migrate away from it, and sdninterfaceapp hasn't engaged there (colindixon, 17:21:29)
    19. https://lists.opendaylight.org/pipermail/sdninterfaceapp-dev/2016-April/000121.html (anipbu, 17:22:16)
    20. https://lists.opendaylight.org/pipermail/sdninterfaceapp-dev/2016-April/000121.html this was there response on 4/12: "SDNINTERFACEAPP is primarily dependent on BGPCEP project. There is no impact on SDNINTERFACEAPP functionality." (colindixon, 17:22:58)
    21. rovarga says that's not true, it's actually a complete copy of BGPCEP code in sndinterfaceapp (colindixon, 17:23:56)
    22. vishnoianil asks what's the next steps, colindixon says it's basically drop the dependency or they will be dropped from the release (colindixon, 17:24:30)

  5. stable/beryllium (colindixon, 17:25:34)
    1. Beryllium SR3 is in one week with a release on July 28, 2016 with a cutoff on Sunday July 24 11:59PM UTC (anipbu, 17:25:38)
    2. We have Beryllium Autorelease issues related to bgpcep and vpnservice (anipbu, 17:25:50)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/224/testReport/ <--- Beryllium Build Test Failures (anipbu, 17:26:00)
    4. We have Beryllium Distribution Test issues in aaa, bgpcep, netconf, nic, ovsdb, snmp, sxp, topoprocessing, usc (anipbu, 17:26:15)
    5. https://jenkins.opendaylight.org/releng/job/integration-distribution-test-beryllium/458/ <--- Beryllium Distribution Test Failures (anipbu, 17:26:25)
    6. zxiiro says the branch won't be frozen for this, but any pushed patches won't be included unless we respin, any new features (e.g., non-fixes) will have to be reverted before respins (colindixon, 17:28:06)
    7. anipbu asks if we should only allow fixes for blocking fixes (colindixon, 17:29:05)
    8. colindixon and anipbu think that's probably the best idea to keep stability and lower-risk in case of respin before we release (colindixon, 17:29:42)
    9. AGREED: at least for now, the TSC says that only fixes for blocking issues should be submitted to stable/beryllium between the first cut and the formal release, other fixes will be reverted (colindixon, 17:30:37)

  6. system integration and test (colindixon, 17:30:58)
    1. jamoluhrsen says everything so far has been covered (colindixon, 17:31:08)
    2. ACTION: jamoluhrsen to send out a list of projects that would currently be labeled as experimental (the data will be from a few months ago) and ask projects to update it if they think they're no longer there (colindixon, 17:32:10)

  7. infrastructure (colindixon, 17:32:52)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-July/005613.html e-mail from rovarga (and follow-ups from others) about the implications of infrastructure issues on the release (colindixon, 17:33:23)
    2. tykeal stopped working on the LDAP replica, when he was unblocked on getting public cloud instances so that we can migrate jobs back into the public cloud (colindixon, 17:33:53)
    3. zxiiro is working on moving integration jobs back into the public cloud as we speak (colindixon, 17:34:08)
    4. tykeal is now back to working on an LDAP replica that would be in the private cloud to see if it fixes Nexus timeouts and other issues (colindixon, 17:34:39)
    5. tykeal says he hopes to have the LDAP replica up by the end of this week, and desperately hopes it will be up by early next week (colindixon, 17:35:02)
    6. if this doesn't fix the issue, we'll have to start a new round of debugging, which nobody is looking forward to (colindixon, 17:35:23)
    7. the failures to clone seem to be due to a large number of jobs that come in all at the same time (these are typically from matrix jobs, i.e., verify jobs) and then hurting gerrit which slows to a crawl, gerrit is already tuned as best they can figure (colindixon, 17:36:16)
    8. the fix to this is slowly migrating its way out zxiiro and our new release engineer are converting matrix jobs out into normal jobs, which should relieve pressure on gerrit, and help with cloning (colindixon, 17:37:08)
    9. rovarga notes that coretutorials and yangtools have already +1ed their move away from matrix jobs (colindixon, 17:37:50)
    10. SNAPSHOTs disappearing shouldn't happen because we have periodic merge jobs, but if they fail there's nothing for it, projects need to pay attention (colindixon, 17:39:16)
    11. colindixon says we've set up our infrastructure to be resilient to delinquent projects, this is an example of a place where we aren't resilient to that (colindixon, 17:40:13)
    12. rovarga asks if we could get a dashboard of this, tykeal says we have an "all merge jobs" tab in jenkins (colindixon, 17:40:28)
    13. https://jenkins.opendaylight.org/releng/view/Merge-Jobs/ the link tykeal was talking about for all merge jobs (colindixon, 17:41:28)
    14. rovarga notes that this page includes for all releases and projects that aren't in boron (colindixon, 17:42:39)
    15. colindixon asks if we can have failed periodic merge jobs e-mail release@lists.opendaylight.org (colindixon, 17:43:33)
    16. ACTION: colindixon to start a thread on how we can better track projects which haven't merged in a while (colindixon, 17:44:00)
    17. tykeal says that we should be able to resolve OutOfMemory errors by asking for a larger instance size based on zxiiro's work to split apart all of our jobs, so they should be fix-able if not fixed (colindixon, 17:44:55)
    18. zxiiro notes that things run by default with 8G of ram and LuisGomez says that OOM errors are often not really that (colindixon, 17:46:15)
    19. rovarga says that the SingleFeatureTest caps heap size at 2G, which is where this is coming from, which worries him that we have single features that can't be installed with 2G of heap (colindixon, 17:46:58)
    20. LuisGomez says OOM in SingleFeatureTest is often something being wrong in the feature dependencies (colindixon, 17:47:26)
    21. rovarga asks about the bottom line, will we miss the deadline, tykeal said that the only remaining issue would be nexus timeouts that should be going away when the replica is live by early next week (colindixon, 17:51:20)
    22. colindixon says his take is that he's gone from ~95% sure we wouldn't slip a few weeks back to 70-80% sure that we won't slip now, but he's still optimistic if things continue to improve (colindixon, 17:53:33)
    23. vishnoianil asks for utilization stats to figure out if we can understand where we are now and will be as we move to testing, tykeal says he can't right now, but there's an open issue with rackspace (colindixon, 17:56:12)
    24. colindixon suggests that looking at jenkins queue depth, even on an hourly basis, would be really helpful (colindixon, 17:56:36)

  8. carbon release plans (colindixon, 17:58:17)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-July/005614.html mail stating that we need an outline by 7/28 (next week) (colindixon, 17:58:39)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan sample release plan (with tentative) (colindixon, 17:58:57)
    3. colindixon says his intuition is that we should approve this outline next week to get some clarity to projects, unless there's a really compelling reason not to (colindixon, 18:00:16)
    4. please, please get feedback so we can vote in the next meeting, to keep the deadline we set for ourselves (colindixon, 18:00:34)

  9. cookies (colindixon, 18:00:51)


Meeting ended at 18:00:55 UTC (full logs).

Action items

  1. anipu to follow up with relevant projects about distribution size: https://lists.opendaylight.org/pipermail/release/2016-July/007250.html
  2. skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?)
  3. colindixon and phrobb to set up a poll of committers, PTLs and TSC members to see if there's a desire to have one TSC meeting a month at an APAC-friendly time
  4. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
  5. phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
  6. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
  7. colindixon to follow up on the whitelist (follow/nofollow) thread with this information
  8. colindixon to try to drive some/all of these ongoing discussions to completion
  9. anipbu to reach out to sdninterfaceapp about removing dependency on tcpmd5
  10. jamoluhrsen to send out a list of projects that would currently be labeled as experimental (the data will be from a few months ago) and ask projects to update it if they think they're no longer there
  11. colindixon to start a thread on how we can better track projects which haven't merged in a while


Action items, by person

  1. anipbu
    1. anipbu to reach out to sdninterfaceapp about removing dependency on tcpmd5
  2. colindixon
    1. skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?)
    2. colindixon and phrobb to set up a poll of committers, PTLs and TSC members to see if there's a desire to have one TSC meeting a month at an APAC-friendly time
    3. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
    4. colindixon to follow up on the whitelist (follow/nofollow) thread with this information
    5. colindixon to try to drive some/all of these ongoing discussions to completion
    6. colindixon to start a thread on how we can better track projects which haven't merged in a while
  3. dfarrell07
    1. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
  4. phrobb
    1. colindixon and phrobb to set up a poll of committers, PTLs and TSC members to see if there's a desire to have one TSC meeting a month at an APAC-friendly time
    2. phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
    3. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
  5. UNASSIGNED
    1. anipu to follow up with relevant projects about distribution size: https://lists.opendaylight.org/pipermail/release/2016-July/007250.html
    2. jamoluhrsen to send out a list of projects that would currently be labeled as experimental (the data will be from a few months ago) and ask projects to update it if they think they're no longer there


People present (lines said)

  1. colindixon (90)
  2. anipbu (19)
  3. odl_meetbot (5)
  4. rovarga (2)
  5. mohnish__ (2)
  6. Chrisy (2)
  7. phrobb (2)
  8. gkaempfer (1)
  9. tykeal (1)
  10. dfarrell07 (1)
  11. zxiiro (1)
  12. ttkacik (1)
  13. abhijitkumbhare (1)
  14. snackewm (1)
  15. vishnoianil (1)


Generated by MeetBot 0.1.4.