#opendaylight-meeting: tsc

Meeting started by colindixon at 17:40:18 UTC (full logs).

Meeting summary

    1. Anil Vishnoi (vishnoianil, 17:40:45)
    2. AGREED: the TSC authorizes zxiiro, tykeal, and anipbu to release SR3 if the bug In NIC is found to be non-blocking, otherwise we will vote on the mailing list no later than Monday (there were 9 +1s so consensus) (colindixon, 17:40:58)

  1. carbon (colindixon, 17:41:10)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-07-28-17.00.html this is actually a continouation of the TSC meeting here (colindixon, 17:41:35)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-July/005614.html we agreed that we would set tentavie dates for Carbon by today (colindixon, 17:41:56)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan sample carbon release plan (with tentative dates) (colindixon, 17:42:13)
    4. gkaempfer asks Why is the release 8 months after Boron while the cadence is 6 months? (colindixon, 17:45:24)
    5. colindixon explains that we basically have 6 4 week periods (M1-M5 and then RCs), the we have 4 weeks from offsets, and then a few weeks of slack in there (colindixon, 17:46:27)
    6. vishnoianil asks if we could cut it down to 6 months, some ideas would be to cut one milestone (M1?) or to cut the distance betwen milestones down to 3 weeks (colindixon, 17:47:30)
    7. anipbu notes that Lunar New Year is January 28, which falls into the M3 Offset 2 timeframe (recall that M3 is the toughest Milestone) (colindixon, 17:47:48)
    8. abhijitkumbhare asks if we're trying to target a specific month for this release (or the next one), do we have an ODL summit 2017 date yet (colindixon, 17:48:30)
    9. colindixon says he'd rather not tie things to the summit and that would be Nitrogen not Carbon, also as our releases calm down a bit, having the release coincide with the summit, might not be required (colindixon, 17:50:25)
    10. ChrisPriceAB and gkaempfer both say that it woudl help a lot of if we could hit a date-based release process, where we shipped twice a year (colindixon, 17:53:05)
    11. colindixon says that his feeling and based on past discussion, the M1 milestone is the one that has the least value, and then if we moved M1 to M0 and then dropped the 2 week gap between the Boron release and M0, that would put the release at 3/30, which would be a lot closer to every 6 months (colindixon, 17:59:02)

  2. shuva as a committer on openflow plugin (colindixon, 17:59:14)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-July/005645.html Shuva Jyoti Kar as OpenFlow Plugin committer (colindixon, 17:59:35)
    2. he has more than 50 merged patches (colindixon, 18:00:15)
    3. https://git.opendaylight.org/gerrit/#/q/owner:shuva.jyoti.kar%2540ericsson.com+status:merged (colindixon, 18:00:22)
    4. VOTE: Voted on "shall the TSC approve Shuva Jyoti Kar as an OpenFlow plugin committer?" Results are, +1: 8 (colindixon, 18:00:37)
    5. AGREED: Shuva is committer on OpenFlow plugin (colindixon, 18:00:44)
    6. dfarrell07 also votes +1 (dfarrell07, 18:00:45)

  3. carbon (colindixon, 18:00:52)
    1. rovarga says he thought he remember saying that the incoming TSC should approve the Carbon release, colindixon says that he remembered us talking about it but deciding that we wouldn't do that because it causes issues either way, either a new TSC inheriting a release plan, or a new one overseeing the final bits of a release (colindixon, 18:04:27)
    2. ChrisPriceAB poitns out that the TSC can change the release plan if they need to, so it seems like a non-issue (colindixon, 18:04:47)
    3. a vote for 1 is also a vote for 3 (colindixon, 18:06:36)
    4. VOTE: Voted on "would you like to (1) approve the current tentative dates (8 months), (2) wait until next week to vote, (3) approve the tentative dates with a caveat that we might try to make 6 months with minimum changes?" Results are, 1: 1, 3: 3, 2: 5 (colindixon, 18:07:21)
    5. ACTION: colindixon to send out a mail with possible trying to shift to 6 months (colindixon, 18:07:46)

  4. cookies (colindixon, 18:08:31)


Meeting ended at 18:08:38 UTC (full logs).

Action items

  1. colindixon to send out a mail with possible trying to shift to 6 months


Action items, by person

  1. colindixon
    1. colindixon to send out a mail with possible trying to shift to 6 months


People present (lines said)

  1. colindixon (37)
  2. odl_meetbot (15)
  3. ChrisPriceAB (10)
  4. gkaempfer (7)
  5. abhijitkumbhare (5)
  6. Chrisy (4)
  7. dfarrell07 (4)
  8. vishnoianil (4)
  9. snackewm (3)
  10. adetalhouet (2)
  11. anipbu (1)


Generated by MeetBot 0.1.4.