#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:14 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:20)
    1. colindixon (colindixon, 17:00:31)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=48426#Agenda the agenda in it's usual place (colindixon, 17:00:43)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-08-11-17.00.html last week's meeting minutes (colindixon, 17:00:53)
    4. gkaempfer (gkaempfer, 17:01:04)
    5. https://wiki.opendaylight.org/view/Wiki_gardening#Search_Engine_Indexing_of_the_wiki information on search engine indexing of the wiki (colindixon, 17:01:32)
    6. https://www.opendaylight.org/global-events LinuxCon North America and Europe are in the events list (colindixon, 17:01:59)
    7. https://wiki.opendaylight.org/view/OpenDaylight_Toolkit:Main https://wiki.opendaylight.org/view/Archive_Proposals/OpenDaylight_Toolkit#Archive_Vote_and_Date colindixon added the relevant bits on the wiki to archive toolkit (colindixon, 17:02:04)
    8. https://lists.opendaylight.org/pipermail/tsc/2016-August/005836.html thread on whether we should only allow blocking bug fixes during RCs (colindixon, 17:02:10)
    9. abhijitkumbhare (abhijitkumbhare, 17:02:13)
    10. Chris Price (ChrisPriceAB, 17:02:15)
    11. https://lists.opendaylight.org/pipermail/release/2016-August/007953.html it seems like the HTTP response codes from RESTCONF is likely to be reasonable (colindixon, 17:02:21)
    12. adetalhouet (adetalhouet, 17:02:25)
    13. mohnish anumala (mohnish__, 17:02:43)
    14. making sure that we can set the the nexus file size back to 512 MB again is being tracked on integration calls (colindixon, 17:02:43)
    15. snackewm (for uri) (snackewm, 17:03:16)
    16. https://lists.opendaylight.org/pipermail/tsc/2016-August/005842.html phrobb's mail to projects to note that who the PTL is at the end of boron has implications for the TSC election, so figure it out if you have to (colindixon, 17:03:27)
    17. ACTION: colindixon to e-mail out results of the APAC-time-zone poll (colindixon, 17:03:28)
    18. so far we only have 5 responses, so please vote if you want to, it closes in 7 hours (colindixon, 17:03:57)
    19. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon? (colindixon, 17:04:03)
    20. ACTION: colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 17:04:09)
    21. Anil Vishnoi (vishnoianil, 17:04:21)
    22. ACTION: anipbu to make sure we release note the change in HTTP RESTCONF RESPONSE codes (colindixon, 17:04:29)
    23. ACTION: colindixon and edwarnicke to try to work through the corner cases and process of the TSC elections https://wiki.opendaylight.org/view/TSC:Election_Proposal (colindixon, 17:05:30)
    24. ACTION: everyone to review the other bits of the TSC elections, most notably the the representing multiple groups or projects and picking represented groups https://wiki.opendaylight.org/view/TSC:Election_Proposal (colindixon, 17:05:38)
    25. jamoluhrsen (jamoluhrsen, 17:06:47)

  2. TSC mailing list votes and discussions (colindixon, 17:06:56)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005809.html Policy on who can attend DDFs (colindixon, 17:07:06)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-August/005836.html only allow blocking bug fixes after RCs start in Carbon (colindixon, 17:07:16)
    3. older ones can be found in the agenda link above (colindixon, 17:07:28)

  3. events (colindixon, 17:08:13)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:20)
    2. LinuxCon NA and OpenStack Days Easy coming up next week (colindixon, 17:08:44)
    3. we've finished the CFP for OpenDaylight Forum India, committee being formed (colindixon, 17:09:05)
    4. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum we really need topics for the Carbon DDF at the summit (colindixon, 17:09:33)

  4. Boron (colindixon, 17:10:34)
    1. We had build failures in FAAS and NETIDE but those issues have been fixed and resolved. (anipbu, 17:10:49)
    2. We had a TWS to discuss the MDSAL Binding Spec V2 (anipbu, 17:11:02)
    3. https://lists.opendaylight.org/pipermail/release/2016-August/007909.html <--- Recoding for MDSAL Binding Spec V2 (anipbu, 17:11:10)
    4. https://lists.opendaylight.org/pipermail/release/2016-August/007941.html <--- PowerPoint Presentation for MDSAL Binding Spec V2 (anipbu, 17:11:16)
    5. https://lists.opendaylight.org/pipermail/release/2016-August/007916.html <--- Email Thread Discussion for MDSAL Binding Spec V2 (anipbu, 17:11:23)
    6. We continue the migration from AsciiDocs to reStructuredText. Request folks to review relevant patches and +1. Projects may also elect to opt out by informing the documentation team at documentation@lists.opendaylight.org (anipbu, 17:12:01)
    7. https://git.opendaylight.org/gerrit/#/q/topic:adoc2rst <--- Documentation Migration Patches (anipbu, 17:12:06)
    8. 6 projects affected by Restconf Response Migration. Projects should review the impact of the changes to Restconf Response. (anipbu, 17:12:34)
    9. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1846323581 <--- Tracking Restconf Response Impact (anipbu, 17:12:48)
    10. Projects please test and report blocking issues with Boron RC0. (anipbu, 17:15:01)
    11. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#RC0 <--- RC0 Download Information (anipbu, 17:15:07)
    12. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620 <--- RC0 Tracking Spreadsheet (anipbu, 17:15:11)
    13. The build for RC1 will start at 23:59:59 UTC on 8/18/2016 (anipbu, 17:15:22)
    14. Projects PTL should sign up for timeslots for the Boron Release Review and provide links to their release notes and release review template (anipbu, 17:15:42)
    15. Sign Up Sheet: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020 (anipbu, 17:15:55)
    16. Release Note: https://wiki.opendaylight.org/view/Sample_Release_Notes (anipbu, 17:16:04)
    17. Release Review Template: https://wiki.opendaylight.org/view/Sample_Release_Review (anipbu, 17:16:10)
    18. 9 projects have made changes to their yang files since RC0 Cutoff: groupbasedpolicy, netvirt, genius, openflowplugin, bgpcep, yangtools, aaa, of-config, sfc (anipbu, 17:16:28)
    19. https://git.opendaylight.org/gerrit/#/dashboard/?title=RC+Status&Yang+File+Changes+Since+RC0=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-08-11 (anipbu, 17:16:33)
    20. ChrisPriceAB says things like the HTTP response codes should probably focus at least as much externally as internally, in particular, most of them will see no idea of whether this change is coming (colindixon, 17:18:35)
    21. ChrisPriceAB says he doesn't think we should stop things over this, but says "we may make this change and have the world hate us for it, but that would be fine as long as we learn" (colindixon, 17:20:08)
    22. edwarnicke says that his take is that if we're going to fix this, we shoudl fix it now, not kick the can down the road (colindixon, 17:20:48)
    23. one appraoch would be to deprecate it, set off alarms, etc. for one release (per ChrisPriceAB) (colindixon, 17:21:43)
    24. ACTION: colindixon to ask how hard it woudl be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron (colindixon, 17:24:04)
    25. mohnish__ asks if we should do new (right) behavior by default or old (wrong) behavior by default, the latter would allow people to move without interruption (colindixon, 17:25:31)
    26. colindixon says that edwarnicke was suggesting the former to make sure people were actively aware that things were changing and not just replay things 6 months from now (colindixon, 17:26:21)
    27. vrpolak will involve changes in a YANG model that changes RESTCONF behavior, which will involve an API change, and to actually flip the switch, you'll need to edit an XML file (colindixon, 17:28:06)

  5. system integration and test (colindixon, 17:28:19)
    1. all covered in infra (colindixon, 17:28:32)

  6. infrastructure (colindixon, 17:28:35)
    1. zxiiro says that there's an issue we're aware of with rackspace public cloud where some CSIT nodes don't come online and we can't ssh to them, seems to happen about 1 time in 6 or 7 (colindixon, 17:29:10)
    2. jamoluhrsen says that this will affect distrirbution-test jobs, which is how we evaluate releases (colindixon, 17:29:34)
    3. colindixon asks if CSIT will make it through that, jamoluhrsen says that we have many jobs which bring up 4+ nodes, that menas it fails with p=0.5 or so, which makes it a huge amount of busy (colindixon, 17:30:40)
    4. rackspace is working on it, we don't know of an ETA yet (colindixon, 17:31:26)
    5. colindixon notes that we're still seeing some Nexus timeouts, but much, much less (colindixon, 17:31:59)
    6. colindixon says he's seen 1 example and run something like 200 verifiy jobs yesterday (colindixon, 17:32:24)
    7. zxiiro says he's see 3 reports so far (colindixon, 17:32:33)

  7. An Ho as committer on releng/autorlease (colindixon, 17:32:50)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005833.html (colindixon, 17:32:57)
    2. https://lists.opendaylight.org/pipermail/dev/2016-August/002620.html votes (colindixon, 17:33:05)
    3. https://git.opendaylight.org/gerrit/#/q/project:releng/autorelease+owner:%22A+H+%253Can.ho%2540huawei.com%253E%22 (colindixon, 17:33:27)
    4. VOTE: Voted on "shall the TSC approve An Ho as a committer on releng/autorelease?" Results are, +1: 9 (colindixon, 17:34:26)
    5. AGREED: An Ho is a committer on releng/autorelease (colindixon, 17:34:44)

  8. TSC elections (colindixon, 17:35:56)
    1. colindixon asks about people's readiness to discuss it (colindixon, 17:36:16)
    2. consensus seems like people need to catch up with the e-mail thread, but we could cover it for a bit (colindixon, 17:36:45)
    3. https://wiki.opendaylight.org/view/TSC:Election_Proposal (colindixon, 17:36:55)
    4. the two major remaining topics are (1) dealing with corner cases, (2) how we will mechanically use CIVS or something else to run the elctions, (3) picking represented groups (colindixon, 17:37:47)
    5. https://wiki.opendaylight.org/view/TSC:Election_Proposal#All_Types.2C_Mature_Lifecycle_States this is the represented group option which seemed to get consensus, but there others above/below it (colindixon, 17:38:07)
    6. abhijitkumbhare asks why we have mature seats here if all the projects have to be mature, colindixon answers it's just to give extra representation to mature projects and an incentive to move to mature (colindixon, 17:41:54)
    7. colindixon notes that having 1/3 (5 seat) cap on mature projects, will probalby be a problem as the number of mature projects grows from where we are now with 8 mature projects: https://wiki.opendaylight.org/view/Category:Mature_Projects (colindixon, 17:43:10)
    8. abhijitkumbhare aks if we really need caps for project categories at all, edwarnicke says that caps are trick and can be bad (colindixon, 17:43:45)
    9. to clarify... edwarnicke favors either no caps on any RG (including company caps) or uniform caps (edwarnicke, 17:44:20)
    10. edwarnicke 's point was that even company caps are *already* producing distortions where strong community members are being bumped (edwarnicke, 17:44:57)
    11. ChrisPriceAB says he worries about how complicated this is and that it might make people have a disconnection between their vote and their results (colindixon, 17:45:22)
    12. in particular ChrisPriceAB notes that this would seem to potentially punish projects for becoming core and/or mature (colindixon, 17:46:50)
    13. some rehashing of the RG caps discussion (colindixon, 17:47:02)
    14. colindixon notes that we're not sure how and if CIVS actually supports scaled popularity and the like (colindixon, 17:48:41)
    15. also, we need to decide if somebody can be elected to the TSC twice in two different elections? also if somebody is the PTL of two projects in a group, do they get 2 votes? (colindixon, 17:49:30)
    16. edwarnicke says his take is that PTLs are voting on behalf of the project, mohnish__ says that in that case, the PTL might have to poll the project, colindixon notes that in general, we let PTLs vote their conscience without having to consult the project on every issue (colindixon, 17:52:57)
    17. vishnoianil says it's not clear if PTLs are voting for themselves or voting for their project, if it's the latter, the PTL should probably get a number votes equal to the number of projects they're leading (colindixon, 17:53:33)
    18. vishnoianil asks how we solve this for committers-at-large, colindixon says that's an election over committers and not projects, so it's one person one vote (colindixon, 17:55:56)
    19. vishnoianil asks if you could vote two different ways with your two votes, phrobb and colindixon say that you might really want to allow that, phrobb also says that if somebody was PTL of projects in 2 different RGs, he would get one vote in each, so maybe he should get 2 votes in one RG (colindixon, 17:58:40)
    20. another corner case would be if the votes are open (colindixon, 18:01:01)

  9. cookies (colindixon, 18:01:20)


Meeting ended at 18:01:28 UTC (full logs).

Action items

  1. colindixon to e-mail out results of the APAC-time-zone poll
  2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
  3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. anipbu to make sure we release note the change in HTTP RESTCONF RESPONSE codes
  5. colindixon and edwarnicke to try to work through the corner cases and process of the TSC elections https://wiki.opendaylight.org/view/TSC:Election_Proposal
  6. everyone to review the other bits of the TSC elections, most notably the the representing multiple groups or projects and picking represented groups https://wiki.opendaylight.org/view/TSC:Election_Proposal
  7. colindixon to ask how hard it woudl be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron


Action items, by person

  1. anipbu
    1. anipbu to make sure we release note the change in HTTP RESTCONF RESPONSE codes
  2. colindixon
    1. colindixon to e-mail out results of the APAC-time-zone poll
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
    3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
    4. colindixon and edwarnicke to try to work through the corner cases and process of the TSC elections https://wiki.opendaylight.org/view/TSC:Election_Proposal
    5. colindixon to ask how hard it woudl be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron
  3. edwarnicke
    1. colindixon and edwarnicke to try to work through the corner cases and process of the TSC elections https://wiki.opendaylight.org/view/TSC:Election_Proposal


People present (lines said)

  1. colindixon (86)
  2. anipbu (21)
  3. edwarnicke (11)
  4. odl_meetbot (11)
  5. abhijitkumbhare (10)
  6. adetalhouet (5)
  7. ChrisPriceAB (5)
  8. jamoluhrsen (4)
  9. vishnoianil (3)
  10. mohnish__ (2)
  11. gkaempfer (2)
  12. snackewm (2)
  13. zxiiro (1)
  14. CaseyODL (1)
  15. phrobb (0)


Generated by MeetBot 0.1.4.