#opendaylight-meeting: carbon release review

Meeting started by anipbu at 13:59:47 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 13:59:53)
    1. PTL and TSC members please #info in (anipbu, 14:00:00)
    2. anipbu (anipbu, 14:00:19)
    3. AnZa (AnZa, 14:00:28)
    4. xingjun (xingjun, 14:00:31)
    5. Thanh (zxiiro, 14:00:54)
    6. gkaempfer (gkaempfer, 14:04:01)

  2. TOPOPROCESSING (anipbu, 14:05:19)
    1. https://git.opendaylight.org/gerrit/#/c/57222 <-- Release Notes (anipbu, 14:05:25)
    2. AnZa is representing TOPOPROCESSING (anipbu, 14:05:39)
    3. odl-topoprocessing-framewrok is experimental as started on the release notes (anipbu, 14:06:19)
    4. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948? (anipbu, 14:07:00)
    5. CSIT jobs are here: https://jenkins.opendaylight.org/releng/view/topoprocessing/job/topoprocessing-csit-1node-topology-operations-all-carbon/ (anipbu, 14:08:50)
    6. TOPOPROCESSING approved for Carbon. Congratulations! (anipbu, 14:11:51)

  3. USC (anipbu, 14:11:56)
    1. https://git.opendaylight.org/gerrit/57205 <-- Release Notes (anipbu, 14:12:03)
    2. anipbu is representing USC (anipbu, 14:12:08)
    3. usc is non-experimental as stated in the release notes (zxiiro, 14:15:24)
    4. USC is in maintenance mode, so no changes in this release (zxiiro, 14:15:49)
    5. USC approved for Carbon. (zxiiro, 14:17:10)

  4. NEMO (anipbu, 14:17:37)
    1. https://git.opendaylight.org/gerrit/57204 <-- Release Notes (anipbu, 14:17:42)
    2. anipbu is representing NEMO (anipbu, 14:17:46)
    3. NEMO is non-experimental as stated in the release notes. (zxiiro, 14:18:35)
    4. nemo is in maintenance mode. no changes in this release (zxiiro, 14:19:17)
    5. NEMO approved for Carbon. (zxiiro, 14:20:11)

  5. DLUXAPPS (anipbu, 14:20:44)
    1. https://git.opendaylight.org/gerrit/#/c/57208/ <-- Release Notes (anipbu, 14:20:50)
    2. Daniel Malachovsky is representing DLUXAPPS (anipbu, 14:20:57)
    3. all dluxapps features are experimental (anipbu, 14:21:59)
    4. DLUXAPPS CSIT have some failures but not blocker issues: https://jenkins.opendaylight.org/releng/job/dluxapps-csit-1node-yangman-all-carbon/ (anipbu, 14:23:21)
    5. dluxapps have tested RC1 and found no blocker issues (anipbu, 14:23:32)
    6. dluxapps tests can be ignored: https://jenkins.opendaylight.org/releng/view/dluxapps/job/dluxapps-csit-1node-yangman-all-carbon/ (anipbu, 14:23:48)
    7. dmalachovsky says dluxapps is new project in carbon, we split dlux into two projects (anipbu, 14:25:55)
    8. dmalachovsky says changes were mostly in infrastructure, not in applications itself (anipbu, 14:26:38)
    9. dluxapps feature name changes: odl-dlux to odl-dluxapps (anipbu, 14:27:23)
    10. DLUXAPPS approved for Carbon. Congratulations! (anipbu, 14:28:53)

  6. FEDERATION (anipbu, 14:28:59)
    1. https://git.opendaylight.org/gerrit/#/c/57207/<-- Release Notes (anipbu, 14:29:04)
    2. Gideon Kaempfer is representing FEDERATION (anipbu, 14:29:27)
    3. all federation features are experimental (anipbu, 14:30:41)
    4. federation is tested only by means of NetVirt (via the NetVirt federation plugin) and should be OK but I wasn't able to positively establish testing status before this review. (anipbu, 14:34:00)
    5. FEDERATION has rested against RC1 and found no blocker (anipbu, 14:34:35)
    6. ACTION: gkaempfer will follow up on RC1 testing with release team once receive positive feedback from the NetVirt federation people (anipbu, 14:36:30)
    7. FEDERATION is pending. Waiting on completion of action items as stated above. (anipbu, 14:40:36)

  7. FAAS (anipbu, 14:40:55)
    1. https://git.opendaylight.org/gerrit/#/c/57212/<-- Release Notes (anipbu, 14:41:01)
    2. xingjun chu is representing FAAS (anipbu, 14:41:07)
    3. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit?us (anipbu, 14:42:31)
    4. FAAS has tested RC1 and found no blocker issues (anipbu, 14:42:45)
    5. FAAS has video, which will be reduced in size (anipbu, 14:43:29)
    6. all FAAS features are experimental as stated on the release notes (anipbu, 14:45:05)
    7. FAAS performs only manual testing as stated on the release notes (anipbu, 14:46:40)
    8. xingjun says that faas is not stateless, but don't have configuration change this release. (anipbu, 14:48:46)
    9. colindixon raised concerns on compatibility and migration. at the very least, users would need to somehow get all the data out and put it all back in (anipbu, 14:50:18)
    10. ACTION: xingjun will update the release notes on the migration and compatibility as per colindixon's comments (anipbu, 14:50:41)
    11. ACTION: xingjun to respond to docs feedback on the release notes patch (anipbu, 14:50:54)
    12. FAAS approved for Carbon pending action items and follow up. Congratulations! (anipbu, 14:51:55)

  8. BGPCEP (anipbu, 14:52:00)
    1. https://git.opendaylight.org/gerrit/#/c/57244/ <-- Release Notes (anipbu, 14:52:06)
    2. Claudio D. Gasparini is representing BGPCEP (anipbu, 14:52:11)
    3. odl-bgpcep-bgp/bmp/pcep are nonexperimental as stated on the release notes (anipbu, 14:54:18)
    4. bgpcep has extensive test coverage: https://jenkins.opendaylight.org/releng/view/bgpcep/ but several are failing in CSIT (anipbu, 14:55:15)
    5. bgpcep has tested RC1 and found no blocker bugs (anipbu, 14:55:32)
    6. colindixon provided some (mostly minor) feedback on the release notes patch, the only one of note is asking if it makes sense to point out that MD5 is believed broken, so presumably TCP-MD5 authentication is as well (colindixon, 14:56:09)
    7. ACTION: cgasparini will follow up on colindixon feedback for the release notes (anipbu, 14:58:06)
    8. BGPCEP had no major changes in this release (anipbu, 15:00:39)
    9. BGPCEP approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:02:32)

  9. GROUPBASEDPOLICY (anipbu, 15:02:37)
    1. https://git.opendaylight.org/gerrit/#/c/57243/ <-- Release Notes (anipbu, 15:02:42)
    2. Vladimir Lavor is representing GROUPBASEDPOLICY (anipbu, 15:02:48)
    3. groupbasedpolicy has tested RC1 and found no blocker bugs (anipbu, 15:03:51)
    4. vlavor notes test failures that can be ignored. (anipbu, 15:05:29)
    5. colindixon provded some feedback on the patch with the only one of note being that the migration should probably say that migration isn't supported since it seems like it's not (colindixon, 15:05:55)
    6. ACTION: vlavor to follow up on feedback on the release notes patch (anipbu, 15:06:19)
    7. all groupbasedpolicy features are experimental as stated on the release notes (anipbu, 15:07:16)
    8. groupbasedpolicy has some CSIT for some features (which are all experimental). The current set of CSIT test failures can be ignored. (anipbu, 15:09:20)
    9. groupbasedpolicy is currently an active project with some features still under development (anipbu, 15:09:55)
    10. groupbasedpolicy has some API changes in this release: https://git.opendaylight.org/gerrit/#/c/49041/ https://git.opendaylight.org/gerrit/#/c/49190/ (anipbu, 15:10:26)
    11. GROUPBASEDPOLICY approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:14:59)

  10. HONEYCOMB/VBD (anipbu, 15:15:03)
    1. https://git.opendaylight.org/gerrit/#/c/57250 <-- Release Notes (anipbu, 15:15:08)
    2. Michal Cmarada is representing HONEYCOMB/VBD (anipbu, 15:15:15)
    3. VBD has tested RC1 and found no blocker (anipbu, 15:17:15)
    4. VBD does not run any CSIT tests (anipbu, 15:17:26)
    5. All VBD features are experimental as stated in the release notes (anipbu, 15:18:25)
    6. colindixon notes that he has feedback on the patch with the only major part being getting clarification on migratoin (colindixon, 15:20:28)
    7. http://testresults.opnfv.org/reporting/functest/release/danube/index-status-apex.html (colindixon, 15:21:07)
    8. VBD running some aditional automated tests as part of Fast Data Stacks (FDS) testing suites (anipbu, 15:22:23)
    9. ACTION: michal-cmarada|2 to follow up on feedback from colindixon on release notes patch regarding clarification on migration (anipbu, 15:23:14)
    10. colindixon, for the FaaS project release notes, I have just replied to all your comments and pushed a new patch. thx (xingjun, 15:23:34)
    11. HONEYCOMB/VBD approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:28:12)

  11. AAA (anipbu, 15:28:18)
    1. https://git.opendaylight.org/gerrit/#/c/57286 <-- Release Notes (anipbu, 15:28:23)
    2. Ryan Goulding is representing AAA (anipbu, 15:28:29)
    3. AAA has tested RC1 and found no blocker (anipbu, 15:30:42)
    4. AAA has three CSIT test failures but they have been updated as "IGNORE" on the spreadsheet (anipbu, 15:31:19)
    5. rgoulding says no major changes in this release (anipbu, 15:33:03)
    6. All AAA features are experimental as stated on the release notes (anipbu, 15:33:54)
    7. ACTION: rgoulding to follow up and update the patch if necessary on the "experimental/nonexperimental" state of AAA's features (anipbu, 15:38:44)
    8. AAA approved for Carbon. Congratulations! (anipbu, 15:40:10)

  12. CONTROLLER (anipbu, 15:40:15)
    1. Tom Pantelis is representing CONTROLLER (anipbu, 15:40:22)
    2. ACTION: pantelis to generate release notes and upload to the docs repo and notify the release team once the release notes are available. (anipbu, 15:42:13)
    3. ACTION: pantelis to reschedule the release review for a later timeslot once release notes are available (anipbu, 15:42:34)
    4. https://github.com/opendaylight/docs/blob/master/docs/getting-started-guide/project-release-notes/sample-release-notes.rst (colindixon, 15:43:44)

  13. SXP (anipbu, 15:50:42)
    1. https://git.opendaylight.org/gerrit/#/c/57047/ <-- Release Notes (anipbu, 15:50:48)
    2. Martin Mihálek is representing SXP (anipbu, 15:50:54)
    3. SXP has tested RC1 and found no blocker bugs (anipbu, 15:51:51)
    4. SXP has CSIT test failures, but they have signed off on the test failures as "OKAY" on the spreadsheet. (anipbu, 15:52:27)
    5. All SXP features are experimental as stated on the release notes (anipbu, 15:53:06)
    6. colindixon left feedback on the patch, but the only major one is asking how the SXP protocol is secured (colindixon, 15:55:16)
    7. ACTION: mamihale to follow up on the feedback on the release notes patch (anipbu, 15:56:22)
    8. mamihale states that in this release, SXP provided one new experimental feature proposed otherwise no big changes (anipbu, 15:58:27)
    9. mamihale states that for security on port 64999 it is used MD5 (anipbu, 15:59:57)
    10. ACTION: mamihale to update the release notes on the security issues (anipbu, 16:00:52)
    11. ACTION: jamoluhrsen to follow up and merge the test patch for SXP (anipbu, 16:01:10)
    12. SXP approved for Carbon pending action items and follow up. Congratulations! (anipbu, 16:03:10)

  14. IOTDM (anipbu, 16:03:15)
    1. https://git.opendaylight.org/gerrit/#/c/57120/ <-- Release Notes (anipbu, 16:03:22)
    2. Tomas Janciga is representing IOTDM (anipbu, 16:03:27)
    3. All IOTDM features are experimental as stated on the release notes (anipbu, 16:07:07)
    4. IOTDM has tested RC1 and found no blockers (anipbu, 16:07:26)
    5. IOTDM has two CSIT test failures and have signed off on them as IGNORE (anipbu, 16:07:54)
    6. ACTION: tjanciga to follow up and update the release notes on the sections that have been left blank (anipbu, 16:11:06)
    7. tjanciga states that for the documentation there are no plans to migrate to RST until after the planned changes to features which will lead to update of documentation (anipbu, 16:13:26)
    8. IOTDM has some major changes in this release with adding new experimental features: Added plugin infrastructure features which allows easy implementation of new device plugins (anipbu, 16:17:23)
    9. IOTDM approved for Carbon pending action items and follow up. Congratulations! (anipbu, 16:20:17)

  15. NETCONF (anipbu, 16:39:19)
    1. https://git.opendaylight.org/gerrit/#/c/57249/ <-- Release Notes (anipbu, 16:39:25)
    2. Jakub Morvay is representing NETCONF (anipbu, 16:39:30)
    3. jmorvay_ says NETCONF team has checked releng jobs and they all passed on RC1 (anipbu, 16:43:22)
    4. NETCONF has tested RC1 and found no blockers (anipbu, 16:43:32)
    5. NETCONF has reviewed CSIT test failures and found no blocker issues (anipbu, 16:43:50)
    6. ACTION: jmorvay_ will update the release notes on the migration (anipbu, 16:49:07)
    7. colindixon states netconf doesn't have a clean way to migrate. jmorvay_ states mountpoints configuration is stored in config DS. Will update the release notes on migration aspects (anipbu, 16:50:41)
    8. netconf features in the release plan marked as not experimental covered in CSIT (anipbu, 16:52:02)
    9. for netconf in carbon, no major changes apart from experimental call-home feature (anipbu, 16:52:30)
    10. NETCONF approved for Carbon pending action items and follow up. Congratulations! (anipbu, 16:54:07)

  16. MDSAL (anipbu, 16:54:12)
    1. https://git.opendaylight.org/gerrit/#/c/57287/ <-- Release Notes (anipbu, 16:54:16)
    2. Martin Ciglan is representing MDSAL (anipbu, 16:54:21)
    3. MDSAL has tested RC1 and found no blockers. (anipbu, 17:02:19)
    4. MDSAL has one CSIT test failures. mciglan says it can be ignored, but will provide more details after the meeting (anipbu, 17:02:54)
    5. ACTION: mciglan to follow up on the CSIT test failures on the spreadsheet (anipbu, 17:03:09)
    6. MDSAL has system test waiver (anipbu, 17:03:35)
    7. odl-mdsal-binding is nonexperimental and all other features are experimental as stated on the release notes (anipbu, 17:04:35)
    8. MDSAL's nonexperimental feature (odl-mdsal-binding) has CSIT coverage but it currently failing. mciglan will follow up with the test team. (anipbu, 17:05:36)
    9. mciglan states there are no major changes in this release (anipbu, 17:08:02)
    10. ACTION: mciglan to follow up on the feedback for the release notes patch (anipbu, 17:09:35)
    11. MDSAL approved for Carbon pending action items and follow up. Congratulations! (anipbu, 17:11:00)

  17. cookies (anipbu, 17:12:09)


Meeting ended at 17:12:20 UTC (full logs).

Action items

  1. gkaempfer will follow up on RC1 testing with release team once receive positive feedback from the NetVirt federation people
  2. xingjun will update the release notes on the migration and compatibility as per colindixon's comments
  3. xingjun to respond to docs feedback on the release notes patch
  4. cgasparini will follow up on colindixon feedback for the release notes
  5. vlavor to follow up on feedback on the release notes patch
  6. michal-cmarada|2 to follow up on feedback from colindixon on release notes patch regarding clarification on migration
  7. rgoulding to follow up and update the patch if necessary on the "experimental/nonexperimental" state of AAA's features
  8. pantelis to generate release notes and upload to the docs repo and notify the release team once the release notes are available.
  9. pantelis to reschedule the release review for a later timeslot once release notes are available
  10. mamihale to follow up on the feedback on the release notes patch
  11. mamihale to update the release notes on the security issues
  12. jamoluhrsen to follow up and merge the test patch for SXP
  13. tjanciga to follow up and update the release notes on the sections that have been left blank
  14. jmorvay_ will update the release notes on the migration
  15. mciglan to follow up on the CSIT test failures on the spreadsheet
  16. mciglan to follow up on the feedback for the release notes patch


Action items, by person

  1. cgasparini
    1. cgasparini will follow up on colindixon feedback for the release notes
  2. colindixon
    1. xingjun will update the release notes on the migration and compatibility as per colindixon's comments
    2. cgasparini will follow up on colindixon feedback for the release notes
    3. michal-cmarada|2 to follow up on feedback from colindixon on release notes patch regarding clarification on migration
  3. gkaempfer
    1. gkaempfer will follow up on RC1 testing with release team once receive positive feedback from the NetVirt federation people
  4. jamoluhrsen
    1. jamoluhrsen to follow up and merge the test patch for SXP
  5. jmorvay_
    1. jmorvay_ will update the release notes on the migration
  6. mamihale
    1. mamihale to follow up on the feedback on the release notes patch
    2. mamihale to update the release notes on the security issues
  7. mciglan
    1. mciglan to follow up on the CSIT test failures on the spreadsheet
    2. mciglan to follow up on the feedback for the release notes patch
  8. michal-cmarada|2
    1. michal-cmarada|2 to follow up on feedback from colindixon on release notes patch regarding clarification on migration
  9. pantelis
    1. pantelis to generate release notes and upload to the docs repo and notify the release team once the release notes are available.
    2. pantelis to reschedule the release review for a later timeslot once release notes are available
  10. rgoulding
    1. rgoulding to follow up and update the patch if necessary on the "experimental/nonexperimental" state of AAA's features
  11. tjanciga
    1. tjanciga to follow up and update the release notes on the sections that have been left blank
  12. vlavor
    1. vlavor to follow up on feedback on the release notes patch
  13. xingjun
    1. xingjun will update the release notes on the migration and compatibility as per colindixon's comments
    2. xingjun to respond to docs feedback on the release notes patch


People present (lines said)

  1. anipbu (349)
  2. colindixon (82)
  3. katie (32)
  4. jamoluhrsen (29)
  5. rgoulding (28)
  6. zxiiro (28)
  7. jmorvay_ (20)
  8. xingjun (19)
  9. pantelis (14)
  10. tjanciga (14)
  11. dmalachovsky (12)
  12. gkaempfer (12)
  13. mciglan (11)
  14. AnZa (10)
  15. cgasparini (9)
  16. michal-cmarada|2 (9)
  17. vlavor (9)
  18. mamihale (9)
  19. odl_meetbot (8)
  20. rovarga (4)


Generated by MeetBot 0.1.4.