#opendaylight-meeting: carbon release review

Meeting started by anipbu at 13:59:27 UTC (full logs).

Meeting summary

  1. roll call (anipbu, 13:59:32)
    1. PTL and TSC members please #info in (anipbu, 13:59:38)
    2. colindixon for docs, ttp, and TSC (colindixon, 14:00:01)
    3. anipbu (anipbu, 14:00:04)
    4. skitt (skitt, 14:00:43)

  2. ODLPARENT (anipbu, 14:00:58)
    1. https://git.opendaylight.org/gerrit/57349 <-- Release Notes (anipbu, 14:01:05)
    2. Stephen Kitt is representing ODLPARENT (anipbu, 14:01:09)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/273/archives/docs/_build/html/ Current ODLParent Generated Release Notes (zxiiro, 14:02:39)
    4. ODLPARENT has tested RC0 and found no blocker bugs (anipbu, 14:04:22)
    5. odlparent has no CSIT test failures (anipbu, 14:04:33)
    6. odlparent has system test waiver (anipbu, 14:04:49)
    7. odlparent has no user-facing features to declare experimental/nonexperimental (anipbu, 14:05:39)
    8. ACTION: skitt to follow up on feedback on release notes regarding formatting, etc. (anipbu, 14:06:04)
    9. odlparent major changes were: improved single feature tests, and Karaf 4 support, fixed the randomness issue with SSH (anipbu, 14:08:24)
    10. ODLPARENT approved for Carbon pending action items and follow up. Congratulations! (anipbu, 14:08:34)

  3. NEUTRON (anipbu, 14:08:41)
    1. https://git.opendaylight.org/gerrit/#/c/57197 <-- Release Notes (anipbu, 14:08:45)
    2. Isaku Yamahata is representing NEUTRON (anipbu, 14:08:50)
    3. https://review.openstack.org/#/c/465189/ (yamahata, 14:09:49)
    4. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/304/archives/docs/_build/html/getting-started-guide/project-release-notes/neutron-northbound.html.gz Neutron Generated Release Notes (zxiiro, 14:10:00)
    5. ACTION: yamahata to follow up on the feedback for the release notes patch, including formatting, etc (anipbu, 14:12:56)
    6. ACTION: yamahata and jamoluhrsen to follow up with Neutron on experimental/nonexperimental tag for features (anipbu, 14:13:59)
    7. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948 (anipbu, 14:15:04)
    8. NEUTRON cool new features: trunk API support, hostconfig for vpp, ovs-dpdk, keystone v3 support (anipbu, 14:15:31)
    9. NEUTRON has tested RC1 and found no blocker bugs (anipbu, 14:17:05)
    10. NEUTRON has no CSIT test failures in int-dist-test job (anipbu, 14:17:22)
    11. All NEUTRON features are marked as experimental for now, but will update the tag after follow up with JamO (anipbu, 14:18:06)
    12. NEUTRON approved for Carbon pending action items and follow up. Congratulations! (anipbu, 14:19:58)

  4. INFRAUTILS (anipbu, 14:20:02)
    1. https://git.opendaylight.org/gerrit/#/c/57403/ <-- Release Notes (anipbu, 14:20:06)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/318/archives/docs/_build/html/getting-started-guide/project-release-notes/infrautils.html.gz Infrautils Generated Release Notes (zxiiro, 14:20:08)
    3. Ravit Peretz is representing INFRAUTILS (anipbu, 14:20:11)
    4. INFRAUTILS has tested RC2 and found no blocker bugs (anipbu, 14:22:40)
    5. INFRAUTILS cool new features: job coordinatore refactoring in infrautils, testutils with JUnit, upcoming system services diagnostics (anipbu, 14:22:54)
    6. ACTION: ravit_ and jamoluhrsen to follow up on the "Experimental" tag for infrautils project (anipbu, 14:25:55)
    7. infrautils has no CSIT tests (and therefor no test failures) (anipbu, 14:27:13)
    8. INFRAUTILS approved for Carbon pending action items and follow up. Congratulations! (anipbu, 14:30:15)

  5. SNMP4SDN (anipbu, 14:30:22)
    1. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/314/archives/docs/_build/html/getting-started-guide/project-release-notes/snmp4sdn.html.gz SNMP4SDN Generated Release Notes (zxiiro, 14:30:27)
    2. https://git.opendaylight.org/gerrit/#/c/57395/ <-- Release Notes (anipbu, 14:30:29)
    3. Yi-Ling Hsieh is representing SNMP4SDN (anipbu, 14:30:34)
    4. Christine for snmp4sdn (Christine, 14:31:09)
    5. Release Notes comments: Mostly formatting. Substantive comment is that the features are (I think) all experimental. (anipbu, 14:31:54)
    6. SNMP4SDN has tested RC2 and found no blocker bugs (anipbu, 14:37:18)
    7. SNMP4SDN has no CSIT test failures as reported by int-dis-test (anipbu, 14:37:58)
    8. SNMP4SDN has no new major features in this release and is in maintenance mode (anipbu, 14:38:18)
    9. ACTION: Christine to follow up on the release notes patch (anipbu, 14:39:09)
    10. ACTION: Christine and jamoluhrsen to follow up with SNMP4SDN on the experimental tag. (anipbu, 14:40:04)
    11. SNMP4SDN approved for Carbon pending action items and follow up. Congratulations! (anipbu, 14:41:52)

  6. LACP (anipbu, 14:41:56)
    1. https://git.opendaylight.org/gerrit/#/c/57422/ <-- Release Notes (anipbu, 14:42:00)
    2. Ravi Sabapathy is representing LACP (anipbu, 14:42:04)
    3. ACTION: LACP will follow up on RCX testing and report back the results. (anipbu, 14:50:04)
    4. LACP review is PENDING until follow up on action items above (anipbu, 14:50:23)
    5. LACP has no new feature in Carbon and is in maintenance mode (anipbu, 14:53:21)
    6. ACTION: LACP will change the release notes patch to say that the features are experimental (anipbu, 14:53:40)
    7. ACTION: Ravi_ to follow up on the release notes patch comments (anipbu, 14:54:24)

  7. INTEGRATION/DISTRIBUTION (anipbu, 14:56:01)
    1. https://git.opendaylight.org/gerrit/57434 <--- Release Notes (anipbu, 14:56:06)
    2. Vratko Polak is representing INTEGRATION/DISTRIBUTION (anipbu, 14:56:10)
    3. INT/DIS has tested RCX and found no blocker bugs. (anipbu, 15:00:24)
    4. INT/DIS has no test failures (anipbu, 15:00:35)
    5. INT/DIS cool new features in this release: Karaf 4, but it is still highly experimental (anipbu, 15:00:57)
    6. ACTION: <vrpolak> to follow up on feedback on the release notes patch (anipbu, 15:01:37)
    7. INT/DIS manual testing: do not expect it would find anything not visible from other projects' manual testing. Most interesting tests are automated already. (anipbu, 15:02:21)
    8. INTEGRATION/DISTRIBUTION approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:03:20)

  8. BIER (anipbu, 15:03:25)
    1. https://git.opendaylight.org/gerrit/#/c/57234/ <-- Release Notes (anipbu, 15:03:30)
    2. Quan Xiong is representing BIER (anipbu, 15:03:35)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/311/archives/docs/_build/html/getting-started-guide/project-release-notes/bier.html.gz BIER Generated Release Notes (zxiiro, 15:04:15)
    4. BIER has tested RC2 and found no blocker bugs (anipbu, 15:12:30)
    5. BIER has marked CSIT test failures as IGNORE (anipbu, 15:12:41)
    6. ACTION: Xiong to update the release review to show experimental=yes for features as per the comments (anipbu, 15:14:14)
    7. BIER features are currently experimental=yes until follow up with jamoluhrsen (anipbu, 15:14:47)
    8. ACTION: Xiong to follow up on the release notes patch comments: Only note of concern is failing CSIT tests. (anipbu, 15:15:29)
    9. BIER approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:16:47)

  9. OF-CONFIG (anipbu, 15:16:56)
    1. https://git.opendaylight.org/gerrit/#/c/57320/ <-- Release Notes (anipbu, 15:17:00)
    2. Wei Meng is representing OF-CONFIG (anipbu, 15:17:05)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/255/archives/docs/_build/html/getting-started-guide/project-release-notes/of-config-release-notes.html.gz OFCONFIG Generated Release Notes (zxiiro, 15:17:11)
    4. OF-CONFIG has tested RC2 and found no blocker bugs (anipbu, 15:26:07)
    5. OF-CONFIG has marked the CSIT test failures as IGNORE (anipbu, 15:26:20)
    6. All OF-CONFIG features are marked as experimental as stated in the release notes (anipbu, 15:26:39)
    7. ACTION: wei_ to follow up with colindixon et al on the comments from the release notes patch: Only note of consequence is clarifying migration. (anipbu, 15:27:31)
    8. Comments from the release notes patch: Only note of consequence is clarifying migration. (anipbu, 15:27:53)
    9. OF-CONFIG has no new feature in this release. It is in maintenance mode. (anipbu, 15:28:21)
    10. OF-CONFIG approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:29:26)

  10. YANGTOOLS (anipbu, 15:29:31)
    1. https://git.opendaylight.org/gerrit/#/c/57264/ <-- Release Notes (anipbu, 15:29:35)
    2. Peter Kajsa, Igor Foltin is representing YANGTOOLS (anipbu, 15:29:42)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/246/archives/docs/_build/html/getting-started-guide/project-release-notes/yangtools.html.gz YangTools Generated Release Notes (zxiiro, 15:29:48)
    4. YANGTOOLS has tested RC2 and found no blocker bugs (anipbu, 15:31:15)
    5. YANGTOOLS has marked the CSIT test failures in int-dis-test as IGNORE (anipbu, 15:31:38)
    6. YANGTOOLS cool new features in this release: YANG statement parser now supports parsing YANG 1.1 models. The second new feature is - deviation statements are resolved during the parsing process (anipbu, 15:31:53)
    7. YANGTOOLS has test waiver since it is consumed by other projects. Features are currently marked as experimental, but odl-yangtools-yang-parser should be nonexperimental. Will follow up with jamoluhrsen later on the experimental tag. (anipbu, 15:33:44)
    8. ACTION: ifoltin to follow up on experimental tag for odl-yangtools-yang-parser (anipbu, 15:34:04)
    9. Release Notes Patch Comments: Only formatting issues except the details about system tests waivers and features being experimental or not. (anipbu, 15:34:27)
    10. ACTION: ifoltin to follow up on release notes patch comments (anipbu, 15:34:40)
    11. YANGTOOLS approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:35:43)

  11. SDNINTERFACEAPP (anipbu, 15:35:47)
    1. https://git.opendaylight.org/gerrit/#/c/57236/ <-- Release Notes (anipbu, 15:35:52)
    2. Sirisha Sangam is representing SDNINTERFACEAPP (anipbu, 15:35:58)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/313/archives/docs/_build/html/getting-started-guide/project-release-notes/odl-sdni-release-notes.html.gz SDNI Generated Release Notes (zxiiro, 15:36:00)
    4. SDNINTERFACEAPP has tested RC2 and found no blocker bugs (anipbu, 15:39:35)
    5. SDNINTERFACEAPP has marked CSIT test failures from int-dis-test job as IGNORE (anipbu, 15:39:47)
    6. All SDNINTERFACEAPP features are experimental as stated on the release notes (anipbu, 15:40:04)
    7. Release Notes Comments: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it. (anipbu, 15:40:27)
    8. ACTION: Sirisha to follow up with colindixon et al on the comments from the release notes patch: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it. (anipbu, 15:41:43)
    9. SDNINTERFACEAPP approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:43:08)

  12. L2SWITCH (anipbu, 15:43:12)
    1. https://git.opendaylight.org/gerrit/#/c/57401/ <-- Release Notes (anipbu, 15:43:18)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/316/archives/docs/_build/html/getting-started-guide/project-release-notes/l2switch.html.gz l2switch Generated Release Notes (zxiiro, 15:43:21)
    3. Sai MarapaReddy is representing L2SWITCH (anipbu, 15:43:23)
    4. L2SWITCH has tested RC2 and found no blockers (anipbu, 15:49:40)
    5. L2SWITCH has no CSIT test failure in int-dis-test job (anipbu, 15:50:10)
    6. L2SWITCH has nonexperimental feature: odl-l2switch-release (Jamo's comments: csit is decent, but some sporadic failures that are tracked as part of bug 6654. Good to go) (anipbu, 15:50:48)
    7. L2SWITCH has release notes patch comments: only major issue is talking about what customized interfaces there are (if any) and also if there are any security issues. At some point there were, e.g., hosts being able to be spoofed and moved, that are still unresolved. (anipbu, 15:51:13)
    8. ACTION: Sai_ to follow up with colindixon on the release notes patch comments for L2SWITCH (anipbu, 15:51:45)
    9. L2SWITCH has no new major changes in this release. It is in maintenance mode. (anipbu, 15:52:20)
    10. L2SWITCH approved for Carbon pending action items and follow up. Congratulations! (anipbu, 15:53:25)

  13. PACKETCABLE (anipbu, 15:53:29)
    1. https://git.opendaylight.org/gerrit/#/c/57218/ <-- Release Notes (anipbu, 15:53:33)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/306/archives/docs/_build/html/getting-started-guide/project-release-notes/packetcable.html.gz PacketCable Generated Release Notes (zxiiro, 15:53:36)
    3. Kevin Kershaw is representing PACKETCABLE (anipbu, 15:53:38)
    4. https://wiki.opendaylight.org/view/PacketCablePCMM:Release_Plan_Carbon#Other (kkershaw, 15:59:26)
    5. PACKETCABLE has tested RC1 and found no blocker bugs (anipbu, 15:59:57)
    6. PACKETCABLE has no CSIT test failures in int-dis-test job. (anipbu, 16:00:10)
    7. PACKETCABLE feature odl-packetcable-policy-server-all should be mark as experimental=yes as per JamO comments on the release notes patch (anipbu, 16:02:44)
    8. ACTION: kkershaw and jamoluhrsen to follow up on the experimental tag (anipbu, 16:03:22)
    9. PACKETCABLE has comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured. (anipbu, 16:04:42)
    10. ACTION: kkershaw to follow up with colindixon on the comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured. (anipbu, 16:05:11)
    11. PACKETCABLE has the following cool new feature in the carbon release: https://wiki.opendaylight.org/view/PacketCablePCMM:Release_Plan_Carbon#Other (anipbu, 16:06:20)
    12. PACKETCABLE approved for Carbon pending action items and follow up. Congratulations! (anipbu, 16:08:04)

  14. EMAN (anipbu, 16:08:07)
    1. https://git.opendaylight.org/gerrit/57219 <-- Release Notes (anipbu, 16:08:11)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/307/archives/docs/_build/html/getting-started-guide/project-release-notes/eman.html.gz EMAN Generated Release Notes (zxiiro, 16:08:13)
    3. Frank Sandoval is representing EMAN (anipbu, 16:08:15)
    4. ACTION: franks_ and EMAN team will follow up on RC2 testing by downloading the zip distribution and confirming if there are blocker bugs. (anipbu, 16:22:06)
    5. EMAN has no CSIT test failures in int-dis-test job. (anipbu, 16:22:20)
    6. All EMAN features are marked as experimental as stated on the release notes (anipbu, 16:22:42)
    7. EMAN comments on the release notes patch: Mostly just formatting an style. It would be good to say that it's the first release instead of just "NA" in a bunch of places. (anipbu, 16:23:04)
    8. ACTION: franks_ to follow up with colindixon on the comments on the release notes patch. (anipbu, 16:23:30)
    9. EMAN cool new features in this release: more coverage of our energy management information model (anipbu, 16:24:15)
    10. EMAN review is PENDING. There are required action items to follow up as stated above. (anipbu, 16:25:20)

  15. NIC (anipbu, 16:28:24)
    1. https://git.opendaylight.org/gerrit/57214 <-- Release Notes (anipbu, 16:28:28)
    2. Yrineu Rodrigues is representing NIC (anipbu, 16:28:32)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/324/archives/docs/_build/html/getting-started-guide/project-release-notes/nic.html.gz NIC Generated Release Notes (zxiiro, 16:28:35)
    4. NIC review is PENDING. No representative showed up for release review. (anipbu, 16:31:44)

  16. OPENFLOWPLUGIN (anipbu, 16:31:54)
    1. https://git.opendaylight.org/gerrit/57365 <-- Release Notes (anipbu, 16:31:58)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/317/archives/docs/_build/html/getting-started-guide/project-release-notes/openflowplugin.html.gz OpenFlowPlugin Generated Release Notes (zxiiro, 16:31:59)
    3. Abhijit Kumbhare is representing OPENFLOWPLUGIN (anipbu, 16:32:02)
    4. OPENFLOWPLUGIN has tested RC1 and found no new blocker bugs (besides the ones already fixed earlier in the week). (anipbu, 16:43:50)
    5. OPENFLOWPLUGIN has several CSIT failures which they review and follow up on: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761 (anipbu, 16:44:25)
    6. ACTION: abhijitkumbhare to follow up on CSIT test failures (anipbu, 16:44:44)
    7. OPENFLOWPLUGIN has release notes comments: Biggest issue is around security. (anipbu, 16:46:00)
    8. ACTION: abhijitkumbhare to follow up with colindixon on release notes comments: Biggest issue is around security. (anipbu, 16:46:27)
    9. OPENFLOWPLUGIN cool new features: Single Model Layer Implementation, Split connection layer from core (anipbu, 16:47:20)
    10. OPENFLOWPLUGIN has a mix of experimental and nonexperimental features. core features are nonexperimental. (anipbu, 16:47:52)
    11. OPENFLOWPLUGIN approved for Carbon pending action items and follow up. Congratulations! (anipbu, 16:48:54)

  17. OCPPLUGIN (anipbu, 16:49:06)
    1. https://git.opendaylight.org/gerrit/57238 <-- Release Notes (anipbu, 16:49:10)
    2. Chinning Lai is representing OCPPLUGIN (anipbu, 16:49:14)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/309/archives/docs/_build/html/getting-started-guide/project-release-notes/ocpplugin-release-notes.html.gz OCPPLUGIN Generated Release Notes (zxiiro, 16:50:02)
    4. OCPPLUGIN has tested RC2 and found no blocker bugs (anipbu, 16:51:39)
    5. OCPPLUGIN has no CSIT test failures as reported by latest iint-dis-test job (anipbu, 16:51:54)
    6. OCPPLUGIN has no new major changes in this release. It is in maintenance mode (anipbu, 16:52:09)
    7. OCPPLUGIN has two nonexperimental features: odl-ocpplugin-southbound and odl-ocpplugin-app-ocp-service as stated on the release notes. (jamoluhrsen comments: like to see more extensive CSIT but was fine with non-experimental labels) (anipbu, 16:53:16)
    8. OCPPLUGIN has comments on the release notes: Mostly minor things (anipbu, 16:53:45)
    9. ACTION: Chinning to follow up with colindixon on the release notes patch comments: Mostly minor things (anipbu, 16:54:17)
    10. OCPPLUGIN approved for Carbon pending action items and follow up. Congratulations! (anipbu, 16:56:07)

  18. OPFLEX (anipbu, 16:56:12)
    1. https://git.opendaylight.org/gerrit/57199 <-- Release Notes (anipbu, 16:56:24)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/310/archives/docs/_build/html/getting-started-guide/project-release-notes/opflex.html.gz OpFlex Generated Release Notes (zxiiro, 16:56:25)
    3. Rob Adams is representing OPFLEX (anipbu, 16:56:28)
    4. OPFLEX has tested RC2 and found no blocker bugs (anipbu, 17:00:50)
    5. OPFLEX has no CSIT test failures in int-dis-test job. (anipbu, 17:01:05)
    6. ACTION: readams to add description on opflex features (the non karaf features) (anipbu, 17:02:23)
    7. ACTION: readams to add link to testing mechanism in the release notes (anipbu, 17:02:41)
    8. OPFLEX cool new features in this release: Improved robustness against configuration problems, Support for neutron-style security groups, Support for load balanced L3/L4 services, For developers: C++11 support (anipbu, 17:03:15)
    9. OPFLEX has release notes comments: Just asking for more info and/or missing sections: moral equivalent of karaf features described (we've done this in the past), security considerations, release mechanics, some more links (anipbu, 17:04:35)
    10. ACTION: readams to follow up with colindixon on the release notes comments as stated above. (anipbu, 17:05:14)
    11. OPFLEX approved for Carbon pending action items and follow up. Congratulations! (anipbu, 17:06:31)

  19. TTP (anipbu, 17:06:35)
    1. https://git.opendaylight.org/gerrit/57442 <--- Release Notes (anipbu, 17:06:40)
    2. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/327/archives/docs/_build/html/getting-started-guide/project-release-notes/ttp.html.gz TTP Generated Release Notes (zxiiro, 17:06:41)
    3. Colin Dixon is representing TTP (anipbu, 17:06:44)
    4. TTP has tested RC2 and found no blocker bugs (anipbu, 17:08:00)
    5. TTP does not have CSIT failures as reported by int-dis-test job (anipbu, 17:08:13)
    6. All TTP are marked as experimental as stated on the release notes (anipbu, 17:08:31)
    7. TTP has no new major features or changes in this release. It is in maintenance mode. (anipbu, 17:10:52)
    8. ACTION: colindixon to follow up with jamoluhrsen in providing description of manual testing in TTP System Test Plan (anipbu, 17:11:25)
    9. TTP has release notes comments: minor formatting. Nothing serious. (anipbu, 17:11:52)
    10. TTP approved for Carbon pending action items and follow up. Congratulations! (anipbu, 17:12:40)

  20. DOCS (anipbu, 17:12:44)
    1. https://git.opendaylight.org/gerrit/57429 <--- Release Notes (anipbu, 17:12:48)
    2. Colin Dixon is representing DOCS (anipbu, 17:12:53)
    3. https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/323/archives/docs/_build/html/getting-started-guide/project-release-notes/docs.html.gz Docs Generated Release Notes (zxiiro, 17:13:22)
    4. DOCS RC testing does not apply. (anipbu, 17:14:30)
    5. DOCS CSIT does not apply. (anipbu, 17:14:37)
    6. DOCS features (producing the documentation literature) is nonexperimental in the sense that folks can consume it and it is up to date. (anipbu, 17:15:34)
    7. DOCS new cool features is per-project release notes (anipbu, 17:15:55)
    8. ACTION: colindixon to follow up on the release notes comments: Minor formatting. Nothing serious. (anipbu, 17:16:28)
    9. DOCS approved for Carbon pending action items and follow up. Congratulations! (anipbu, 17:17:05)

  21. Missing Projects (anipbu, 17:17:11)
  22. cookies (anipbu, 17:19:19)


Meeting ended at 17:19:28 UTC (full logs).

Action items

  1. skitt to follow up on feedback on release notes regarding formatting, etc.
  2. yamahata to follow up on the feedback for the release notes patch, including formatting, etc
  3. yamahata and jamoluhrsen to follow up with Neutron on experimental/nonexperimental tag for features
  4. ravit_ and jamoluhrsen to follow up on the "Experimental" tag for infrautils project
  5. Christine to follow up on the release notes patch
  6. Christine and jamoluhrsen to follow up with SNMP4SDN on the experimental tag.
  7. LACP will follow up on RCX testing and report back the results.
  8. LACP will change the release notes patch to say that the features are experimental
  9. Ravi_ to follow up on the release notes patch comments
  10. <vrpolak> to follow up on feedback on the release notes patch
  11. Xiong to update the release review to show experimental=yes for features as per the comments
  12. Xiong to follow up on the release notes patch comments: Only note of concern is failing CSIT tests.
  13. wei_ to follow up with colindixon et al on the comments from the release notes patch: Only note of consequence is clarifying migration.
  14. ifoltin to follow up on experimental tag for odl-yangtools-yang-parser
  15. ifoltin to follow up on release notes patch comments
  16. Sirisha to follow up with colindixon et al on the comments from the release notes patch: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it.
  17. Sai_ to follow up with colindixon on the release notes patch comments for L2SWITCH
  18. kkershaw and jamoluhrsen to follow up on the experimental tag
  19. kkershaw to follow up with colindixon on the comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured.
  20. franks_ and EMAN team will follow up on RC2 testing by downloading the zip distribution and confirming if there are blocker bugs.
  21. franks_ to follow up with colindixon on the comments on the release notes patch.
  22. abhijitkumbhare to follow up on CSIT test failures
  23. abhijitkumbhare to follow up with colindixon on release notes comments: Biggest issue is around security.
  24. Chinning to follow up with colindixon on the release notes patch comments: Mostly minor things
  25. readams to add description on opflex features (the non karaf features)
  26. readams to add link to testing mechanism in the release notes
  27. readams to follow up with colindixon on the release notes comments as stated above.
  28. colindixon to follow up with jamoluhrsen in providing description of manual testing in TTP System Test Plan
  29. colindixon to follow up on the release notes comments: Minor formatting. Nothing serious.


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to follow up on CSIT test failures
    2. abhijitkumbhare to follow up with colindixon on release notes comments: Biggest issue is around security.
  2. Chinning
    1. Chinning to follow up with colindixon on the release notes patch comments: Mostly minor things
  3. Christine
    1. Christine to follow up on the release notes patch
    2. Christine and jamoluhrsen to follow up with SNMP4SDN on the experimental tag.
  4. colindixon
    1. wei_ to follow up with colindixon et al on the comments from the release notes patch: Only note of consequence is clarifying migration.
    2. Sirisha to follow up with colindixon et al on the comments from the release notes patch: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it.
    3. Sai_ to follow up with colindixon on the release notes patch comments for L2SWITCH
    4. kkershaw to follow up with colindixon on the comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured.
    5. franks_ to follow up with colindixon on the comments on the release notes patch.
    6. abhijitkumbhare to follow up with colindixon on release notes comments: Biggest issue is around security.
    7. Chinning to follow up with colindixon on the release notes patch comments: Mostly minor things
    8. readams to follow up with colindixon on the release notes comments as stated above.
    9. colindixon to follow up with jamoluhrsen in providing description of manual testing in TTP System Test Plan
    10. colindixon to follow up on the release notes comments: Minor formatting. Nothing serious.
  5. franks_
    1. franks_ and EMAN team will follow up on RC2 testing by downloading the zip distribution and confirming if there are blocker bugs.
    2. franks_ to follow up with colindixon on the comments on the release notes patch.
  6. ifoltin
    1. ifoltin to follow up on experimental tag for odl-yangtools-yang-parser
    2. ifoltin to follow up on release notes patch comments
  7. kkershaw
    1. kkershaw and jamoluhrsen to follow up on the experimental tag
    2. kkershaw to follow up with colindixon on the comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured.
  8. Ravi_
    1. Ravi_ to follow up on the release notes patch comments
  9. ravit_
    1. ravit_ and jamoluhrsen to follow up on the "Experimental" tag for infrautils project
  10. readams
    1. readams to add description on opflex features (the non karaf features)
    2. readams to add link to testing mechanism in the release notes
    3. readams to follow up with colindixon on the release notes comments as stated above.
  11. Sai_
    1. Sai_ to follow up with colindixon on the release notes patch comments for L2SWITCH
  12. Sirisha
    1. Sirisha to follow up with colindixon et al on the comments from the release notes patch: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it.
  13. skitt
    1. skitt to follow up on feedback on release notes regarding formatting, etc.
  14. vrpolak
    1. <vrpolak> to follow up on feedback on the release notes patch
  15. wei_
    1. wei_ to follow up with colindixon et al on the comments from the release notes patch: Only note of consequence is clarifying migration.
  16. Xiong
    1. Xiong to update the release review to show experimental=yes for features as per the comments
    2. Xiong to follow up on the release notes patch comments: Only note of concern is failing CSIT tests.
  17. yamahata
    1. yamahata to follow up on the feedback for the release notes patch, including formatting, etc
    2. yamahata and jamoluhrsen to follow up with Neutron on experimental/nonexperimental tag for features
  18. UNASSIGNED
    1. LACP will follow up on RCX testing and report back the results.
    2. LACP will change the release notes patch to say that the features are experimental


People present (lines said)

  1. anipbu (443)
  2. colindixon (66)
  3. zxiiro (40)
  4. abhijitkumbhare (26)
  5. Ravi_ (18)
  6. ravit_ (16)
  7. LuisGomez (15)
  8. yamahata (15)
  9. skitt (15)
  10. wei_ (15)
  11. kkershaw (13)
  12. franks_ (13)
  13. readams (11)
  14. Xiong (11)
  15. Christine (9)
  16. Sirisha (9)
  17. odl_meetbot (8)
  18. vrpolak (7)
  19. ifoltin (7)
  20. Sai_ (5)
  21. Chinning (4)
  22. lalit (1)


Generated by MeetBot 0.1.4.