#opendaylight-meeting: carbon release sync

Meeting started by colindixon at 15:03:21 UTC (full logs).

Meeting summary

  1. state of the world (colindixon, 15:03:28)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC0_Download (anipbu, 15:03:48)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC0_Download we have an RC0 (colindixon, 15:04:06)
    3. https://lists.opendaylight.org/pipermail/release/2017-May/010838.html asking people to test (colindixon, 15:04:45)
    4. https://git.opendaylight.org/gerrit/#/q/branch:stable/carbon+status:merged recently merged patches (colindixon, 15:05:12)
    5. the above is probably a rough approximation of patches merged, that may or may not be blocking bug fixes (colindixon, 15:05:52)
    6. https://git.opendaylight.org/gerrit/#/c/56854/ (colindixon, 15:06:23)
    7. https://git.opendaylight.org/gerrit/#/c/56747/ (colindixon, 15:07:25)
    8. colindixon is working katie to get a release review template and schedule together, anipbu is cc'ed on the latest mail (colindixon, 15:09:13)
    9. colindixon would like to have release review and releases notes combined into one document push to git as rst in the docs repo (colindixon, 15:10:31)
    10. https://git.opendaylight.org/gerrit/#/c/56957/ the sample release document (colindixon, 15:15:12)
    11. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968 (anipbu, 15:15:25)
    12. ACTION: anipbu will work with katie send out a note asking people to make a copy of this sample relase review document and submit it as a patch before their release review (colindixon, 15:17:42)
    13. it probalby makes sense for abelur_zzz and zxiiro-away to insist on a BUG ID for merged patches from now on and if it doesn't seem like a blocker push back (colindixon, 15:24:35)
    14. ACTION: colindixon to look into why iotdm is failing in autorelease (colindixon, 15:24:47)
    15. ACTION: colindixon to open a bug to provide some sane way to test locally if a project can build without nexus for their own artifacts (colindixon, 15:25:17)
    16. anipbu asks who needs to be present for release reviews, colindixon says that he'd like zxiiro-away, colindixon and/or anipbu to be present if possible (colindixon, 15:32:00)


Meeting ended at 14:52:11 UTC (full logs).

Action items

  1. anipbu will work with katie send out a note asking people to make a copy of this sample relase review document and submit it as a patch before their release review
  2. colindixon to look into why iotdm is failing in autorelease
  3. colindixon to open a bug to provide some sane way to test locally if a project can build without nexus for their own artifacts


Action items, by person

  1. anipbu
    1. anipbu will work with katie send out a note asking people to make a copy of this sample relase review document and submit it as a patch before their release review
  2. colindixon
    1. colindixon to look into why iotdm is failing in autorelease
    2. colindixon to open a bug to provide some sane way to test locally if a project can build without nexus for their own artifacts


People present (lines said)

  1. colindixon (16)
  2. odl_meetbot (3)
  3. zxiiro (2)
  4. anipbu (2)


Generated by MeetBot 0.1.4.