#opendaylight-meeting: genius

Meeting started by vorburger at 15:04:54 UTC (full logs).

Meeting summary

    1. everybody can write #info <your-name> (vorburger, 15:08:08)
    2. edavsua (edavsua, 15:08:19)
    3. faseela (faseela, 15:08:23)

  1. rollcall (vorburger, 15:08:26)
  2. Service Binding On Tunnels Spec Review (vorburger, 15:09:47)
  3. Spec diag status framework (vorburger, 15:11:44)
  4. Blueprint Migration status (vorburger, 15:12:09)
    1. David working on mdsalutil (having problems with the circular dependencies), Edwin on interfacemanager (vorburger, 15:14:01)
    2. I am having problems with the circular dependencies (edavsua, 15:14:02)

  5. Checkstyle enforcement (vorburger, 15:15:15)
    1. ACTION: vorburger switch mdsal-api to Checkstyle enforcement (vorburger, 15:15:47)

  6. M4 (02/16/2017) readiness, can we have API freeze by next week? (vorburger, 15:16:25)
  7. Cache API (infrautils) "heads-up" (WIP) : https://git.opendaylight.org/gerrit/#/c/48920/ (vorburger, 15:18:34)
  8. patches for review merge - https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:22:34)
    1. ACTION: vorburger we'll merge https://git.opendaylight.org/gerrit/50923 after CSIT passed (vorburger, 15:25:28)
    2. ACTION: Tali https://git.opendaylight.org/gerrit/#/c/51561/ (vorburger, 15:26:49)
    3. ACTION: Vishal (?) to review https://git.opendaylight.org/gerrit/#/c/50306/ (vorburger, 15:27:40)
    4. ACTION: Hema to re-review https://git.opendaylight.org/gerrit/#/c/50274/ (vorburger, 15:28:30)
    5. ACTION: Hema https://git.opendaylight.org/gerrit/#/c/50299/ (vorburger, 15:31:48)
    6. ACTION: Faseela https://git.opendaylight.org/gerrit/#/c/51518/1 (vorburger, 15:33:41)
    7. ACTION: Vivek, Peri, Tali (?) https://git.opendaylight.org/gerrit/#/c/50779/ (vorburger, 15:36:11)
    8. ACTION: Hema https://git.opendaylight.org/gerrit/#/c/51220/ (vorburger, 15:38:34)

  9. boron broken due to https://bugs.opendaylight.org/show_bug.cgi?id=7537 (vorburger, 15:40:06)
    1. ACTION: shague to check, vorburger can assist (vorburger, 15:40:47)

  10. AbstractDataBrokerTest (vorburger, 15:41:00)
    1. ACTION: vorburger to send email to genius-dev (vorburger, 15:41:10)

  11. patches overdue - https://git.opendaylight.org/gerrit/#/dashboard/?title=Genius+abandonment+review&Send+email+warning+due+to+3+weeks+inaction=project:genius+status:open+age:21d+-age:31d&Close+due+to+4+weeks+inaction=project:genius+status:open+age:31d (vorburger, 15:41:28)
    1. ACTION: Faseela to ping Satish to react to https://git.opendaylight.org/gerrit/#/c/50085/ (vorburger, 15:43:46)
    2. Faseela thinks https://git.opendaylight.org/gerrit/#/c/49633/ can be abandoned, Hema agrees; so abandoned (vorburger, 15:46:09)

  12. Cache (vorburger, 15:47:35)
    1. vorburger: vishal: use non-static concurrent map as local cache, until new infrautils caches infra is available. that's still better than using @Deprecated CacheUtil with the static (vorburger, 15:49:09)

  13. meetbot (vorburger, 15:49:20)
    1. ACTION: vorburger to raise helpdesk ticket to ask for odl_meetbot to be in #opendaylight-genius (vorburger, 15:50:01)
    2. ACTION: everyone to participate more actively with taking minutes (vorburger, 15:50:30)

  14. rollcall (vorburger, 15:50:51)
    1. Participants (people should #info in themselves next week): Sam, Vishal, Hema, Faseela, David, Tali, Michael (vorburger, 15:50:55)


Meeting ended at 15:50:58 UTC (full logs).

Action items

  1. vorburger switch mdsal-api to Checkstyle enforcement
  2. vorburger we'll merge https://git.opendaylight.org/gerrit/50923 after CSIT passed
  3. Tali https://git.opendaylight.org/gerrit/#/c/51561/
  4. Vishal (?) to review https://git.opendaylight.org/gerrit/#/c/50306/
  5. Hema to re-review https://git.opendaylight.org/gerrit/#/c/50274/
  6. Hema https://git.opendaylight.org/gerrit/#/c/50299/
  7. Faseela https://git.opendaylight.org/gerrit/#/c/51518/1
  8. Vivek, Peri, Tali (?) https://git.opendaylight.org/gerrit/#/c/50779/
  9. Hema https://git.opendaylight.org/gerrit/#/c/51220/
  10. shague to check, vorburger can assist
  11. vorburger to send email to genius-dev
  12. Faseela to ping Satish to react to https://git.opendaylight.org/gerrit/#/c/50085/
  13. vorburger to raise helpdesk ticket to ask for odl_meetbot to be in #opendaylight-genius
  14. everyone to participate more actively with taking minutes


Action items, by person

  1. faseela
    1. Faseela https://git.opendaylight.org/gerrit/#/c/51518/1
    2. Faseela to ping Satish to react to https://git.opendaylight.org/gerrit/#/c/50085/
  2. odl_meetbot
    1. vorburger to raise helpdesk ticket to ask for odl_meetbot to be in #opendaylight-genius
  3. vorburger
    1. vorburger switch mdsal-api to Checkstyle enforcement
    2. vorburger we'll merge https://git.opendaylight.org/gerrit/50923 after CSIT passed
    3. shague to check, vorburger can assist
    4. vorburger to send email to genius-dev
    5. vorburger to raise helpdesk ticket to ask for odl_meetbot to be in #opendaylight-genius
  4. UNASSIGNED
    1. Tali https://git.opendaylight.org/gerrit/#/c/51561/
    2. Vishal (?) to review https://git.opendaylight.org/gerrit/#/c/50306/
    3. Hema to re-review https://git.opendaylight.org/gerrit/#/c/50274/
    4. Hema https://git.opendaylight.org/gerrit/#/c/50299/
    5. Vivek, Peri, Tali (?) https://git.opendaylight.org/gerrit/#/c/50779/
    6. Hema https://git.opendaylight.org/gerrit/#/c/51220/
    7. everyone to participate more actively with taking minutes


People present (lines said)

  1. vorburger (37)
  2. odl_meetbot (4)
  3. edavsua (3)
  4. faseela (1)


Generated by MeetBot 0.1.4.