#opendaylight-meeting: genius

Meeting started by edavsua at 15:03:04 UTC (full logs).

Meeting summary

    1. Hello (edavsua, 15:03:15)
    2. skitt (skitt, 15:03:58)
    3. edavsua (edavsua, 15:04:08)
    4. Vishal Thapar (vthapar, 15:05:46)
    5. vorburger (vorburger, 15:06:27)
    6. faseelak (faseelak, 15:06:40)
    7. shague (shague, 15:06:53)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2017/genius/opendaylight-meeting-genius.2017-02-09-15.04.html (vorburger, 15:07:13)
    9. ACTION: vorburger to send email to genius-dev re. AbstractDataBroker (vorburger, 15:11:50)

  1. DCN Deprecation Weather item (vorburger, 15:13:15)
    1. faseelak sent out mail and created weather page (vthapar, 15:13:51)
    2. https://wiki.opendaylight.org/view/Weather#Genius_AbstractDataChangeListener_clean-up (vthapar, 15:14:37)
    3. Genius patch for deprecation https://git.opendaylight.org/gerrit/#/c/51876/ (vthapar, 15:14:57)
    4. ACTION: shague to review netvirt patches (which?) and merge to unblock https://git.opendaylight.org/gerrit/#/c/51876/ (vorburger, 15:17:08)

  2. AsyncListenerBase scale issues - track progress on netvirt (edavsua, 15:17:39)
    1. various people are putting in patches in netvirt re. this topic (vorburger, 15:18:41)
    2. ACTION: vthapar to prepare netvirt patches for removing use of AsyncDataChangeListeners (vthapar, 15:27:43)

  3. blueprint migration (vorburger, 15:30:52)
    1. 3 modules in genius are pending (vorburger, 15:31:04)
    2. interfacemanager mdsalutil fcaps (faseelak, 15:32:47)
    3. ACTION: edavsua will try to solve the circular dependency in mdsal-impl (edavsua, 15:35:15)
    4. if breaking that dependency is possible (time-wise) I'll continue with the blueprint migration (edavsua, 15:36:21)
    5. https://git.opendaylight.org/gerrit/#/c/51927/ (vorburger, 15:38:39)
    6. ACTION: edavsua to check fcap blueprint migration status (vorburger, 15:42:34)

  4. Checkstyle (vorburger, 15:45:13)
    1. missing CS compliance: (1) interfacemanager-impl, (2) mdsal-impl, (3) itm-impl (vorburger, 15:46:12)

  5. patches for review merge (vorburger, 15:46:33)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:46:41)
    2. ACTION: edavsua to get https://git.opendaylight.org/gerrit/51270 reviewed by SFC (vthapar, 15:58:53)
    3. ACTION: faseelak review https://git.opendaylight.org/gerrit/#/c/51909/ (vorburger, 16:00:55)

  6. overdue patches (vorburger, 16:06:57)
    1. ACTION: viveks to check with respective owners (vorburger, 16:07:12)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Genius+abandonment+review&Send+email+warning+due+to+3+weeks+inaction=project:genius+status:open+age:21d+-age:31d&Close+due+to+4+weeks+inaction=project:genius+status:open+age:31d (vorburger, 16:07:18)


Meeting ended at 16:07:27 UTC (full logs).

Action items

  1. vorburger to send email to genius-dev re. AbstractDataBroker
  2. shague to review netvirt patches (which?) and merge to unblock https://git.opendaylight.org/gerrit/#/c/51876/
  3. vthapar to prepare netvirt patches for removing use of AsyncDataChangeListeners
  4. edavsua will try to solve the circular dependency in mdsal-impl
  5. edavsua to check fcap blueprint migration status
  6. edavsua to get https://git.opendaylight.org/gerrit/51270 reviewed by SFC
  7. faseelak review https://git.opendaylight.org/gerrit/#/c/51909/
  8. viveks to check with respective owners


Action items, by person

  1. edavsua
    1. edavsua will try to solve the circular dependency in mdsal-impl
    2. edavsua to check fcap blueprint migration status
    3. edavsua to get https://git.opendaylight.org/gerrit/51270 reviewed by SFC
  2. faseelak
    1. faseelak review https://git.opendaylight.org/gerrit/#/c/51909/
  3. shague
    1. shague to review netvirt patches (which?) and merge to unblock https://git.opendaylight.org/gerrit/#/c/51876/
  4. vorburger
    1. vorburger to send email to genius-dev re. AbstractDataBroker
  5. vthapar
    1. vthapar to prepare netvirt patches for removing use of AsyncDataChangeListeners


People present (lines said)

  1. vorburger (26)
  2. vthapar (13)
  3. edavsua (9)
  4. odl_meetbot (7)
  5. skitt (3)
  6. faseelak (3)
  7. shague (2)
  8. faseela (0)


Generated by MeetBot 0.1.4.