#opendaylight-meeting: kernel projects

Meeting started by colindixon at 16:05:22 UTC (full logs).

Meeting summary

  1. agenda (colindixon, 16:05:26)
    1. https://wiki.opendaylight.org/view/Kernel_Projects_Call#Upcoming_Agenda_Topics (colindixon, 16:05:47)
    2. colindixon will cover karaf 3 vs. karaf 4 in Carbon (colindixon, 16:06:40)

  2. karaf 3 vs. karaf 4 (colindixon, 16:06:51)
    1. https://lists.opendaylight.org/pipermail/release/2017-May/010765.html all other links can be found from here (colindixon, 16:07:21)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-09-15.01.html longer summary here (colindixon, 16:09:49)
    3. rovarga asks does this mean that starting day 1 in nitrogen we can kill off karaf 3 and push on Karaf 4 (colindixon, 16:12:07)
    4. colindixon says his take is that we should make nitrogen about paying down our techincal debt as far as it goes around Karaf 4 and bundle/feature lifecycle management, including non-leaf bundles/features supporting refresh/shutdown/reload (colindixon, 16:14:01)
    5. skitt asks if the right thing to do is to drop everyone from the release and then not add them back until they meet their requirements (colindixon, 16:14:29)
    6. is this a way to force projects to take on technical debt earlier (colindixon, 16:17:27)
    7. robert also suggests looking at mliestones to drop projects if they don't meet them (colindixon, 16:20:14)
    8. colindixon also brings up the idea of having failures on autorelease blocking that branch until it's fixed (colindixon, 16:21:40)
    9. there some opposition to this, it may make the problem worse by requiring a small set of people to sign off on the patches to fix things (colindixon, 16:24:32)
    10. colindixon notes that otherwise, we haven't had much succes in keeping our autorlease, e.g., the validation that what we have works, working to keep us honest (colindixon, 16:25:23)
    11. skitt also talks about and rovarga asks if what happens next should be starting to get odlparent to release a non-snapshot version and then adding people in only as they work with that (colindixon, 16:26:03)
    12. after that we release everything else based on that and keep working (colindixon, 16:26:35)
    13. there is a long talk about how we would go about this approach possibly at the beginning of Nitrogen or Oxygen (colindixon, 16:32:49)
    14. vorburger asks how this would start, what's the next step? skitt and rovarga say that the basic strategy is to put what we feel we need into odlparent for the next release, then release it and tell everyone to move to that. (colindixon, 16:35:26)
    15. there is some back and forth about hoping that we get more than six month cadence out fo this for new features and functionality (colindixon, 16:37:59)
    16. skitt also notes that this might help with deprecation and things since you don't need a flag day, you can clearly fork the timeline (colindixon, 16:38:43)
    17. vorburger asks what's next concretely, skitt answers: nitrogen release plan, then odlparent's changes, then release odlparent and make people move to it (colindixon, 16:45:22)
    18. https://wiki.opendaylight.org/view/ODL_Parent:Carbon_Release_Plan (skitt, 16:49:48)
    19. ACTION: colindixon to work with skitt to figure out what the timeline might look like for nitrogen and what feautres need to go in and start shipping (colindixon, 16:54:52)

  3. vorburger started working on infrautils.ready (to tell when things are up) (colindixon, 16:55:39)
    1. actual propsl later (colindixon, 16:55:46)

  4. open patches (colindixon, 16:56:57)
    1. https://git.opendaylight.org/gerrit/#/c/54965/ can we merge this, rovarga? (colindixon, 16:57:07)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=8226 fixes that bug (colindixon, 16:57:17)
    3. rovarga says that they're down to 3 issues, at least one of which needs more informatin (colindixon, 16:58:53)
    4. vorburger asks why so averse to suppress warnings all, rovarga says it's caught real issues in the past (colindixon, 16:59:50)
    5. vorburger says, "desptie not saying it, rovarga, you are -2ing that patch and asking to get it resolved on the bug." rovarga says yes. (colindixon, 17:00:29)
    6. https://git.opendaylight.org/gerrit/#/q/topic:bumpCheckstyle when can we do this? rovarga says in nitrogen, but we need to fix it (colindixon, 17:01:27)
    7. correction: I am -1ing the patch. I am not actively telling other committers not to merge it :) (rovarga, 17:01:30)
    8. rovarga says we are broken in nitrogen and need to fix that (colindixon, 17:02:24)
    9. ACTION: colindixon, vorburger will try to remove snmp4sdn from nitrogen for now (colindixon, 17:02:42)


Meeting ended at 17:03:07 UTC (full logs).

Action items

  1. colindixon to work with skitt to figure out what the timeline might look like for nitrogen and what feautres need to go in and start shipping
  2. colindixon, vorburger will try to remove snmp4sdn from nitrogen for now


Action items, by person

  1. colindixon
    1. colindixon to work with skitt to figure out what the timeline might look like for nitrogen and what feautres need to go in and start shipping
    2. colindixon, vorburger will try to remove snmp4sdn from nitrogen for now
  2. skitt
    1. colindixon to work with skitt to figure out what the timeline might look like for nitrogen and what feautres need to go in and start shipping


People present (lines said)

  1. colindixon (35)
  2. skitt (4)
  3. rovarga (4)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.