#opendaylight-meeting: kernel projects

Meeting started by colindixon at 16:01:29 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:01:33)
    1. BUG-8413 NETCONF times out with large RPC responses from devices (colindixon, 16:03:43)
    2. NETONF password encryption (colindixon, 16:03:50)
    3. Boron-SR4 (colindixon, 16:04:03)
    4. Karaf 4 (colindixon, 16:04:05)
    5. NETCONF committer status? (colindixon, 16:04:49)

  2. Boron-SR4 (colindixon, 16:04:52)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Boron_SR4_Download (anipbu, 16:05:07)
    2. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471 (anipbu, 16:05:33)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Boron_SR4_Download downlad and info (colindixon, 16:05:54)
    4. sign-offs for test failure status https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471 (colindixon, 16:06:13)
    5. nobody says they have any Boron-SR4 issues at this time (colindixon, 16:07:13)

  3. Karaf 4 (colindixon, 16:07:30)
    1. the plan is to move to using odlparent version 1.9.0 today, should be done the rest of today by releng staff (colindixon, 16:08:01)
    2. we plan to move to odlparent 2.0.0 on Monday, June 19th and that will result in their being no Karaf 3 (colindixon, 16:08:18)
    3. rgoulding says there are some features that we might want to move into odlparent, will that require another stage release like this? (colindixon, 16:10:07)
    4. colindixon says in theory not because projects should depend on [2.0.0,2.1), but we haven't tried it (colindixon, 16:10:41)
    5. skitt and anipbu ask if we can please hold off on doing things that aren't directly Karaf 4 related for now (colindixon, 16:11:33)
    6. rgoulding says it's mostly migrationg jolokia from controller to odlparent (colindixon, 16:11:51)
    7. https://wiki.opendaylight.org/view/Karaf_4_migration (anipbu, 16:12:11)
    8. anipbu explains that projects will be expected to migrate to odlparent 2.0.0 on their own, patches will not be provided becuase it isn't mechanical (colindixon, 16:12:16)
    9. https://wiki.opendaylight.org/view/Karaf_4_migration these are the instructions (colindixon, 16:12:24)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=8682 (anipbu, 16:12:26)
    11. https://bugs.opendaylight.org/show_bug.cgi?id=8622 (anipbu, 16:12:33)
    12. two blocking bugs assigned to kernel projects for karaf (colindixon, 16:12:43)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=8682 (AAA) (colindixon, 16:12:43)
    14. https://bugs.opendaylight.org/show_bug.cgi?id=8622 (odlparent) (colindixon, 16:13:00)
    15. vorburger and rgoulding says that the AAA issue has been fixed with a revert (colindixon, 16:13:19)
    16. skitt says that after talking with upstream Karaf devs and they seem to think that it's not dependency resolution that's the issue, it's that we have unnecessary refreshes which shouldn't be happening (colindixon, 16:18:28)
    17. feature:install -v will tell you what it intends to refresh and why (colindixon, 16:18:47)
    18. skitt says that org.json is part of the problem becuase it's interaction with jackson causes both to be refreshed (colindixon, 16:19:13)
    19. skitt says that feature:install X twice should work without a refresh (colindixon, 16:23:34)
    20. the way to avoid this is (in theorgy) that we need avoid bundle wirlng loops (colindixon, 16:24:02)
    21. skitt notes that netconf/restconf + org.json issues might explain most of it (colindixon, 16:25:07)
    22. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Karaf_4_Coordinators (anipbu, 16:25:19)
    23. https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001075.html (anipbu, 16:25:41)
    24. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Karaf_4_Coordinators (colindixon, 16:26:10)
    25. https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001075.html (colindixon, 16:26:16)
    26. the plan is to try to get all projects moved toward having a karaf 4 distribtuion building locally by 6/21 and 6/28 to have things merged in distribution (colindixon, 16:27:46)
    27. the netvirt project is tentativelly on board with that, but also notes they are basing that on the hope that it becomes possible to bring Karaf 4 up (colindixon, 16:29:07)

  4. BUG-8413 (colindixon, 16:29:17)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8413 (colindixon, 16:30:05)
    2. rgoulding asks if we have keeplaive enabled, maybe disabling that would help? (colindixon, 16:31:37)
    3. rovarga_ asks how long does the device take to respond? colindixon says they'll look it. (colindixon, 16:33:15)

  5. NETCONF password encryption (and indirectly NETCONF committers) (colindixon, 16:33:49)
    1. https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001178.html (colindixon, 16:34:23)
    2. https://git.opendaylight.org/gerrit/#/c/52528/ (colindixon, 16:34:44)
    3. rovarga_ says that he worries about the Blueprint switchover since last time it broke things (colindixon, 16:36:01)
    4. rovarga_ says that jakub and tomas are busy in the controller, and haven't been able to devote much time to netconf (colindixon, 16:36:18)
    5. https://git.opendaylight.org/gerrit/#/c/57368/ the netconf blueprint patch (colindixon, 16:38:26)
    6. TomP and rovarga_ talk about the possible issues with this patch for a bit (colindixon, 16:38:49)
    7. colindixon and rgoulding ask if we need more committers, rovarga_ asks if there are people who know the code and are willing (colindixon, 16:41:23)
    8. colindixon suggests maybe rgoulding (colindixon, 16:41:42)
    9. ACTION: rovarga_ to send mail to the netconf mailing list about how rgoulding (and others) might be able to (colindixon, 16:42:55)
    10. rgoulding says he'd really like a clear path to being a comitter before he sinks a lot of time into it (colindixon, 16:43:16)
    11. TomP adds that getting more comitters on netconf matters becuase we currently only have 2 active committers and both from one company (colindixon, 16:44:11)
    12. anipbu also notes that netconf hasn't sent intent to participate in nitrogen (rovarga_ notes that yangtools and mdsal haven't either) (colindixon, 16:45:29)

  6. recently merged patches (colindixon, 16:45:45)
    1. (colindixon, 16:45:57)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merg (colindixon, 16:45:58)
    3. https://git.opendaylight.org/gerrit/#/c/54981/ checkstyle bump might cause some issues with migration to 1.9.0 (colindixon, 16:46:56)
    4. rovarga_ says that two spaces between import and package, and final keywords being used in abstract classes (colindixon, 16:47:34)
    5. rovarga_ notes that aside from the EffectiveSchemaContext movement, all the patches are moving the internal parser implementation (for yangtools and mdsal) (colindixon, 16:49:22)
    6. there is some improvement in parsing booleans, this is blocking on a bad ALTO model (colindixon, 16:50:11)
    7. https://git.opendaylight.org/gerrit/58761 (rovarga_, 16:50:24)
    8. example of changes uncovered by the checkstyle bump (rovarga_, 16:50:40)
    9. TomP calls out some really old code in controller which we're trying to remove and hopefully it won't break anything, but it shouldn't (colindixon, 16:54:23)

  7. upcoming patches (colindixon, 16:55:24)
    1. (colindixon, 16:55:34)
    2. (colindixon, 16:55:35)
    3. (colindixon, 16:55:36)
    4. (colindixon, 16:55:37)
    5. (colindixon, 16:55:39)
    6. (colindixon, 16:55:40)
    7. (colindixon, 16:55:42)
    8. (colindixon, 16:55:43)
    9. (colindixon, 16:55:45)
    10. (colindixon, 16:55:46)
    11. (colindixon, 16:55:48)
    12. (colindixon, 16:55:49)
    13. (colindixon, 16:55:51)
    14. (colindixon, 16:55:52)
    15. (colindixon, 16:55:54)
    16. (colindixon, 16:55:55)
    17. (colindixon, 16:55:57)
    18. (colindixon, 16:55:58)
    19. (colindixon, 16:56:00)
    20. (colindixon, 16:56:01)
    21. (colindixon, 16:56:03)
    22. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age (colindixon, 16:56:06)
    23. (colindixon, 16:56:07)
    24. (colindixon, 16:56:09)
    25. (colindixon, 16:56:10)
    26. (colindixon, 16:56:12)
    27. (colindixon, 16:56:13)
    28. (colindixon, 16:56:15)
    29. (colindixon, 16:56:16)
    30. (colindixon, 16:56:17)
    31. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d (colindixon, 16:56:18)


Meeting ended at 17:00:29 UTC (full logs).

Action items

  1. rovarga_ to send mail to the netconf mailing list about how rgoulding (and others) might be able to


Action items, by person

  1. rgoulding
    1. rovarga_ to send mail to the netconf mailing list about how rgoulding (and others) might be able to
  2. rovarga_
    1. rovarga_ to send mail to the netconf mailing list about how rgoulding (and others) might be able to


People present (lines said)

  1. colindixon (103)
  2. anipbu (7)
  3. rovarga_ (7)
  4. rgoulding (5)
  5. skitt (5)
  6. odl_meetbot (4)
  7. zxiiro (1)


Generated by MeetBot 0.1.4.