#opendaylight-meeting: kernel projects

Meeting started by colindixon at 16:03:45 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:03:49)
    1. anipbu asks to cover cover Karaf 4 again (colindixon, 16:04:00)

  2. clustering split-brain behavior (colindixon, 16:06:26)
    1. skitt says he and others were wondering what the split-brain behavior in OpenDaylight with clustering (colindixon, 16:07:00)
    2. skitt says his understanding was that things should stop if there are less than half of the nodes on one half (colindixon, 16:07:26)
    3. rovarga says that according to RAFT new transactions should fail on the minority side and so the data store will "stop", but nothing else will change, e.g., applications will stil run (colindixon, 16:08:26)
    4. rovarga says that it's all Raft, so go read it, colindixon and TomP add additional comments that some things have been added on top of and aroudn Raft that may change some of the behavior, but still it generally applies (colindixon, 16:11:57)

  3. Karaf 4 (colindixon, 16:13:17)
    1. https://lists.opendaylight.org/pipermail/release/2017-June/011221.html (anipbu, 16:13:41)
    2. https://lists.opendaylight.org/pipermail/release/2017-June/011221.html (anipbu, 16:13:46)
    3. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 16:19:25)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=7891 (anipbu, 16:19:37)
    5. the plan is to release odlparent 2.0.0 sometime in the next 48 hours and then bump to that in yangtools (and break the world) early on Thursday morning (colindixon, 16:20:21)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=8571 (anipbu, 16:20:23)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=8622 (anipbu, 16:20:28)
    8. https://lists.opendaylight.org/pipermail/release/2017-June/011221.html <--- This is the current plan for Karaf 4 Migration (anipbu, 16:22:06)
    9. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-June/004775.html <-- Netvirt running into karaf 4 issues and requesting 24 hour delay in odlparent 2.0.0 migration (anipbu, 16:23:34)
    10. http://karaf.922171.n3.nabble.com/Understanding-features-and-dependencies-td4050692.html#a4050698 upstream Karaf's comments on our issues (colindixon, 16:23:38)
    11. Kernal projects should delay migration by 24 hours (anipbu, 16:23:50)
    12. for what it's worth, feautre:install shoudn't refresh bundles just because (colindixon, 16:23:51)
    13. https://meetings.opendaylight.org/opendaylight-meeting/2017/nitrogen_release_sync/opendaylight-meeting-nitrogen_release_sync.2017-06-19-15.02.html this meeting has some more notes on the refresh issues (colindixon, 16:24:25)
    14. Stephen agrees to release Emergency Release of ODLPARENT 2.0.1 if critical error is found (anipbu, 16:24:27)
    15. There exists blocker bugs in Karaf 4: https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 16:25:01)
    16. https://bugs.opendaylight.org/show_bug.cgi?id=7891 <--- rovarga to look into Netconf Karaf 4 Blocker Bug (anipbu, 16:25:30)
    17. https://bugs.opendaylight.org/show_bug.cgi?id=8571 and https://bugs.opendaylight.org/show_bug.cgi?id=8622 <--- skitt to look into resolving the Odlparent Karaf 4 Blocker Bugs (anipbu, 16:26:01)
    18. some discussion on Karaf 4 Dependency Resolution between colindixon skitt rovarga (anipbu, 16:26:37)
    19. colindixon added some of this discussion to bug 8622 (colindixon, 16:27:49)
    20. skitt notes that beanutils (and having two versions?) in AAA is the current place where unintentional bundle refreshes are causing issues, there's a lot of discussion of how to get down to one version (colindixon, 16:28:22)
    21. ACTION: rgoulding to look into AAA optional dependencies on beanutils and what it might be causing issues with Karaf 4 (colindixon, 16:28:42)
    22. if you embed dependencies and then re-export them, that can cause problem by creating cycles (colindixon, 16:29:09)
    23. some more conversations around replacing org.json with jackson and gson, and the general idea is that in OpenDaylight should probably move to gson (colindixon, 16:33:02)
    24. ACTION: rgoulding to look into and maybe lean on AAA's dependencies to maybe get away from org.json (colindixon, 16:33:48)

  4. netconf committers (colindixon, 16:37:12)
    1. colindixon basically says he's willing to take anything he can get, but we need to some point where there's regular interaction with the netconf comitters, no regular interaction doesn't work (colindixon, 16:39:32)
    2. https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001205.html (colindixon, 16:40:11)
    3. TomP and rgoulding add that people need to at least appear every few days (maybe once a week would work if it was communicated), but once a moth or once per multiple weeks really doesn't work (colindixon, 16:40:44)

  5. deprecating the config subsystem (colindixon, 16:43:16)
    1. TomP says that basically it's just the controller and netconf that use the config subsystem now (colindixon, 16:43:47)
    2. TomP asks if it's time to remove the config subsystem way to do mounts in NETCONF (colindixon, 16:45:02)
    3. it's been deprecated (in that it says don't do it) since Beryllium, could we take it out? (colindixon, 16:45:20)
    4. the other thing using the config subsytem is YANGlib, which seems to be an optional feature to act as a schemastore (colindixon, 16:50:04)
    5. rovarga says that this is probalby required for RFC-8040 support (colindixon, 16:52:31)

  6. review merged and pending patches (colindixon, 16:54:39)
    1. AAA is now Activatorless—it's all Blueprint (colindixon, 16:55:31)


Meeting ended at 16:58:48 UTC (full logs).

Action items

  1. rgoulding to look into AAA optional dependencies on beanutils and what it might be causing issues with Karaf 4
  2. rgoulding to look into and maybe lean on AAA's dependencies to maybe get away from org.json


Action items, by person

  1. rgoulding
    1. rgoulding to look into AAA optional dependencies on beanutils and what it might be causing issues with Karaf 4
    2. rgoulding to look into and maybe lean on AAA's dependencies to maybe get away from org.json


People present (lines said)

  1. colindixon (37)
  2. anipbu (14)
  3. odl_meetbot (5)
  4. rgoulding (1)


Generated by MeetBot 0.1.4.