#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:03:29 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:04:23)
    1. Karaf 4 Discussion (rgoulding, 16:04:28)
    2. odlparent 2.0.0 (rgoulding, 16:04:40)
    3. odl-mdsal-apidocs Bug 8752 - apidoc explorer show/hide and list operations no longer works (rgoulding, 16:04:53)
    4. https://wiki.opendaylight.org/index.php?title=Kernel_Projects_Call&oldid=58253#Upcoming_Agenda_Topics pulling from here (colindixon, 16:04:57)
    5. Bug 8750 - Unnable to receive DataTreeChanged notifications (rgoulding, 16:05:01)
    6. NETCONF encrypted passwords patch (rgoulding, 16:05:09)

  2. Karaf 4 Discussion (rgoulding, 16:05:29)
    1. https://git.opendaylight.org/gerrit/#/q/topic:odlparent200 (anipbu, 16:05:59)
    2. https://lists.opendaylight.org/pipermail/controller-dev/2017-June/013611.html (anipbu, 16:06:27)
    3. https://git.opendaylight.org/gerrit/#/c/59303/ (anipbu, 16:06:35)
    4. ACTION: kernel committers to review the features in integration-distribution (rgoulding, 16:07:20)
    5. benchmarks should not be included in the integration distribution (rgoulding, 16:11:03)
    6. some of the netconf feature repositories seemto be missing (rgoulding, 16:12:57)

  3. odl-mdsal-apidocs (rgoulding, 16:13:58)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8752 (rgoulding, 16:14:07)
    2. kernel projects agree to move forward with merging patch 59303. any missing features will be added with a separate patch (anipbu, 16:15:02)
    3. it seems like we need to actually fix this, but we don't know how yet (colindixon, 16:16:35)

  4. Bug 8750 - Unnable to receive DataTreeChanged notifications (rgoulding, 16:16:40)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8750 (rgoulding, 16:16:47)
    2. is the data actually stored in the data store? (rgoulding, 16:18:25)
    3. events don’t seem to get propagated (rgoulding, 16:18:37)
    4. has anyone else noticed this? (rgoulding, 16:18:53)
    5. if you POST into config data store, is the data actually getting stored in the DS (rgoulding, 16:20:48)
    6. rovarga_ asks if the data is actually getting written into the data store (colindixon, 16:21:00)
    7. yrineu says that he's able to do a post and then see the results (colindixon, 16:21:35)
    8. ACTION: yrnieu to update Bug 8750 after trying to do an HTTP GET and see if the data is propagated to the DS (rgoulding, 16:23:25)
    9. it seems as though the general feeling is that the issue has to be in the code logic in NIC, but maybe looking at the toaster would help (colindixon, 16:23:56)
    10. TomP wants to know if the listener is actually getting registered (colindixon, 16:25:48)
    11. TomP wants to know if it's single node or clustered (colindixon, 16:26:23)
    12. rovarga_ asks if this is DCLs or DTCLs? rovarga_ notes that DCLs might need to be migrated to DTCLs (colindixon, 16:26:54)
    13. yrineu confirms that it is org.opendaylight.controller.md.sal.binding.api.DataTreeChangeListener; (rgoulding, 16:27:17)
    14. when we merge the integration distribution patch then we will see the result (rgoulding, 16:30:52)
    15. implicit reproduction attempt through automated CSIT (rgoulding, 16:31:06)

  5. NETCONF encrypted passwords patch (rgoulding, 16:31:28)
    1. https://git.opendaylight.org/gerrit/#/c/52528/ (rgoulding, 16:31:39)
    2. ACTION: jmorvay to follow up with Tomas Cere about encrypted passwords patch (rgoulding, 16:35:31)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=1643 (rgoulding, 16:36:47)
    4. the above bug explains that we shoudl be able to filter what we see on the northbound (rgoulding, 16:37:07)

  6. RESTCONF bp patch (rgoulding, 16:38:09)
    1. tpantelis left in existing config yang for backwards compatibility (rgoulding, 16:38:38)
    2. should we just remove it? (rgoulding, 16:38:43)
    3. https://git.opendaylight.org/gerrit/#/c/57368/ (rgoulding, 16:39:10)
    4. the patch above has the existing config yang, but it is a NOOP (rgoulding, 16:39:25)
    5. it is deprecated, but is still present (rgoulding, 16:39:38)
    6. jmorvay says in NETCONF they just deprecated the config yang in previous release and removed in present one (rgoulding, 16:40:09)
    7. tpantelis to push a patch to remove the module classes and config (rgoulding, 16:40:52)

  7. remove the CSS based netconf connector (rgoulding, 16:42:35)
    1. it has been deprecated since Beryllium (rgoulding, 16:42:44)
    2. can we remove it? (rgoulding, 16:42:50)
    3. jmorvay thinks it is safe to remove it (rgoulding, 16:43:07)
    4. we advised for several releases to use odl-netconf-{clustered}-topology (rgoulding, 16:43:26)
    5. should we do a weather item? (rgoulding, 16:43:37)
    6. ACTION: tpantelis to send a weather item to controller-dev netconf-dev and release (rgoulding, 16:44:10)
    7. we should release note that we are killing it (rgoulding, 16:45:28)
    8. can release notes be a living document? (rgoulding, 16:46:47)
    9. https://github.com/opendaylight/docs/tree/master/docs/getting-started-guide/project-release-notes just edit files there (colindixon, 16:47:27)
    10. ACTION: colindixon to send email to release mailing list suggesting that we should update release notes as we go through the release (rgoulding, 16:48:05)
    11. http://docs.opendaylight.org/en/latest/getting-started-guide/release_notes.html they're immediately rendered there on every docs merge (colindixon, 16:48:42)
    12. rovarga asks is this something that we should be checking at M3 when all features should be in? (rgoulding, 16:51:39)
    13. give a nudge at M3 to start this document? (rgoulding, 16:51:53)
    14. ACTION: colindixon to add this to M3 readout for docs (rgoulding, 16:52:13)

  8. merged/on-deck patches (rgoulding, 16:52:36)
    1. ACTION: rgoulding investigate if we can get rid of beanutils once shiro.ini is dead and we are on shiro-core 1.4.0 (rgoulding, 16:55:37)


Meeting ended at 16:56:30 UTC (full logs).

Action items

  1. kernel committers to review the features in integration-distribution
  2. yrnieu to update Bug 8750 after trying to do an HTTP GET and see if the data is propagated to the DS
  3. jmorvay to follow up with Tomas Cere about encrypted passwords patch
  4. tpantelis to send a weather item to controller-dev netconf-dev and release
  5. colindixon to send email to release mailing list suggesting that we should update release notes as we go through the release
  6. colindixon to add this to M3 readout for docs
  7. rgoulding investigate if we can get rid of beanutils once shiro.ini is dead and we are on shiro-core 1.4.0


Action items, by person

  1. colindixon
    1. colindixon to send email to release mailing list suggesting that we should update release notes as we go through the release
    2. colindixon to add this to M3 readout for docs
  2. rgoulding
    1. rgoulding investigate if we can get rid of beanutils once shiro.ini is dead and we are on shiro-core 1.4.0
  3. UNASSIGNED
    1. kernel committers to review the features in integration-distribution
    2. yrnieu to update Bug 8750 after trying to do an HTTP GET and see if the data is propagated to the DS
    3. jmorvay to follow up with Tomas Cere about encrypted passwords patch
    4. tpantelis to send a weather item to controller-dev netconf-dev and release


People present (lines said)

  1. rgoulding (58)
  2. colindixon (11)
  3. odl_meetbot (7)
  4. anipbu (4)


Generated by MeetBot 0.1.4.