#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:02:07 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:02:21)
    1. Karaf 4 Update (rgoulding, 16:02:31)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d (rgoulding, 16:02:40)
    3. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d (rgoulding, 16:02:48)
    4. Bug 8413 (rgoulding, 16:03:32)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=8771 (rgoulding, 16:03:40)
    6. NETCONF encryption patches (rgoulding, 16:03:51)
    7. NETCONF public key authentication patch (rgoulding, 16:03:58)

  2. karaf 4 update (rgoulding, 16:05:00)
    1. projects dependent on odl-netconf-connector will still have failing distribution-check (rgoulding, 16:06:23)
    2. ACTION: rgoulding to push snmp into integration/distribution (rgoulding, 16:07:39)

  3. Bug8771 (rgoulding, 16:08:47)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8771 (rgoulding, 16:08:52)
    2. only when install odl-netconf-clustered-topology (rgoulding, 16:12:36)
    3. this is every single distribution-check job that installs the feature above (rgoulding, 16:15:56)
    4. several bundles getting uninstalled (rgoulding, 16:24:55)
    5. 2017-06-29 10:02:55,000 | INFO | config-pusher | ConfigPusherImpl | 142 - org.opendaylight.controller.config-persister-impl - 0.7.0.SNAPSHOT | Pushing configuration snapshot 00-netty.xml(odl-netconf-impl,odl-netconf-impl) (rgoulding, 16:25:01)
    6. 2017-06-29 10:02:49,570 | INFO | pool-2-thread-1 | FeaturesServiceImpl | 9 - org.apache.karaf.features.core - 4.0.9 | io.netty.handler/4.1.8.Final (Should be wired to: bcprov/1.56.0 (through [io.netty.handler/4.1.8.Final] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.bouncycastle.asn1.x500)(version>=1.54.0)(!(version>=2.0.0)))"; resolution:=optional), bcpkix/1.56.0 (through [io.netty.handler/4.1.8.Final (rgoulding, 16:26:56)
    7. bcpkix needs to be pusehd into startupbundles (rgoulding, 16:27:05)
    8. should stop the bundle refresh (rgoulding, 16:27:44)

  4. Bug8413 (rgoulding, 16:30:00)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8413 (rgoulding, 16:30:15)
    2. issues like this need performance snapshot and memory dump (rgoulding, 16:31:12)
    3. ACTION: Sai to get this info and attach to bug (rgoulding, 16:31:46)
    4. is this reproducible with Carbon and Nitrogen? (rgoulding, 16:33:00)
    5. try with carbon and nitrogen (rgoulding, 16:33:04)
    6. many issues fixed since Boron-SR1 (rgoulding, 16:33:13)
    7. this was tried with Boron (rgoulding, 16:33:19)

  5. NETCONF encryption (rgoulding, 16:33:38)
    1. https://git.opendaylight.org/gerrit/#/c/60298/ (rgoulding, 16:33:45)
    2. the patch is creating multiple sessions one after another (rgoulding, 16:35:12)
    3. the patch should be changed from a listener to an RPC (rgoulding, 16:35:22)
    4. issue a message in the log (rgoulding, 16:36:14)
    5. at warning level (rgoulding, 16:36:18)
    6. small change really and will improve code (rgoulding, 16:37:03)
    7. will get rid of race condition and multiple session issue (rgoulding, 16:37:22)
    8. testtool bug hit the race (rgoulding, 16:37:38)

  6. NETCONF public key authentication (rgoulding, 16:39:57)
    1. https://git.opendaylight.org/gerrit/#/c/59537/ (rgoulding, 16:40:05)
    2. ACTION: tcere to take a look tomorrow (rgoulding, 16:41:04)
    3. any CSIT on this yet? (rgoulding, 16:41:38)
    4. ACTION: Atul to do some CSIT for public key auth tests (rgoulding, 16:41:53)

  7. merged/pending patches (rgoulding, 16:42:38)
    1. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d (rgoulding, 16:42:46)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d (rgoulding, 16:43:31)
    3. ACTION: tpantelis to review a few patches that Robert added him as a reviewer to (rgoulding, 16:44:38)


Meeting ended at 16:45:31 UTC (full logs).

Action items

  1. rgoulding to push snmp into integration/distribution
  2. Sai to get this info and attach to bug
  3. tcere to take a look tomorrow
  4. Atul to do some CSIT for public key auth tests
  5. tpantelis to review a few patches that Robert added him as a reviewer to


Action items, by person

  1. rgoulding
    1. rgoulding to push snmp into integration/distribution
  2. UNASSIGNED
    1. Sai to get this info and attach to bug
    2. tcere to take a look tomorrow
    3. Atul to do some CSIT for public key auth tests
    4. tpantelis to review a few patches that Robert added him as a reviewer to


People present (lines said)

  1. rgoulding (63)
  2. odl_meetbot (7)


Generated by MeetBot 0.1.4.