#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:01:39 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:01:47)
    1. kernel projects status for Nitrogen (rgoulding, 16:04:45)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d (rgoulding, 16:04:55)
    3. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d (rgoulding, 16:05:01)

  2. kernel projects status for Nitrogen (rgoulding, 16:05:15)
    1. AAA just needed Bug 8195 which was in this morning (rgoulding, 16:07:32)
    2. yangtools is code complete for Nitrogen. Some issues with correctness of Yang 1.1 which should be nailed down by RC0 (rgoulding, 16:07:54)
    3. yangtools in reasonable shape and good to go (rgoulding, 16:08:01)
    4. MD-SAL has a few changes that need to go in. One of those involves performance/correctness to Binding Spec v2 (rgoulding, 16:08:22)
    5. improvements to Data Tree Sharding (rgoulding, 16:08:29)
    6. patches will also affect controller (rgoulding, 16:08:48)
    7. controller doesn’t seem to have any outstanding work for Nitrogen (rgoulding, 16:09:37)
    8. tell-tell based prognosis: kinda late in the game but we can give it a try if downstream projects are okay with it (rgoulding, 16:10:00)
    9. most of the bugs were edge cases with retries etc. (rgoulding, 16:10:41)
    10. the performance aspect of it may be different though and there may be some kinks that we have not yet caught (rgoulding, 16:10:57)
    11. things we can only catch in much wider testing (rgoulding, 16:11:06)
    12. we should be good to go flipping it on depending on what releng/release teams say (rgoulding, 16:11:25)
    13. we are not worse than we were before (rgoulding, 16:11:36)
    14. Robert thinks it is go at this point (rgoulding, 16:12:12)
    15. all we need to do is ask release to see whether we can flip it on in Nitrogen (rgoulding, 16:12:22)
    16. if not in Nitrogen then first thing when we do branch cutting (rgoulding, 16:12:34)
    17. TomP waiting for switch in order to move to Artery (rgoulding, 16:12:57)
    18. just slicing without Artery will help (rgoulding, 16:13:08)
    19. probably too late for Artery for Nitrogen (rgoulding, 16:13:14)
    20. offset 1 M5 is this thursday (rgoulding, 16:14:43)
    21. RC0 is 8/14/2017, not this thursday but next (rgoulding, 16:14:56)
    22. rovarga the plan ahead involves flipping the switch, but keeping the old protocol for one release. then we can remove completely in a following release (rgoulding, 16:15:44)
    23. it is keeping us from removing TransactionTimeouts (rgoulding, 16:16:03)
    24. odlparent is fine with 2.0.2 for Nitrogen (rgoulding, 16:17:57)
    25. NETCONF project release status (rgoulding, 16:18:13)
    26. jmorvay Bug 7891 fixed thanks to Luis Gomez (rgoulding, 16:18:25)
    27. Bug7883 and Bug 8916 are major/blocker but not confirmed yet (rgoulding, 16:18:56)
    28. ACTION: jmorvay to look and see if these are true blockers for Nitrogen (rgoulding, 16:19:24)

  3. merged/pending patches (rgoulding, 16:20:59)
    1. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d (rgoulding, 16:21:09)
    2. plan to remove yang-data-impl XML parser that is scheduled. downstream users have been transitioned. That is to reduce the numberof old parsers to support code maintenance going forward (rgoulding, 16:22:32)
    3. for MD-SAL Bug-8733 includes performance optimizations (rgoulding, 16:23:07)
    4. https://git.opendaylight.org/gerrit/#/c/59537/ (rgoulding, 16:24:15)
    5. some style issues etc. but after they are fixed we can commence with further review (rgoulding, 16:25:19)
    6. you still have to use password? (rgoulding, 16:25:25)
    7. if the user has given public key and username/password credentials, both methods will be tried. public key-auth is tried first, then username/password. (rgoulding, 16:26:31)
    8. the issue is that if a device only uses public key-auth you still need to specify username/password in put request (rgoulding, 16:27:25)
    9. they might still be forced to configure something here (rgoulding, 16:27:36)
    10. this should be an authentication “choice” (rgoulding, 16:28:27)
    11. the passphrase should be encrypted (rgoulding, 16:31:10)
    12. NETCONF username/password encryption password in review by jmorvay (rgoulding, 16:35:17)
    13. ACTION: rgoulding to make release note for the log message for failed decryption (rgoulding, 16:37:34)


Meeting ended at 16:39:24 UTC (full logs).

Action items

  1. jmorvay to look and see if these are true blockers for Nitrogen
  2. rgoulding to make release note for the log message for failed decryption


Action items, by person

  1. rgoulding
    1. rgoulding to make release note for the log message for failed decryption


People present (lines said)

  1. rgoulding (49)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.