#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 15:59:33 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 15:59:46)
    1. kernel projects status for Nitrogen (rgoulding, 15:59:48)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d (rgoulding, 15:59:55)
    3. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d (rgoulding, 16:00:03)
    4. odlparent 2.0.3 (rgoulding, 16:04:11)

  2. odlparent 2.0.3 release (rgoulding, 16:04:34)
    1. https://lists.opendaylight.org/pipermail/odlparent-dev/2017-August/001289.html (rgoulding, 16:05:07)
    2. fixes issues with bouncy castle starting restarts in NETCONF (rgoulding, 16:05:18)
    3. bumps version for javassist (rgoulding, 16:05:25)
    4. staging repository is in the email and can be added to ~/.m2/settings.xml (rgoulding, 16:06:10)
    5. skitt asks projects to test if they can (rgoulding, 16:06:25)
    6. mdsal, aaa and netconf are required, and some other offset 1 & 2 projects will need to be patched for javassist changes (rgoulding, 16:06:49)
    7. two projects have trouble adding features (packetcable encounters OOM during SFT) (rgoulding, 16:07:24)
    8. increasing timeout does help for SFT for packetcable (rgoulding, 16:07:36)
    9. Bug8941 is the bug for OOM issue (rgoulding, 16:07:56)
    10. we will need to fix broken unit tests that are fixed by this bug (rgoulding, 16:08:15)
    11. in the next two days, vrpolak will provide status on whether this change fixes SFT (rgoulding, 16:08:34)
    12. skitt, should we hold off on 2.0.3 then? (rgoulding, 16:08:45)
    13. vrpolak, aside from OOM we aren’t seeing other issues. (rgoulding, 16:08:58)
    14. rovarga we should start adopting it ASAP then to rule out false positives etc. (rgoulding, 16:09:14)
    15. distribution is also seeing this issue (rgoulding, 16:09:24)
    16. even if distribution needs 2.0.4 we can adopt 2.0.3 now (rgoulding, 16:09:32)
    17. rovarga asks vrpolak if we have heap dump of OOM (rgoulding, 16:10:17)
    18. vrpolak cannot find a heapdump anywhere on the filesystem (rgoulding, 16:10:27)
    19. vrpolak says that something funny is happening with how surefire is handling this case (rgoulding, 16:10:51)
    20. rovarga asks zxirro to take a look at the workspaces for heap dump since JVM claims heap dump was taken (rgoulding, 16:11:36)
    21. https://jenkins.opendaylight.org/sandbox/job/distribution-verify-nitrogen/3/console <-- run with *.hprof missing (vrpolak, 16:12:32)
    22. ACTION: zxirro to look at patch and system for missing heapdump (rgoulding, 16:12:56)
    23. https://git.opendaylight.org/gerrit/61274 <-- example Change which generates .hprof (vrpolak, 16:13:19)
    24. rovarga asks if there is a way to get all logs with a link instead of using recursive curl method (rgoulding, 16:13:53)
    25. zxirro says that the only ways he know how to do it are to do it with recursive wget / curl (rgoulding, 16:14:08)
    26. rovarga asks if we can use RO access w/ SCP access on the directories (rgoulding, 16:14:25)
    27. zxirro thinks LF IT staff will push back (rgoulding, 16:14:36)
    28. zxirro says SSH is an exception for GIT interactions (rgoulding, 16:14:54)
    29. zxirro doesn’t think they will allow it since it is managed internally by LF IT (rgoulding, 16:15:11)
    30. rovarga we have generated features which are part of the space, but downloading the features.xml takes a very long time at present (rgoulding, 16:15:38)
    31. zxirro maybe we can just make it a single zip? (rgoulding, 16:15:53)
    32. rovarga having directory exploded useful for console log etc (rgoulding, 16:16:12)
    33. in which downloading the entire shebang would be a waste of time (rgoulding, 16:16:22)
    34. but sometimes you need the interesting bits that are archived (rgoulding, 16:16:30)
    35. there are two use cases (rgoulding, 16:16:35)
    36. zxirro instructs rovarga to issue a help desk ticket for this (rgoulding, 16:16:47)
    37. https://nexus.opendaylight.org/content/repositories/odlparent-1061/ (rgoulding, 16:17:38)
    38. add the above repo temporarily in order to test 2.0.3 with local build (rgoulding, 16:17:55)
    39. make sure to remove afterwards though! (rgoulding, 16:18:02)

  3. kernel projects status for Nitrogen (rgoulding, 16:18:33)
    1. rovarga says that there is OOM issue shared between Carbon andNitrogen (rgoulding, 16:18:59)
    2. we plan to do branch cutting at M5 Offset 2 (rgoulding, 16:19:37)
    3. in this release that coincides iwht RC0 (rgoulding, 16:19:53)
    4. which is Monday (rgoulding, 16:19:57)
    5. one more issue in NETCONF related to parsing XML (rgoulding, 16:20:33)
    6. blocking bug in NETCONF Bug8944 (rgoulding, 16:20:57)
    7. https://git.opendaylight.org/gerrit/#/c/61333/ (rgoulding, 16:21:02)
    8. above is the candidate patch (rgoulding, 16:21:06)
    9. should be done by end of week (rgoulding, 16:21:10)
    10. some changes are needed (rgoulding, 16:21:13)

  4. pending/merged patches (rgoulding, 16:22:18)
    1. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d (rgoulding, 16:22:28)
    2. protocol-framework moved to netconf (rgoulding, 16:24:08)
    3. https://git.opendaylight.org/gerrit/#/c/60902/ (rgoulding, 16:24:10)
    4. should we be good to go with removing from controller (rgoulding, 16:24:16)
    5. https://git.opendaylight.org/gerrit/#/c/60903/2 (rgoulding, 16:24:48)
    6. rovarga will hunt down rogue users fo it and switch them to netconf (rgoulding, 16:25:01)
    7. just changed groupId and movped it (rgoulding, 16:25:07)
    8. lldp library needs to be removed, but it is too late in the relase (rgoulding, 16:25:19)
    9. shague was looking to do this at some point (rgoulding, 16:25:26)
    10. some sort of caretaker project (rgoulding, 16:25:32)
    11. no status updates or anything and won’t participate in the normal simultaneous release process (rgoulding, 16:25:48)
    12. same issue with yangtools triemap implementation (rgoulding, 16:26:01)
    13. discussion still ongoing on how to handle this (rgoulding, 16:26:31)
    14. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d (rgoulding, 16:27:13)
    15. all outstanding yangtools patches are planned for after the branch cut (rgoulding, 16:27:51)
    16. some will be backportedto Nitrogen post release (rgoulding, 16:27:58)
    17. MDSAL patches are mostly fixes to binding spec v2 (rgoulding, 16:28:09)
    18. should not be an issue since there are no consumers at present (rgoulding, 16:28:22)
    19. same story for controller (rgoulding, 16:28:26)


Meeting ended at 16:29:05 UTC (full logs).

Action items

  1. zxirro to look at patch and system for missing heapdump


People present (lines said)

  1. rgoulding (76)
  2. odl_meetbot (3)
  3. vrpolak (2)


Generated by MeetBot 0.1.4.