#opendaylight-meeting: kernel projects

Meeting started by ryangoulding at 15:58:23 UTC (full logs).

Meeting summary

  1. agenda bashing (ryangoulding, 15:58:29)
    1. Checkstyle more rulez (ryangoulding, 15:58:39)
    2. JavaDoc sites, next step? Merge https://git.opendaylight.org/gerrit/#/c/60213/ (ryangoulding, 15:58:51)
    3. Discussion: Should each thing create its own ExecutorService or should we have a single central shared one? Like an EE servers's manged thread pools. (ryangoulding, 15:58:59)
    4. (ryangoulding, 15:59:12)
    5. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&infrautils+patches=project:infrautils+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT (ryangoulding, 15:59:13)
    6. (ryangoulding, 15:59:19)
    7. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&infrautils+patches=project:infrautils+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AA (ryangoulding, 15:59:20)

  2. Bug 8413 (ryangoulding, 16:04:55)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=8413 (ryangoulding, 16:05:04)
    2. ACTION: jmorvay to take a look this week, but he has been caught up with Nitrogen release process (ryangoulding, 16:06:37)
    3. previously tcere was looking, but he is out (ryangoulding, 16:06:46)
    4. jmorvay will update appropriately once he finds something else otu (ryangoulding, 16:06:57)

  3. Michael’s topics (ryangoulding, 16:09:02)
    1. we will discuss these next week when Michael is on the call (ryangoulding, 16:09:11)

  4. distribution-check jobs failing might be AAA (ryangoulding, 16:14:49)
    1. SFT failing and AAA is only one writing so it appears to be a likely candidate (ryangoulding, 16:15:08)
    2. ACTION: rovarga to find a failed job and send to rgoulding (ryangoulding, 16:15:42)
    3. ACTION: rgoulding to take a further look into why this is happening (ryangoulding, 16:15:50)

  5. on-deck / merged patches (ryangoulding, 16:16:44)
    1. (ryangoulding, 16:16:56)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&infrautils+patches=project:infrautils+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT (ryangoulding, 16:16:56)
    3. a slew of patches will go in the day after nitrogen release (ryangoulding, 16:17:42)
    4. yangtools will soon be disconnected from the rest of the release, but is blocked until we have nitrogen release candidate. Then consumers will revert to a release version. (ryangoulding, 16:18:59)
    5. we will likely need a week of breakage to handle the yangtools API changes etc. (ryangoulding, 16:19:13)
    6. Bug9092 (ryangoulding, 16:23:22)
    7. https://git.opendaylight.org/gerrit/#/c/62849/1 (ryangoulding, 16:23:30)
    8. ^ workaround for json serialization in nitrogen (ryangoulding, 16:23:39)
    9. permanent solution in oxygen will involve using yangtools apis (ryangoulding, 16:23:50)


Meeting ended at 16:28:28 UTC (full logs).

Action items

  1. jmorvay to take a look this week, but he has been caught up with Nitrogen release process
  2. rovarga to find a failed job and send to rgoulding
  3. rgoulding to take a further look into why this is happening


People present (lines said)

  1. ryangoulding (36)
  2. odl_meetbot (4)


Generated by MeetBot 0.1.4.