#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 15:54:26 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 15:54:30)
    1. JavaDoc sites, next step? Merge https://git.opendaylight.org/gerrit/#/c/60213/ (rgoulding, 15:54:38)
    2. continued from last week… Discussion: Should each thing create its own ExecutorService or should we have a single central shared one? Like an EE servers's manged thread pools. (rgoulding, 15:54:51)
    3. Websocket and clustering: https://git.opendaylight.org/gerrit/#/c/63264/ (rgoulding, 15:54:58)
    4. merged/pending patches in the last week (rgoulding, 15:55:10)
    5. https://www.opendaylight.org/events/odl-oxygen-developer-design-forum (rgoulding, 15:59:56)

  2. Oxygen DDF (rgoulding, 16:03:43)
    1. https://www.opendaylight.org/events/odl-oxygen-developer-design-forum (rgoulding, 16:03:54)
    2. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum (rgoulding, 16:04:56)

  3. JavaDoc site docs (rgoulding, 16:05:55)
    1. JavaDoc sites, next step? Merge https://git.opendaylight.org/gerrit/#/c/60213/ (rgoulding, 16:06:01)
    2. https://git.opendaylight.org/gerrit/#/c/60213/ (rgoulding, 16:06:06)
    3. Michael V. feels stuck on how to move forward with this. We probably need Thanh’s help (rgoulding, 16:06:29)
    4. instead of just putting it in “sites” put it in a new location perhaps (rgoulding, 16:10:14)
    5. perhaps something like “/javadocs” (rgoulding, 16:10:21)
    6. that way we can have both systems concurrently while making the transition (rgoulding, 16:10:33)
    7. vorburger feels like this is caution for cuation’s sake because he doesn’t know if there are any users of this (rgoulding, 16:10:48)
    8. each component had its own maven site, which made it somewhat hard to use (rgoulding, 16:12:05)
    9. but the point is there could have been some users (rgoulding, 16:12:11)
    10. if we determine that we can build javadoc in the new location w/ better format then we can probably stop building theold one (rgoulding, 16:12:53)
    11. ACTION: vorburger to open helpdesk ticket to make anew site for “javadoc(s)" (rgoulding, 16:13:16)
    12. we need the javadocs to be deployed to some directory, then we could point the site to the directory (rgoulding, 16:14:10)
    13. vorburger says it is put in target (rgoulding, 16:14:21)
    14. deploy-site.xml example https://github.com/opendaylight/odlparent/blob/master/deploy-site.xml (zxiiro, 16:15:43)
    15. https://github.com/opendaylight/odlparent/blob/master/deploy-site.xml#L38 (rgoulding, 16:16:06)
    16. we could put the javadocs here, or change this to wherever the javadoc is generated (rgoulding, 16:16:40)
    17. https://github.com/opendaylight/odlparent/blob/master/deploy-site.xml#L20 (rgoulding, 16:17:21)
    18. content/sites/javadoc instead of content/sites/site for the second site url (rgoulding, 16:17:39)
    19. every project will need this file to deploy (rgoulding, 16:18:04)
    20. we could get jjb to push the file in (rgoulding, 16:18:14)
    21. start with odlparent first then figure out how to handle other projects (rgoulding, 16:18:26)

  4. Websocket and clustering: https://git.opendaylight.org/gerrit/#/c/63264/ (rgoulding, 16:19:07)
    1. https://git.opendaylight.org/gerrit/#/c/63264/ (rgoulding, 16:19:19)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=9147 (rgoulding, 16:19:46)
    3. https://git.opendaylight.org/gerrit/#/q/topic:ListenerAdapterTreeMigration (rgoulding, 16:20:39)
    4. it appears that ths is the right approach (rgoulding, 16:23:33)
    5. this code just predates that change (rgoulding, 16:23:37)
    6. ClusteredDOMDataTreeChangeListener should eventually be killed eventually, but probably not as relevant to this individual use case (rgoulding, 16:24:51)
    7. it is mroe forward looking (rgoulding, 16:24:56)
    8. tree based change is by design (rgoulding, 16:26:52)

  5. Discussion: Should each thing create its own ExecutorService or should we have a single central shared one? Like an EE servers's manged thread pools. (rgoulding, 16:29:58)
    1. https://git.opendaylight.org/gerrit/#/c/59177/ (rgoulding, 16:30:17)
    2. prompted by thinking about how https://git.opendaylight.org/gerrit/#/c/59177/ users should obtain an ExecutorService (rgoulding, 16:30:27)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=11 (rgoulding, 16:30:40)
    4. one application may starve another if there is not application awareness in the threading model (rgoulding, 16:32:41)
    5. https://git.opendaylight.org/gerrit/#/c/63439/ (vorburger, 16:32:44)
    6. the existing mechanisms are not meant to be global services,they are meant for morelocal use cases (rgoulding, 16:33:22)
    7. threadpools are allocated to handle a certain exchange point (i.e., DTCL) (rgoulding, 16:33:38)
    8. so they are grouped by workflow (rgoulding, 16:33:44)
    9. there is a competing bug that says we should be able to better isolate application workflows (rgoulding, 16:34:04)
    10. https://git.opendaylight.org/gerrit/#/c/63439 (rgoulding, 16:34:38)
    11. in this patch, this ensures that no work stealing is achieved. each workload is mapped to a key (rgoulding, 16:35:28)
    12. so you don’t have a Thread per DTCL (rgoulding, 16:35:56)

  6. merged/pending patches (rgoulding, 16:36:52)
    1. https://git.opendaylight.org/gerrit/#/c/48710/ (rgoulding, 16:37:51)
    2. not completely not impactful (rgoulding, 16:37:57)
    3. David is putting in additional changes to adjust for this ^^ (rgoulding, 16:38:08)
    4. does this impact only trailing whitespace in src/main/resources (rgoulding, 16:38:19)
    5. activates checkstyle on src/main/resources, but only real impact is that non-java files are validated (line endings, no trailing tabs/spaces) (rgoulding, 16:38:53)
    6. is checkstyle checking the extension? (rgoulding, 16:39:44)
    7. vorburger thinks just by file extension (rgoulding, 16:39:51)
    8. when odlparent with this patch is adopted there may be some work to clean up src/main/resources (rgoulding, 16:40:23)
    9. should be trivial and there is info on how to make the change when we transition to the new odlparent version (rgoulding, 16:40:38)
    10. no one really barked about putting this in (rgoulding, 16:41:05)
    11. this will need to be release noted for sure though (rgoulding, 16:41:11)
    12. in 3.0.0 (rgoulding, 16:41:15)
    13. this patch is listed in an email that vorburger sent out and agreed we should handle this with release note (rgoulding, 16:41:35)
    14. rovarga thinks this is okay; need to follow up with Stephen who has -1 (rgoulding, 16:42:37)
    15. I'll remove my -1, and merge it (rgoulding, 16:42:55)


Meeting ended at 16:44:22 UTC (full logs).

Action items

  1. vorburger to open helpdesk ticket to make anew site for “javadoc(s)"


Action items, by person

  1. vorburger
    1. vorburger to open helpdesk ticket to make anew site for “javadoc(s)"


People present (lines said)

  1. rgoulding (71)
  2. zxiiro (6)
  3. odl_meetbot (3)
  4. vorburger (2)


Generated by MeetBot 0.1.4.