#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:00:48 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:00:59)
    1. odlparent 3.0 release timing (rgoulding, 16:13:52)
    2. merged/pending patchs (rgoulding, 16:13:58)

  2. odlparent 3.0 release timing (rgoulding, 16:14:04)
    1. yangtools 2.0.0 is getting there, and adjustment patches in controller/mdsal are getting done. will still require changees as yangtools is still changing (rgoulding, 16:14:45)
    2. and odlparent release will need to be planned for htis, and yangtools will likely start pulling in the snapshot version (rgoulding, 16:15:07)
    3. two big ticket items are karaf 4.1.2 and 4.1.3 (which gives us the ability to use version ranges) (rgoulding, 16:15:36)
    4. there will be netty api breakages (rgoulding, 16:16:18)
    5. release of karaf 4.1.3 should happen anytime now (upstream controlled) (rgoulding, 16:16:39)
    6. akka might also be a candidate but it is fine if we miss it (rgoulding, 16:17:19)

  3. FindBugs discussion (rgoulding, 16:32:17)
    1. enabling static analysis tooling for null checking like FB or spotcheck (rgoulding, 16:32:31)
    2. the alternative is to eliminate use of null (using guava and things like Optional instead) (rgoulding, 16:32:48)
    3. we need to centralize on some static analysis tools at some point (rgoulding, 16:33:13)
    4. can still return null for Optional (BAD!) but it can happen. This is something static analysis can pick up and warn us about (rgoulding, 16:34:19)
    5. https://git.opendaylight.org/gerrit/#/c/64816/5/yang/yang-model-api/src/main/java/org/opendaylight/yangtools/yang/model/api/DataNodeContainer.java (rovarga_, 16:34:43)
    6. in the above patch, new code should use the new method (findDataChildByName “find” similar to guava naming convention) (rgoulding, 16:35:30)
    7. that way you can get compatibility and also deprecation warnings around the old method (“getDataChildByName") (rgoulding, 16:35:47)
    8. ACTION: take the Annotation discussion to the mailing list (rgoulding, 16:37:28)
    9. may need instruction material on how to enable this in other IDE(s) aside from Eclipse (rgoulding, 16:37:47)
    10. the issue is that findbugs isn’t really actively maintained and spotbugs we have more active upstream community (rgoulding, 16:39:14)
    11. should be the same code base with new fixes on top (rgoulding, 16:40:13)

  4. Member fails to rejoin cluster after it is quarantined (rgoulding, 16:49:10)
    1. https://jira.opendaylight.org/browse/CONTROLLER-1783 (rgoulding, 16:49:11)
    2. https://git.opendaylight.org/gerrit/#/c/62451/ (rgoulding, 16:56:03)
    3. ACTION: LuisGomez to add log of after the stop in Oxygen or Nitrogen (rgoulding, 16:56:44)
    4. fix for karaf restart: https://git.opendaylight.org/gerrit/64971 (rovarga_, 16:58:54)
    5. wasn’t in Nitrogen so shouldn’t need to block SR1 for that (rgoulding, 16:59:45)


Meeting ended at 17:01:44 UTC (full logs).

Action items

  1. take the Annotation discussion to the mailing list
  2. LuisGomez to add log of after the stop in Oxygen or Nitrogen


People present (lines said)

  1. rgoulding (30)
  2. odl_meetbot (4)
  3. rovarga_ (2)


Generated by MeetBot 0.1.4.