#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 17:02:22 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 17:02:28)
    1. Take a decision together re. latest odlparent 3.0.0 full switch over time box date (and some back-ports to a 2.0.6/2.0.7 as a fallback) (rgoulding, 17:02:39)
    2. https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018 (rgoulding, 17:02:47)

  2. odlparent 3.0.0 (rgoulding, 17:04:18)
    1. issues with AAA sorted through a few changes in odlparent (rgoulding, 17:04:45)
    2. GSON patch still needed? (rgoulding, 17:05:44)
    3. skitt says it would be good to have (rgoulding, 17:05:55)
    4. https://git.opendaylight.org/gerrit/#/c/66056/ (rgoulding, 17:05:57)
    5. vorburger afraid it may be late in the cycle ot make the switch (rgoulding, 17:11:32)
    6. due to holidays we may end up slipping (rgoulding, 17:13:46)
    7. if many leaf projects do not adhere and do the upgrade, that would delay the simultaneous release (rgoulding, 17:14:15)
    8. odlparent upgrade gives us several things including ability to use version ranges, upstream dependencies upgrade (incl. guava), latest karaf shell (much better looking) (rgoulding, 17:17:17)
    9. since it is tied with yangtools 2.0.0, it gives us several bugfixes in the yangtools parser (rgoulding, 17:17:36)
    10. the question isn’t whether to do it, but rather when to do it (rgoulding, 17:20:17)
    11. vorburger is stressing that the timeline is the issue (rgoulding, 17:23:20)
    12. when do you think projects actually will do this? (rgoulding, 17:23:28)
    13. ACTION: update wiki as we complete patches (rgoulding, 17:34:35)

  3. “version” in integration (rgoulding, 17:41:09)
    1. “version” feature uses CSS (rgoulding, 17:41:16)
    2. need to migrate to blueprint (rgoulding, 17:41:40)
    3. Luis asks is CSS deprecated officially? (rgoulding, 17:42:13)
    4. CSS is deprecated (rgoulding, 17:42:32)
    5. https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-distribution-version/src/main/feature/feature.xml#L12 (rgoulding, 17:44:13)
    6. we need to officially release messaging that CSS is done (rgoulding, 17:44:23)
    7. has TomP done this? (rgoulding, 17:44:29)
    8. ACTION: rgoulding to ask tpantelis' (rgoulding, 17:44:33)

  4. release management in Fluorine (rgoulding, 17:47:59)
    1. i.e., application projects releasing independently (rgoulding, 17:48:12)
    2. how to add artifacts to the distribution (rgoulding, 17:48:26)
    3. karaf-plugin in odlparent is used to look at all the features/dependencies and make sure it is stashed in system/ so that we can start offline (rgoulding, 17:49:06)
    4. when we build distribution we are using karaf-maven-plugin (rgoulding, 17:49:17)
    5. that creates zips, tar/gz and kar(s) for single features and feature repositories (rgoulding, 17:49:33)
    6. that is probably what we should use based on this newly proposed model (rgoulding, 17:49:44)
    7. have the application projects generate a kar, copy the file somewhere, then feature:install on that needed feature (rgoulding, 17:50:17)
    8. this should be do-able using the off the shelf karaf-maven-plugin (rgoulding, 17:52:10)


Meeting ended at 17:53:10 UTC (full logs).

Action items

  1. update wiki as we complete patches
  2. rgoulding to ask tpantelis'


Action items, by person

  1. rgoulding
    1. rgoulding to ask tpantelis'


People present (lines said)

  1. rgoulding (39)
  2. odl_meetbot (4)


Generated by MeetBot 0.1.4.