#opendaylight-meeting: kernel projets

Meeting started by colindixon at 16:05:42 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:05:47)
    1. https://wiki.opendaylight.org/view/Kernel_Projects_Call#Upcoming_Agenda_Topics (colindixon, 16:06:07)
    2. skitt added leaf nodes in NETCONF and Karaf 4 (colindixon, 16:06:38)

  2. Boron-SR3 NETCONF test failures (colindixon, 16:06:58)
    1. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1776065453 (colindixon, 16:07:11)
    2. these three failures happen (colindixon, 16:07:26)
    3. https://jenkins.opendaylight.org/releng/job/netconf-csit-3node-clustering-all-boron/448/ (colindixon, 16:07:28)
    4. https://jenkins.opendaylight.org/releng/job/netconf-csit-3node-periodic-clustering-scale-all-boron/347/ (colindixon, 16:07:34)
    5. https://jenkins.opendaylight.org/releng/job/netconf-csit-3node-periodic-clustering-scale-only-boron/339/ (colindixon, 16:07:40)
    6. vratko says that the 3-node all seems to be an issue with compatible with all, the other two he needs to look into (colindixon, 16:09:24)

  3. leaf nodes in NETCONF (colindixon, 16:09:34)
    1. https://git.opendaylight.org/gerrit/52173 (colindixon, 16:09:52)
    2. joshua asked skitt to ask rovarga look at it again (colindixon, 16:11:22)
    3. rovarga says that he has no remaining opposition (colindixon, 16:11:34)

  4. Karaf 4 (colindixon, 16:12:17)
    1. genius is currently the big blocker (colindixon, 16:12:35)
    2. sfc takes ~5 minutes in Karaf 3, and blows up to 10-15 minutes in Karaf 4 (colindixon, 16:13:10)
    3. there's a patch to odlparent that fixes things, but breaks the distribution check (colindixon, 16:14:11)
    4. https://git.opendaylight.org/gerrit/#/c/53109/ this is the odlparent patch (colindixon, 16:15:20)
    5. vorburger says he's surprised that this is a genius-only thing, that being said they can add genius to a singlefeaturetest for bundles in the blacklist (colindixon, 16:18:01)
    6. the consensus is to add genius to the SFT blacklist and merge the Karaf 4 patch (skitt, 16:21:04)
    7. and keep on working on the odlparent patch (skitt, 16:21:12)
    8. this will unblock SFC and netvirt (skitt, 16:21:21)

  5. merged patches (colindixon, 16:24:21)
    1. agreed; I'll put in the blacklist patch (vorburger, 16:24:25)
    2. one patch for -XX jvm options to fix issues in some uncommon places (colindixon, 16:24:37)
    3. https://git.opendaylight.org/gerrit/53553 enfore binary/string length in YANG tools, broke NETCONF, but it's unbroken now (colindixon, 16:25:03)
    4. controller patches are mostly adding unit tests for work on BUG-5280 + fixing issues flushed out by testing (colindixon, 16:26:30)
    5. netconf call home is merged plus a temorary fix for the breakage caused with YANG tools enforcing string length (colindixon, 16:27:06)
    6. https://git.opendaylight.org/gerrit/#/c/52019/ add import/export keystore CLI commans (colindixon, 16:27:45)

  6. unmerged patches (colindixon, 16:30:43)
    1. #Info distributed shard patches that need TomP to look at them in controller (colindixon, 16:30:45)
    2. https://git.opendaylight.org/gerrit/#/c/47887/ is anyone interested in running with the code to implement the ssh public key authentication? (colindixon, 16:31:57)

  7. meeting organization (colindixon, 16:36:49)
    1. vorburger says he's really struggling with WebEx (colindixon, 16:37:04)
    2. https://fedoramagazine.org/firefox-npapi-plugins-fedora/ (vorburger, 16:37:36)
    3. https://www.bluejeans.com/ (vorburger, 16:38:12)
    4. skitt and vorburger are stuggling with LInux and WebEx (colindixon, 16:38:38)
    5. colindixon says that he has no problem trying out BlueJeans (colindixon, 16:39:29)
    6. CaseyODL says that they've looked at BlueJeans in the past, his memory was that cost and lack of (free?) intenational dial-in numbers (colindixon, 16:40:46)
    7. vorburger (and others) note that there are no free interanationl dial-in numbers for our WebEx (colindixon, 16:41:41)
    8. for now Red Hat is paying for the NetVirt, OVSDB, and Genius calls every week on BlueJeans (colindixon, 16:42:05)
    9. colindixon says he's happy to try bluejeans next week (colindixon, 16:44:13)
    10. ACTION: skitt will look into recordings for webex asking shague (colindixon, 16:45:02)
    11. ACTION: vorburger to set up a BlueJeans meeting for next week to play with (colindixon, 16:45:29)


Meeting ended at 16:45:57 UTC (full logs).

Action items

  1. skitt will look into recordings for webex asking shague
  2. vorburger to set up a BlueJeans meeting for next week to play with


Action items, by person

  1. skitt
    1. skitt will look into recordings for webex asking shague
  2. vorburger
    1. vorburger to set up a BlueJeans meeting for next week to play with


People present (lines said)

  1. colindixon (43)
  2. odl_meetbot (3)
  3. skitt (3)
  4. vorburger (3)


Generated by MeetBot 0.1.4.