#opendaylight-meeting: nitrogen release sync

Meeting started by colindixon at 15:00:56 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 15:01:02)
    1. karaf 4 status (colindixon, 15:03:05)
    2. remove projects from autorelease, releng/builder, and integration/distribution (colindixon, 15:03:25)
    3. Boron-SR4 (colindixon, 15:03:42)
    4. other general topics (colindixon, 15:03:46)

  2. Boron-SR4 (colindixon, 15:03:50)
    1. we believe that it's good to go, we've notified all the projects and reaching out to projects with test failres to see if they want voluntarily mark their test isssues as "ignore" (colindixon, 15:04:30)
    2. the only major issue we have is with CLM, do we want to do it for SRs (colindixon, 15:05:26)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#SR4_Prebuild (anipbu, 15:06:10)
    4. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471 (anipbu, 15:06:10)
    5. colindixon says for right now, lets ignore it, staring with Carbon, it probably makes sense to start tracking CLM "failures" the same way we track CSIT failures to make that faster (colindixon, 15:06:12)
    6. anipbu says he expects Boron-SR4 on time on schedule (colindixon, 15:06:36)
    7. ACTION: colindixon to make sure that the release notes speak to the CVEs fix in SR3 and workarounds for others (colindixon, 15:07:01)
    8. ACTION: colindixon to open a bug against Boron-SR4 for security content of the release (colindixon, 15:07:49)

  3. karaf 4 status (colindixon, 15:08:36)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf (anipbu, 15:09:36)
    2. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 15:09:38)
    3. we're missing skitt and rovarga today, but I think the status seems something like "nearly all projecs have karaf 4 feautures, but we're still sorting out dependency issues" (colindixon, 15:10:13)
    4. https://lists.opendaylight.org/pipermail/release/2017-June/011159.html (anipbu, 15:10:21)
    5. skitt is working on seeing if moving to the Karaf 3 resolver in Karaf 4 just fixes all of our issues (colindixon, 15:10:36)
    6. during the DDF, skitt also presented other possible ways with dependency=true and/or using other techniques like if we can get access to --no-refresh-bundles with feature:install by default (colindixon, 15:15:27)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf (colindixon, 15:15:35)
    8. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (colindixon, 15:15:40)
    9. https://lists.opendaylight.org/pipermail/release/2017-June/011159.html (colindixon, 15:15:46)

  4. removing projects from autorelease, releng/builder, integregration/distribution (colindixon, 15:16:04)
    1. zxiiro says that all the offset 0 projects are in autorelease, but nothing else is (colindixon, 15:16:24)
    2. plan is to remove odlparent as soon as we downgrade all projects to depend on the carbon version of odlparent (colindixon, 15:16:46)
    3. currently we're blocked on the fact that infrautils depends on an oldparent module that was added in nitrogen, so if we remove odlparent from autorelease, it will fail (colindixon, 15:17:21)
    4. we've removed the autorealease-validate-nitrogen job in releng/builder from everyone but offset 0 projects (colindixon, 15:18:05)
    5. currently integration/distribution is not in autorelease, so it's not on the critical path to have projects removed from it (colindixon, 15:18:40)
    6. in the short-to-medium-term, we shoudl remove all but offset 0 projects from integration/distribution and add it back to autorelease (colindixon, 15:19:05)
    7. ACTION: zxiiro to open a bug about infrauitls and it's dependency on nitrogent odlparent (colindixon, 15:19:18)
    8. ACTION: colindixon to open a bug to remove all non-offset0 projects from int/dist and add it back to autorelease (colindixon, 15:19:49)

  5. karaf 4 dependency resolution (colindixon, 15:20:56)
    1. skitt says he's waiting for some info from karaf 4 upstream (colindixon, 15:21:07)
    2. skitt still needs to test using karaf 3 resolver in karaf 4 (colindixon, 15:22:02)
    3. http://karaf.922171.n3.nabble.com/Basic-questions-about-bundles-and-features-td4050547.html (colindixon, 15:22:30)
    4. http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html (colindixon, 15:22:58)
    5. http://karaf.922171.n3.nabble.com/complete-documentation-for-features-xml-tc4048897.html (skitt, 15:23:54)
    6. it seems like there are a few possible ways forward: (1) use the karaf 3 resolver in karaf 4, (2) fix all bundles/features to be reloadable, (3) we could move to using dependency=true, which won't reload them, but it doesn't load them for you, it's possible that adding prerequisite=true as well would fix it, but that seems to expose bugs in Karaf, (4) figure out if we can effectively enable --no-auto-refresh (colindixon, 15:31:51)
    7. the plan of record is to target (1) as a stop-gap and then either (3) or (4) (colindixon, 15:32:16)
    8. skitt says the hope is that once we get (1) working, we can then add projects back and then we can accomplish either (3) or (4) with only changes in odlparent, so we won't have to kick all projects out again (colindixon, 15:34:25)
    9. skitt asks if int/dist is planning to move away from boot features, rovarga says they're considering it, but haven't done it yet (colindixon, 15:35:18)
    10. colindixon asks why, rovarga says that it avoids hitting two feature installation code paths in Karaf since boot features and feature:install hit different things, the downside is that project-local distributions (and SFT) will have to be modified to do a feature:install instead (colindixon, 15:36:57)
    11. this would also have to change CSTI (colindixon, 15:37:05)
    12. it also is not how most downstreams work, but it is how the upstream OpenDaylight distribution works (colindixon, 15:37:23)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=8622 the new bug to track karaf 4 depenency resolution issues (colindixon, 15:38:21)
    14. rovarga suggests that we treat infrautils as an offset 1 project for now and drop it from autorelease until we find a way forward (colindixon, 15:39:48)
    15. ACTION: zxiiro to remove infrautils from autorelease (colindixon, 15:39:57)


Meeting ended at 15:42:05 UTC (full logs).

Action items

  1. colindixon to make sure that the release notes speak to the CVEs fix in SR3 and workarounds for others
  2. colindixon to open a bug against Boron-SR4 for security content of the release
  3. zxiiro to open a bug about infrauitls and it's dependency on nitrogent odlparent
  4. colindixon to open a bug to remove all non-offset0 projects from int/dist and add it back to autorelease
  5. zxiiro to remove infrautils from autorelease


Action items, by person

  1. colindixon
    1. colindixon to make sure that the release notes speak to the CVEs fix in SR3 and workarounds for others
    2. colindixon to open a bug against Boron-SR4 for security content of the release
    3. colindixon to open a bug to remove all non-offset0 projects from int/dist and add it back to autorelease
  2. zxiiro
    1. zxiiro to open a bug about infrauitls and it's dependency on nitrogent odlparent
    2. zxiiro to remove infrautils from autorelease


People present (lines said)

  1. colindixon (48)
  2. anipbu (7)
  3. odl_meetbot (3)
  4. skitt (1)
  5. zxiiro (1)


Generated by MeetBot 0.1.4.