#opendaylight-meeting: nitrogen release sync

Meeting started by colindixon at 15:05:42 UTC (full logs).

Meeting summary

  1. where we are (colindixon, 15:05:45)
    1. we are halfway through migrating to odlparent 1.9.0 release (colindixon, 15:06:10)
    2. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0 all patches (colindixon, 15:06:21)
    3. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0+status:open open patches (colindixon, 15:06:33)
    4. zxiiro is merging them in a particluar order (colindixon, 15:06:53)
    5. https://git.opendaylight.org/gerrit/#/c/58831/ failed to bump, zxiiro is looking into it (colindixon, 15:08:20)
    6. it seems like the patch is failing becuase (a) autorelease nitgrogen is just broken, (b) distribution3 check because it doesn't have karaf 3 anymore, (c) the nitrogen distribution check is failing becuase int/dist is still looking for 1.9.0-SNAPSHOT (colindixon, 15:13:01)
    7. ACTION: zxiiro will e-mail the list to make sure nobdy is surprised before we merge it (colindixon, 15:13:10)
    8. colindixon notes that it looks like the release script worked to produce 1.9.0 and things are good, for 1.9.0 we shouldn't need a stability branch, since we'll hit 2.0.0 next week (colindixon, 15:15:29)
    9. however the plan going forward is to have stability branches after the fact to avoid the overhead unless we need it (colindixon, 15:16:45)
    10. vorburger notes that it probably makes sense to bump to 2.0.0 as late as possible but before Karaf 3 is removed (colindixon, 15:18:08)
    11. early next week, we'll start moving projects into autorelease after validattion of Karaf 4 readiness (colindixon, 15:19:20)
    12. https://bugs.opendaylight.org/show_bug.cgi?id=8686 is what's currently blocking netvirt and genius (vorburger, 15:20:43)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=8694 is what's currently blocking netvirt and genius (the 8686 is "just" shutdown) (vorburger, 15:22:52)
    14. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 15:24:33)

  2. reviewing karaf 4 tracking sheet (colindixon, 15:29:55)
    1. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (colindixon, 15:30:01)
    2. listen to recording for some blow-by-blow review (colindixon, 15:30:10)
    3. there is a discussion about when and if we want to remove the non-offset-0 projects from int/dist (colindixon, 15:30:29)
    4. the current plan was to combine that with removing karaf 3 from int/dist (colindixon, 15:30:49)
    5. the new plan is to break that into two patches, first drop all non-offset-0 projects, then drop karaf 3 (colindixon, 15:31:12)
    6. ACTION: LuisGomez to break apart the patch for int/dist into two parts: first drop all non-offset-0 projects, then drop karaf 3 (colindixon, 15:31:30)

  3. projects that aren't leaves and may be unresponsive (colindixon, 15:35:14)
    1. this list is: dlux, snmp, tsdr, l2switch (colindixon, 15:35:24)
    2. colindixon says he should be able to get l2switch to work (colindixon, 15:37:25)
    3. https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/351/dependencies.log.gz dependencies log (zxiiro, 15:38:36)
    4. vorburger notes that we should drop dependencies on dead projects (colindixon, 15:41:01)
    5. colindixon and anipbu agree, but point out it's not that easy (colindixon, 15:41:13)
    6. ACTION: zxiiro will ping all projects (including these 4 that might be non-responsive) (colindixon, 15:43:35)
    7. ACTION: zxiiro and/or vorburger to add infrautils back to autorelease assuming that it works with 1.9.0 odlparent (colindixon, 15:53:17)


Meeting ended at 15:53:48 UTC (full logs).

Action items

  1. zxiiro will e-mail the list to make sure nobdy is surprised before we merge it
  2. LuisGomez to break apart the patch for int/dist into two parts: first drop all non-offset-0 projects, then drop karaf 3
  3. zxiiro will ping all projects (including these 4 that might be non-responsive)
  4. zxiiro and/or vorburger to add infrautils back to autorelease assuming that it works with 1.9.0 odlparent


Action items, by person

  1. vorburger
    1. zxiiro and/or vorburger to add infrautils back to autorelease assuming that it works with 1.9.0 odlparent
  2. zxiiro
    1. zxiiro will e-mail the list to make sure nobdy is surprised before we merge it
    2. zxiiro will ping all projects (including these 4 that might be non-responsive)
    3. zxiiro and/or vorburger to add infrautils back to autorelease assuming that it works with 1.9.0 odlparent


People present (lines said)

  1. colindixon (29)
  2. odl_meetbot (4)
  3. vorburger (3)
  4. anipbu (1)
  5. zxiiro (1)


Generated by MeetBot 0.1.4.