#opendaylight-meeting: nitrogen release sync

Meeting started by colindixon at 15:06:05 UTC (full logs).

Meeting summary

  1. state of the world (colindixon, 15:06:13)
  2. karaf (anipbu, 15:06:42)
    1. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 <--- Karaf 4 status spreadsheet (anipbu, 15:06:55)
    2. in general, we're in less great shape than we'd like (colindixon, 15:06:56)
    3. only 21 projects are in integration/distribution right now, which is less than half than those that were in carbon (colindixon, 15:07:52)
    4. 5 projects have made no progress on karaf 4: eman, nemo, ofconfig, tsdr, usc (colindixon, 15:09:18)
    5. anipbu notes that he's responsible for nemo and usc, so he'll work on it this week (colindixon, 15:09:38)
    6. https://logs.opendaylight.org/releng/jenkins092/autorelease-release-nitrogen/122/dependencies.log.gz Nitrogen dependencies.log (zxiiro, 15:11:08)
    7. colindixon asks if the remaining projects are leaf projects, anipbu says he thinks yes, so we can and will drop them at RC0 barring something significant happening (colindixon, 15:11:13)
    8. https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/400/dependencies.log.gz Carbon dependencies.log (zxiiro, 15:11:26)
    9. based on the carbon dependencies log, both iotdm and cardinal depend on tsdr, iotdm isn't in nitrogen, and the tsdr dependency from cardinal isn't real based on skitt looking at it (colindixon, 15:13:28)
    10. ACTION: anipbu to reach out to cardinal and ask them to remove dep on tsdr (anipbu, 15:13:33)
    11. thus it seems like these are all leaf projects and do not pose a release risk to nitrogen (colindixon, 15:14:02)
    12. anipbu notes that NETCONF has a bug that is blocking it from moving to karaf 4 fully and/or any of it's dependencies https://bugs.opendaylight.org/show_bug.cgi?id=7891 (colindixon, 15:15:57)
    13. the NETCONF project is aware of this and working on it, but understaffed https://lists.opendaylight.org/pipermail/release/2017-July/011758.html (colindixon, 15:17:12)
    14. it should be noted that NETCONF is understaffed at the moment, this remains a significant risk to the nitrogen release (colindixon, 15:17:59)

  3. projects that aren't in distribution (colindixon, 15:18:13)
    1. anipbu wants to talk about the projects that were not leaves in carbon, but have yet to make it back to the distribution (colindixon, 15:18:36)
    2. anipbu notes that SNMP hasn't gotten there yet (colindixon, 15:18:55)
    3. skitt says he'll look on Monday if Frank doesn't get to it by then, also he notes that TomP and Ryan Goulding should also be committers as soon as Frank votes publicly (he's given private notes) (colindixon, 15:20:03)
    4. sfc is blocked on netconf (see the above bug) (colindixon, 15:20:24)
    5. l2swithc isn't in there yet, but should be easy to get in (colindixon, 15:20:39)
    6. ACTION: colindixon and/or klou will reach out to sai and get him to add it to distribution (colindixon, 15:20:51)

  4. leaf projects not in the distribution (colindixon, 15:22:28)
    1. fast review of each (colindixon, 15:22:31)
    2. alto isn't done, would be fine to drop (colindixon, 15:22:58)
    3. bier is at 67% and would be fine to drop (colindixon, 15:23:24)
    4. cardinal has a patch to be added to the distribution, but running into problems, need help, zxiiro has been trying to help needs help from integration (colindixon, 15:24:09)
    5. dlux is done, but just needs to send their intent to participate, colindixon says they're done he'll send it on their behalf (colindixon, 15:24:48)
    6. ACTION: colindixon to talk about making dlux a leaf project in oxygen unless we can fix it's resource issue (colindixon, 15:25:32)
    7. eman already discussed, hasn't started (colindixon, 15:26:02)
    8. faas is at 33%, grouppolicy depends on faas at least by our script (colindixon, 15:26:48)
    9. ACTION: anipbu to look into if GBP actually depends on FaaS and maybe remove that (colindixon, 15:27:17)
    10. faas depends on sfc which depends on netconf (colindixon, 15:27:28)
    11. groupbased policy is a non-leaf project, blocked by netconf (colindixon, 15:27:40)
    12. honeycomb/vbd has a patch open to be added to the distribution, groupbasedpolicy and lispflowmapping both depend on vbd (colindixon, 15:28:32)
    13. ACTION: anipbu to follow up with honeycomb/vbd to see where they are and if they're going to make it (colindixon, 15:29:04)
    14. l2switch see above (colindixon, 15:29:08)
    15. mdsal is done, but hasn't submitted their intent to participate (colindixon, 15:29:23)
    16. ACTION: colindixon will send intent to participate on mdsal's behalf (colindixon, 15:29:41)
    17. neutron was added to the distribution, removed, has been added back again (colindixon, 15:30:16)
    18. nic has a patch to be added into the distribution, is having problems, is leaf project (colindixon, 15:30:57)
    19. ocpplugin has a patch and it verifies, so they are likely good (colindixon, 15:31:46)
    20. ofconfig hasn't started (see above) (colindixon, 15:32:05)
    21. packetcable has a failing patch to be added to the distribution, last touched on the 24th, leaf projct (colindixon, 15:32:23)
    22. sfc blocked on netconf (colindixon, 15:32:39)
    23. snmp see above, skitt will follow up if frank doesn't (colindixon, 15:32:57)
    24. snmp4sdn has a patch to distribution that verifies, so they're OK (colindixon, 15:33:19)
    25. colindixon asks if that's real, skitt notes that they still pull in the AD-SAL still, I guess if they don't break anyone else, that's fine (colindixon, 15:34:45)
    26. tsdr was talked about above (colindixon, 15:35:30)
    27. unimgr has been asking for help, colindixon and zxiiro helped some, they are a leaf project (colindixon, 15:36:14)
    28. usc and nemo were talked about above (colindixon, 15:36:54)
    29. THESE PROJECTS ARE NON-LEAF AND NOT DONE: faas, groupbasedpolicy, honeycomb/vbd, l2switch, netconf, sfc, tsdr (colindixon, 15:41:23)
    30. for what it's worth dlux and mdsal haven't done paperwork, but are code-complete (colindixon, 15:41:46)


Meeting ended at 15:44:08 UTC (full logs).

Action items

  1. anipbu to reach out to cardinal and ask them to remove dep on tsdr
  2. colindixon and/or klou will reach out to sai and get him to add it to distribution
  3. colindixon to talk about making dlux a leaf project in oxygen unless we can fix it's resource issue
  4. anipbu to look into if GBP actually depends on FaaS and maybe remove that
  5. anipbu to follow up with honeycomb/vbd to see where they are and if they're going to make it
  6. colindixon will send intent to participate on mdsal's behalf


Action items, by person

  1. anipbu
    1. anipbu to reach out to cardinal and ask them to remove dep on tsdr
    2. anipbu to look into if GBP actually depends on FaaS and maybe remove that
    3. anipbu to follow up with honeycomb/vbd to see where they are and if they're going to make it
  2. colindixon
    1. colindixon and/or klou will reach out to sai and get him to add it to distribution
    2. colindixon to talk about making dlux a leaf project in oxygen unless we can fix it's resource issue
    3. colindixon will send intent to participate on mdsal's behalf


People present (lines said)

  1. colindixon (57)
  2. odl_meetbot (6)
  3. anipbu (3)
  4. zxiiro (2)
  5. CaseyODL (0)


Generated by MeetBot 0.1.4.