#opendaylight-meeting: nitrogen release synx

Meeting started by colindixon at 15:03:14 UTC (full logs).

Meeting summary

  1. current status (colindixon, 15:03:20)
    1. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.8.0-Carbon (anipbu, 15:04:05)
    2. anipbu notes that that there were build failures in nitrogen over the weekend, not cleary if patch 58662 fixed it (colindixon, 15:04:15)
    3. the latests nitrogen autorelease failed on odlparent becuase the versoin in the license should be 0.2.0-Carbon instead of 0.3.0-Nitrogen, there are two candidate patches (colindixon, 15:07:07)
    4. this only blocks autorelease nitrogen and the controller (colindixon, 15:07:25)
    5. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.8.0-Carbon these patches are almost all merged (colindixon, 15:07:36)
    6. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.8.0-Carbon+status:open (anipbu, 15:07:41)
    7. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.8.0-Carbon+status:open five projects fail when we downgrade the version of odlparent for reasons that zxiiro doesn't understand (colindixon, 15:08:09)
    8. ACTION: anipbu will send mails to bier, groupbasedpolicy, snmp4sdn, ocpplugin, sdninterfaceapp since they have to make their 1.8.0 odlparent build, zxiiro also notes that NIC depends on GBP (colindixon, 15:09:22)
    9. zxiiro has the patch for NIC submitted (colindixon, 15:11:13)

  2. odds and ends (colindixon, 15:11:38)
    1. colindixon notes that we seem to be having a hard time getting netconf developers to respond to things (colindixon, 15:11:39)
    2. https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/thread.html colindixon notes that in June no netconf-dev mailing list has gotten a response from a committer (colindixon, 15:12:26)
    3. colindixon notes that's a significant risk to OpenDaylight and nitrogen (colindixon, 15:12:54)
    4. https://git.opendaylight.org/gerrit/#/c/58543/6 this patch has at least temporariliy blocked JSON RPC, which is actively developed if not explicitly paticipating in nitrogen (colindixon, 15:13:28)
    5. https://lists.opendaylight.org/pipermail/yangtools-dev/2017-June/001892.html discussion on that topic (colindixon, 15:13:56)
    6. https://lists.opendaylight.org/pipermail/documentation/2017-June/001212.html read the docs is failing to build consistently and we don't know why (colindixon, 15:16:16)
    7. it has finally built the stable/carbon docs to get the release notes right, but we should look into why it's failing when we can (colindixon, 15:17:03)

  3. boron-sr4 (colindixon, 15:17:21)
    1. anipbu says we're waiing for the distribution test jobs and we need to get sign offs and we can use the ignores from last time (colindixon, 15:17:37)
    2. no blocker bugs so far (colindixon, 15:17:41)
    3. colindixon brings this up because the jenkins queues are very high because of the daily builds, since the branch is frozen, zxiiro will make it weekly now (colindixon, 15:19:03)
    4. ACTION: colindixon to work on the security announcement around Boron-SR4 (colindixon, 15:20:15)


Meeting ended at 17:04:20 UTC (full logs).

Action items

  1. anipbu will send mails to bier, groupbasedpolicy, snmp4sdn, ocpplugin, sdninterfaceapp since they have to make their 1.8.0 odlparent build, zxiiro also notes that NIC depends on GBP
  2. colindixon to work on the security announcement around Boron-SR4


Action items, by person

  1. anipbu
    1. anipbu will send mails to bier, groupbasedpolicy, snmp4sdn, ocpplugin, sdninterfaceapp since they have to make their 1.8.0 odlparent build, zxiiro also notes that NIC depends on GBP
  2. colindixon
    1. colindixon to work on the security announcement around Boron-SR4


People present (lines said)

  1. colindixon (28)
  2. odl_meetbot (5)
  3. anipbu (3)
  4. skitt (1)


Generated by MeetBot 0.1.4.