#opendaylight-meeting: nitrogen sync

Meeting started by zxiiro at 15:00:47 UTC (full logs).

Meeting summary

  1. general (zxiiro, 15:04:14)
    1. autorelease nitrogen nic failure is resolved. autorelease job is now running. (zxiiro, 15:05:12)
    2. odlparent 2.0.3 is released. but SFT seems to be broken due to failing to find artifact. skitt and rovarga are investigating. (zxiiro, 15:06:02)
    3. m5 offset 2 is next Monday. (zxiiro, 15:06:46)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2017/nitrogen_release_sync/opendaylight-meeting-nitrogen_release_sync.2017-07-28-15.06.html (colindixon, 15:08:04)
    5. last time we checked the following were non-leaf projects that weren't in nitrogen: faas, groupbasedpolicy, honeycomb/vbd, l2switch, netconf, sfc, tsdr (colindixon, 15:08:58)
    6. tsdr and faas aren't, but they're now leaves (colindixon, 15:09:15)
    7. that _should_ mean that we have only leaves missing, 38 projects so far in autorelease (colindixon, 15:11:32)
    8. ACTION: colindixon and maybe zxiiro to look into who's in autorelease, but not integration/distribution (colindixon, 15:13:35)
    9. respin odlparent 2.0.4 coming soon (zxiiro, 15:15:38)
    10. rovarga asks if we can automate version bumping as part of releasing artifacts (colindixon, 15:16:32)
    11. zxiiro will look into automating the process, e.g., maybe lock the branch, then release, then create a version bump patch, publish it to gerrit, and leave the branch locked until that patch is merged (colindixon, 15:18:50)
    12. https://jira.linuxfoundation.org/browse/RELENG-374 Jira to make release process more self serve (zxiiro, 15:22:19)

  2. carbon (zxiiro, 15:24:52)
    1. shague points out that autorelease-carbon was broken on NIC, we want to make sure that SR2 gets out on time next week (colindixon, 15:25:50)
    2. https://git.opendaylight.org/gerrit/#/c/61432/ nic patch (shague, 15:26:03)
    3. ACTION: shague and/or zxiiro will focus on tracking carbon autorelease and keeping on hammering (colindixon, 15:31:42)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=8941 (rovarga, 15:32:59)


Meeting ended at 15:36:36 UTC (full logs).

Action items

  1. colindixon and maybe zxiiro to look into who's in autorelease, but not integration/distribution
  2. shague and/or zxiiro will focus on tracking carbon autorelease and keeping on hammering


Action items, by person

  1. colindixon
    1. colindixon and maybe zxiiro to look into who's in autorelease, but not integration/distribution
  2. shague
    1. shague and/or zxiiro will focus on tracking carbon autorelease and keeping on hammering
  3. zxiiro
    1. colindixon and maybe zxiiro to look into who's in autorelease, but not integration/distribution
    2. shague and/or zxiiro will focus on tracking carbon autorelease and keeping on hammering


People present (lines said)

  1. zxiiro (12)
  2. colindixon (11)
  3. odl_meetbot (6)
  4. rovarga (2)
  5. shague (2)
  6. skitt (0)
  7. anipbu (0)
  8. CaseyODL (0)


Generated by MeetBot 0.1.4.