#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:11 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 18:00:16)
    1. skitt (skitt, 18:00:30)
    2. anipbu (anipbu, 18:00:37)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53150#Agenda today's agenda (colindixon, 18:00:43)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-02-24-04.34.html last week's meeting minutes (thanks vishnoianil!) (colindixon, 18:00:57)
    5. Hideyuki (hideyuki, 18:01:03)
    6. colindixon (colindixon, 18:01:03)
    7. Thanh (zxiiro, 18:01:15)
    8. edwarnicke_ (edwarnicke_, 18:01:31)
    9. ACTION: vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project (colindixon, 18:01:59)
    10. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 18:02:00)
    11. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 18:02:01)
    12. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 18:02:01)
    13. Anil Vishnoi (vishnoianil, 18:02:11)
    14. https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707 (anipbu, 18:02:33)
    15. abhijitkumbhare (abhijitkumbhare, 18:02:33)
    16. jamoluhrsen (jamoluhrsen, 18:02:42)
    17. https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707 <--- Categorizing autorelease failures (anipbu, 18:02:47)
    18. rovarga (rovarga, 18:03:21)
    19. LuisGomez (LuisGomez, 18:03:45)
    20. Current progress on Karaf 4: https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1 (skitt, 18:04:02)
    21. it seems like we're planning to get readouts about Karaf 4 from M5 milestones per katie and anipbu, phrobb asks if we could do it earlier, skitt says that the above linked bug dependency tree is a good list of what's left (colindixon, 18:06:39)
    22. rovarga and skitt say that skitt has done the bulk of the work here (colindixon, 18:07:21)
    23. rovarga says that cross-project stuff doesn't seem to be work and that worries him from an SR and planning perspective (colindixon, 18:08:17)
    24. skitt says it's worrying to see so little engagment from so many projects, e.g., this work and mockito from vorburger (colindixon, 18:09:57)
    25. colindixon says in general, his approach has been you can't make projects stay engaged, you can make it as easy as possible to stay engaged and you can make it so disengaged projects hurt the rest as little as possible (colindixon, 18:10:46)
    26. vishnoianil says that his take is that things like this (cross-project) need to be scoped and fully anounced by M3 to get things done easily, and we have to make it clear we'll drop people if they don't do it, edwarnicke_ agrees that's sort of our one hammer, not shipping projects (colindixon, 18:11:57)
    27. it's pretty clear that this has been a huge burden on a very small number of people, e.g., skitt, rovarga and vorburger, which isn't sustainable, healthy or good for the OpenDaylight community (colindixon, 18:13:51)
    28. vishnoianil and rovarga go back and forth about how that might be resolve and why projects don't respond and if we should change things to encourage projects to be more attentive (colindixon, 18:19:31)
    29. rovarga says that we should consider shifting our stance to kick people out of the release if they do things like miss multiple milestones (colindixon, 18:20:28)
    30. edwarnicke_ says he's open with that, as long as we make it clear when people will be dropped and how they can remediate it and when (colindixon, 18:21:58)
    31. an example might be if you milestone readout is late (how late?) then you will be removed for some period of time until you get the new ones, that might get more compliance (colindixon, 18:23:42)
    32. ACTION: colindixon to start a thead talking about what we migth do to address unresponsive projects and have something to actually act on in the next meeting or so (colindixon, 18:25:46)
    33. abhijitkumbhare says that in line with that, there's too many projects and too many unusable projects (colindixon, 18:26:24)
    34. skitt says that he gets the impression that many projects use OpenDaylight for infra and release, basically you get code-dump at M4 or M5 with no open development (colindixon, 18:26:51)
    35. skitt says we need to figure out carrots in addition to sticks (colindixon, 18:27:09)
    36. colindixon notes that docuemnting how to ship apps and projects that work with an SR but aren't part of the SR might alleviate some pressure, edwarnicke_ notes that will intereact potentailly badly with offline installation and running of ODL (colindixon, 18:28:59)
    37. ACTION: vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there (colindixon, 18:30:25)
    38. ACTION: colindixon to set up some kind of meeting (or at least thread) about semantic-versioning-ish things for nitrogen (colindixon, 18:30:32)

  2. carbon (colindixon, 18:31:10)
    1. all M4 offset 0 and offset 1 are in but aaa and snmp (colindixon, 18:31:45)
    2. https://wiki.opendaylight.org/view/Weather#OpenFlowPlugin_-_Turn_Single_Layer_Serialization_on_by_default weather item (colindixon, 18:32:11)
    3. if you want to go back to the old way of OpenFlow serialization, you can follow instructions here: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:OF13%2B_Single_Layer_Serialization#Disabled (colindixon, 18:32:51)
    4. M4 offset 2 is due today (colindixon, 18:33:10)
    5. katiezhang says that there are not many missed M3 offset 2 reports (colindixon, 18:33:23)
    6. M5 offset 0 is today (colindixon, 18:33:53)
    7. https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1544647361 (katiezhang, 18:34:39)
    8. https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1544647361 milestone readouts so far here (colindixon, 18:35:01)
    9. https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=355465003 <= M2 status (hideyuki, 18:36:03)
    10. hideyuki note that many offset 2 projects don't have M3 milestones, rovarga adds that we're missing M2 status too (colindixon, 18:36:05)
    11. rovarga says that his take is that we have many projects now which are now 3 milestones behind (colindixon, 18:38:15)
    12. ACTION: katiezhang will let projects know that the TSC will likely drop projects from the release unless they submit correct, acceptable M4 and M5 (colindixon, 18:42:17)
    13. anipbu notes that you also need to review M4 and M5 readouts carefully to make sure they're correct (colindixon, 18:43:50)
    14. from katie: M3 offset 1 snmp offset 1 M3 offset 2 "atrium capwap cardinal centinel didm eman integration/distribution iotdm lacp natapp next of-config opflex sdninterfaceapp snbi usecplugin vpnservice yang-push yangide" (colindixon, 18:44:54)

  3. boron (colindixon, 18:45:31)
    1. boron SR3 release on 3/23, cutoff on 3/19, so that's 3 weesk to releas, 2.5 weeks to cutoff (colindixon, 18:46:35)
    2. boron autorelease is currently failing (caused by security update of bouncycastle) rovarga will look at it (colindixon, 18:46:53)
    3. ACTION: rovarga will be looking at boron autorelease failures with USC and bouncycastle having issues (colindixon, 18:47:07)

  4. events (colindixon, 18:47:22)
    1. ONS is coming up the first week of April, we're having a docfest Sunday and Monday, there will be space on Monday, there may be space on Sunday too, but we'll have hotel rooms if nothing else (colindixon, 18:48:00)
    2. LuisGomez asks if you can come to the docfest w/o registering, if that's an issue let us know (colindixon, 18:48:40)
    3. skitt asking about having a summit later this year, phrobb says it's up in the air, his take is less than 50/50, the board needs to decide by 3/15 (colindixon, 18:50:23)
    4. phrobb says that the goal of the LF right now is to have an end user and business and general interest networking event in the spring and have that be ONS (colindixon, 18:51:18)
    5. phrobb says that there is a goal to have a fall conference that's more techincally oriented (closer to how the ODL summit was), but do it with more than just ODL, e.g., ODL + OPNFV + FD.io + … (colindixon, 18:52:00)
    6. phrobb says that the question is if we have the runway to do the fall one in 2017 or punt to 2018 (colindixon, 18:52:21)
    7. phrobb says that we may end up doing more, smaller events in more areas instead of a big bang summit (colindixon, 18:52:49)

  5. system integration and test (colindixon, 18:53:21)
    1. nothing this week (colindixon, 18:53:23)

  6. events cont'd (colindixon, 18:56:23)
    1. we need be sure to keep cirtical mass, people just flying in for 2 days is harder to get funds for, gets lower attendance, and is incentives less people to come, e.g., DDFs w/o an attached summit (colindixon, 18:57:41)
    2. ACTION: phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing? (colindixon, 18:58:05)
    3. abhijitkumbhare asks if we should move it to some other time, phrobb says that in general we've tried to line up DDFs coincident with the gap between releases (colindixon, 18:58:59)
    4. this is to the extent that we haven't done them all with summits in the past some of the time (colindixon, 18:59:18)
    5. if those constraints are changing, phrobb would love to note (colindixon, 18:59:51)
    6. rovarga suggests that maybe just making it a DDF + hackfest that is longer without necessarily having a major colocated event might actually work well too (colindixon, 19:00:23)
    7. skitt agrees with that point (colindixon, 19:00:41)
    8. skitt also note that cross-community DDFs (which which might be easier if we synced releases) (colindixon, 19:01:47)

  7. cookies (colindixon, 19:02:30)


Meeting ended at 19:03:02 UTC (full logs).

Action items

  1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project
  2. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  3. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. colindixon to start a thead talking about what we migth do to address unresponsive projects and have something to actually act on in the next meeting or so
  6. vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there
  7. colindixon to set up some kind of meeting (or at least thread) about semantic-versioning-ish things for nitrogen
  8. katiezhang will let projects know that the TSC will likely drop projects from the release unless they submit correct, acceptable M4 and M5
  9. rovarga will be looking at boron autorelease failures with USC and bouncycastle having issues
  10. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?


Action items, by person

  1. anipbu
    1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. colindixon to start a thead talking about what we migth do to address unresponsive projects and have something to actually act on in the next meeting or so
    4. colindixon to set up some kind of meeting (or at least thread) about semantic-versioning-ish things for nitrogen
  3. katiezhang
    1. katiezhang will let projects know that the TSC will likely drop projects from the release unless they submit correct, acceptable M4 and M5
  4. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    3. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
  5. rovarga
    1. rovarga will be looking at boron autorelease failures with USC and bouncycastle having issues
  6. vishnoianil
    1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project
  7. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs


People present (lines said)

  1. colindixon (82)
  2. odl_meetbot (9)
  3. katiezhang (5)
  4. skitt (4)
  5. abhijitkumbhare (4)
  6. anipbu (3)
  7. jamoluhrsen (3)
  8. hideyuki (2)
  9. edwarnicke_ (1)
  10. rovarga (1)
  11. LuisGomez (1)
  12. zxiiro (1)
  13. vishnoianil (1)
  14. phrobb (0)
  15. CaseyODL (0)


Generated by MeetBot 0.1.4.