#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:12 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:18)
    1. colindixon (colindixon, 17:00:21)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53276#Agenda (colindixon, 17:00:26)
    3. abhijitkumbhare (abhijitkumbhare, 17:00:33)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-09-17.59.html last week's meeting mintues (colindixon, 17:00:41)
    5. Anil Vishnoi (vishnoianil, 17:00:48)
    6. anipbu (anipbu, 17:00:50)
    7. Thanh Ha (zxiiro, 17:00:53)
    8. vishnoianil, anipbu will followed-up wtih LACP project to clean up the committer list, it looks like it's been done (colindixon, 17:01:34)
    9. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:01:47)
    10. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:01:53)
    11. Hideyuki (hideyuki, 17:01:56)
    12. vrpolak says that the basic features for a karaf4 distribution is there, but it's missing things as basic as restconf, once that's in more project features are coming, the ETA for th RESTCONF feature is Monday (colindixon, 17:03:14)
    13. LuisGomez (LuisGomez, 17:03:37)
    14. ACTION: colindixon will add Karaf 4 tracking as part of the weekly carbon readout (colindixon, 17:03:37)
    15. jamoluhrsen (jamoluhrsen, 17:03:51)
    16. ACTION: phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing? (colindixon, 17:04:07)
    17. jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro started to look into a 6 month timeframe for our release (colindixon, 17:04:49)
    18. https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1544647361 (katie, 17:05:07)
    19. ACTION: colindixon to send notes from the 6-month cadence meetings to the TSC maiing list (colindixon, 17:05:22)

  2. TSC mailing list votes and discussions (colindixon, 17:05:56)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html Nitrogen planning (colindixon, 17:06:06)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-February/006581.html Namespace management (colindixon, 17:06:27)
    3. rovarga (rovarga, 17:07:08)
    4. ACTION: zxiiro to write up what he understands about namespace management and commit it to docs someplace (colindixon, 17:07:17)
    5. https://lists.opendaylight.org/pipermail/tsc/2017-February/006578.html projects with few/no active committers (colindixon, 17:07:28)
    6. https://lists.opendaylight.org/pipermail/release/2017-January/009034.html flagship features in Carbon (colindixon, 17:07:43)
    7. https://lists.opendaylight.org/pipermail/tsc/2017-March/006696.html semantic versioning (or something like it) in Nitrogen (colindixon, 17:08:02)
    8. shague (shague, 17:08:55)

  3. events (colindixon, 17:09:51)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-March/006756.html ODL meeting at ONS (colindixon, 17:10:03)
    2. https://wiki.opendaylight.org/view/Events:Main wiki events page (colindixon, 17:10:24)
    3. ACTION: colindixon to add wiki events page to TSC agenda (colindixon, 17:10:35)
    4. VOTE: Voted on "TSC members, are you attending ONS?" Results are, yes: 8, no: 3 (colindixon, 17:13:00)
    5. note that LuisGomez, abhijitkumbhare, jamoluhrsen are not attending ONS, but could attend a breakfast TSC meeting (colindixon, 17:13:22)
    6. VOTE: Voted on "should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15 or cancel ut?" Results are (colindixon, 17:17:15)
    7. VOTE: Voted on "should we move the Thursday 4/6 TSC call to be a breakfast meeting at ONS at 7:30-8:15, evening 5-6p, or cancel it?" Results are, cancel: 5, breakfast: 2 (colindixon, 17:19:49)
    8. AGREED: we will cancel the Thurdsay, 4/6 TSC call because of ONS (colindixon, 17:20:06)
    9. colindixon asks phrobb and CaseyODL when we wanted to have some kind of OpenDaylight group gathering to chat about interesting topics? (colindixon, 17:22:06)
    10. the answers as to when it might happen seems to be Tuesday or Thursday evening (colindixon, 17:22:51)
    11. ACTION: phrobb, CaseyODL and colindixon to follow up with some kind of planning formal or informal (colindixon, 17:23:07)
    12. lunch also might be an option, some uncoference time might be possible too (colindixon, 17:24:09)
    13. there is a DDF coming up 5/30 and 6/1, we're looking to get topics by the end of april to put up some agenda so people (mostly semi-outsiders) can decide whether to attend (colindixon, 17:25:25)
    14. the OPNFV summit's (Beijing in late June) CFP is open until 3/27 (colindixon, 17:26:31)
    15. the CFP for LinuxCon/ContainerCon/CloudOpen in China closes 3/18, there is a networking track there (it's the week after the OPNFV summit in Beijing) (colindixon, 17:27:26)

  4. Boron (colindixon, 17:28:05)
    1. the cutoff for SR3 is 3/19, and the relased date is looking at 3/23 (colindixon, 17:28:26)
    2. there are 46 open patches (colindixon, 17:28:32)
    3. from kate: "Total 46 netvirt 16 " snmp4sdn" 2 netconf 3 dlux 3 openflowplugin 7 l2switch 1 usc 1 iotdm 2 topoprocessing 1 genius 3 sfc 1 vtc 1 ovsdb 2 docs 1 tsdr 1 aaa 1" (colindixon, 17:29:01)
    4. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/207/ Current Boron build attempt (zxiiro, 17:29:52)
    5. rovarga notes that Boron-SR3 is the first RFC-compatible version of RESTCONF, we might want to make a bigger splash about that (colindixon, 17:31:13)
    6. ACTION: rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF (colindixon, 17:32:15)
    7. rovarga asks about if there are any blocking Boron-SR3 bugs, people say no, but we should probably ask (colindixon, 17:32:49)
    8. vishnoianil say that there are blocking bugs in OFP, but there are patches that will get in by sunday for it (colindixon, 17:33:36)
    9. ACTION: katie to email the release list to ask if there are other blocking bugs and start to track them (colindixon, 17:34:07)
    10. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- Eight blocker bugs in openflowplugin, odlparent, netvirt (colindixon, 17:35:46)

  5. carbon (colindixon, 17:36:06)
    1. M3 and M4 missign reports down from 27 and 26 to 9 for each (colindixon, 17:37:04)
    2. we still haven't gotten a response from SNMP except that there are no resources to work on (colindixon, 17:37:37)
    3. the following projets in ODL rely on SNMP: eman, tsdr, and didm, so removing it would actively hurt those projects (colindixon, 17:38:40)
    4. phrobb further points out that people might be using it outside OpenDaylight (colindixon, 17:39:05)
    5. vpnservice is not participating in Carbon (Merge to Netvirt) (colindixon, 17:41:41)
    6. sdninterfaceapp, LACP, didm have no change since M2 (colindixon, 17:41:42)
    7. natapp, snbi, usecplugin, and yangide are not participating Carbon (colindixon, 17:41:43)
    8. ACTION: zxiiro to remove natapp, snbi, usecplugin, vpnservice and yangide from autorelease if they aren't already (colindixon, 17:42:18)
    9. ACTION: colindixon to remove natapp, snbi, usecplugin, vpnservice and yangide from docs if they aren't already (colindixon, 17:42:35)
    10. ACTION: colindixon to ping ryan about aaa M4 and M5 readout (colindixon, 17:43:18)
    11. missing M4 status from: alto atrium capwap cardinal centinel docs eman integration/distribution next of-config opflex packetcable ttp yang-push (colindixon, 17:44:00)
    12. ACTION: katiezhang to follow up with validation of M4 Status per project (anipbu, 17:44:44)
    13. katie validated that M4 status had correct informatin and is working to ping projects where information is pining those projects to update (colindixon, 17:44:54)
    14. colindixon asks about M5 offset 0, katie says everyone but aaa is in (colindixon, 17:45:07)
    15. M4 offset 1 is due today (colindixon, 17:45:17)
    16. https://lists.opendaylight.org/pipermail/release/2017-March/009587.html (katie, 17:46:15)
    17. https://lists.opendaylight.org/pipermail/release/2017-March/009587.html NetVirt request to add a user facing feature to add more user-control over how things are activated, the functionality was already there (colindixon, 17:46:56)
    18. "Note: This email is an advisement of intent to seek a waiver of '''API FREEZE'''. The patch for this would be going to: SFC https://git.opendaylight.org/gerrit/#/c/52901/ The following projects have been determined to be impacted: Netvirt - Consumer GBP - Consumer No API changing code will be committed until these projects have agreed to wave API FREEZE, but Gerrits may be pushed. The following bugzilla h (colindixon, 17:47:26)
    19. jamoluhrsen notes that the integration team sees migrating to Karaf 4 as a risk to the release, not critical yet, but real (colindixon, 17:49:24)
    20. rovarga notes that sdninterfaceapp has not made any progress on getting off of their fork of bgpcep despite it being the only listed deliverable for Carbon (colindixon, 17:51:20)
    21. colindixon notes that, in essence, the TSC has two (maybe 3 options), drop them from Carbon, leave them in Carbon, lastly maybe label them as experimental (colindixon, 17:52:12)
    22. rovarga notes that it's not just about copying code, but really because the promised to do this both as part of the boron release review and the carbon release plan (colindixon, 17:53:36)
    23. colindixon notes that he's not sure what the precedent would be of saying that you can't copy properly licensed code into your repo, rovarga notes (as he put above) it's less aobut that and more about not meeting promised deliverables (colindixon, 17:55:17)
    24. edwarnicke asks if there are mechanically, problems with having sdninterface in the project, colindixon says no, edwarnicke asks about stoping over the same model, using the same ports, using the same models, etc. (colindixon, 17:58:05)
    25. colindixon notes that even if the stomped on the same models, or same ports, if they said that they weren't compatible, we would still have allowed them to be here (colindixon, 17:59:01)
    26. ACTION: colindixon to start a thread on the TSC list about what to do with sdninterfaceapp given what has happened (colindixon, 18:01:20)

  6. TSC membership (colindixon, 18:02:55)
    1. phrobb says that Lori will take Alexis's seat on the TSC (colindixon, 18:03:15)
    2. ACTION: colindixon to send out the mail about Lori being the newest TSC member (colindixon, 18:04:27)

  7. cookies (colindixon, 18:04:44)


Meeting ended at 18:05:10 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. colindixon will add Karaf 4 tracking as part of the weekly carbon readout
  4. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
  5. colindixon to send notes from the 6-month cadence meetings to the TSC maiing list
  6. zxiiro to write up what he understands about namespace management and commit it to docs someplace
  7. colindixon to add wiki events page to TSC agenda
  8. phrobb, CaseyODL and colindixon to follow up with some kind of planning formal or informal
  9. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
  10. katie to email the release list to ask if there are other blocking bugs and start to track them
  11. zxiiro to remove natapp, snbi, usecplugin, vpnservice and yangide from autorelease if they aren't already
  12. colindixon to remove natapp, snbi, usecplugin, vpnservice and yangide from docs if they aren't already
  13. colindixon to ping ryan about aaa M4 and M5 readout
  14. katiezhang to follow up with validation of M4 Status per project
  15. colindixon to start a thread on the TSC list about what to do with sdninterfaceapp given what has happened
  16. colindixon to send out the mail about Lori being the newest TSC member


Action items, by person

  1. CaseyODL
    1. phrobb, CaseyODL and colindixon to follow up with some kind of planning formal or informal
    2. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon will add Karaf 4 tracking as part of the weekly carbon readout
    3. colindixon to send notes from the 6-month cadence meetings to the TSC maiing list
    4. colindixon to add wiki events page to TSC agenda
    5. phrobb, CaseyODL and colindixon to follow up with some kind of planning formal or informal
    6. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
    7. colindixon to remove natapp, snbi, usecplugin, vpnservice and yangide from docs if they aren't already
    8. colindixon to ping ryan about aaa M4 and M5 readout
    9. colindixon to start a thread on the TSC list about what to do with sdninterfaceapp given what has happened
    10. colindixon to send out the mail about Lori being the newest TSC member
  3. katie
    1. katie to email the release list to ask if there are other blocking bugs and start to track them
  4. lori
    1. colindixon to send out the mail about Lori being the newest TSC member
  5. rovarga
    1. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
  6. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. zxiiro to write up what he understands about namespace management and commit it to docs someplace
    3. zxiiro to remove natapp, snbi, usecplugin, vpnservice and yangide from autorelease if they aren't already
  7. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
    3. katiezhang to follow up with validation of M4 Status per project


People present (lines said)

  1. colindixon (99)
  2. odl_meetbot (26)
  3. katie (16)
  4. anipbu (9)
  5. jamoluhrsen (8)
  6. LuisGomez (6)
  7. abhijitkumbhare (6)
  8. zxiiro (5)
  9. edwarnicke (5)
  10. lori (5)
  11. hideyuki (4)
  12. rovarga (3)
  13. shague (3)
  14. vishnoianil (3)
  15. vina_ermagan (2)
  16. gzhao (1)
  17. CaseyODL (1)


Generated by MeetBot 0.1.4.