#opendaylight-meeting: tsc

Meeting started by colindixon at 17:01:35 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:01:40)
    1. colindixon (colindixon, 17:01:58)
    2. anipbu (anipbu, 17:02:00)
    3. abhijitkumbhare (abhijitkumbhare, 17:02:07)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-04-13-17.00.html last week's meeting minutes (colindixon, 17:02:09)
    5. Hideyuki (hideyuki, 17:02:17)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54053#Agenda agenda (colindixon, 17:02:26)
    7. Anil Vishnoi (vishnoianil, 17:02:29)
    8. skitt (skitt, 17:02:37)
    9. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:02:57)
    10. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:02:58)
    11. ACTION: katiezhang to follow up with validation of M4 and M5 Status per project (colindixon, 17:02:59)
    12. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 17:03:00)
    13. ACTION: colindixon to create postmortem topics for Carbon and add the clustering breakage to it (colindixon, 17:03:01)
    14. Daniel Farrell for Jamo (dfarrell07, 17:03:08)
    15. ACTION: colindixon to add beryllium security release if needed to the agenda for next week if we don't get to it (colindixon, 17:03:28)
    16. LuisGomez (LuisGomez, 17:03:46)
    17. ACTION: jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez (colindixon, 17:04:18)
    18. https://git.opendaylight.org/gerrit/#/c/53797/ (dfarrell07, 17:04:19)
    19. the idea is to merge that patch today (colindixon, 17:04:43)
    20. ACTION: colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation (colindixon, 17:04:55)
    21. edwarnicke (edwarnicke, 17:05:28)
    22. shague (shague, 17:05:43)
    23. lori (lori, 17:06:16)
    24. rovarga (rovarga, 17:06:29)
    25. ACTION: colindixon to add back should we do Karaf 4 in Carbon or Nitrogetn (especially if Ntirogen is a mini-release) (colindixon, 17:06:32)

  2. events (colindixon, 17:06:59)
    1. https://www.opendaylight.org/global-events (colindixon, 17:07:09)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:07:19)
    3. DDF on 5/31 and 6/1 is coming up (colindixon, 17:07:45)
    4. https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum topics page for the DDF, please get them in so we can start planning things (colindixon, 17:08:13)

  3. Boron (colindixon, 17:08:35)
    1. nothing this week (colindixon, 17:08:51)

  4. Carbon (colindixon, 17:08:56)
    1. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ we have had a few successful builds of autorelease carbon (colindixon, 17:09:25)
    2. as we're adding projects back in with Karaf 4 support, we're seeing some instability (colindixon, 17:09:42)
    3. currently, TSDR and Cardinal aren't really ready and needs to be taken out (colindixon, 17:10:05)
    4. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 Karaf 4 tracking sheet (colindixon, 17:10:21)
    5. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 Karaf 4 blocking bugs sheet (colindixon, 17:10:55)
    6. Vratko's patch to make jobs karaf-version specific was just merged (dfarrell07, 17:11:58)
    7. we're just getting CSIT that runs against Karaf 4 now (colindixon, 17:12:52)
    8. vorburger noticed issues with Karaf 4 and pax exam that we will need to fix to get tests working right (colindixon, 17:13:54)
    9. The Carbon autorelease jobs that recently "worked" didn't actually push artifacts to Nexus (so they are gone), zxiiro will add logic to check if size is problem, we don't have the RC0 mentioned on TSC mail thread (dfarrell07, 17:15:18)
    10. colindixon says that his feel is that we're 1.5-2 weeks behind right now, because we have had sucessful builds of autorelease carbon and we're likley to have all the projects we need in by the end of this week and/or beginning of next week (colindixon, 17:17:57)
    11. skitt says that's his take too (colindixon, 17:18:06)
    12. colindixon notes that this is assuming that nothing unexpected _really_ blows up as we start to be able to test and bang on our Karaf 4 distribution, vishnoianil also confirms that (colindixon, 17:18:39)
    13. ACTION: zxiiro to look into how to ensure that we actually will actually have a version of the distribution on successful runs, even storing it in Jenkins (colindixon, 17:21:05)
    14. colindixon asks if we have a karaf 3 distribution? vrpolak and rovarga say yes and it's looking mostly like it's working. (colindixon, 17:25:26)
    15. that means that we do have the option of going back to karaf 3 if we chose to do so, so that's at least the option (colindixon, 17:25:59)
    16. at this point we have a karaf 4 distribution, but the only thing that's in it is RESTCONF (colindixon, 17:27:36)
    17. anipbu asks if the plan is for projects to add themselves to the karaf 4 distribution, vrpolak says that maybe the better appraoch now is to start with offset 0 and move forward adding features from karaf 3 and make sure distribution checks work (colindixon, 17:28:39)
    18. anipbu asks what the ETA would be? vrpolak doesn't know? probably in 1 week if he has to do it himself. (colindixon, 17:30:22)
    19. ACTION: colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features (colindixon, 17:31:55)
    20. colindixon aks if the genera idea of waiting until next week to figure out how long a delay we think we need to ship Karaf 4 (colindixon, 17:36:24)
    21. colindixon asks the TSC what we feel like we should do, wait another week for more information, decide to abandon Karaf 4 in Carbon, or charge ahead on Karaf 4 no matter the delay (colindixon, 17:39:37)
    22. VOTE: Voted on "should we (1) abandon karaf 4 in Carbon, focus on Karaf 3 with a quick (with 3ish months or shorter) follow-on release to target karaf 4, (2) wait a week and see where we are, (3) push on Karaf 4 unless the delay egregious, e.g., 6+ weeks?" Results are, 1: 1, 3: 3, 2: 8 (colindixon, 17:41:38)

  5. system integration and test (colindixon, 17:43:00)
    1. anipbu says he's considering a blacklist of integration test failures because there are currently 214 and that's too many to follow up on each one (colindixon, 17:43:27)
    2. if you have test failures and want us to care about them, look now :-) (colindixon, 17:43:41)
    3. LuisGomez says that the patch for doing test of Karaf 4 was merged, the default for CSIT is now Karaf 4, so it's going to start failing a lot (colindixon, 17:45:22)
    4. our current plan is to only use CSIT on either Karaf 4 or Karaf 3 (colindixon, 17:46:11)
    5. https://lists.opendaylight.org/pipermail/release/2017-April/010130.html there's an ongoing meeting, currently at 8a pacific every day for (hopefully) 15 minutes (colindixon, 17:48:40)
    6. skitt asks what happened with release reviews, colindixon says we're not really yet ready yet, among other things, we really want to know from projects that they've tried their karaf 4 distribution (colindixon, 17:50:59)
    7. ACTION: colindixon to make sure people have been told that their release reviews will start likely sometime next week (colindixon, 17:51:45)

  6. infrastructure (colindixon, 17:52:07)
    1. nothing other than the missed artifacts being published in from autorelease for carbon (colindixon, 17:52:39)
    2. ACTION: colindixon to bring up SNMP committers and/or dropping it in Nitrogen (colindixon, 17:55:09)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/251/artifact/dependencies.log (anipbu, 17:55:57)

  7. TSC conference platform (colindixon, 17:57:56)
    1. CaseyODL says he hopes people have gotten some time with Zoom and BlueJeans, and seen what things are like (colindixon, 17:58:44)
    2. CaseyODL says at this point since many other LF projects use Zoom and it's much lower cost, the plan is to move to Zoom unless there is a critical complaint that means we shouldn't (colindixon, 17:59:24)
    3. CaseyODL further says that Zoom has been responsive to fixing issues and adding features, tykeal says he's been impressed with Zoom responses too (colindixon, 18:00:25)
    4. CaseyODL plans to cancel all WebEx meetings this week and migrating meetings to Zoom (colindixon, 18:00:55)
    5. nobody objects (colindixon, 18:03:55)

  8. cookies (colindixon, 18:03:57)


Meeting ended at 18:04:00 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. katiezhang to follow up with validation of M4 and M5 Status per project
  4. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  5. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
  6. colindixon to add beryllium security release if needed to the agenda for next week if we don't get to it
  7. jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
  8. colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation
  9. colindixon to add back should we do Karaf 4 in Carbon or Nitrogetn (especially if Ntirogen is a mini-release)
  10. zxiiro to look into how to ensure that we actually will actually have a version of the distribution on successful runs, even storing it in Jenkins
  11. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
  12. colindixon to make sure people have been told that their release reviews will start likely sometime next week
  13. colindixon to bring up SNMP committers and/or dropping it in Nitrogen


Action items, by person

  1. anipbu
    1. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    3. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
    4. colindixon to add beryllium security release if needed to the agenda for next week if we don't get to it
    5. colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation
    6. colindixon to add back should we do Karaf 4 in Carbon or Nitrogetn (especially if Ntirogen is a mini-release)
    7. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
    8. colindixon to make sure people have been told that their release reviews will start likely sometime next week
    9. colindixon to bring up SNMP committers and/or dropping it in Nitrogen
  3. LuisGomez
    1. jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
  4. tykeal
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. zxiiro to look into how to ensure that we actually will actually have a version of the distribution on successful runs, even storing it in Jenkins
    3. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features


People present (lines said)

  1. colindixon (74)
  2. katie (16)
  3. odl_meetbot (10)
  4. dfarrell07 (9)
  5. rovarga (6)
  6. zxiiro (5)
  7. edwarnicke (5)
  8. hideyuki (5)
  9. abhijitkumbhare (5)
  10. tykeal (4)
  11. anipbu (4)
  12. skitt (3)
  13. lori (3)
  14. vishnoianil (3)
  15. shague (2)
  16. CaseyODL (2)
  17. LuisGomez (1)


Generated by MeetBot 0.1.4.