#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 03:30:54 UTC (full logs).

Meeting summary

    1. jamoluhrsen (jamoluhrsen, 03:31:44)

  1. agenda bashing and roll call (colindixon, 03:31:45)
    1. colindixon (colindixon, 03:31:46)
    2. Andrew Grimberg proxy for Thanh Ha (tykeal, 03:31:48)
    3. Daniel Farrell for Sam Hague (dfarrell07, 03:31:57)
    4. lori (lori, 03:32:38)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-05-18.04.html last week's meetin minutes (colindixon, 03:32:48)
    6. LuisGomez (LuisGomez, 03:32:59)
    7. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54302#Agenda agnda for this week (colindixon, 03:33:05)
    8. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 03:33:18)
    9. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 03:33:19)
    10. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 03:33:20)
    11. ACTION: colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features (colindixon, 03:33:21)
    12. colindixon created postmortem topics for Carbon and added the clustering breakage to it https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Lessons_learned_during_the_Carbon_release (colindixon, 03:33:29)
    13. we will remember to question SNMP when/if it seeks to participate in Nitrogen (colindixon, 03:33:30)
    14. colindixon has made sure people have been told that their release reviews will start once we have some RCs to have tested (colindixon, 03:33:31)
    15. https://bugs.opendaylight.org/show_bug.cgi?id=8265 it appears as though autorelease-carbon failing to create staging repositories was due to either (1) something very strange about tsdr or cardinal or (2) something about our current tests (colindixon, 03:33:32)
    16. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-05-18.04.html see 5.p for where the TSC agreed to make Karaf 4 a requirement for Carbon on 1/5/17 (colindixon, 03:33:33)
    17. https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165 (katie, 03:36:23)
    18. abhijitkumbhare (abhijitkumbhare, 03:37:58)
    19. ACTION: katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165 (colindixon, 03:37:58)
    20. we do have the security team on the agend for today (colindixon, 03:38:12)
    21. jamoluhrsen ran one AAA CSIT against the artifacts that came out of the sandbox job, and that worked 2 of 3 times (colindixon, 03:39:42)
    22. Anil Vishnoi (vishnoianil, 03:40:41)

  2. events (colindixon, 03:41:05)
    1. https://www.opendaylight.org/global-events (colindixon, 03:41:08)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 03:41:08)
    3. hopefully we'll be done releasing carbon by the DDF on 5/31 (colindixon, 03:41:15)

  3. boron (colindixon, 03:42:05)
    1. nothing this week (colindixon, 03:42:12)

  4. infrastructure (colindixon, 03:42:30)
    1. we will have a maintainance window on Saturday https://lists.opendaylight.org/pipermail/release/2017-April/010435.html critical security fixes (colindixon, 03:43:09)
    2. tykeal says that he hopes it should be fast, but it's 3-hours (colindixon, 03:43:23)

  5. Carbon (colindixon, 03:43:42)
    1. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 this is the blocking bugs part of the one big spreadsheet (colindixon, 03:44:02)
    2. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 karaf 4 progress in the same spreadsheet (colindixon, 03:44:16)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ last succsessful autoreleas was last week (7d7h ago) (colindixon, 03:44:44)
    4. https://jenkins.opendaylight.org/sandbox/job/autorelease-release-notests-carbon/ we have a skiptest autorelease job in the sandbox, that hopefully abelur will move to regular autorelese, that does produce artifacts (colindixon, 03:45:33)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=8322 this bug is tracking our woes with autorelease (colindixon, 03:46:08)
    6. colindixon goes on a long tirade about how to progress from here, which boils down to BUGs 8322 to 8325 (colindixon, 03:51:43)
    7. colindixon and LuisGomez say that ignoring unit tests failures in autorelease, is probably relatively safe since most (hopefully all) projecst will be checking for their own unit test failures (colindixon, 03:54:01)
    8. https://jenkins.opendaylight.org/releng/view/Merge-Carbon/ (abelur, 03:54:32)
    9. https://jenkins.opendaylight.org/releng/view/Merge-Carbon/ this is a good link to see if unit tests are failing in projects (colindixon, 03:54:39)
    10. we can see there that merge jobs are not failing, so it's special about autorelease that things are failing (colindixon, 03:55:52)
    11. abelur says he's noticed high memory usage, now including sar files in artifacts so we can look at it (colindixon, 03:58:24)
    12. colindixon notes that expeting projects to look there won't happen, we will need to find particular culprits (colindixon, 03:58:44)

  6. (really a subtopic of carbon) karaf distributino testing and CSIT stuff (colindixon, 03:59:30)
    1. we removed all features from the karaf4 distribution because the distribution-check job was taking way too long (colindixon, 04:00:04)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=7900 bug 7900 fixed that, so we should be able to add features back (colindixon, 04:00:32)
    3. vrpolak notes that for most projects that now means we can make progress, but some projects being added will break things again (colindixon, 04:01:03)
    4. ACTION: vrpolak can you please mark the bugs against projects as blockers (colindixon, 04:01:20)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=7891 <-- Things to fix in Netconf. (vrpolak, 04:02:10)
    6. the lifecycle management in karaf 4 is different from karaf 3 and that is causing us issues (colindixon, 04:03:26)
    7. https://git.opendaylight.org/gerrit/56147 <-- An example of Karaf 4 feature fix. (vrpolak, 04:03:55)
    8. LuisGomez, vrpolak, and jamoluhrsen note that we might need to have some pretty wide-ranging changes across projects to fix things related to that (colindixon, 04:03:57)
    9. colindixon would like to note that vrpolak actually knows what he's talking about here, unlike jamoluhrsen and colindixon (colindixon, 04:04:45)
    10. abhijitkumbhare asks if there's light at the end of the tunnel, colindixon says it's basically that things seem to actually work once you get a distribution, so things are likely much better than it appears and most things are false positives (colindixon, 04:07:06)
    11. https://git.opendaylight.org/gerrit/56100 <-- Opt-in way to test Carbon Karaf 4 once a feature repo is in distribution (before abandoning Carbon Karaf 3 test). (vrpolak, 04:08:51)
    12. colindixon notes that if things were really all on fire all over the place, we wouldn't see projects able to test with local distributions and we'd see merge failures and CSIT was also broken (colindixon, 04:10:04)
    13. abelur notes that he's already on BUG-8323 (with -DskipTests) and BUG-8324 (with -fn) (colindixon, 04:10:41)
    14. abelur notes that -fn might not be as useful as we hope, colindixon agrees, but maybe hopes it will flush out some of our failures (colindixon, 04:14:17)

  7. (really a sub-topic of carbon) karaf 4 features into int/dist (colindixon, 04:15:04)
    1. https://lists.opendaylight.org/pipermail/release/2017-April/010444.html (colindixon, 04:15:27)
    2. it seems as though the integration team, e.g., jamoluhrsen, vrpolak, LuisGomez and others are going to be adding karaf 4 features to integration/distribution rather than relying on projects (colindixon, 04:16:05)
    3. this will start tomorrow, probably hopefully (colindixon, 04:16:32)
    4. vrpolak_ notes that The next big thing we need to make work in Karaf 4 is netconf-connector. Many projects use that to reconfigure ODL in CSIT (colindixon, 04:16:40)
    5. https://git.opendaylight.org/gerrit/#/c/56036/ colindixon thinks we can merge this now (colindixon, 04:17:23)

  8. security team (colindixon, 04:18:20)
    1. we'll cover this again next week because rovarga is the biggest person who wants this covered (colindixon, 04:19:36)
    2. basically, we don't have enough spare cycles from people on the security team, which is basically edwarnicke, cdub, rovarga, rgoulding, and a few people who only basically file CVEs now (David Jorm, Kurt Seifreid, and Summer Long) (colindixon, 04:21:04)
    3. if there are people who would like to help, we are currently deeply in need of extra cycles handing security-related things and vulnerability reports (colindixon, 04:22:19)
    4. we are handling things, but help would be good (colindixon, 04:22:39)

  9. cookies (colindixon, 04:24:13)


Meeting ended at 04:24:25 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  4. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
  5. katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
  6. vrpolak can you please mark the bugs against projects as blockers


Action items, by person

  1. anipbu
    1. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    3. colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
  3. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. tykeal
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. vrpolak
    1. vrpolak can you please mark the bugs against projects as blockers


People present (lines said)

  1. colindixon (65)
  2. jamoluhrsen (10)
  3. tykeal (7)
  4. dfarrell07 (6)
  5. abhijitkumbhare (6)
  6. odl_meetbot (5)
  7. vrpolak (3)
  8. abelur (3)
  9. LuisGomez (2)
  10. vrpolak_ (1)
  11. lori (1)
  12. vishnoianil (1)
  13. katie (1)
  14. phrobb (0)
  15. anipbu (0)
  16. CaseyODL (0)


Generated by MeetBot 0.1.4.