#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:30 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:35)
    1. skitt (skitt, 17:00:38)
    2. colindixon (colindixon, 17:00:41)
    3. Vratko Polak proxying for Luis Gomez (vrpolak, 17:00:47)
    4. Daniel Farrell for Jamo (dfarrell07, 17:00:47)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-06-17.04.html last week's meeting minutes (colindixon, 17:00:55)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=58746#Agenda the agenda (colindixon, 17:01:09)
    7. Hideyuki (hideyuki, 17:01:24)
    8. rovarga (rovarga, 17:01:28)
    9. anipbu (anipbu, 17:01:29)
    10. Anil Vishnoi (vishnoianil, 17:01:30)
    11. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:01:30)
    12. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:01:30)
    13. ACTION: colindixon to look to see if any current security response team members would like to voluntarily step down for any reason (colindixon, 17:01:32)
    14. ACTION: rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller (colindixon, 17:01:33)
    15. ACTION: CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them (colindixon, 17:01:33)
    16. ACTION: CaseyODL to send mail to controller-dev about the DDF poll too (colindixon, 17:02:43)
    17. shague (shague, 17:03:21)
    18. the issue of carbon support lifetime was resovled last TSC call (colindixon, 17:03:21)
    19. I don't think we are in depserate need of a Karaf 4 expert/consultant anymore (colindixon, 17:03:38)
    20. ACTION: CaseyODL to add this release manager position be made a priority for the next board meeting (colindixon, 17:04:00)
    21. CaseyODL says that there is a member company entertaining providing a release manager, but it hasn't gone to the board yet (colindixon, 17:04:45)
    22. ACTION: phrobb to bring the need for a security manager to the board and figure out if we can get a response (colindixon, 17:05:35)
    23. the security wiki page has been updated (skitt, 17:06:01)

  2. security response team (colindixon, 17:07:05)
    1. edwarnicke (edwarnicke, 17:08:44)
    2. https://wiki.opendaylight.org/view/Events#Upcoming_Events (CaseyODL, 17:09:41)
    3. skitt asks how changes in the security team are things that are done by current members or the TSC, colindixon says basically the TSC has all the power there, but in practice the team's opinions (and votes) are taken seriously (colindixon, 17:10:13)

  3. mailing list discussions and votes (colindixon, 17:10:59)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description (colindixon, 17:11:18)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-June/007506.html future dveloper design forums (colindixon, 17:11:30)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-July/007626.html survey (colindixon, 17:11:43)
    4. https://lists.opendaylight.org/pipermail/tsc/2017-July/007628.html survey accessilble in China (colindixon, 17:11:50)

  4. events (colindixon, 17:12:24)
    1. https://www.opendaylight.org/global-events (colindixon, 17:12:28)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:12:32)
    3. CableLabs Summer Conference in Keystone, CO on August 6-9th (colindixon, 17:13:13)
    4. Open Source Summit North America is 9/11 in Los Angeles (colindixon, 17:13:41)
    5. SDN/NFV World Congress in Europe will have ODL presence will be followed by an ODL road tour (colindixon, 17:14:16)

  5. carbon (colindixon, 17:14:29)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/SR1/Status <--- We would like to present the final build for Carbon SR1. There are no pending blocking bugs. All test issues found have been signed off as "OKAY" to release. (anipbu, 17:14:48)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#SR1_Download <--- Carbon SR1 Build 20170712 (anipbu, 17:15:58)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR2 is scheduled for 8/17/2017. The stable/carbon branches will be unlocked for only 4 weeks for development. (anipbu, 17:16:47)
    4. VOTE: Voted on "shall the TSC approve the release of Carbon SR1 as summarized by anipbu above?" Results are, +1: 10 (colindixon, 17:17:58)
    5. AGREED: Carbon-SR1 is released (colindixon, 17:18:16)
    6. given that Nitrogen ships on 9/7 (planned), it seems like 8/17 or 9/21 are the two valid dates to target for Carbon-SR2 that don't directly conflict with Nitrogen (colindixon, 17:20:57)
    7. VOTE: Voted on "shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release?" Results are (colindixon, 17:22:14)
    8. VOTE: Voted on "shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release?" Results are, Aug17: 9 (colindixon, 17:23:06)
    9. AGREED: we will keep Carbon-SR2 at 2017-08-17 (colindixon, 17:23:18)

  6. Nitrogen (colindixon, 17:23:26)
    1. https://lists.opendaylight.org/pipermail/release/2017-July/011587.html <--- SFT was hanging for over 3 hrs in Clustered Netconf Topology :: Netconf Connector (anipbu, 17:23:38)
    2. https://lists.opendaylight.org/pipermail/release/2017-July/011590.html <--- SFT was hanging for over 3 hrs in neutron :: integration-test (anipbu, 17:23:42)
    3. https://xkcd.com/1179/ (CaseyODL, 17:23:52)
    4. colindixon asks skitt and rovarga what's going on, rovarga says he's responded on the thread that it seems to be something to do with AAA (colindixon, 17:25:27)
    5. there's also an issue ith threadpool in controller, that we need to go mess with (colindixon, 17:26:00)
    6. rovarga says that a thread-dump would still be useful, if zxiiro could produce it, that would help a lot (colindixon, 17:26:18)
    7. ACTION: colindixon, CaseyODL, and/or anipbu to find somebody to look at the controller threadpool issue, maybe ping TomP (colindixon, 17:27:21)

  7. system integration and testing (colindixon, 17:27:44)
    1. the SFT hangs we already talked about, otherwise nothing (colindixon, 17:28:05)

  8. infra (colindixon, 17:28:18)
    1. no updates this week (colindixon, 17:28:22)

  9. Amoury archive review (colindixon, 17:28:39)
    1. https://wiki.opendaylight.org/view/Archive_Proposals/Armoury (colindixon, 17:28:47)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-June/007621.html process started 2 weesk ago on 2017-06-29 (colindixon, 17:29:35)
    3. colindixon notes that the above thread has Alexis who is the PTL saying we should archive it (colindixon, 17:30:23)
    4. rovarga asks is there something similar in ODL, edwarnicke says no, but APPC in ONAP does a very similar thing and is based on ODL (colindixon, 17:31:09)
    5. VOTE: Voted on "shall the TSC archive Amoury?" Results are, +1: 11 (colindixon, 17:31:44)
    6. AGREED: Amoury has been archived (colindixon, 17:31:51)
    7. ACTION: colindixon to add the note about APPC in ONAP doing similar things to the Armoury Archive Proposal (colindixon, 17:32:09)

  10. Discovery Project Archive Review (colindixon, 17:32:34)
    1. https://wiki.opendaylight.org/view/Archive_Proposals/Discovery (colindixon, 17:32:37)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-June/007613.html archival proposed on 2017-06-29 (colindixon, 17:32:58)
    3. VOTE: Voted on "shall the TSC archive the Discovery project?" Results are, +1: 9 (colindixon, 17:34:27)
    4. AGREED: the Discovery project has been archived (colindixon, 17:34:36)

  11. cookies (colindixon, 17:35:40)


Meeting ended at 17:35:43 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
  4. rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
  5. CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
  6. CaseyODL to send mail to controller-dev about the DDF poll too
  7. CaseyODL to add this release manager position be made a priority for the next board meeting
  8. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  9. colindixon, CaseyODL, and/or anipbu to find somebody to look at the controller threadpool issue, maybe ping TomP
  10. colindixon to add the note about APPC in ONAP doing similar things to the Armoury Archive Proposal


Action items, by person

  1. anipbu
    1. colindixon, CaseyODL, and/or anipbu to find somebody to look at the controller threadpool issue, maybe ping TomP
  2. CaseyODL
    1. CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
    2. CaseyODL to send mail to controller-dev about the DDF poll too
    3. CaseyODL to add this release manager position be made a priority for the next board meeting
    4. colindixon, CaseyODL, and/or anipbu to find somebody to look at the controller threadpool issue, maybe ping TomP
  3. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
    3. CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
    4. colindixon, CaseyODL, and/or anipbu to find somebody to look at the controller threadpool issue, maybe ping TomP
    5. colindixon to add the note about APPC in ONAP doing similar things to the Armoury Archive Proposal
  4. phrobb
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    3. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  5. rovarga
    1. rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
  6. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way


People present (lines said)

  1. colindixon (77)
  2. odl_meetbot (25)
  3. anipbu (13)
  4. skitt (9)
  5. rovarga (7)
  6. dfarrell07 (7)
  7. CaseyODL (7)
  8. vishnoianil (6)
  9. shague (5)
  10. edwarnicke (5)
  11. hideyuki (5)
  12. zxiiro (5)
  13. vrpolak (5)
  14. phrobb (0)


Generated by MeetBot 0.1.4.