#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:33 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:39)
    1. Thanh (zxiiro, 17:00:52)
    2. Huan (Huan, 17:01:15)
    3. skitt (skitt, 17:02:44)
    4. Anil VIshnoi (vishnoianil, 17:02:55)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=58746#Agenda agenda (colindixon, 17:03:11)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-06-17.04.html last week's minutes (colindixon, 17:03:30)
    7. rovarga (rovarga, 17:03:44)
    8. LuisGomez (LuisGomez, 17:04:05)
    9. lori (lori, 17:04:28)
    10. abhijitkumbhare (abhijitkumbhare, 17:05:00)
    11. https://www.opendaylight.org/global-events returns 404? (Huan, 17:05:00)
    12. shague (shague, 17:05:09)
    13. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-13-17.00.html note that these are the real last-weeks' minutes (colindixon, 17:07:46)
    14. moving "colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way" out of being weekly tracked (colindixon, 17:08:13)
    15. moving "phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials" out weekly tracked (colindixon, 17:10:02)
    16. colindixon has requested that edwarnicke and cdub be removed from the security response team based on their requests (colindixon, 17:10:29)
    17. jamoluhrsen (jamoluhrsen, 17:10:31)
    18. ACTION: colindixon to update the wiki with the changes to the security response team (colindixon, 17:10:44)
    19. ACTION: colindixon is still trying to hunt down one more unresponsive security response team member (colindixon, 17:11:05)
    20. rovarga reach edout to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller, the two options are (i) move it to openflowplugin or (ii) it's own project (colindixon, 17:12:21)
    21. rovarga says he thinks making it it's own project might make it's own sense, it's only 4k lines of code, if we just released it might be easier to make it just frozen (colindixon, 17:14:20)
    22. phrobb has removed cdub from the Security@lists.opendaylight.org mailing list. phrobb notes that edwarnicke is not on this mailing list. (phrobb, 17:14:42)
    23. ACTION: rovarga to start a thread on the TSC about creating a project for liblldp and how we can do it in an efficient way (shague and colindixon note that a full project might be an issue) (colindixon, 17:15:28)
    24. ACTION: phrobb to send a test-email to security mailing list with the list of people who are on the list. (phrobb, 17:16:52)
    25. edwarnicke (edwarnicke, 17:16:58)
    26. ACTION: CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them (colindixon, 17:17:03)
    27. ACTION: skitt to open a helpdesk ticket so security team members can see who’s on the mailing list (skitt, 17:17:27)
    28. CaseyODL did send the DDF poll to controller-dev, I think the plan is to close it before next week's TSC meeting (colindixon, 17:17:49)
    29. ACTION: CaseyODL to add this release manager position be made a priority for the next board meeting (colindixon, 17:18:02)
    30. ACTION: phrobb to bring the need for a security manager to the board and figure out if we can get a response (colindixon, 17:18:09)
    31. colindixon has lost the link, but TomP submitted a patch to fix the threadpool issue in the controller that was causing SFT hangs, fix was in AAA (colindixon, 17:18:33)
    32. colindixon added the note about APPC in ONAP doing similar things to the Armoury Archive Proposal (colindixon, 17:18:49)
    33. CaseyODL says that there is a release manager volunteer from Brocade (Kit Lou) who is working with anipbu and others to try to get spun up (colindixon, 17:21:04)
    34. targeting the first week in october in the bay area for a Oxygen DDF, looking for member orgs to host it (colindixon, 17:22:06)
    35. CaseyODL says that there were only 13 responses to the mandarin poll and even then there were very few fields filled out (colindixon, 17:22:39)
    36. the dominant info from the mandarin poll was a bunch of cities in Asia as a place host it (colindixon, 17:23:30)
    37. dfarrell07 says that there's an OPNFV plugfest in portland in september sometime, dfarrell07 asks if we've considered co-located (colindixon, 17:24:11)
    38. CaseyODL says that very few people say co-location mattered in the poll (colindixon, 17:24:26)
    39. that OPNFV plugfest is in December according to CaseyODL (dfarrell07, 17:25:17)

  2. mailing list votes and discussions (colindixon, 17:25:47)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-July/007668.html e-mail creation review for OVIL (colindixon, 17:25:55)
    2. please go look at that thread and where it points (colindixon, 17:26:10)
    3. colindixon notes that there's already been _a lot_ of discussion in the threads pointed to from ther (colindixon, 17:28:11)

  3. events (colindixon, 17:28:19)
    1. https://www.opendaylight.org/global-events (colindixon, 17:28:29)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:28:35)
    3. see information about the Oxygen DDF above in these minutes (colindixon, 17:28:52)
    4. we have the cablelabs even happening in august (colindixon, 17:28:59)

  4. nitrogen (colindixon, 17:30:03)
    1. zxiiro as of this morning, we've added all of the projects that have submitted patches to autorelease and int/dist (colindixon, 17:30:44)
    2. zxiiro has a build going that will test things, but as of yesterday, we had a passing autorelease build (colindixon, 17:30:59)
    3. jamoluhrsen notes that m5 offset 0 is in 8 days (colindixon, 17:31:08)
    4. abhijitkumbhare asks how we're doing on Karaf 4 migration, zxiiro says looking at the autorelease pom, we're still missing a lot of projects (colindixon, 17:31:45)
    5. zxiiro says that we have 26 in autorelease right now (colindixon, 17:32:14)
    6. https://www.opendaylight.org/global-events is fixed. (CaseyODL, 17:32:56)
    7. colindixon says at this point, projects not migrating to karaf 4 seems like it's laziness (colindixon, 17:33:47)
    8. ACTION: colindixon, zxiiro, and/or anipbu to look into if netconf (not just restconf) is enabled in karaf 4 in int/dist (colindixon, 17:34:39)
    9. it could also be summer vacations delaying migration (edwarnicke, 17:35:05)
    10. colindixon notes that laziness is (intentionally overstated) includes summer vacation, abandoned projects, etc. (colindixon, 17:36:39)
    11. ACTION: colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated (colindixon, 17:38:01)

  5. carbon (colindixon, 17:38:10)
    1. Carbon-SR2 code freeze is 2017-08-10 with release expected 2017-08-17 (zxiiro, 17:38:26)
    2. autorelease carbon has been failing for 7 days, currently on GBP renderer, so reaching out after the call (colindixon, 17:39:16)

  6. system integration and test (colindixon, 17:39:31)
    1. nothing this week (colindixon, 17:39:39)
    2. nothing to report for sys int test (jamoluhrsen, 17:39:40)

  7. back to carbon (colindixon, 17:40:36)
    1. kevin wang says he has a patch he needs merged in carbon for bgpcep, colindixon and/or anipbu will help find a committer (colindixon, 17:41:14)
    2. ACTION: colindixon and/or anipbu to try to find a bgpcep committer today if at all possible? (colindixon, 17:42:03)
    3. https://git.opendaylight.org/gerrit/#/c/60401/ is the patch (colindixon, 17:43:04)

  8. infra (colindixon, 17:43:36)
    1. no updates this week (colindixon, 17:43:41)

  9. cookies (colindixon, 17:46:05)


Meeting ended at 17:46:24 UTC (full logs).

Action items

  1. colindixon to update the wiki with the changes to the security response team
  2. colindixon is still trying to hunt down one more unresponsive security response team member
  3. rovarga to start a thread on the TSC about creating a project for liblldp and how we can do it in an efficient way (shague and colindixon note that a full project might be an issue)
  4. phrobb to send a test-email to security mailing list with the list of people who are on the list.
  5. CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
  6. skitt to open a helpdesk ticket so security team members can see who’s on the mailing list
  7. CaseyODL to add this release manager position be made a priority for the next board meeting
  8. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  9. colindixon, zxiiro, and/or anipbu to look into if netconf (not just restconf) is enabled in karaf 4 in int/dist
  10. colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
  11. colindixon and/or anipbu to try to find a bgpcep committer today if at all possible?


Action items, by person

  1. anipbu
    1. colindixon, zxiiro, and/or anipbu to look into if netconf (not just restconf) is enabled in karaf 4 in int/dist
    2. colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
    3. colindixon and/or anipbu to try to find a bgpcep committer today if at all possible?
  2. CaseyODL
    1. CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
    2. CaseyODL to add this release manager position be made a priority for the next board meeting
  3. colindixon
    1. colindixon to update the wiki with the changes to the security response team
    2. colindixon is still trying to hunt down one more unresponsive security response team member
    3. rovarga to start a thread on the TSC about creating a project for liblldp and how we can do it in an efficient way (shague and colindixon note that a full project might be an issue)
    4. CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
    5. colindixon, zxiiro, and/or anipbu to look into if netconf (not just restconf) is enabled in karaf 4 in int/dist
    6. colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
    7. colindixon and/or anipbu to try to find a bgpcep committer today if at all possible?
  4. phrobb
    1. phrobb to send a test-email to security mailing list with the list of people who are on the list.
    2. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  5. rovarga
    1. rovarga to start a thread on the TSC about creating a project for liblldp and how we can do it in an efficient way (shague and colindixon note that a full project might be an issue)
  6. shague
    1. rovarga to start a thread on the TSC about creating a project for liblldp and how we can do it in an efficient way (shague and colindixon note that a full project might be an issue)
  7. skitt
    1. skitt to open a helpdesk ticket so security team members can see who’s on the mailing list
  8. zxiiro
    1. colindixon, zxiiro, and/or anipbu to look into if netconf (not just restconf) is enabled in karaf 4 in int/dist


People present (lines said)

  1. colindixon (77)
  2. skitt (9)
  3. jamoluhrsen (8)
  4. odl_meetbot (7)
  5. rovarga (5)
  6. CaseyODL (4)
  7. zxiiro (4)
  8. shague (3)
  9. phrobb (3)
  10. Huan (3)
  11. edwarnicke (2)
  12. dfarrell07 (2)
  13. LuisGomez (1)
  14. lori (1)
  15. abhijitkumbhare (1)
  16. vishnoianil (1)
  17. anipbu (0)


Generated by MeetBot 0.1.4.