#opendaylight-meeting: tsc

Meeting started by colindixon at 03:30:10 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 03:30:14)
    1. abhijitkumbhare (abhijitkumbhare, 03:30:22)
    2. colindixon (colindixon, 03:30:23)
    3. Thanh (zxiiro, 03:30:25)
    4. ACTION: colindixon to follow up about one last non-responsive security response team members (colindixon, 03:30:54)
    5. ACTION: colindixon, zxiiro, and/or anipbu to follow up with the fact that odl-netconf-mdsal seems to still not be active in nitrogen: https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml#L142 (colindixon, 03:31:05)
    6. ACTION: skitt to open a helpdesk ticket so security team members can see who’s on the mailing list (colindixon, 03:31:45)
    7. Ding (Ding, 03:31:46)
    8. anipbu (anipbu, 03:31:50)
    9. ACTION: phrobb to bring the need for a security manager to the board and figure out if we can get a response (colindixon, 03:32:03)
    10. Daniel Farrell for Jamo and Sam (dfarrell07, 03:32:19)
    11. ACTION: colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated (colindixon, 03:32:19)
    12. https://git.opendaylight.org/gerrit/#/c/60401/ bgpcep committers are paying some attention here (colindixon, 03:33:39)
    13. phrobb did send the current security mailing list members to the list (colindixon, 03:33:43)
    14. https://wiki.opendaylight.org/view/Security:Main#Security_Response_Team colindixon updated the wiki with the changes to the security response team (colindixon, 03:33:49)
    15. Anil Vishnoi (vishnoianil, 03:34:06)
    16. LuisGomez (LuisGomez, 03:34:12)
    17. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=59648#Agenda (colindixon, 03:34:48)
    18. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-06-17.04.html last week's meeting minutes (colindixon, 03:35:02)

  2. TSC mailing list votes and discussions (colindixon, 03:35:51)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-July/007714.html OVIL approved as an incubation project (colindixon, 03:36:13)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-July/007699.html Thread on moving liblldp code out of controller (colindixon, 03:36:38)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2017-July/000659.html Thread on a possible new liblldp project (colindixon, 03:36:57)
    4. for what it's worth, it _seems_ like the code might be able to live in OpenFlow plugin, which seems easier than a new project (colindixon, 03:37:22)
    5. ACTION: abhijitkumbhare will follow up next week about the liblldp code living in openflow plugin once he pings the other committers (colindixon, 03:37:41)
    6. https://lists.opendaylight.org/pipermail/tsc/2017-July/007721.html Purging unused ODL Nexus repositories (colindixon, 03:38:30)
    7. dfarrell07 says that he thinks these are from shague's initial pacakgin efforts from Hydrogen or Helium and aren't/shouldn't be used anymore (colindixon, 03:39:10)
    8. VOTE: Voted on "shall the TSC approve the purging of unused yum repos for OpenDaylight artifacts?" Results are, +1: 8 (colindixon, 03:40:04)
    9. These old repos became more confusing when we starting pushing modern artifacts to Nexus (dfarrell07, 03:40:23)
    10. AGREED: abelur can purge the old yum repos (colindixon, 03:41:07)

  3. events (colindixon, 03:42:11)
    1. https://www.opendaylight.org/global-events (colindixon, 03:42:39)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 03:42:43)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-July/007684.html Oxygen DDF e-mail with info from CaseyODL (colindixon, 03:42:58)
    4. it will be at Ericsson in the bay area on October 9-10th (colindixon, 03:44:19)
    5. also CableLabs Summer Conference in colorado August 7-9th, Open Source Summit North America in LA September 11-13th (colindixon, 03:44:21)
    6. CaseyODL begs people to provide topics for the DDF (colindixon, 03:44:48)

  4. carbon (colindixon, 03:45:17)
    1. Hideyuki (hideyuki, 03:45:29)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR2 on 8/17/2017 with Cutoff on Sunday 8/13 at 23:59 UTC Time. (anipbu, 03:45:39)
    3. https://lists.opendaylight.org/pipermail/release/2017-July/011714.html <--- Failure in lispflowmapping, but it maybe a "random" failure (anipbu, 03:45:49)

  5. nitrogen (anipbu, 03:46:24)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan#Schedule <--- Nitrogen M5 Offset 0 is due this Friday 7/28/2017 (anipbu, 03:46:51)
    2. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1316886236 <--- We are missing M0 Status from DLUX, MDSAL, NEXT, SNMP (anipbu, 03:47:52)
    3. colindixon says that since NEXT is a leaf project, they aren't in the release at this point, it _could_ change, but would take some serious efforts (colindixon, 03:50:01)
    4. ACTION: colindixon, zxiiro and/or anipbu to reach out to DLUX, MDSAL and SNMP to figure out if they're participating and what needs to happen (colindixon, 03:50:30)
    5. ACTION: anipbu to follow up with daexim in nitrogen (anipbu, 03:52:03)
    6. a discussion back and forth about daexim and whether it's in nitrogen, zxiiro says it's in autorelease, anipbu says it's not in the release per his notes (colindixon, 03:52:05)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=7891 LuisGomez notes that netconf has issues in the distribution and it's not working (still) (colindixon, 03:53:21)
    8. https://git.opendaylight.org/gerrit/59855 Patch to add Daexim to autorelease (zxiiro, 03:53:29)
    9. ACTION: colindixon and/or anipbu to reach out to the NETCONF project about BUG-7891 since it's currently the biggest risk to Nitrogen (colindixon, 03:54:09)
    10. https://lists.opendaylight.org/pipermail/release/2017-July/011713.html <--- Autorelease failure in BGPCEP (anipbu, 03:54:46)
    11. zxiiro says that should go away in the next build (colindixon, 03:55:13)
    12. https://lists.opendaylight.org/pipermail/release/2017-July/011696.html <--- OpenFlowPlugin and OpenFlowJava Merge (anipbu, 03:55:19)
    13. We are in the process of emailing projects that they may be dropped from Nitrogen if they do not complete Karaf 4 Migration. (anipbu, 03:56:16)
    14. karaf blocker bugs: 8803-yangtools bug; snmp needs to be added to distribution; 7891-netconf bug (anipbu, 03:56:43)
    15. we are still less than 30 projects in autorelease (anipbu, 03:57:46)

  6. system integration and test (colindixon, 03:59:46)
    1. there are number of projects having verify failures because of an external issue: currently it's an issue with github and how they're hosting coala (colindixon, 04:00:39)
    2. there are number of projects having verify failures because of an external issue: currently it's an issue with github and how they're hosting an nltk package that coala uses for some things (colindixon, 04:01:34)
    3. zxiiro is looking into how to host those files internally in the meantime (colindixon, 04:01:40)

  7. infra (colindixon, 04:01:56)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-July/007711.html maintainence 4-8p pacific on Sunday (colindixon, 04:02:52)

  8. cookies (colindixon, 04:04:07)


Meeting ended at 04:04:17 UTC (full logs).

Action items

  1. colindixon to follow up about one last non-responsive security response team members
  2. colindixon, zxiiro, and/or anipbu to follow up with the fact that odl-netconf-mdsal seems to still not be active in nitrogen: https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml#L142
  3. skitt to open a helpdesk ticket so security team members can see who’s on the mailing list
  4. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  5. colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
  6. abhijitkumbhare will follow up next week about the liblldp code living in openflow plugin once he pings the other committers
  7. colindixon, zxiiro and/or anipbu to reach out to DLUX, MDSAL and SNMP to figure out if they're participating and what needs to happen
  8. anipbu to follow up with daexim in nitrogen
  9. colindixon and/or anipbu to reach out to the NETCONF project about BUG-7891 since it's currently the biggest risk to Nitrogen


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare will follow up next week about the liblldp code living in openflow plugin once he pings the other committers
  2. anipbu
    1. colindixon, zxiiro, and/or anipbu to follow up with the fact that odl-netconf-mdsal seems to still not be active in nitrogen: https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml#L142
    2. colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
    3. colindixon, zxiiro and/or anipbu to reach out to DLUX, MDSAL and SNMP to figure out if they're participating and what needs to happen
    4. anipbu to follow up with daexim in nitrogen
    5. colindixon and/or anipbu to reach out to the NETCONF project about BUG-7891 since it's currently the biggest risk to Nitrogen
  3. colindixon
    1. colindixon to follow up about one last non-responsive security response team members
    2. colindixon, zxiiro, and/or anipbu to follow up with the fact that odl-netconf-mdsal seems to still not be active in nitrogen: https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml#L142
    3. colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
    4. colindixon, zxiiro and/or anipbu to reach out to DLUX, MDSAL and SNMP to figure out if they're participating and what needs to happen
    5. colindixon and/or anipbu to reach out to the NETCONF project about BUG-7891 since it's currently the biggest risk to Nitrogen
  4. zxiiro
    1. colindixon, zxiiro, and/or anipbu to follow up with the fact that odl-netconf-mdsal seems to still not be active in nitrogen: https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml#L142
    2. colindixon, zxiiro and/or anipbu to reach out to DLUX, MDSAL and SNMP to figure out if they're participating and what needs to happen
  5. UNASSIGNED
    1. skitt to open a helpdesk ticket so security team members can see who’s on the mailing list
    2. phrobb to bring the need for a security manager to the board and figure out if we can get a response


People present (lines said)

  1. colindixon (55)
  2. anipbu (13)
  3. odl_meetbot (10)
  4. dfarrell07 (8)
  5. zxiiro (4)
  6. abhijitkumbhare (3)
  7. vishnoianil (3)
  8. Ding (2)
  9. LuisGomez (2)
  10. hideyuki (1)
  11. CaseyODL (1)
  12. abelur (1)


Generated by MeetBot 0.1.4.