#opendaylight-meeting: tsc

Meeting started by colindixon at 17:03:35 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:03:36)
    1. jamoluhrsen (jamoluhrsen, 17:03:39)
    2. rovarga (rovarga, 17:03:44)
    3. Daniel Farrell for Stephen Kitt (dfarrell07, 17:03:44)
    4. colindixon (colindixon, 17:03:45)
    5. Anil Vishnoi (vishnoianil, 17:03:51)
    6. abhijitkumbhare (abhijitkumbhare, 17:03:51)
    7. edwarnicke (edwarnicke, 17:04:25)
    8. Thanh (zxiiro, 17:04:32)
    9. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=64051#Agenda (colindixon, 17:05:53)
    10. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-24-03.28.html last meetings' minutes (colindixon, 17:06:05)
    11. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.02.html two weeks ago meeting's minutes (colindixon, 17:06:14)
    12. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.48.html two weeks ago meeting's minutes II (colindixon, 17:06:27)
    13. jamoluhrsen wants to add "how to not be late in releases?" to the agenda (colindixon, 17:07:34)
    14. ACTION: colindixon and/or CaseyODL to look int why recording isn't working in Zoom (colindixon, 17:08:03)

  2. updates (colindixon, 17:08:06)
    1. shague (shague, 17:08:13)
    2. nothing new this week (colindixon, 17:08:34)

  3. events (colindixon, 17:08:44)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:53)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:09:03)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-July/007684.html DDF coming up (colindixon, 17:09:21)
    4. phrobb is looking for how we can participate in the ONAP DDF in December (currently 2nd week fo December in the bay area at Intel Santa clara) (colindixon, 17:09:49)
    5. dfarrell07 asks about hotels near the DDF, CaseyODL says he might be able to get a block discount, but if it goes past today, just book something (colindixon, 17:11:36)
    6. colindixon says probably just booking will make sense (CaseyODL seems to mostly agree) (colindixon, 17:12:08)

  4. carbon (colindixon, 17:12:15)
    1. we have 6 blocker bugs for SR2 as of this morning (colindixon, 17:12:57)
    2. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 - carbon tracking sheet (klou, 17:12:58)
    3. jamoluhrsen says that there a two bugs filed recently that he's checking if they're blocking (likely not), 1 but had a merged patch this morning and is hopefully fixed (BUG-9060), can't comment on the other three bugs (colindixon, 17:14:40)
    4. 9063 and 9064 are likely not blocking (according to jamo) (colindixon, 17:15:51)
    5. 9061 jamoluhrsen says is a maybe non-blocker, but bad (colindixon, 17:18:54)
    6. 9034 rovarga says is a umbrella bug for things the tooling exposed about not closing transaction chains (we need to look at it, figure out if it's a regression) (colindixon, 17:19:25)
    7. 9054 has a patch, which is waiting for review (colindixon, 17:19:51)
    8. it sounds like the next steps are: investigate everything but 9054 with a critical eye for if they're blockers or just bad (blocker is a regression with no reasonable workaround), then merge the patch for 9054 (colindixon, 17:21:43)
    9. rovarga asks how long we should delay carbon, do we want to set a line in the sand? (colindixon, 17:23:08)
    10. VOTE: Voted on "should we focus on cabon-sr2 first, nitrogen first, or both at the same time?" Results are, both: 2, C: 4, N: 3 (colindixon, 17:26:41)
    11. it sounds like we shoudl focus on carbon first, probalby true if we can get it done in the next ~24 hours, maybe less so if it drifts (colindixon, 17:28:03)
    12. vishnoianil and dfarrell07 say that SRs are less important to keep on-time vs. releasing Nitrogen on-time to keep the 6-month release cycle (colindixon, 17:30:38)
    13. vishnoianil asks if we slip the nitrogen release by two weeks, what will happen and will it be OK, can we start the Oxygen release on the same schedule as planned (colindixon, 17:31:25)
    14. rovarga says getting something that is currently active used downstream faster may matter more than getting them a shiny new object (colindixon, 17:32:14)
    15. shague says that it takes a 32 GB box and that only buys you ~24 hours, telling a customer you have to reboot ODL every 24 hours in production is a bad idea, might actually be "not a reasonable workaround" (colindixon, 17:38:27)
    16. it sounds ike the issues in carbon are also issues in nitrogen, so there's no value to focusing on eone or th eother (colindixon, 17:39:14)
    17. also in general, we prefer quality over timeliness, so… fixing the issues we understand before shipping is better (colindixon, 17:40:57)
    18. vishnoianil says that people will forgvie a mildly broken Nitrogen mroe than a mildly broken Carbon-SR2 (colindixon, 17:41:15)
    19. rovarga says he thinks SR2 is better than SR1, especially without clustering, so it might be worth shipping SR2 as is, but I think others think the key metric is still missing (colindixon, 17:43:22)

  5. nitrogen (colindixon, 17:43:52)
    1. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=592032762 - nitrogen tracking sheet (klou, 17:44:04)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-nitrogen/ we have working builds! (colindixon, 17:44:09)
    3. klou says that we're officially only 2 days late, but that may be misleading (colindixon, 17:44:35)
    4. 8858 is waiting on a +2 from TomP in Carbon, and then go into nitrogen and master (rovarga says that it's not critical enough to block SR2) (colindixon, 17:46:30)
    5. 8741 the startup archetype is broken for Karaf 4, this is likely a blocker (colindixon, 17:46:59)
    6. 9044 after hard reset, Robot fails to establish SSH connection to karaf: jamoluhrsen says he's looking into it to figure out if it's a real issue or just affecting tests (colindixon, 17:48:49)
    7. 9044 is using kill -9, it would be nice to know if a more graceful reboot would work (colindixon, 17:49:30)
    8. 8987 example-bgp-rib does not exist when updating peer configuration, nobody seems to know what this is (colindixon, 17:50:03)
    9. 9057 IncompatibleClassChangeError in RPC test: rovarga says that this is seeming to point to an inconsistent distribution, it's the first time we're seeing it, so may take some time to understand (colindixon, 17:50:46)
    10. 9054 Singleton leader chasing exhausts heap space in few hours (manifestation of stabiltiy issues in carbon on this list) (colindixon, 17:51:18)
    11. we still have 3-4 projects that haven't reviewed the test results, jamoluhrsen says to just get them to review RC2 (colindixon, 17:52:00)
    12. aaa, bier, snmp, sfc, unimgr are the ones, of those sfc and aaa are the only ones I'd worry about (colindixon, 17:52:57)
    13. colindixon asks if anyone disagrees with the idea of getting the patch for 9054 merged in Carbon, then ship SR2, then work the remaining bugs in both Nitrogen and Carbon (colindixon, 17:58:11)
    14. rovarga notes that TomP beign somewhat off the grid is hurting our debugging now because clustering issues basically fall to Robert or TomP (colindixon, 17:58:45)
    15. rovarga points out that punting on SR2 doesn't necessariy help, it will just make it fall on top of nitrogen SR1 and oxygen spinup (colindixon, 18:04:41)
    16. VOTE: Voted on "what to do with Carbon-SR2: ship it and open the branch, just open the branch, leave the branch closed?" Results are, ship: 1, open: 7 (colindixon, 18:06:05)
    17. ACTION: colindixon to (immediately) send mail to TSC about SR2 (colindixon, 18:06:35)

  6. cookies (colindixon, 18:07:25)


Meeting ended at 18:07:31 UTC (full logs).

Action items

  1. colindixon and/or CaseyODL to look int why recording isn't working in Zoom
  2. colindixon to (immediately) send mail to TSC about SR2


Action items, by person

  1. colindixon
    1. colindixon and/or CaseyODL to look int why recording isn't working in Zoom
    2. colindixon to (immediately) send mail to TSC about SR2


People present (lines said)

  1. colindixon (74)
  2. dfarrell07 (20)
  3. odl_meetbot (18)
  4. abhijitkumbhare (11)
  5. rovarga (9)
  6. edwarnicke (6)
  7. vishnoianil (6)
  8. zxiiro (5)
  9. jamoluhrsen (3)
  10. gzhao (2)
  11. shague (2)
  12. klou (2)
  13. lori (1)


Generated by MeetBot 0.1.4.