#opendaylight-meeting: tsc

Meeting started by skitt at 17:01:30 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (skitt, 17:01:40)
    1. jamoluhrsen (jamoluhrsen, 17:02:13)
    2. anipbu (anipbu, 17:02:13)
    3. skitt (skitt, 17:02:14)
    4. rovarga (rovarga, 17:02:16)
    5. gilesheron (for edwarnicke) (gilesheron, 17:02:19)
    6. last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-10-12-17.00.html (skitt, 17:02:30)
    7. LuisGomez (LuisGomez, 17:03:30)
    8. Thanh (zxiiro, 17:04:01)
    9. Anil Vishnoi (vishnoianil, 17:05:21)
    10. huan (huan, 17:05:38)
    11. ACTION: colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are) (skitt, 17:06:49)
    12. CaseyODL would like some help with messaging around the TSC election which are due to start on Sunday (skitt, 17:08:38)
    13. CaseyODL has notes from the AG to discuss today (skitt, 17:09:03)
    14. shague (shague, 17:10:11)
    15. there's still space available at the OPNFV plugfest, see the events section on the wiki (skitt, 17:10:37)
    16. https://www.regonline.com/registration/Checkin.aspx?EventID=2027715 (CaseyODL, 17:10:38)
    17. it's taking place at the Intel campus in Hillsboro near Portland, Oregon (skitt, 17:11:02)
    18. we're still waiting on the board for an official response re. the security manager position (skitt, 17:11:46)
    19. if we don't find anyone, CaseyODL will take the role but that will result in him having to reduce his involvement in other areas (skitt, 17:12:32)
    20. ACTION: rovarga to add a session to the TWS page about the lessons learned from nitrogen (skitt, 17:13:50)
    21. dfarrell07 says there's no pressing concern re OPNFV and Nitrogen SR1 (skitt, 17:14:55)
    22. CaseyODL underlines the importance of attending next Monday's TWS call, re ODL stable distributions (skitt, 17:15:27)
    23. ACTION: CaseyODL to make sure we get whatever details we can for the India road show, ONS and ONAP forum are at least on the wiki events page (skitt, 17:16:25)
    24. ACTION: zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs (skitt, 17:17:11)

  2. mailing list (skitt, 17:17:18)
    1. JIRA migration: tykeal has sent a few emails about that (skitt, 17:17:56)
    2. the migration has happened, including some things which shouldn't have been able to happen (skitt, 17:18:14)
    3. changes made to Bugzilla during the migration are not in JIRA (skitt, 17:18:25)
    4. some fields have not been carried over, but we had a month to test beforehand so ... (skitt, 17:18:50)
    5. people asked about mapping old bug ids to new bug ids, there's an "external issue id" field that can be used for that (skitt, 17:19:15)
    6. user mapping has caused some issues but there is a way to merge accounts so helpdesk can fix those issues (skitt, 17:19:34)
    7. ACTION: tykeal to send an email explaining how to map bug ids (skitt, 17:20:19)
    8. there's no global version to JIRA, all projects need to manage their own lists (skitt, 17:24:19)
    9. we should be able to have much better bug tracking wrt versions, but we need to be careful so that things stay somewhat consistent across projects (skitt, 17:26:10)
    10. abhijitkumbhare (had info’ed in on a wrong channel earlier by mistake) (abhijitkumbhare, 17:27:00)
    11. filters can be set up across projects, and JIRA has very useful dashboards (skitt, 17:28:27)
    12. labels are global so that could be used for synchronisation (skitt, 17:29:29)
    13. labels are created on the fly (and are case-sensitive) (skitt, 17:29:53)
    14. shague asks about links from Gerrit to Bugzilla, and how to transition those to JIRA (skitt, 17:31:24)
    15. tykeal has a number of actions in progress to address that (skitt, 17:31:55)

  3. events (skitt, 17:32:06)
  4. Oxygen (skitt, 17:32:46)
    1. we're trying to collect M1 readouts (skitt, 17:33:23)
    2. offset 0 and 1 is past due, offset 2 is this Saturday (skitt, 17:33:49)
    3. the readouts should be in .rst files checked in to the docs project (skitt, 17:33:59)
    4. we have a good autorelease build for Oxygen (skitt, 17:34:18)
    5. abhijitkumbhare asks why we're asking projects to use .rst format now for readouts (skitt, 17:35:42)
    6. klou says it's easier to maintain, easier to compile etc.; zxiiro says it's easier to search (skitt, 17:36:06)
    7. open question whether to use the wiki or .rst for release plans (skitt, 17:37:45)

  5. Nitrogen (skitt, 17:38:49)
    1. good builds the past two days (skitt, 17:39:01)
    2. SR1 has two blocker bugs, 9163 in controller and 9007 in openflowplugin (skitt, 17:39:14)
    3. if those are resolved soon we can meet the target date of October 26 (skitt, 17:39:47)
    4. 9163 apparently has a patch already (skitt, 17:40:21)
    5. ACTION: klou to send the controller team an email about 9163 (skitt, 17:41:48)

  6. Carbon (skitt, 17:42:16)
    1. SR2 released last week, not much to discuss (skitt, 17:42:25)

  7. Committer promotions (skitt, 17:43:39)
    1. klou is now a committer on releng/autorelease (skitt, 17:43:54)

  8. Notes from the AG (skitt, 17:44:37)
    1. the AG would like to talk about clustering in more detail (skitt, 17:44:58)
    2. in particular active/active failover (skitt, 17:45:06)
    3. CaseyODL directed the AG to the kernel call (skitt, 17:45:12)
    4. they brought up the need to upgrade Swagger (skitt, 17:45:44)
    5. and requested a tl;dr version of the DDF (skitt, 17:45:56)
    6. ACTION: CaseyODL and a few others to write up a summary of the DDF (skitt, 17:46:24)

  9. TSC elections (skitt, 17:46:49)
    1. emails going out next Sunday (skitt, 17:47:07)
    2. CaseyODL needs help with the messaging (skitt, 17:47:15)
    3. the messaging should be similar to the last elections (skitt, 17:47:42)
    4. two weeks of nominations and two weeks of voting, as usual (skitt, 17:48:39)

  10. Verify w/ dependencies (skitt, 17:48:58)
    1. https://lists.opendaylight.org/pipermail/dev/2017-October/004164.html (skitt, 17:49:08)
    2. the job takes a list of patches, in the order they need to build (odlparent patches first, etc.) (skitt, 17:49:48)
    3. the job will apply the patches and run verify on the Gerrit patch that's driving the recheck (skitt, 17:50:35)

  11. cookies (skitt, 17:51:33)


Meeting ended at 17:51:41 UTC (full logs).

Action items

  1. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
  2. rovarga to add a session to the TWS page about the lessons learned from nitrogen
  3. CaseyODL to make sure we get whatever details we can for the India road show, ONS and ONAP forum are at least on the wiki events page
  4. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
  5. tykeal to send an email explaining how to map bug ids
  6. klou to send the controller team an email about 9163
  7. CaseyODL and a few others to write up a summary of the DDF


Action items, by person

  1. CaseyODL
    1. CaseyODL to make sure we get whatever details we can for the India road show, ONS and ONAP forum are at least on the wiki events page
    2. CaseyODL and a few others to write up a summary of the DDF
  2. rovarga
    1. rovarga to add a session to the TWS page about the lessons learned from nitrogen
  3. skitt
    1. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
  4. tykeal
    1. tykeal to send an email explaining how to map bug ids
  5. zxiiro
    1. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
  6. UNASSIGNED
    1. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
    2. klou to send the controller team an email about 9163


People present (lines said)

  1. skitt (76)
  2. zxiiro (7)
  3. jamoluhrsen (7)
  4. odl_meetbot (5)
  5. CaseyODL (1)
  6. rovarga (1)
  7. tykeal (1)
  8. shague (1)
  9. gilesheron (1)
  10. LuisGomez (1)
  11. anipbu (1)
  12. huan (1)
  13. vishnoianil (1)
  14. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.