#opendaylight-meeting: tsc

Meeting started by CaseyODL at 17:04:43 UTC (full logs).

Meeting summary

    1. abhijitkumbhare (abhijitkumbhare, 17:05:04)
    2. Thanh (zxiiro, 17:05:22)
    3. TSC members please #info in (skitt, 17:05:27)
    4. skitt (skitt, 17:05:30)
    5. rovarga_ (rovarga_, 17:05:31)
    6. Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-10-26-03.32.html (skitt, 17:05:40)
    7. Lessons learned from Nitrogen scheduled for Monday 13's TWS (skitt, 17:06:47)
    8. ACTION: colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are) (skitt, 17:07:08)
    9. ACTION: rovarga to add a session to the TWS page about the lessons learned from nitrogen (skitt, 17:07:28)
    10. lhinds (lhinds, 17:08:14)
    11. jamoluhrsen (jamoluhrsen, 17:08:46)
    12. Anil Vishnoi (vishnoianil, 17:08:51)

  1. JIRA migration (skitt, 17:09:04)
    1. a few hiccups, mostly for people who hadn't provided their initial account info (skitt, 17:09:19)
    2. issues with watches, they're working for tykeal but not for shague and various others (skitt, 17:09:41)
    3. could be an issue with the mail path between the LF and users, the SMTP servers aren't the same (skitt, 17:10:19)
    4. rovarga_ gets email from JIRA, so it could just be Red Hat (skitt, 17:10:51)
    5. https://wiki.opendaylight.org/view/TSC:Main#Agenda (dfarrell07, 17:12:46)
    6. question about adding the ability for anyone to add watchers (skitt, 17:14:05)
    7. enough voting on the mailing list, this will be enabled (skitt, 17:14:17)
    8. JIRA workflow email discussion: https://lists.opendaylight.org/pipermail/tsc/2017-October/008193.html (skitt, 17:16:14)
    9. the current workflow is in bad shape, we need to either agree on a common workflow for every one or tell projects to choose (skitt, 17:16:53)
    10. rovarga_ suggests porting over the Bugzilla workflow, tykeal says that's not trivial (skitt, 17:17:38)
    11. zxiiro raises the issue that JIRA isn't publicly viewable for anonymous users (not logged in) (skitt, 17:18:46)
    12. ACTION: tykeal to allow non-logged-in users to view JIRA (skitt, 17:19:09)
    13. Proposal to allow releng team to merge all version bump patches https://lists.opendaylight.org/pipermail/tsc/2017-October/008218.html (zxiiro, 17:19:13)

  2. RelEng Team to perform all version bumping activities (skitt, 17:19:32)
    1. decided on the mailing list (skitt, 17:19:39)

  3. GNT creation review (skitt, 17:19:46)
    1. ACTION: anipbu to revive the GNT creation discussion (skitt, 17:20:27)

  4. TrieMap creation review (skitt, 17:20:33)
    1. ACTION: rovarga_ to revive the TrieMap creation review (skitt, 17:20:41)

  5. liblldp project proposal (skitt, 17:20:58)
    1. ACTION: shague to revive the liblldp project discussion if appropriate (skitt, 17:21:19)

  6. RelEng Team to perform all version bumping activities, take two (skitt, 17:21:29)
    1. I believe openflowplugin took lldp so no need to revive the discussion (shague, 17:21:55)
    2. VOTE: Voted on "The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first?" Results are, +1: 10 (CaseyODL, 17:24:20)
    3. AGREED: The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first. (skitt, 17:24:32)

  7. Inter-project dependencies (skitt, 17:25:17)
    1. ACTION: skitt or rovarga_ to revive the discussion (skitt, 17:25:24)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-September/007937.html Disscussion on Inter-project dependencies. (CaseyODL, 17:26:01)
    3. Vratko has been working on a verification tool (skitt, 17:26:04)
    4. some of rovarga_'s patches have been merged so the situation has improved (skitt, 17:26:29)

  8. Events (skitt, 17:26:55)
  9. Releases/distributions refactoring discussions (skitt, 17:27:08)
    1. https://docs.google.com/presentation/d/18BF5I4WIGgYXr1-oPAyxgtPKFtkKnDz77c05cYLBllY/ Sam's slide summery (dfarrell07, 17:27:24)
    2. TWS on the topic next Monday (skitt, 17:28:06)
    3. the poll has been sent out, no responses yet (skitt, 17:28:31)

  10. Events (skitt, 17:29:03)
    1. OPNFV plug-fest in December, register soon (skitt, 17:29:30)
    2. Open Source Leadership Summit in March (skitt, 17:29:41)
    3. ONS in March with co-located ODL DDF (skitt, 17:29:48)
    4. https://lists.opendaylight.org/pipermail/tsc/2017-November/008240.html (anipbu, 17:30:43)
    5. LF networking projects informational update: https://lists.opendaylight.org/pipermail/tsc/2017-November/008240.html (skitt, 17:31:11)
    6. webinar next Monday, 6pm PT (skitt, 17:31:19)
    7. same again next Tuesday, 7am PT (skitt, 17:31:33)
    8. topic is the umbrella discussion in progress for all the networking projects in the LF (skitt, 17:32:00)

  11. Oxygen (skitt, 17:32:38)
    1. M2 milestone coming up, Nov 7/14/21 (skitt, 17:32:48)
    2. still missing M1 milestones for ~20 projects (skitt, 17:33:01)
    3. new project P4Plugin wishing to join the release (skitt, 17:33:10)
    4. this is an existing project wishing to join (skitt, 17:33:44)
    5. no need for a TSC vote to approve their joining (skitt, 17:34:07)
    6. ACTION: klou to continue pinging projects for M1 milestones (skitt, 17:35:08)

  12. Nitrogen (skitt, 17:35:22)
    1. SR1 candidate ready, waiting for teams to check off CSIT issues (skitt, 17:35:40)
    2. big issues with ODL getting killed, so no urgency for teams to look into CSIT issues (skitt, 17:36:36)
    3. blocker bugs will be opened as necessary (skitt, 17:36:44)
    4. SR2 planned for December 7 (skitt, 17:36:52)
    5. given that SR1 will only go out next week at the earliest, klou asks if we should move SR2 back (skitt, 17:37:11)
    6. LuisGomez suggests waiting until we get closer to the release (skitt, 17:38:24)
    7. we'll wait until late November/early December to see if we have something worth releasing before the end-of-year holidays (skitt, 17:38:50)

  13. Carbon (skitt, 17:38:52)
    1. SR3 was planned for November 9 (skitt, 17:39:12)
    2. klou sent out an email regarding SR3 and has had no reaction so far (skitt, 17:39:32)
    3. given the recent release of SR2, no point in releasing SR3 now (skitt, 17:39:52)
    4. SR4 was planned for February 15 (skitt, 17:40:11)
    5. rovarga_ suggests moving SR3 to half-way between now and SR4 (skitt, 17:40:21)
    6. the release plan doesn't reflect the longer release plan we approved a while ago (skitt, 17:42:16)
    7. the February 15 release won't be the last Carbon release (skitt, 17:42:30)
    8. we'd need one last release three months later (skitt, 17:42:44)
    9. Carbon is supposed to be supported as long as Nitrogen which has one last release on May 7 (skitt, 17:44:03)
    10. rovarga_ suggests taking this to the mailing list so we can dig up the relevant meeting minutes (skitt, 17:44:57)
    11. he also suggests avoiding back-to-back Carbon/Nitrogen releases given how much trouble we had with the Nitrogen GA (skitt, 17:45:20)

  14. Committer promotion for SXP (Martin Dindoffer) (skitt, 17:46:50)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-October/008114.html nomination (dfarrell07, 17:46:56)
    2. VOTE: Voted on "Does the TSC approve Martin Dindoffer as SXP Committer?" Results are, +1: 9 (dfarrell07, 17:48:12)
    3. AGREED: Martin Dindoffer is an SXP Committer (skitt, 17:48:27)
    4. ACTION: skitt to inform the various parties (skitt, 17:48:36)
    5. ACTION: skitt to inform the various parties that Martin Dindoffer is approved as SXP Committer (skitt, 17:48:53)

  15. Infrastructure (skitt, 17:49:37)
    1. at the end of December we need to migrate off our cloud provider (skitt, 17:50:15)
    2. we'll be migrating over the next two months (skitt, 17:50:29)
    3. the migration has already started and explains some of the recent disruption (skitt, 17:51:15)
    4. next up is Gerrit which will also involve a switch to LFID (skitt, 17:51:25)
    5. then Nexus and Jenkins and the build CI (skitt, 17:51:37)
    6. the new provider has different OpenStack flavours (skitt, 17:53:04)
    7. the Heat templates need to be updated (skitt, 17:53:12)
    8. the new provider has no quota for us (skitt, 17:53:26)
    9. but we do run the risk of over-spending (skitt, 17:53:50)
    10. rovarga_ asks if we can automate emailing the TSC meeting IRC logs to a mailing list (skitt, 17:58:32)
    11. tykeal asks that we open a ticket but it will be very low priority (skitt, 17:59:03)
    12. ACTION: rovarga_ to open a ticket asking for IRC meeting log search or emailing to the mailing list (skitt, 17:59:38)

  16. Security coordinator (skitt, 18:00:11)
    1. lhinds is Red Hat's nomination for the security coordinator role (skitt, 18:00:24)
    2. his bio went to the TSC mailing list (skitt, 18:00:36)
    3. first task would be to set up a proper embargo process (as done in OPNFV etc.) (skitt, 18:02:26)
    4. other topics could include threat analysis, secure coding etc. (skitt, 18:02:37)
    5. VOTE: Voted on "Shall the TSC approve Luke Hines as Security Manager?" Results are, 0: 1, +1: 7 (skitt, 18:05:18)
    6. https://lists.opendaylight.org/pipermail/tsc/2017-November/008236.html Luke's bio (dfarrell07, 18:05:21)
    7. AGREED: the TSC approves Luke Hinds as Security coordinator (skitt, 18:05:49)

  17. Cookies (skitt, 18:06:08)


Meeting ended at 18:06:19 UTC (full logs).

Action items

  1. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
  2. rovarga to add a session to the TWS page about the lessons learned from nitrogen
  3. tykeal to allow non-logged-in users to view JIRA
  4. anipbu to revive the GNT creation discussion
  5. rovarga_ to revive the TrieMap creation review
  6. shague to revive the liblldp project discussion if appropriate
  7. skitt or rovarga_ to revive the discussion
  8. klou to continue pinging projects for M1 milestones
  9. skitt to inform the various parties
  10. skitt to inform the various parties that Martin Dindoffer is approved as SXP Committer
  11. rovarga_ to open a ticket asking for IRC meeting log search or emailing to the mailing list


Action items, by person

  1. anipbu
    1. anipbu to revive the GNT creation discussion
  2. klou
    1. klou to continue pinging projects for M1 milestones
  3. rovarga_
    1. rovarga_ to revive the TrieMap creation review
    2. skitt or rovarga_ to revive the discussion
    3. rovarga_ to open a ticket asking for IRC meeting log search or emailing to the mailing list
  4. shague
    1. shague to revive the liblldp project discussion if appropriate
  5. skitt
    1. skitt or rovarga_ to revive the discussion
    2. skitt to inform the various parties
    3. skitt to inform the various parties that Martin Dindoffer is approved as SXP Committer
  6. tykeal
    1. tykeal to allow non-logged-in users to view JIRA
  7. UNASSIGNED
    1. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
    2. rovarga to add a session to the TWS page about the lessons learned from nitrogen


People present (lines said)

  1. skitt (118)
  2. odl_meetbot (22)
  3. dfarrell07 (14)
  4. rovarga_ (8)
  5. abhijitkumbhare (7)
  6. zxiiro (6)
  7. CaseyODL (6)
  8. shague (4)
  9. lhinds (4)
  10. anipbu (4)
  11. jamoluhrsen (4)
  12. LuisGomez (3)
  13. edwarnicke (3)
  14. vishnoianil (3)
  15. tykeal (1)
  16. klou (1)


Generated by MeetBot 0.1.4.