#opendaylight-meeting: tsc

Meeting started by CaseyODL at 18:01:47 UTC (full logs).

Meeting summary

    1. Anil Vishnoi (vishnoianil, 18:03:06)
    2. LuisGomez (LuisGomez, 18:03:19)

  1. Agenda bashing (skitt, 18:03:29)
    1. abhijitkumbhare (abhijitkumbhare, 18:03:35)
    2. TSC members please info in (skitt, 18:03:36)
    3. skitt (skitt, 18:03:38)
    4. jamoluhrsen (jamoluhrsen, 18:03:43)
    5. Thanh (zxiiro, 18:03:55)
    6. shague (shague, 18:03:57)
    7. Last week’s minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-11-02-17.04.html (skitt, 18:04:02)
    8. lori (lori, 18:04:08)
    9. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-11-09-18.01.log.txt (skitt, 18:04:28)
    10. rovarga (rovarga, 18:04:47)
    11. anipbu (anipbu, 18:05:27)
    12. ACTION: colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are) (skitt, 18:07:10)
    13. ACTION: rovarga to add a session to the TWS page about the lessons learned from nitrogen (skitt, 18:07:30)

  2. Events (skitt, 18:09:11)
    1. There aren’t enough candidates (skitt, 18:09:30)
    2. for the kernel projects, so the nomination period needs to be extended (skitt, 18:09:43)
    3. the nomination period isn’t actually over (skitt, 18:11:57)
    4. ACTION: CaseyODL to send a reminder to the PTLs re nomination for the TSC elections (skitt, 18:13:04)
    5. for groups with the same number of nominees as positions, we don’t need elections (skitt, 18:15:33)
    6. no new information re. events proper (skitt, 18:15:53)
    7. the LF has been made aware of the holiday issue for the ODL DDF at ONS (skitt, 18:16:23)
    8. (Passover starting right after ONS) (skitt, 18:16:37)
    9. CaseyODL encourages members of the ODL community who can go to the OPNFV plug-fest next month to go (skitt, 18:17:50)

  3. Oxygen (skitt, 18:18:26)
    1. we’re still waiting for M1 read-outs from ~10 projects (skitt, 18:18:46)
    2. do we want to drop the leaf projects or give them more time? (skitt, 18:19:00)
    3. M2 is now (skitt, 18:19:11)
    4. ACTION: klou to send a final reminder to projects missing their M1 milestones (skitt, 18:21:16)
    5. Offset 0 projects still missing: mdsal and yangtools (skitt, 18:22:26)
    6. Offset 1 projects include snmp (skitt, 18:22:52)
    7. ACTION: rovarga follow up on offset-0 M1 readout by Monday (rovarga, 18:22:58)
    8. ACTION: skitt to follow up on snmp readout by Monday (skitt, 18:24:20)
    9. phrobb points out that the real question is whether we should slip the project if offsets 0 and 1 aren’t making the read-outs (skitt, 18:26:07)
    10. rather than discussing removing projects once the deadline is gone (skitt, 18:26:58)
    11. two emails? for leaf projects, after Tuesday they will be kicked out, for non-leaf projects the TSC will have to discuss the situation (skitt, 18:29:28)
    12. klou would like to have the ability to add versions in all projects in JIRA (skitt, 18:31:21)
    13. currently only committers can do that (skitt, 18:31:50)
    14. VOTE: Voted on "Should klou be allowed to add versions in all projects in JIRA (both define versions and set fix versions)?" Results are, 0: 1, +1: 9 (skitt, 18:34:17)
    15. AGREED: klou is allowed to add versions in all projects in JIRA (both define versions and set fix versions) (skitt, 18:34:32)

  4. Nitrogen (skitt, 18:35:19)
    1. new blockers since last week, all resolved this morning, last patch in netconf merged (skitt, 18:35:44)
    2. new build started ~4h ago (skitt, 18:35:50)
    3. if the build is good it should be ready to go out (skitt, 18:37:53)
    4. action zxiiro to document the yangtools Nitrogen -> v1.2.x branch rename (for future lock-downs) (skitt, 18:40:20)

  5. Carbon (skitt, 18:40:52)
    1. klou sent an email follow-up re. the Carbon support duration after last week’s TSC and hasn’t had any response (skitt, 18:41:29)
    2. SR3 was supposed to go out today (skitt, 18:42:01)
    3. issues still the same as last week: aligning SR4 with the release of Oxygen, SR3 somewhere between now and then, half-way perhaps? (skitt, 18:43:56)
    4. i.e. move SR4 out 2-3 weeks (skitt, 18:44:08)
    5. March 7 is the formal Oxygen release, with SRs until November 7 (skitt, 18:46:03)
    6. no projects have contacted klou with information on anything significant for Carbon (skitt, 18:46:35)
    7. we should probably move SR3 to early next year, unless big issues crop up before then (skitt, 18:47:01)
    8. this is for Carbon (skitt, 18:55:30)
    9. VOTE: Voted on "Shall we move the SR3 release date to December 14, 2017, and SR4 to March 15, 2018?" Results are, +1: 10 (skitt, 18:56:58)
    10. AGREED: Carbon SR3 is December 14, 2017, Carbon SR4 is March 15, 2018 (skitt, 18:57:17)

  6. Infrastructure (skitt, 18:57:27)
    1. nothing this week (skitt, 18:57:45)

  7. Cookies (skitt, 18:58:19)


Meeting ended at 18:58:59 UTC (full logs).

Action items

  1. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
  2. rovarga to add a session to the TWS page about the lessons learned from nitrogen
  3. CaseyODL to send a reminder to the PTLs re nomination for the TSC elections
  4. klou to send a final reminder to projects missing their M1 milestones
  5. rovarga follow up on offset-0 M1 readout by Monday
  6. skitt to follow up on snmp readout by Monday


Action items, by person

  1. CaseyODL
    1. CaseyODL to send a reminder to the PTLs re nomination for the TSC elections
  2. rovarga
    1. rovarga to add a session to the TWS page about the lessons learned from nitrogen
    2. rovarga follow up on offset-0 M1 readout by Monday
  3. skitt
    1. skitt to follow up on snmp readout by Monday
  4. UNASSIGNED
    1. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
    2. klou to send a final reminder to projects missing their M1 milestones


People present (lines said)

  1. skitt (62)
  2. odl_meetbot (15)
  3. rovarga (4)
  4. anipbu (4)
  5. zxiiro (4)
  6. vishnoianil (4)
  7. shague (3)
  8. LuisGomez (3)
  9. lori (3)
  10. abhijitkumbhare (3)
  11. jamoluhrsen (3)
  12. tykeal (2)
  13. CaseyODL (2)
  14. dfarrell07 (1)


Generated by MeetBot 0.1.4.